Adding notebook version 1.0.1.

An organizer for storing information and to-do lists.

PR:		19289
Submitted by:	Mario S F Ferreira <lioux@linf.unb.br>
This commit is contained in:
Steve Price 2000-09-18 00:34:29 +00:00
parent 632f263f0d
commit 4c63a3187d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=32789
10 changed files with 215 additions and 0 deletions

View File

@ -18,6 +18,7 @@
SUBDIR += korganizer11-i18n
SUBDIR += kproject
SUBDIR += moneydance
SUBDIR += notebook
SUBDIR += offix-trash
SUBDIR += plan
SUBDIR += sliderule

105
deskutils/notebook/Makefile Normal file
View File

@ -0,0 +1,105 @@
# New ports collection makefile for: Notebook
# Date created: 14 June 2000
# Whom: Mario S F Ferreira <lioux@linf.unb.br> et al.
#
# $FreeBSD$
#
PORTNAME= notebook
PORTVERSION= 1.0.1
CATEGORIES= deskutils
MASTER_SITES= ftp://ftp.newplanetsoftware.com/pub/notebook/source/
DISTNAME= Notebook_source-${PORTVERSION}
MAINTAINER= lioux@linf.unb.br
BUILD_DEPENDS= nonexistent:${JXPORT}:configure \
makemake:${JXPORT}
LIB_DEPENDS= jx-1_5_3.1:${JXPORT} \
jtoolbar-0_5_4.0:${PORTSDIR}/x11-toolkits/libjtoolbar \
jtree-1_1_7.1:${PORTSDIR}/x11-toolkits/libjtree
WRKSRC= ${WRKDIR}/JX-1.5.3
USE_XLIB= yes
USE_GMAKE= yes
MAKE_ARGS= CC="${CC}" CXX="${CXX}" \
CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
MAKE_ENV= JX_INSTALL_ROOT="${X11BASE}/bin" \
JX_LIB_ROOT="${X11BASE}/lib"
PLIST_SUB= PORTNAME="${PORTNAME}"
# Make environment
PORTINCLUDES= -I${X11BASE}/include/jx \
-I${X11BASE}/include/jcore \
-I${X11BASE}/include/jtoolbar \
-I${X11BASE}/include/jtree
# Installs dir with proper permissions
INSTALL_DATA_DIR= ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755
# program files
PROGRAMFILES= notebook/notebook
# documents
DOCFILES= LICENSE README.binary
DOCDIR_PREFIX= ${PREFIX}/share/doc/${PORTNAME}
# additional configuration and header files
EXTRALIB_PREFIX= ${X11BASE}/lib/jx
EXTRALIBFILES_MAKE_WRKSRC= include/make
# main jx distribution files needed for building
COPY_JXDIRS= include
COPY_JXFILES= Makefile
# main jx distribution port wrksrc
JXPORT= ${PORTSDIR}/x11-toolkits/jx
JXPORT_WRKSRC= ${JXPORT}/work/JX-1.5.3
JX_MAKE_CONSTANTS= jtoolbar_constants jtree_constants
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 300000
ALL_TARGET= freebsd3.x
.else
ALL_TARGET= freebsd2.x
.endif
.if defined(NOPORTDOCS)
PLIST_SUB+= PORTDOCS:="@comment "
.else
PLIST_SUB+= PORTDOCS:=
.endif # !defined(NOPORTDOCS)
post-extract:
.for i in ${COPY_JXDIRS}
@${CP} -Rp ${JXPORT_WRKSRC}/${i} ${WRKSRC}
.endfor
.for i in ${COPY_JXFILES}
@${CP} -p ${JXPORT_WRKSRC}/${i} ${WRKSRC}
.endfor
post-patch:
@${ECHO} "SEARCHDIRS += ${PORTINCLUDES}" >> \
${WRKSRC}/${EXTRALIBFILES_MAKE_WRKSRC}/jx_constants
pre-build:
.for i in ${JX_MAKE_CONSTANTS}
@${LN} -sf ${EXTRALIB_PREFIX}/make/${i} ${WRKSRC}/include/make
.endfor
post-build:
@cd ${WRKSRC}/programs/${PORTNAME}; ${SETENV} ${MAKE_ENV} makemake; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS}
do-install:
.if !defined(NOPORTDOCS)
# Install all documentation
@${INSTALL_DATA_DIR} ${DOCDIR_PREFIX}
.for i in ${DOCFILES}
@${INSTALL_DATA} ${WRKSRC}/programs/${PORTNAME}/${i} ${DOCDIR_PREFIX}
.endfor
.endif # !defined(NOPORTDOCS)
# Install all programs
.for i in ${PROGRAMFILES}
@${INSTALL_PROGRAM} ${WRKSRC}/programs/${i} ${PREFIX}/bin
.endfor
.include <bsd.port.post.mk>

View File

@ -0,0 +1 @@
MD5 (Notebook_source-1.0.1.tar.gz) = 124b6ebb276db6e4f82b24e0316e3802

View File

@ -0,0 +1,28 @@
--- Makefile.orig Sat Sep 11 17:44:38 1999
+++ Makefile Wed Jun 14 01:07:15 2000
@@ -262,25 +262,11 @@
freebsd2.x: prep
@ln -s sys/FreeBSD-2.x_g++ \
include/make/jx_config
- @ln -s ../../include/missing_proto/jMissingProto_empty.h \
- include/jcore/jMissingProto.h
- @ln -s config-freebsd.h \
- ACE/ACE_wrappers/ace/config.h
- @ln -s platform_freebsd.GNU \
- ACE/ACE_wrappers/include/makeinclude/platform_macros.GNU
- @${INSTALL_CMD}
.PHONY : freebsd3.x
freebsd3.x: prep
@ln -s sys/FreeBSD-3.x_g++ \
include/make/jx_config
- @ln -s ../../include/missing_proto/jMissingProto_empty.h \
- include/jcore/jMissingProto.h
- @ln -s config-freebsd-pthread.h \
- ACE/ACE_wrappers/ace/config.h
- @ln -s platform_freebsd_pthread.GNU \
- ACE/ACE_wrappers/include/makeinclude/platform_macros.GNU
- @${INSTALL_CMD}
#
# SunOS 4.x

View File

@ -0,0 +1,11 @@
--- include/make/sys/FreeBSD-2.x_g++.orig Wed Jun 14 01:44:51 2000
+++ include/make/sys/FreeBSD-2.x_g++ Wed Jun 14 01:45:00 2000
@@ -35,7 +35,7 @@
# Comment this out if ACE or other code gives you warnings that
# you can't avoid.
-J_DIE_ON_WARNING := -Werror
+#J_DIE_ON_WARNING := -Werror
# Uncomment this if istrstream is broken. One way to check is to run
# testjcore/testJFileArray.

View File

@ -0,0 +1,11 @@
--- include/make/sys/FreeBSD-3.x_g++.orig Wed Jun 14 01:44:51 2000
+++ include/make/sys/FreeBSD-3.x_g++ Wed Jun 14 01:45:00 2000
@@ -35,7 +35,7 @@
# Comment this out if ACE or other code gives you warnings that
# you can't avoid.
-J_DIE_ON_WARNING := -Werror
+#J_DIE_ON_WARNING := -Werror
# Uncomment this if istrstream is broken. One way to check is to run
# testjcore/testJFileArray.

View File

@ -0,0 +1,44 @@
--- programs/notebook/Make.header.orig Mon Oct 4 20:49:51 1999
+++ programs/notebook/Make.header Wed Jun 14 23:46:30 2000
@@ -14,13 +14,14 @@
# Directories to search for header files
-SEARCHDIRS := -I- \
+SEARCHDIRS = -I- \
-I${CODEDIR} \
-I${TREEDIR} \
-I${TOOLBARDIR} \
-I${JCOREDIR} \
-I${JXDIR} \
- -I${ACE_ROOT}
+ -I${ACE_ROOT} \
+ ${J_X11_INCLUDE_DIR}
# other constants
@@ -37,15 +38,6 @@
# library dependencies
-ifdef J_BUILD_SHARED_LIB
- LIB_DEPS := ${JLIBDIR}/libjtree-${JTREE_LIB_VERSION}.so \
- ${JLIBDIR}/libjtoolbar-${JTOOLBAR_LIB_VERSION}.so
-# ${JLIBDIR}/libjsearch-${JSEARCH_LIB_VERSION}.so
-else
- LIB_DEPS := ${JLIBDIR}/libjtree-${JTREE_LIB_VERSION}.a \
- ${JLIBDIR}/libjtoolbar-${JTOOLBAR_LIB_VERSION}.a
-# ${JLIBDIR}/libjsearch-${JSEARCH_LIB_VERSION}.a
-endif
# make variables
@@ -64,7 +56,7 @@
#####
.PHONY : default
-default: libs notebook
+default: notebook
.PHONY : Makefiles
Makefiles:

View File

@ -0,0 +1 @@
Organizer for storing information and to-do lists

View File

@ -0,0 +1,9 @@
Buzzer Electronic Notebook
Nothing is more annoying than trying to find the piece of information
that you need. If you have as many projects as we do, it rivals
the task of searching the Web! Buzzer is designed to solve this
problem by providing a single place to store all your information,
notes, tidbits, and to-do lists.
WWW: http://www.newplanetsoftware.com/notebook/

View File

@ -0,0 +1,4 @@
bin/notebook
%%PORTDOCS:%%share/doc/%%PORTNAME%%/LICENSE
%%PORTDOCS:%%share/doc/%%PORTNAME%%/README.binary
%%PORTDOCS:%%@dirrm share/doc/%%PORTNAME%%