- Update to 1.9.0 [1][2]
- Sort option handlers in alphabetical order - Turn PYTHON option off by default due to the change in devel/py-setuptools r1.23 [3] - Move post-patch: upwards - Pet portlint - Cosmetic change [3] http://www.freebsd.org/cgi/cvsweb.cgi/ports/devel/py-setuptools/Makefile.diff?r1=1.22;r2=1.23;f=h Changes: http://trac.osgeo.org/gdal/wiki/Release/1.9.0-News PR: ports/164468 [1], ports/167277 [2] Submitted by: lbartoletti <coder@tuxfamily.org> [1] Muhammad Moinur Rahman <5u623l20@gmail.com> [2]
This commit is contained in:
parent
e5a36098a3
commit
4bff8408e3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=296949
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= gdal
|
||||
PORTVERSION= 1.8.1
|
||||
PORTREVISION= 5
|
||||
PORTVERSION= 1.9.0
|
||||
CATEGORIES= graphics geography
|
||||
MASTER_SITES= http://download.osgeo.org/gdal/ \
|
||||
ftp://ftp.remotesensing.org/pub/gdal/ \
|
||||
@ -17,7 +16,6 @@ MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= A translator library for geospatial data formats
|
||||
|
||||
CONFIGURE_ARGS= --datadir=${DATADIR} --with-libz=/usr
|
||||
CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
|
||||
GNU_CONFIGURE= yes
|
||||
LDFLAGS+= -L${LOCALBASE}
|
||||
MAKEFILE= GNUmakefile
|
||||
@ -26,10 +24,6 @@ USE_AUTOTOOLS= libtool
|
||||
USE_GMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
|
||||
.endif
|
||||
|
||||
OPTIONS= CFITSIO "FITS support" off \
|
||||
CURL "Curl support" off \
|
||||
ECW "ECW & JPEG2000 support (THREAD required)" off \
|
||||
@ -50,7 +44,7 @@ OPTIONS= CFITSIO "FITS support" off \
|
||||
PHP "PHP support" off \
|
||||
PNG "PNG support" on \
|
||||
PROJ "Projection support via proj" off \
|
||||
PYTHON "Python support" on \
|
||||
PYTHON "Python support" off \
|
||||
RUBY "Ruby support" off \
|
||||
SQLITE "SQLite support" off \
|
||||
THREAD "Thread support" off \
|
||||
@ -63,135 +57,145 @@ XERCES_PORT?= textproc/xerces-c3
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
|
||||
.endif
|
||||
|
||||
.if defined(WITH_NETCDF) && (${NETCDF_VER} == "4")
|
||||
WITH_HDF5= yes
|
||||
HDF5_VER= 18
|
||||
.endif
|
||||
|
||||
.if defined(WITH_CFITSIO)
|
||||
LIB_DEPENDS+= cfitsio.0:${PORTSDIR}/astro/cfitsio
|
||||
CONFIGURE_ARGS+= --with-cfitsio=${LOCALBASE}
|
||||
LIB_DEPENDS+= cfitsio.0:${PORTSDIR}/astro/cfitsio
|
||||
CONFIGURE_ARGS+=--with-cfitsio=${LOCALBASE}
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-cfitsio=no
|
||||
CONFIGURE_ARGS+=--with-cfitsio=no
|
||||
.endif
|
||||
|
||||
.if defined(WITH_CURL)
|
||||
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
|
||||
CONFIGURE_ARGS+= --with-curl=${LOCALBASE}/bin/curl-config
|
||||
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
|
||||
CONFIGURE_ARGS+=--with-curl=${LOCALBASE}/bin/curl-config
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-curl=no
|
||||
CONFIGURE_ARGS+=--with-curl=no
|
||||
.endif
|
||||
|
||||
.if defined(WITH_EXPAT)
|
||||
LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
|
||||
CONFIGURE_ARGS+= --with-expat=${LOCALBASE} \
|
||||
--with-expat-inc=${LOCALBASE}/include \
|
||||
--with-expat-lib=-lexpat
|
||||
LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
|
||||
CONFIGURE_ARGS+=--with-expat=${LOCALBASE} \
|
||||
--with-expat-inc=${LOCALBASE}/include \
|
||||
--with-expat-lib=-lexpat
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-expat=no
|
||||
CONFIGURE_ARGS+=--with-expat=no
|
||||
.endif
|
||||
|
||||
.if defined(WITH_GEOS)
|
||||
LIB_DEPENDS+= geos.0:${PORTSDIR}/graphics/geos
|
||||
CONFIGURE_ARGS+= --with-geos=${LOCALBASE}/bin/geos-config
|
||||
LIB_DEPENDS+= geos.0:${PORTSDIR}/graphics/geos
|
||||
CONFIGURE_ARGS+=--with-geos=${LOCALBASE}/bin/geos-config
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-geos=no
|
||||
CONFIGURE_ARGS+=--with-geos=no
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_GEOTIFF)
|
||||
LIB_DEPENDS+= geotiff.3:${PORTSDIR}/graphics/libgeotiff
|
||||
CONFIGURE_ARGS+= --with-geotiff=${LOCALBASE}
|
||||
LIB_DEPENDS+= geotiff.3:${PORTSDIR}/graphics/libgeotiff
|
||||
CONFIGURE_ARGS+=--with-geotiff=${LOCALBASE}
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_GIF)
|
||||
LIB_DEPENDS+= gif.5:${PORTSDIR}/graphics/giflib
|
||||
CONFIGURE_ARGS+= --with-gif=${LOCALBASE}
|
||||
LIB_DEPENDS+= gif.5:${PORTSDIR}/graphics/giflib
|
||||
CONFIGURE_ARGS+=--with-gif=${LOCALBASE}
|
||||
.endif
|
||||
|
||||
.if defined(WITH_GRASS)
|
||||
GRASS_INST_DIR= grass
|
||||
CONFIGURE_ARGS+= --with-grass=${LOCALBASE}/${GRASS_INST_DIR} \
|
||||
--with-grasslib=${LOCALBASE}/${GRASS_INST_DIR}/lib
|
||||
GRASS_INST_DIR?=grass
|
||||
BUILD_DEPENDS+= grass>=0:${PORTSDIR}/databases/grass
|
||||
RUN_DEPENDS+= grass>=0:${PORTSDIR}/databases/grass
|
||||
CONFIGURE_ARGS+=--with-grass=${LOCALBASE}/${GRASS_INST_DIR} \
|
||||
--with-grasslib=${LOCALBASE}/${GRASS_INST_DIR}/lib
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-grass=no
|
||||
CONFIGURE_ARGS+=--with-grass=no
|
||||
.endif
|
||||
|
||||
.if defined(WITH_HDF4)
|
||||
LIB_DEPENDS+= mfhdf.3:${PORTSDIR}/science/hdf
|
||||
CONFIGURE_ARGS+= --with-hdf4=${LOCALBASE}
|
||||
LIB_DEPENDS+= mfhdf.3:${PORTSDIR}/science/hdf
|
||||
CONFIGURE_ARGS+=--with-hdf4=${LOCALBASE}
|
||||
.endif
|
||||
|
||||
.if defined(WITH_HDF5)
|
||||
.if (${NETCDF_VER} == "4")
|
||||
LIB_DEPENDS+= hdf5.7:${PORTSDIR}/science/hdf5-18
|
||||
LIB_DEPENDS+= hdf5.7:${PORTSDIR}/science/hdf5-18
|
||||
.else
|
||||
LIB_DEPENDS+= hdf5.0:${PORTSDIR}/science/hdf5
|
||||
LIB_DEPENDS+= hdf5.0:${PORTSDIR}/science/hdf5
|
||||
.endif
|
||||
CONFIGURE_ARGS+= --with-hdf5=${LOCALBASE}
|
||||
CONFIGURE_ARGS+=--with-hdf5=${LOCALBASE}
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_JASPER)
|
||||
LIB_DEPENDS+= jasper.4:${PORTSDIR}/graphics/jasper
|
||||
CONFIGURE_ARGS+= --with-jasper=${LOCALBASE}
|
||||
LIB_DEPENDS+= jasper.4:${PORTSDIR}/graphics/jasper
|
||||
CONFIGURE_ARGS+=--with-jasper=${LOCALBASE}
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_JPEG)
|
||||
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
|
||||
CONFIGURE_ARGS+= --with-jpeg=${LOCALBASE}
|
||||
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
|
||||
CONFIGURE_ARGS+=--with-jpeg=${LOCALBASE}
|
||||
.endif
|
||||
|
||||
.if defined(WITH_MYSQL)
|
||||
USE_MYSQL= yes
|
||||
CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}/bin/mysql_config
|
||||
USE_MYSQL= yes
|
||||
CONFIGURE_ARGS+=--with-mysql=${LOCALBASE}/bin/mysql_config
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-mysql=no
|
||||
CONFIGURE_ARGS+=--with-mysql=no
|
||||
.endif
|
||||
|
||||
.if defined(WITH_NETCDF)
|
||||
.if (${NETCDF_VER} == "4")
|
||||
LIB_DEPENDS+= netcdf.7:${PORTSDIR}/science/netcdf4
|
||||
LIB_DEPENDS+= netcdf.7:${PORTSDIR}/science/netcdf4
|
||||
.else
|
||||
LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
|
||||
LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
|
||||
.endif
|
||||
CONFIGURE_ARGS+= --with-netcdf=${LOCALBASE}
|
||||
CONFIGURE_ARGS+=--with-netcdf=${LOCALBASE}
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-netcdf=no
|
||||
CONFIGURE_ARGS+=--with-netcdf=no
|
||||
.endif
|
||||
|
||||
.if defined(WITH_ODBC)
|
||||
LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
|
||||
CONFIGURE_ARGS+= --with-odbc=${LOCALBASE}
|
||||
LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
|
||||
CONFIGURE_ARGS+=--with-odbc=${LOCALBASE}
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-odbc=no
|
||||
CONFIGURE_ARGS+=--with-odbc=no
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PERL)
|
||||
USE_PERL5= yes
|
||||
CONFIGURE_ARGS+= --with-perl
|
||||
USE_PERL5= yes
|
||||
CONFIGURE_ARGS+=--with-perl
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PGSQL)
|
||||
USE_PGSQL= yes
|
||||
CONFIGURE_ARGS+= --with-pg=${LOCALBASE}/bin/pg_config
|
||||
USE_PGSQL= yes
|
||||
CONFIGURE_ARGS+=--with-pg=${LOCALBASE}/bin/pg_config
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-pg=no
|
||||
CONFIGURE_ARGS+=--with-pg=no
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PHP)
|
||||
USE_PHP= yes
|
||||
CONFIGURE_ARGS+= --with-php
|
||||
USE_PHP= yes
|
||||
CONFIGURE_ARGS+=--with-php
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_PNG)
|
||||
LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
|
||||
CONFIGURE_ARGS+= --with-png=${LOCALBASE}
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PROJ)
|
||||
LIB_DEPENDS+= proj.7:${PORTSDIR}/graphics/proj
|
||||
CONFIGURE_ARGS+= --with-static-proj4=${LOCALBASE}
|
||||
LIB_DEPENDS+= proj.7:${PORTSDIR}/graphics/proj
|
||||
CONFIGURE_ARGS+=--with-static-proj4=${LOCALBASE}
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-static-proj4=no
|
||||
CONFIGURE_ARGS+=--with-static-proj4=no
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_PYTHON)
|
||||
USE_PYTHON= yes
|
||||
.include "${PORTSDIR}/Mk/bsd.python.mk"
|
||||
CONFIGURE_ARGS+= --with-python
|
||||
|
||||
BUILD_DEPENDS+= ${PYEASYINSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
|
||||
@ -212,14 +216,8 @@ PLIST_SUB+= PYEASYINSTALL_EGG=${PYEASYINSTALL_EGG} PYTHON=""
|
||||
PLIST_SUB+= PYTHON="@comment "
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_PNG)
|
||||
LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
|
||||
CONFIGURE_ARGS+= --with-png=${LOCALBASE}
|
||||
.endif
|
||||
|
||||
.if defined(WITH_RUBY)
|
||||
USE_RUBY= yes
|
||||
.include "${PORTSDIR}/Mk/bsd.ruby.mk"
|
||||
CONFIGURE_ARGS+= --with-ruby
|
||||
.endif
|
||||
|
||||
@ -263,28 +261,28 @@ CONFIGURE_ARGS+= --with-xerces=no
|
||||
.endif
|
||||
|
||||
.if defined(WITH_HDF4) && defined(WITH_HDF5)
|
||||
IGNORE= You can't use HDF4 with HDF5.
|
||||
.endif
|
||||
|
||||
pre-build:
|
||||
.if defined(WITH_PYTHON)
|
||||
@(cd ${BUILD_WRKSRC}/swig/python; \
|
||||
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} setopt -c build -o build-platlib -s lib.${PYEASYINSTALL_OSARCH:S/^-//}; \
|
||||
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} setopt -c build -o build-temp -s temp.${PYEASYINSTALL_OSARCH:S/^-//}-${PYTHON_VER}; \
|
||||
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} setopt -c bdist_egg -o plat-name -s ${PYEASYINSTALL_OSARCH:S/^-//}; \
|
||||
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} setopt -c bdist -o plat-name -s ${PYEASYINSTALL_OSARCH:S/^-//})
|
||||
IGNORE= you cannot use HDF4 with HDF5
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
.if defined(WITH_PYTHON)
|
||||
@${REINPLACE_CMD} -e '\
|
||||
s,%%MAKE_ENV%%,${MAKE_ENV},; \
|
||||
s,%%PYTHON_SITELIBDIR%%,${PYTHON_SITELIBDIR},; \
|
||||
s,%%PYEASYINSTALL_BINDIR%%,${PYEASYINSTALL_BINDIR},; \
|
||||
s,%%PYEASYINSTALL_SITELIBDIR%%,${PYEASYINSTALL_SITELIBDIR},; \
|
||||
s,%%PYEASYINSTALL_EGG%%,${PYEASYINSTALL_EGG},; \
|
||||
s,%%WRKSRC%%,${WRKSRC},; \
|
||||
' ${WRKSRC}/swig/python/GNUmakefile
|
||||
@${REINPLACE_CMD} \
|
||||
-e 's|%%MAKE_ENV%%|${MAKE_ENV}|' \
|
||||
-e 's|%%PYTHON_SITELIBDIR%%|${PYTHON_SITELIBDIR}|' \
|
||||
-e 's|%%PYEASYINSTALL_BINDIR%%|${PYEASYINSTALL_BINDIR}|' \
|
||||
-e 's|%%PYEASYINSTALL_SITELIBDIR%%|${PYEASYINSTALL_SITELIBDIR}|' \
|
||||
-e 's|%%PYEASYINSTALL_EGG%%|${PYEASYINSTALL_EGG}|' \
|
||||
-e 's|%%WRKSRC%%|${WRKSRC}|' \
|
||||
${WRKSRC}/swig/python/GNUmakefile
|
||||
.endif
|
||||
|
||||
post-build:
|
||||
.if defined(WITH_PYTHON)
|
||||
@cd ${BUILD_WRKSRC}/swig/python/ && \
|
||||
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} setopt -c build -o build-platlib -s lib.${PYEASYINSTALL_OSARCH:S/^-//} && \
|
||||
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} setopt -c build -o build-temp -s temp.${PYEASYINSTALL_OSARCH:S/^-//}-${PYTHON_VER} && \
|
||||
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} setopt -c bdist_egg -o plat-name -s ${PYEASYINSTALL_OSARCH:S/^-//} && \
|
||||
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} setopt -c bdist -o plat-name -s ${PYEASYINSTALL_OSARCH:S/^-//}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (gdal-1.8.1.tar.gz) = d5d76b85b4a7a0e28ead6c92be0eba9e2b2361a06db0a60ef0fb85db63e7a5df
|
||||
SIZE (gdal-1.8.1.tar.gz) = 8852355
|
||||
SHA256 (gdal-1.9.0.tar.gz) = 38e094ae453bb85b25f735aa167b740ec9d9185306cb465f608f827e6be158c7
|
||||
SIZE (gdal-1.9.0.tar.gz) = 9435584
|
||||
|
15
graphics/gdal/files/patch-configure
Normal file
15
graphics/gdal/files/patch-configure
Normal file
@ -0,0 +1,15 @@
|
||||
--- configure.orig 2011-12-23 09:51:45.000000000 +0800
|
||||
+++ configure 2011-12-23 15:30:42.540316668 +0800
|
||||
@@ -21140,10 +21140,10 @@
|
||||
if { test -x "$ncdump"; }; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking libnetcdf version with $ncdump" >&5
|
||||
$as_echo_n "checking libnetcdf version with $ncdump... " >&6; }
|
||||
- netcdf_version=`$ncdump 2>&1 | grep "netcdf library version" | awk '{gsub(/"/,"");print $4}'`
|
||||
+ netcdf_version=`$ncdump 2>&1 | grep "netcdf library version" | awk '{gsub(/"/,"");print $4}' | sed 's|^\(.\).*$|\1|'`
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: got $netcdf_version" >&5
|
||||
$as_echo "got $netcdf_version" >&6; }
|
||||
- if test "$netcdf_version" != "" -a "${netcdf_version:0:1}" == "4" ; then
|
||||
+ if test "$netcdf_version" != "" -a "${netcdf_version}" == "4" ; then
|
||||
nc_config=$NETCDF_ROOT"/bin/nc-config"
|
||||
fi
|
||||
fi
|
@ -28,6 +28,7 @@ bin/gdalenhance
|
||||
bin/gdalinfo
|
||||
bin/gdallocationinfo
|
||||
bin/gdalmanage
|
||||
bin/gdalsrsinfo
|
||||
bin/gdaltindex
|
||||
bin/gdaltransform
|
||||
bin/gdalwarp
|
||||
@ -40,7 +41,6 @@ bin/ogrtindex
|
||||
%%PYTHON%%bin/rgb2pct.py
|
||||
bin/testepsg
|
||||
include/cpl_atomic_ops.h
|
||||
include/cpl_base64.h
|
||||
include/cpl_config.h
|
||||
include/cpl_config_extras.h
|
||||
include/cpl_conv.h
|
||||
@ -96,7 +96,7 @@ include/vrtdataset.h
|
||||
lib/libgdal.a
|
||||
lib/libgdal.la
|
||||
lib/libgdal.so
|
||||
lib/libgdal.so.16
|
||||
lib/libgdal.so.17
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
|
||||
@ -163,14 +163,19 @@ lib/libgdal.so.16
|
||||
%%DATADIR%%/ecw_cs.wkt
|
||||
%%DATADIR%%/ellipsoid.csv
|
||||
%%DATADIR%%/epsg.wkt
|
||||
%%DATADIR%%/esri_StatePlane_extra.wkt
|
||||
%%DATADIR%%/esri_Wisconsin_extra.wkt
|
||||
%%DATADIR%%/esri_extra.wkt
|
||||
%%DATADIR%%/gcs.csv
|
||||
%%DATADIR%%/gcs.override.csv
|
||||
%%DATADIR%%/gdal_datum.csv
|
||||
%%DATADIR%%/gdalicon.png
|
||||
%%DATADIR%%/geoccs.csv
|
||||
%%DATADIR%%/gt_datum.csv
|
||||
%%DATADIR%%/gt_ellips.csv
|
||||
%%DATADIR%%/header.dxf
|
||||
%%DATADIR%%/nitf_spec.xml
|
||||
%%DATADIR%%/nitf_spec.xsd
|
||||
%%DATADIR%%/pci_datum.txt
|
||||
%%DATADIR%%/pci_ellips.txt
|
||||
%%DATADIR%%/pcs.csv
|
||||
|
Loading…
Reference in New Issue
Block a user