Update to 4.01, which has several new screensavers, and the usual

assortment of bugs fixed. The author has incorporated several of
our patches, so I can reduce or eliminate them. However, I had
to add one small patch to get -lcompat into one of the new
screensavers.

In addition to the upgrade, I'm also reverting most of the recent
gnome changes in favor of forcing the xml files into one location
regardless of gnome/not gnome. I think long term this will be
a better strategy.
This commit is contained in:
Doug Barton 2002-02-25 10:10:16 +00:00
parent 5e9116e2ae
commit 4b95408e97
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=55225
6 changed files with 210 additions and 431 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= xscreensaver
PORTVERSION= 4.00
PORTREVISION= 2
PORTVERSION= 4.01
CATEGORIES?= x11
MASTER_SITES= http://www.jwz.org/xscreensaver/
@ -55,11 +54,17 @@ MAN1= attraction.1 blitspin.1 bouboule.1 braid.1 \
xscreensaver-gl-helper.1 xscreensaver.1 xsublim.1 xteevee.1 \
zoom.1 molecule.1 rotzoomer.1 bumps.1 xscreensaver-getimage.1 \
xscreensaver-getimage-file.1 xscreensaver-getimage-video.1 \
speedmine.1 whirlygig.1 penetrate.1
speedmine.1 whirlygig.1 penetrate.1 glforestfire.1 \
glsnake.1 sballs.1 twang.1 xspirograph.1
post-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "*.[ch]" | xargs ${PERL} -pi -e \
's|malloc\.h|stdlib.h|g'
@ ${CP} ${WRKSRC}/configure ${WRKSRC}/configure.Patched
@ ${SED} -e 's#-lpthread#${PTHREAD_LIBS}#g' \
${WRKSRC}/configure.Patched > ${WRKSRC}/configure
.for file in extrusion.c
@ ${CP} ${WRKSRC}/hacks/glx/${file} ${WRKSRC}/hacks/glx/${file}.Dist
@ ${SED} -e 's/malloc.h/stdlib.h/g' ${WRKSRC}/hacks/glx/${file}.Dist > \
${WRKSRC}/hacks/glx/${file}
.endfor
.include <bsd.port.post.mk>

View File

@ -1 +1 @@
MD5 (xscreensaver-4.00.tar.gz) = 4745690b32b4d85741dfafedb565feb2
MD5 (xscreensaver-4.01.tar.gz) = 8d7c8b9620dfaccfb876380995af259b

View File

@ -1,283 +1,23 @@
--- configure.orig Wed Jan 2 02:15:22 2002
+++ configure Wed Feb 13 12:55:17 2002
@@ -3270,253 +3270,2 @@
--- configure.Dist Sun Feb 24 01:56:28 2002
+++ configure Sun Feb 24 22:45:24 2002
@@ -10309,13 +10309,13 @@
-
- echo $ac_n "checking for X app-defaults directory""... $ac_c" 1>&6
-echo "configure:3285: checking for X app-defaults directory" >&5
-if eval "test \"`echo '$''{'ac_cv_x_app_defaults'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
-else
-
- rm -fr conftestdir
- if mkdir conftestdir; then
- cd conftestdir >&-
- # Make sure to not put "make" in the Imakefile rules, since we grep it out.
- cat > Imakefile <<'EOF'
-acfindx:
- @echo 'ac_x_app_defaults="${XAPPLOADDIR}"'
-EOF
- if (xmkmf) >/dev/null 2>/dev/null && test -f Makefile; then
- # GNU make sometimes prints "make[1]: Entering...", which'd confuse us.
- eval `${MAKE-make} acfindx 2>/dev/null | grep -v make`
- fi
- cd .. >&-
- rm -fr conftestdir
# Now that we know whether we have Gnome, we can decide where the XML
# config files get installed.
-if test -z "$HACK_CONF_DIR" ; then
- if test -n "$GNOME_DATADIR" ; then
- HACK_CONF_DIR='${GNOME_DATADIR}/control-center/screensavers'
- else
- HACK_CONF_DIR='${prefix}/lib/xscreensaver/config'
- fi
- if test x"$ac_x_app_defaults" = x; then
-
- # Look for the directory under a standard set of common directories.
- # Check X11 before X11Rn because it's often a symlink to the current release.
- for ac_dir in \
- /usr/X11/lib/app-defaults \
- /usr/X11R6/lib/app-defaults \
- /usr/X11R6/lib/X11/app-defaults \
- /usr/X11R5/lib/app-defaults \
- /usr/X11R5/lib/X11/app-defaults \
- /usr/X11R4/lib/app-defaults \
- /usr/X11R4/lib/X11/app-defaults \
- \
- /usr/lib/X11/app-defaults \
- /usr/lib/X11R6/app-defaults \
- /usr/lib/X11R5/app-defaults \
- /usr/lib/X11R4/app-defaults \
- \
- /usr/local/X11/lib/app-defaults \
- /usr/local/X11R6/lib/app-defaults \
- /usr/local/X11R5/lib/app-defaults \
- /usr/local/X11R4/lib/app-defaults \
- \
- /usr/local/lib/X11/app-defaults \
- /usr/local/lib/X11R6/app-defaults \
- /usr/local/lib/X11R6/X11/app-defaults \
- /usr/local/lib/X11R5/app-defaults \
- /usr/local/lib/X11R5/X11/app-defaults \
- /usr/local/lib/X11R4/app-defaults \
- /usr/local/lib/X11R4/X11/app-defaults \
- \
- /usr/X386/lib/X11/app-defaults \
- /usr/x386/lib/X11/app-defaults \
- /usr/XFree86/lib/X11/app-defaults \
- \
- /usr/lib/X11/app-defaults \
- /usr/local/lib/X11/app-defaults \
- /usr/unsupported/lib/X11/app-defaults \
- /usr/athena/lib/X11/app-defaults \
- /usr/local/x11r5/lib/X11/app-defaults \
- /usr/lpp/Xamples/lib/X11/app-defaults \
- /lib/usr/lib/X11/app-defaults \
- \
- /usr/openwin/lib/app-defaults \
- /usr/openwin/lib/X11/app-defaults \
- /usr/openwin/share/lib/app-defaults \
- /usr/openwin/share/lib/X11/app-defaults \
- \
- /X11R6/lib/app-defaults \
- /X11R5/lib/app-defaults \
- /X11R4/lib/app-defaults \
- ; \
- do
- if test -d "$ac_dir"; then
- ac_x_app_defaults=$ac_dir
- break
- fi
- done
-
- fi
- if test x"$ac_x_app_defaults" = x; then
- ac_cv_x_app_defaults="/usr/lib/X11/app-defaults"
- else
- # Record where we found app-defaults for the cache.
- ac_cv_x_app_defaults="$ac_x_app_defaults"
- fi
-fi
-
-echo "$ac_t""$ac_cv_x_app_defaults" 1>&6
- eval ac_x_app_defaults="$ac_cv_x_app_defaults"
-case "$host" in
- *-hpux*)
-
- # The following arcana was gleaned from conversations with
- # Eric Schwartz <erics@col.hp.com>:
- #
- # On HPUX 10.x, the parts of X that HP considers "standard" live in
- # /usr/{include,lib}/X11R6/. The parts that HP doesn't consider
- # "standard", notably, Xaw and Xmu, live in /usr/contrib/X11R6/.
- # Yet /usr/contrib/X11R6/ comes preinstalled on all HPUX systems.
- # Also, there are symlinks from /usr/include/ and /usr/lib/ into
- # /usr/{include,lib}/X11R6/, so that (if you don't use Xmu at all)
- # you don't need any -I or -L arguments.
- #
- # On HPUX 9.x, /usr/{include,lib}/X11R5/ and /usr/contrib/X11R5/
- # are the same division as 10.x. However, there are no symlinks to
- # the X stuff from /usr/include/ and /usr/lib/, so -I and -L
- # arguments are always necessary.
- #
- # However, X11R6 was available on HPUX 9.x as a patch: if that
- # patch was installed, then all of X11R6 went in to
- # /usr/contrib/X11R6/ (there was no /usr/{include,lib}/X11R6/.)
- #
- # HPUX 8.x was the same as 9.x, but was X11R4 instead (I don't know
- # whether R5 was available as a patch; R6 undoubtedly was not.)
- #
- # So. We try and use the highest numbered pair of
- # /usr/{include,lib}/X11R?/ and /usr/contrib/X11R?/{include,lib}/
- # that are available. We do not mix and match different versions
- # of X.
- #
- # Question I still don't know the answer to: (do you?)
- #
- # * On HPUX 9.x, where /usr/include/X11R5/ was standard, and
- # /usr/contrib/X11R6/ could be installed as a patch, what was in
- # that contrib directory? Did it contain so-called "standard"
- # X11R6, or did it include Xaw and Xmu as well? If the former,
- # where did one find Xaw and Xmu on 9.x R6 systems? Would this
- # be a situation where one had to reach into the R5 headers and
- # libs to find Xmu? That is, must both R6 and R5 directories
- # be on the -I and -L lists in that case?
- #
- for version in X11R6 X11R5 X11R4 ; do
- # if either pair of directories exists...
- if test -d /usr/include/$version || test -d /usr/contrib/$version/include
- then
- # if contrib exists, use it...
- if test -d /usr/contrib/$version/include ; then
- X_CFLAGS="$X_CFLAGS -I/usr/contrib/$version/include"
- X_LIBS="$X_LIBS -L/usr/contrib/$version/lib"
- fi
- # if the "standard" one exists, use it.
- if test -d /usr/include/$version ; then
- X_CFLAGS="$X_CFLAGS -I/usr/include/$version"
- X_LIBS="$X_LIBS -L/usr/lib/$version"
- fi
- # since at least one of the pair exists, go no farther.
- break
- fi
- done
-
- # Now find Motif. Thanks for not making xmkmf find this by
- # default, you losers.
- #
- if test -d /usr/include/Motif2.1 ; then
- X_CFLAGS="$X_CFLAGS -I/usr/include/Motif2.1"
- X_LIBS="$X_LIBS -L/usr/lib/Motif2.1"
- elif test -d /usr/include/Motif1.2 ; then
- X_CFLAGS="$X_CFLAGS -I/usr/include/Motif1.2"
- X_LIBS="$X_LIBS -L/usr/lib/Motif1.2"
- elif test -d /usr/include/Motif1.1 ; then
- X_CFLAGS="$X_CFLAGS -I/usr/include/Motif1.1"
- X_LIBS="$X_LIBS -L/usr/lib/Motif1.1"
- fi
-
- # Now let's check for the pseudo-standard locations for OpenGL and XPM.
- #
- if test -d /opt/graphics/OpenGL/include ; then
- # HP-UX 10.20 puts it here
- X_CFLAGS="-I/opt/graphics/OpenGL/include $X_CFLAGS"
- X_LIBS="-L/opt/graphics/OpenGL/lib $X_LIBS"
- elif test -d /opt/Mesa/lib ; then
- X_CFLAGS="-I/opt/Mesa/include $X_CFLAGS"
- X_LIBS="-L/opt/Mesa/lib $X_LIBS"
- fi
-
-
- if test -d /opt/xpm/lib/X11 ; then
- X_CFLAGS="-I/opt/xpm/include $X_CFLAGS"
- X_LIBS="-L/opt/xpm/lib/X11 $X_LIBS"
- fi
-
- # On HPUX, default to installing in /opt/xscreensaver/ instead of
- # in /usr/local/, unless there is already an xscreensaver in
- # /usr/local/bin/. This can be overridden with the --prefix arg
- # to configure. I'm not sure this is the right thing to do, but
- # Richard Lloyd says so...
- #
- if test \! -x /usr/local/bin/xscreensaver ; then
- ac_default_prefix=/opt/xscreensaver
- fi
-
- ;;
- *-solaris*)
-
- # Thanks for not making xmkmf find this by default, pinheads.
- # And thanks for moving things around again, too. Is this
- # really the standard location now? What happened to the
- # joke that this kind of thing went in /opt?
- # cthomp says "answer: CDE (Common Disorganized Environment)"
- #
- if test -f /usr/dt/include/Xm/Xm.h ; then
- X_CFLAGS="$X_CFLAGS -I/usr/dt/include"
- X_LIBS="$X_LIBS -L/usr/dt/lib -R:/usr/dt/lib"
-
- # Some versions of Slowlaris Motif require -lgen. But not all. Why?
- echo $ac_n "checking for regcmp in -lgen""... $ac_c" 1>&6
-echo "configure:3492: checking for regcmp in -lgen" >&5
-ac_lib_var=`echo gen'_'regcmp | sed 'y%./+-%__p_%'`
-if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
-else
- ac_save_LIBS="$LIBS"
-LIBS="-lgen $LIBS"
-cat > conftest.$ac_ext <<EOF
-#line 3500 "configure"
-#include "confdefs.h"
-/* Override any gcc2 internal prototype to avoid an error. */
-/* We use char because int might match the return type of a gcc2
- builtin and then its argument prototype would still apply. */
-char regcmp();
-
-int main() {
-regcmp()
-; return 0; }
-EOF
-if { (eval echo configure:3511: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- eval "ac_cv_lib_$ac_lib_var=yes"
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- eval "ac_cv_lib_$ac_lib_var=no"
-fi
-rm -f conftest*
-LIBS="$ac_save_LIBS"
-
-fi
-if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
- echo "$ac_t""yes" 1>&6
- X_LIBS="$X_LIBS -lgen"
-else
- echo "$ac_t""no" 1>&6
-fi
-
- fi
- ;;
- esac
echo $ac_n "checking for XPointer""... $ac_c" 1>&6
@@ -6001,3 +5750,3 @@
# from Tim Showalter <tjs+@andrew.cmu.edu>
- PASSWD_LIBS="$PASSWD_LIBS -lkrb -ldes"
+ PASSWD_LIBS="$PASSWD_LIBS -lkrb -ldes -lcom_err"
fi
@@ -7315,4 +7064,4 @@
GNOME_DATADIR=""
- if test "$have_gnome" = yes -a "$have_gtk" = yes; then
- GNOME_DATADIR=`$gnome_config --datadir`
+ if test "$have_gnome" = yes; then
+ GNOME_DATADIR="${prefix}/share/gnome"
fi
@@ -9885,2 +9634,4 @@
HACK_CONF_DIR='${GNOME_DATADIR}/control-center/screensavers'
+ elif test -n "$CONFIGDIR" ; then
+ HACK_CONF_DIR="$CONFIGDIR"
else
@@ -9940,4 +9691,2 @@
+#if test -z "$HACK_CONF_DIR" ; then
+# if test -n "$GNOME_DATADIR" ; then
+# HACK_CONF_DIR='${GNOME_DATADIR}/control-center/screensavers'
+# else
+# HACK_CONF_DIR='${prefix}/lib/xscreensaver/config'
+# fi
+#fi
-APPDEFAULTS=$ac_x_app_defaults
-
@@ -10147,3 +9896,3 @@
s%@HACK_CONF_DIR@%$HACK_CONF_DIR%g
-s%@APPDEFAULTS@%$APPDEFAULTS%g
+s%@APPDEFAULTS@%$libdir/X11/app-defaults%g
s%@DEPEND@%$DEPEND%g
# canonicalize slashes.
HACK_CONF_DIR=`echo "${HACK_CONF_DIR}" | sed 's@/$@@;s@//*@/@g'`

View File

@ -1,7 +1,9 @@
--- driver/Makefile.in.orig Wed Jan 2 02:15:24 2002
+++ driver/Makefile.in Wed Feb 13 13:14:40 2002
@@ -20,3 +20,3 @@
GNOME_CCDIR = $(GNOME_DATADIR)/control-center/Desktop
--- driver/Makefile.in.orig Sun Feb 24 01:56:29 2002
+++ driver/Makefile.in Sun Feb 24 22:48:36 2002
@@ -19,7 +19,7 @@
GNOME_DATADIR = @GNOME_DATADIR@
GNOME_CCDIR_1 = $(GNOME_DATADIR)/control-center/Desktop
GNOME_CCDIR_2 = $(GNOME_DATADIR)/control-center/capplets
-GNOME_PANELDIR = $(GNOME_DATADIR)/gnome/apps/Settings/Desktop
+GNOME_PANELDIR = $(GNOME_DATADIR)/apps/Settings/Desktop
GNOME_ICONDIR = $(GNOME_DATADIR)/pixmaps

View File

@ -0,0 +1,11 @@
--- hacks/glx/Makefile.in.Dist Sun Feb 24 01:56:30 2002
+++ hacks/glx/Makefile.in Sun Feb 24 23:50:55 2002
@@ -374,7 +374,7 @@
$(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(GRAB_OBJS) $(HACK_LIBS)
glsnake: glsnake.o $(HACK_OBJS)
- $(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(HACK_LIBS)
+ $(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(HACK_LIBS) -lcompat
boxed: boxed.o $(HACK_OBJS)
$(CC_HACK) -o $@ $@.o $(HACK_OBJS) $(HACK_LIBS)

View File

@ -7,11 +7,13 @@ bin/xscreensaver-getimage-file
bin/xscreensaver-getimage-video
bin/xscreensaver-gl-helper
bin/xscreensaver-hacks/ant
bin/xscreensaver-hacks/apollonian
bin/xscreensaver-hacks/atlantis
bin/xscreensaver-hacks/attraction
bin/xscreensaver-hacks/blaster
bin/xscreensaver-hacks/blitspin
bin/xscreensaver-hacks/bouboule
bin/xscreensaver-hacks/boxed
bin/xscreensaver-hacks/braid
bin/xscreensaver-hacks/bsod
bin/xscreensaver-hacks/bubble3d
@ -35,6 +37,7 @@ bin/xscreensaver-hacks/distort
bin/xscreensaver-hacks/drift
bin/xscreensaver-hacks/engine
bin/xscreensaver-hacks/epicycle
bin/xscreensaver-hacks/euler2d
bin/xscreensaver-hacks/extrusion
bin/xscreensaver-hacks/fadeplot
bin/xscreensaver-hacks/flag
@ -45,7 +48,9 @@ bin/xscreensaver-hacks/forest
bin/xscreensaver-hacks/galaxy
bin/xscreensaver-hacks/gears
bin/xscreensaver-hacks/gflux
bin/xscreensaver-hacks/glforestfire
bin/xscreensaver-hacks/glplanet
bin/xscreensaver-hacks/glsnake
bin/xscreensaver-hacks/gltext
bin/xscreensaver-hacks/goop
bin/xscreensaver-hacks/grav
@ -59,6 +64,7 @@ bin/xscreensaver-hacks/ifs
bin/xscreensaver-hacks/imsmap
bin/xscreensaver-hacks/interference
bin/xscreensaver-hacks/jigsaw
bin/xscreensaver-hacks/juggle
bin/xscreensaver-hacks/julia
bin/xscreensaver-hacks/kaleidescope
bin/xscreensaver-hacks/kumppa
@ -86,6 +92,7 @@ bin/xscreensaver-hacks/penrose
bin/xscreensaver-hacks/petri
bin/xscreensaver-hacks/phosphor
bin/xscreensaver-hacks/pipes
bin/xscreensaver-hacks/polyominoes
bin/xscreensaver-hacks/pulsar
bin/xscreensaver-hacks/pyro
bin/xscreensaver-hacks/qix
@ -96,6 +103,7 @@ bin/xscreensaver-hacks/rorschach
bin/xscreensaver-hacks/rotor
bin/xscreensaver-hacks/rotzoomer
bin/xscreensaver-hacks/rubik
bin/xscreensaver-hacks/sballs
bin/xscreensaver-hacks/shadebobs
bin/xscreensaver-hacks/sierpinski
bin/xscreensaver-hacks/sierpinski3d
@ -116,8 +124,10 @@ bin/xscreensaver-hacks/strange
bin/xscreensaver-hacks/superquadrics
bin/xscreensaver-hacks/swirl
bin/xscreensaver-hacks/t3d
bin/xscreensaver-hacks/thornbird
bin/xscreensaver-hacks/triangle
bin/xscreensaver-hacks/truchet
bin/xscreensaver-hacks/twang
bin/xscreensaver-hacks/vermiculate
bin/xscreensaver-hacks/vidwhacker
bin/xscreensaver-hacks/vines
@ -145,146 +155,157 @@ lib/X11/app-defaults/XScreenSaver
%%GNOME:%%share/gnome/pixmaps/screensaver-power.xpm
%%GNOME:%%share/gnome/pixmaps/screensaver-snap.xpm
%%GNOME:%%share/gnome/pixmaps/xscreensaver.xpm
%%CONFIGDIR%%/README
%%CONFIGDIR%%/ant.xml
%%CONFIGDIR%%/atlantis.xml
%%CONFIGDIR%%/attraction.xml
%%CONFIGDIR%%/blaster.xml
%%CONFIGDIR%%/blitspin.xml
%%CONFIGDIR%%/bouboule.xml
%%CONFIGDIR%%/braid.xml
%%CONFIGDIR%%/bsod.xml
%%CONFIGDIR%%/bubble3d.xml
%%CONFIGDIR%%/bubbles.xml
%%CONFIGDIR%%/bumps.xml
%%CONFIGDIR%%/cage.xml
%%CONFIGDIR%%/ccurve.xml
%%CONFIGDIR%%/circuit.xml
%%CONFIGDIR%%/compass.xml
%%CONFIGDIR%%/coral.xml
%%CONFIGDIR%%/cosmos.xml
%%CONFIGDIR%%/critical.xml
%%CONFIGDIR%%/crystal.xml
%%CONFIGDIR%%/cynosure.xml
%%CONFIGDIR%%/dangerball.xml
%%CONFIGDIR%%/decayscreen.xml
%%CONFIGDIR%%/deco.xml
%%CONFIGDIR%%/deluxe.xml
%%CONFIGDIR%%/demon.xml
%%CONFIGDIR%%/discrete.xml
%%CONFIGDIR%%/distort.xml
%%CONFIGDIR%%/drift.xml
%%CONFIGDIR%%/electricsheep.xml
%%CONFIGDIR%%/engine.xml
%%CONFIGDIR%%/epicycle.xml
%%CONFIGDIR%%/extrusion.xml
%%CONFIGDIR%%/fadeplot.xml
%%CONFIGDIR%%/flag.xml
%%CONFIGDIR%%/flame.xml
%%CONFIGDIR%%/flipscreen3d.xml
%%CONFIGDIR%%/flow.xml
%%CONFIGDIR%%/forest.xml
%%CONFIGDIR%%/galaxy.xml
%%CONFIGDIR%%/gears.xml
%%CONFIGDIR%%/gflux.xml
%%CONFIGDIR%%/glplanet.xml
%%CONFIGDIR%%/gltext.xml
%%CONFIGDIR%%/goban.xml
%%CONFIGDIR%%/goop.xml
%%CONFIGDIR%%/grav.xml
%%CONFIGDIR%%/greynetic.xml
%%CONFIGDIR%%/halo.xml
%%CONFIGDIR%%/helix.xml
%%CONFIGDIR%%/hopalong.xml
%%CONFIGDIR%%/hyperball.xml
%%CONFIGDIR%%/hypercube.xml
%%CONFIGDIR%%/ifs.xml
%%CONFIGDIR%%/imsmap.xml
%%CONFIGDIR%%/interference.xml
%%CONFIGDIR%%/jigsaw.xml
%%CONFIGDIR%%/julia.xml
%%CONFIGDIR%%/kaleidescope.xml
%%CONFIGDIR%%/kumppa.xml
%%CONFIGDIR%%/lament.xml
%%CONFIGDIR%%/laser.xml
%%CONFIGDIR%%/lightning.xml
%%CONFIGDIR%%/lisa.xml
%%CONFIGDIR%%/lissie.xml
%%CONFIGDIR%%/lmorph.xml
%%CONFIGDIR%%/loop.xml
%%CONFIGDIR%%/maze.xml
%%CONFIGDIR%%/menger.xml
%%CONFIGDIR%%/moebius.xml
%%CONFIGDIR%%/moire.xml
%%CONFIGDIR%%/moire2.xml
%%CONFIGDIR%%/molecule.xml
%%CONFIGDIR%%/morph3d.xml
%%CONFIGDIR%%/mountain.xml
%%CONFIGDIR%%/munch.xml
%%CONFIGDIR%%/nerverot.xml
%%CONFIGDIR%%/noseguy.xml
%%CONFIGDIR%%/pedal.xml
%%CONFIGDIR%%/penetrate.xml
%%CONFIGDIR%%/penrose.xml
%%CONFIGDIR%%/petri.xml
%%CONFIGDIR%%/phosphor.xml
%%CONFIGDIR%%/pipes.xml
%%CONFIGDIR%%/pulsar.xml
%%CONFIGDIR%%/pyro.xml
%%CONFIGDIR%%/qix.xml
%%CONFIGDIR%%/rd-bomb.xml
%%CONFIGDIR%%/ripples.xml
%%CONFIGDIR%%/rocks.xml
%%CONFIGDIR%%/rorschach.xml
%%CONFIGDIR%%/rotor.xml
%%CONFIGDIR%%/rotzoomer.xml
%%CONFIGDIR%%/rubik.xml
%%CONFIGDIR%%/shadebobs.xml
%%CONFIGDIR%%/sierpinski.xml
%%CONFIGDIR%%/sierpinski3d.xml
%%CONFIGDIR%%/slidescreen.xml
%%CONFIGDIR%%/slip.xml
%%CONFIGDIR%%/sonar.xml
%%CONFIGDIR%%/speedmine.xml
%%CONFIGDIR%%/sphere.xml
%%CONFIGDIR%%/sphereEversion.xml
%%CONFIGDIR%%/spiral.xml
%%CONFIGDIR%%/spotlight.xml
%%CONFIGDIR%%/sproingies.xml
%%CONFIGDIR%%/squiral.xml
%%CONFIGDIR%%/ssystem.xml
%%CONFIGDIR%%/stairs.xml
%%CONFIGDIR%%/starfish.xml
%%CONFIGDIR%%/starwars.xml
%%CONFIGDIR%%/stonerview.xml
%%CONFIGDIR%%/strange.xml
%%CONFIGDIR%%/superquadrics.xml
%%CONFIGDIR%%/swirl.xml
%%CONFIGDIR%%/t3d.xml
%%CONFIGDIR%%/triangle.xml
%%CONFIGDIR%%/truchet.xml
%%CONFIGDIR%%/vermiculate.xml
%%CONFIGDIR%%/vidwhacker.xml
%%CONFIGDIR%%/vines.xml
%%CONFIGDIR%%/wander.xml
%%CONFIGDIR%%/webcollage.xml
%%CONFIGDIR%%/whirlwindwarp.xml
%%CONFIGDIR%%/whirlygig.xml
%%CONFIGDIR%%/worm.xml
%%CONFIGDIR%%/xaos.xml
%%CONFIGDIR%%/xdaliclock.xml
%%CONFIGDIR%%/xearth.xml
%%CONFIGDIR%%/xfishtank.xml
%%CONFIGDIR%%/xflame.xml
%%CONFIGDIR%%/xjack.xml
%%CONFIGDIR%%/xlyap.xml
%%CONFIGDIR%%/xmatrix.xml
%%CONFIGDIR%%/xmountains.xml
%%CONFIGDIR%%/xrayswarm.xml
%%CONFIGDIR%%/xsnow.xml
%%CONFIGDIR%%/xspirograph.xml
%%CONFIGDIR%%/xteevee.xml
%%CONFIGDIR%%/zoom.xml
@dirrm %%CONFIGDIR%%
share/xscreensaver/config/README
share/xscreensaver/config/ant.xml
share/xscreensaver/config/apollonian.xml
share/xscreensaver/config/atlantis.xml
share/xscreensaver/config/attraction.xml
share/xscreensaver/config/blaster.xml
share/xscreensaver/config/blitspin.xml
share/xscreensaver/config/bouboule.xml
share/xscreensaver/config/boxed.xml
share/xscreensaver/config/braid.xml
share/xscreensaver/config/bsod.xml
share/xscreensaver/config/bubble3d.xml
share/xscreensaver/config/bubbles.xml
share/xscreensaver/config/bumps.xml
share/xscreensaver/config/cage.xml
share/xscreensaver/config/ccurve.xml
share/xscreensaver/config/circuit.xml
share/xscreensaver/config/compass.xml
share/xscreensaver/config/coral.xml
share/xscreensaver/config/cosmos.xml
share/xscreensaver/config/critical.xml
share/xscreensaver/config/crystal.xml
share/xscreensaver/config/cynosure.xml
share/xscreensaver/config/dangerball.xml
share/xscreensaver/config/decayscreen.xml
share/xscreensaver/config/deco.xml
share/xscreensaver/config/deluxe.xml
share/xscreensaver/config/demon.xml
share/xscreensaver/config/discrete.xml
share/xscreensaver/config/distort.xml
share/xscreensaver/config/drift.xml
share/xscreensaver/config/electricsheep.xml
share/xscreensaver/config/engine.xml
share/xscreensaver/config/epicycle.xml
share/xscreensaver/config/euler2d.xml
share/xscreensaver/config/extrusion.xml
share/xscreensaver/config/fadeplot.xml
share/xscreensaver/config/flag.xml
share/xscreensaver/config/flame.xml
share/xscreensaver/config/flipscreen3d.xml
share/xscreensaver/config/flow.xml
share/xscreensaver/config/forest.xml
share/xscreensaver/config/galaxy.xml
share/xscreensaver/config/gears.xml
share/xscreensaver/config/gflux.xml
share/xscreensaver/config/glforestfire.xml
share/xscreensaver/config/glplanet.xml
share/xscreensaver/config/glsnake.xml
share/xscreensaver/config/gltext.xml
share/xscreensaver/config/goban.xml
share/xscreensaver/config/goop.xml
share/xscreensaver/config/grav.xml
share/xscreensaver/config/greynetic.xml
share/xscreensaver/config/halo.xml
share/xscreensaver/config/helix.xml
share/xscreensaver/config/hopalong.xml
share/xscreensaver/config/hyperball.xml
share/xscreensaver/config/hypercube.xml
share/xscreensaver/config/ifs.xml
share/xscreensaver/config/imsmap.xml
share/xscreensaver/config/interference.xml
share/xscreensaver/config/jigsaw.xml
share/xscreensaver/config/juggle.xml
share/xscreensaver/config/julia.xml
share/xscreensaver/config/kaleidescope.xml
share/xscreensaver/config/kumppa.xml
share/xscreensaver/config/lament.xml
share/xscreensaver/config/laser.xml
share/xscreensaver/config/lightning.xml
share/xscreensaver/config/lisa.xml
share/xscreensaver/config/lissie.xml
share/xscreensaver/config/lmorph.xml
share/xscreensaver/config/loop.xml
share/xscreensaver/config/maze.xml
share/xscreensaver/config/menger.xml
share/xscreensaver/config/moebius.xml
share/xscreensaver/config/moire.xml
share/xscreensaver/config/moire2.xml
share/xscreensaver/config/molecule.xml
share/xscreensaver/config/morph3d.xml
share/xscreensaver/config/mountain.xml
share/xscreensaver/config/munch.xml
share/xscreensaver/config/nerverot.xml
share/xscreensaver/config/noseguy.xml
share/xscreensaver/config/pedal.xml
share/xscreensaver/config/penetrate.xml
share/xscreensaver/config/penrose.xml
share/xscreensaver/config/petri.xml
share/xscreensaver/config/phosphor.xml
share/xscreensaver/config/pipes.xml
share/xscreensaver/config/polyominoes.xml
share/xscreensaver/config/pulsar.xml
share/xscreensaver/config/pyro.xml
share/xscreensaver/config/qix.xml
share/xscreensaver/config/rd-bomb.xml
share/xscreensaver/config/ripples.xml
share/xscreensaver/config/rocks.xml
share/xscreensaver/config/rorschach.xml
share/xscreensaver/config/rotor.xml
share/xscreensaver/config/rotzoomer.xml
share/xscreensaver/config/rubik.xml
share/xscreensaver/config/sballs.xml
share/xscreensaver/config/shadebobs.xml
share/xscreensaver/config/sierpinski.xml
share/xscreensaver/config/sierpinski3d.xml
share/xscreensaver/config/slidescreen.xml
share/xscreensaver/config/slip.xml
share/xscreensaver/config/sonar.xml
share/xscreensaver/config/speedmine.xml
share/xscreensaver/config/sphere.xml
share/xscreensaver/config/sphereEversion.xml
share/xscreensaver/config/spiral.xml
share/xscreensaver/config/spotlight.xml
share/xscreensaver/config/sproingies.xml
share/xscreensaver/config/squiral.xml
share/xscreensaver/config/ssystem.xml
share/xscreensaver/config/stairs.xml
share/xscreensaver/config/starfish.xml
share/xscreensaver/config/starwars.xml
share/xscreensaver/config/stonerview.xml
share/xscreensaver/config/strange.xml
share/xscreensaver/config/superquadrics.xml
share/xscreensaver/config/swirl.xml
share/xscreensaver/config/t3d.xml
share/xscreensaver/config/thornbird.xml
share/xscreensaver/config/triangle.xml
share/xscreensaver/config/truchet.xml
share/xscreensaver/config/twang.xml
share/xscreensaver/config/vermiculate.xml
share/xscreensaver/config/vidwhacker.xml
share/xscreensaver/config/vines.xml
share/xscreensaver/config/wander.xml
share/xscreensaver/config/webcollage.xml
share/xscreensaver/config/whirlwindwarp.xml
share/xscreensaver/config/whirlygig.xml
share/xscreensaver/config/worm.xml
share/xscreensaver/config/xaos.xml
share/xscreensaver/config/xdaliclock.xml
share/xscreensaver/config/xearth.xml
share/xscreensaver/config/xfishtank.xml
share/xscreensaver/config/xflame.xml
share/xscreensaver/config/xjack.xml
share/xscreensaver/config/xlyap.xml
share/xscreensaver/config/xmatrix.xml
share/xscreensaver/config/xmountains.xml
share/xscreensaver/config/xrayswarm.xml
share/xscreensaver/config/xsnow.xml
share/xscreensaver/config/xspirograph.xml
share/xscreensaver/config/xteevee.xml
share/xscreensaver/config/zoom.xml
@dirrm share/xscreensaver/config
@dirrm share/xscreensaver
%%NOGNOME:%%@dirrm share/xscreensaver
@dirrm bin/xscreensaver-hacks