[maintainer update] comms/gnokii update to 0.6.4

upgrade to 0.6.4 just released. Added a knob tolink smsd to glib2.
	minor changes to the messages regarding smsd in pre-fetch.

PR:		ports/72929
Submitted by:	Guido Falsi <mad@madpilot.net>
This commit is contained in:
Edwin Groothuis 2004-10-26 01:35:09 +00:00
parent 016f874909
commit 4b84fd7224
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=120191
4 changed files with 45 additions and 9 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= gnokii
PORTVERSION= 0.6.3
PORTVERSION= 0.6.4
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
@ -68,8 +68,12 @@ WITH_PGSQL= yes
.else
PLIST_SUB+= PGM='@comment '
.endif
.if defined(SMSD_WITH_GLIB2)
USE_GNOME+= glib20
.else
USE_GNOME+= glib12
.endif
.endif
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --without-x
@ -90,6 +94,7 @@ PLIST_SUB+= NLS="@comment "
.endif
pre-fetch:
.if !defined(WITH_SMSD)
@${ECHO}
@${ECHO} "If you plan using the smsd daemon for automatically receiving,"
@${ECHO} "managing and sending SMSes define WITH_SMSD=yes."
@ -98,6 +103,13 @@ pre-fetch:
@${ECHO} "will be automatically compiled in. Normal file systems support is"
@${ECHO} "always compiled in."
@${ECHO}
.endif
.if !defined(SMSD_WITH_GLIB2)
@${ECHO}
@${ECHO} "smsd defaults to using glib1, if you'd rather link with glib2
@${ECHO} "define SMSD_WITH_GLIB2=yes"
@${ECHO}
.endif
post-patch:
.for f in ${FIXPREFIX}
@ -114,6 +126,9 @@ post-patch:
@${FIND} ${WRKSRC} -type f -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} \
-e 's|<stdint.h>|<inttypes.h>|'
.endif
.if defined(SMSD_WITH_GLIB2)
@cd ${WRKSRC} && ${PATCH} -s <${PATCHDIR}/smsd-Makefile-WITH_GLIB.diff
.endif
post-build:
.if defined(WITH_SMSD)

View File

@ -1,2 +1,2 @@
MD5 (gnokii-0.6.3.tar.bz2) = 7e932688aeaa2ca8be2f2e3b3bf1b90e
SIZE (gnokii-0.6.3.tar.bz2) = 1824992
MD5 (gnokii-0.6.4.tar.bz2) = e48e72b4038481509f32e2a7596dc2d5
SIZE (gnokii-0.6.4.tar.bz2) = 2006834

View File

@ -1,5 +1,5 @@
--- smsd/Makefile.orig Fri Feb 13 18:58:38 2004
+++ smsd/Makefile Fri Feb 13 19:02:30 2004
--- smsd/Makefile.orig Wed Oct 20 17:24:58 2004
+++ smsd/Makefile Wed Oct 20 17:25:10 2004
@@ -26,9 +26,9 @@
LDLIBS += $(PTHREAD_LIBS) \
$(shell $(GLIBLDLIBS))
@ -7,8 +7,8 @@
-LDLIBS += -rdynamic $(TOPDIR)/common/libgnokii.la -ldl
+# LDLIBS += -rdynamic $(TOPDIR)/common/libgnokii.la -ldl
# Some systems, eg. FreeBSD don't have libdl. Use this:
-# LDLIBS += -s -rdynamic -L$(TOPDIR)/common -lgnokii
+LDLIBS += -s -rdynamic -L$(TOPDIR)/common -lgnokii
-# LDLIBS += -s -rdynamic -L$(TOPDIR)/common -lgnokii -pthread -L../getopt -lgetopt
+LDLIBS += -s -rdynamic -L$(TOPDIR)/common -lgnokii -pthread
ifdef XPM_LIBS
LDLIBS +=$(XPM_LIBS)
OBJS = smsd.lo \
lowlevel.lo

View File

@ -0,0 +1,21 @@
--- smsd/Makefile.orig Wed Oct 20 17:26:17 2004
+++ smsd/Makefile Wed Oct 20 17:26:25 2004
@@ -6,14 +6,14 @@
# $Id: Makefile,v 1.31 2004/08/03 09:29:09 ja Exp $
#
-GLIBCFLAGS = glib-config --cflags
-GLIBLDLIBS = glib-config --libs
+#GLIBCFLAGS = glib-config --cflags
+#GLIBLDLIBS = glib-config --libs
# Comment out above lines and uncomment below lines if you want compile smsd
# with glib2 instead of glib1.
#
-#GLIBCFLAGS = pkg-config --cflags glib-2.0
-#GLIBLDLIBS = pkg-config --libs glib-2.0
+GLIBCFLAGS = pkg-config --cflags glib-2.0
+GLIBLDLIBS = pkg-config --libs glib-2.0
TOPDIR=..
include $(TOPDIR)/Makefile.global