www/py-django-classy-tags: Update to 4.0.0

- Update WWW
- Update LICENSE_FILE
- Fix RUN_DEPENDS
- Take maintainership

Changes:	https://github.com/django-cms/django-classy-tags/releases
This commit is contained in:
Po-Chuan Hsieh 2023-01-30 20:35:04 +08:00
parent 55886bc535
commit 4b7bfa6e2c
No known key found for this signature in database
GPG Key ID: 9A4BD10F002DD04B
4 changed files with 16 additions and 36 deletions

View File

@ -1,22 +1,20 @@
PORTNAME= django-classy-tags
PORTVERSION= 2.0.0
PORTREVISION= 2
PORTVERSION= 4.0.0
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Class based template tags for Django
WWW= https://github.com/ojii/django-classy-tags
WWW= https://github.com/django-cms/django-classy-tags
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django32>=1.11:www/py-django32@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django32>=3.2:www/py-django32@${PY_FLAVOR}
USES= python:3.5+
USE_PYTHON= autoplist distutils
USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1602936218
SHA256 (django-classy-tags-2.0.0.tar.gz) = d59d98bdf96a764dcf7a2929a86439d023b283a9152492811c7e44fc47555bc9
SIZE (django-classy-tags-2.0.0.tar.gz) = 21026
TIMESTAMP = 1674590032
SHA256 (django-classy-tags-4.0.0.tar.gz) = db9fc7c5ed08dc2619cc4c19b19514cdac13ddb618278ab07094c626d28eef0d
SIZE (django-classy-tags-4.0.0.tar.gz) = 24686

View File

@ -1,16 +0,0 @@
Avoid the installation of the test suite in the top-level directory
of ${PYTHON_SITELIBDIR}.
See also: https://github.com/django-cms/django-classy-tags/issues/58
--- setup.py.orig 2020-08-26 08:49:51 UTC
+++ setup.py
@@ -41,7 +41,7 @@ setup(
license='BSD',
description='Class based template tags for Django',
long_description=open('README.rst').read(),
- packages=find_packages(),
+ packages=find_packages(exclude=("tests",)),
include_package_data=True,
zip_safe=False,
install_requires=REQUIREMENTS,

View File

@ -1,11 +1,9 @@
The goal of this project is to create a new way of writing Django template tags
which is fully compatible with the current Django templating infrastructure.
This new way should be easy, clean and require as little boilerplate code as
possible while still staying as powerful as possible.
Features:
* Class based template tags.
* Template tag argument parser.
* Declarative way to define arguments.
* Supports (theoretically infinite) parse-until blocks.
* Extensible!
possible while still staying as powerful as possible. Some features:
- Class based template tags.
- Template tag argument parser.
- Declarative way to define arguments.
- Supports (theoretically infinite) parse-until blocks.
- Extensible!