Work around a bug in gcc <5.0 by compiling with -std=gnu89 instead of gnu99.

https://gcc.gnu.org/bugzilla/show_bug.cgi?id=63567

Got will support building with gcc 4.2.1 until OpenBSD retires gcc
on all archs.
This commit is contained in:
Christian Weisgerber 2020-12-29 16:26:45 +00:00
parent 6dba070842
commit 4b6db79490
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=559592
2 changed files with 10 additions and 3 deletions

View File

@ -2,6 +2,7 @@
PORTNAME= got
PORTVERSION= 0.47
PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://gameoftrees.org/releases/
@ -11,7 +12,7 @@ COMMENT= Game of Trees version control system
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/LICENCE
USES= compiler:c11 uidfix
USES= uidfix
n= ${.newline}
post-extract:

View File

@ -1,9 +1,15 @@
--- Makefile.inc.orig 2020-11-26 12:53:05 UTC
--- Makefile.inc.orig 2020-12-19 00:55:45 UTC
+++ Makefile.inc
@@ -4,6 +4,13 @@ CPPFLAGS += -DGOT_LIBEXECDIR=${LIBEXECDIR} -DGOT_VERSI
@@ -4,6 +4,19 @@ CPPFLAGS += -DGOT_LIBEXECDIR=${LIBEXECDIR} -DGOT_VERSI
#CFLAGS += -DGOT_OBJ_CACHE_DEBUG
#CFLAGS += -DGOT_DIFF_NO_MMAP
+# work around https://gcc.gnu.org/bugzilla/show_bug.cgi?id=63567
+.include <bsd.compiler.mk>
+.if ${COMPILER_TYPE} == "gcc" && ${COMPILER_VERSION} < 50000
+CSTD = gnu89
+.endif
+
+OPENBSD_COMPAT := ${.PARSEDIR}/openbsd-compat
+CFLAGS += ${CPPFLAGS} -I${OPENBSD_COMPAT}
+CFLAGS += -Wno-pointer-sign