Upgrade to 1.3, and add libgdk_imlib.

This commit is contained in:
Vanilla I. Shu 1998-04-29 21:32:49 +00:00
parent 9fa4bce3fd
commit 4b56eb1feb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=10766
14 changed files with 160 additions and 271 deletions

View File

@ -1,13 +1,12 @@
# New ports collection makefile for: imlib
# Version required: 1.1
# Version required: 1.3
# Date created: 10 June 1997
# Whom: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
#
# $Id: Makefile,v 1.17 1998/03/28 19:49:58 ache Exp $
# $Id: Makefile,v 1.18 1998/04/15 22:17:56 jseger Exp $
#
DISTNAME= Imlib-1.1
PKGNAME= imlib-1.1
DISTNAME= imlib-1.3
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.enlightenment.org/pub/imlib/TAR/ \
ftp://ftp.labs.redhat.com/pub/imlib/TAR/
@ -17,12 +16,16 @@ MAINTAINER= vanilla@FreeBSD.ORG
LIB_DEPENDS= png\\.2\\.:${PORTSDIR}/graphics/png \
jpeg\\.8\\.:${PORTSDIR}/graphics/jpeg \
tiff34\\.1\\.:${PORTSDIR}/graphics/tiff34 \
gif\\.3\\.:${PORTSDIR}/graphics/giflib
gif\\.3\\.:${PORTSDIR}/graphics/giflib \
gtk\\.1\\.:${PORTSDIR}/x11/gtk
USE_GMAKE= yes
USE_X11= ues
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/imlib/Imlib
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
LIBS=-L${LOCALBASE}/lib \
INSTALL="/usr/bin/install -c"
WRKSRC= ${WRKDIR}/imlib
post-install:
${LDCONFIG} -m ${PREFIX}/lib

View File

@ -1 +1 @@
MD5 (Imlib-1.1.tar.gz) = 27f85550e7eb6b2c8ed6e72e962931b7
MD5 (imlib-1.3.tar.gz) = 6b672e10e70c0a8b0a51de823c6f6859

View File

@ -1,40 +1,25 @@
--- configure.orig Fri Feb 20 09:42:49 1998
+++ configure Tue Mar 10 09:40:36 1998
@@ -826,6 +826,7 @@
# AFS /usr/afsws/bin/install, which mishandles nonexistent args
# SVR4 /usr/ucb/install, which tries to use the nonexistent group "staff"
# ./install, which can be erroneously created by make from ./install.sh.
+INSTALL='/usr/bin/install -c'
echo $ac_n "checking for a BSD compatible install""... $ac_c" 1>&6
echo "configure:831: checking for a BSD compatible install" >&5
if test -z "$INSTALL"; then
@@ -2590,14 +2591,14 @@
fi
--- configure.orig Wed Apr 22 07:47:30 1998
+++ configure Thu Apr 30 05:05:50 1998
@@ -3215,14 +3215,14 @@
GX_LIBS="$GTK_LIBS"
fi
- echo $ac_n "checking for TIFFOpen in -ltiff""... $ac_c" 1>&6
-echo "configure:2595: checking for TIFFOpen in -ltiff" >&5
-ac_lib_var=`echo tiff'_'TIFFOpen | sed 'y%./+-%__p_%'`
+ echo $ac_n "checking for TIFFOpen in -ltiff34""... $ac_c" 1>&6
+echo "configure:2595: checking for TIFFOpen in -ltiff34" >&5
+ac_lib_var=`echo tiff34'_'TIFFOpen | sed 'y%./+-%__p_%'`
-echo $ac_n "checking for main in -ltiff""... $ac_c" 1>&6
-echo "configure:3220: checking for main in -ltiff" >&5
-ac_lib_var=`echo tiff'_'main | sed 'y%./+-%__p_%'`
+echo $ac_n "checking for main in -ltiff34""... $ac_c" 1>&6
+echo "configure:3220: checking for main in -ltiff34" >&5
+ac_lib_var=`echo tiff34'_'main | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-ltiff \
+LIBS="-ltiff34 \
-L/usr/lib -L/lib -L/usr/local/lib -L/usr/X11/lib -L/usr/X11R6/lib \
-L/usr/local/X11/lib -L/usr/openwin/lib -lc -lm $LIBS"
-LIBS="-ltiff $GX_LIBS $LIBS"
+LIBS="-ltiff34 $GX_LIBS $LIBS"
cat > conftest.$ac_ext <<EOF
@@ -2627,13 +2628,13 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
- ac_tr_lib=HAVE_LIB`echo tiff | sed -e 's/[^a-zA-Z0-9_]/_/g' \
+ ac_tr_lib=HAVE_LIB`echo tiff34 | sed -e 's/[^a-zA-Z0-9_]/_/g' \
-e 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/'`
cat >> confdefs.h <<EOF
#line 3228 "configure"
#include "confdefs.h"
@@ -3252,7 +3252,7 @@
#define $ac_tr_lib 1
EOF
@ -43,26 +28,3 @@
else
echo "$ac_t""no" 1>&6
@@ -2642,7 +2643,7 @@
if test "" != ""; then
enl_lib_subdir=
else
- enl_lib_subdir=tiff
+ enl_lib_subdir=tiff34
fi
enl_cur_var=tiff_TIFFOpen
echo $ac_n "checking for tiffio.h""... $ac_c" 1>&6
@@ -2673,11 +2674,11 @@
fi
echo "$ac_t""$enl_tmp_var" 1>&6
\
-extras="$extras -DBUILTIN_TIFF"; LIBS="$LIBS -lm -ltiff"
+extras="$extras -DBUILTIN_TIFF"; LIBS="$LIBS -lm -ltiff34"
else
echo "$ac_t""no" 1>&6
\
-{ echo "configure: error: ********** Disabling libtiff support ************" 1>&2; exit 1; }
+{ echo "configure: error: ********** Disabling libtiff34 support ************" 1>&2; exit 1; }
fi

View File

@ -1,13 +1,28 @@
--- Imlib_private.h.orig Tue Feb 17 17:27:25 1998
+++ Imlib_private.h Tue Feb 17 17:28:06 1998
@@ -42,10 +42,10 @@
--- Imlib/Imlib_private.h.orig Thu Apr 30 04:23:24 1998
+++ Imlib/Imlib_private.h Thu Apr 30 04:23:46 1998
@@ -38,10 +38,10 @@
#include <png.h>
#endif
#ifdef BUILTIN_TIFF
#ifdef HAVE_LIBTIFF
-#include <tiffio.h>
+#include <tiff34/tiffio.h>
#endif
#ifdef BUILTIN_GIF
#ifdef HAVE_LIBGIF
-#include <gif_lib.h>
+#include <giflib/gif_lib.h>
#endif
#define BYTE_ORD_24_RGB 0
--- gdk_imlib/gdk_imlib_private.h.orig Thu Apr 30 04:34:52 1998
+++ gdk_imlib/gdk_imlib_private.h Thu Apr 30 04:35:11 1998
@@ -46,10 +46,10 @@
#include <png.h>
#endif
#ifdef HAVE_LIBTIFF
-#include <tiffio.h>
+#include <tiff34/tiffio.h>
#endif
#ifdef HAVE_LIBGIF
-#include <gif_lib.h>
+#include <giflib/gif_lib.h>
#endif

View File

@ -1,81 +1,33 @@
--- Makefile.in.orig Wed Feb 25 00:34:26 1998
+++ Makefile.in Tue Mar 10 09:47:49 1998
@@ -30,7 +30,7 @@
INSTALL = @INSTALL@
INSTALLBIN = $(INSTALL) -m 755
INSTALLLIB = $(INSTALL) -m 644
-SYS_CONFIG = /etc
+SYS_CONFIG = /usr/X11R6/etc/imlib
--- gdk_imlib/Makefile.in.orig Wed Apr 22 07:47:28 1998
+++ gdk_imlib/Makefile.in Thu Apr 30 05:14:53 1998
@@ -111,7 +111,7 @@
utils.c \
save.c
.SUFFIXES:
.SUFFIXES: .c .o
@@ -51,15 +51,14 @@
-libgdk_imlib_la_LDFLAGS = -version-info 4:0:3
+libgdk_imlib_la_LDFLAGS = -version-info 1:3:0
libgdk_imlib_la_LDDADD = $(LIBS)
top_srcdir = @top_srcdir@
srcdir = @srcdir@
-prefix = @prefix@
-exec_prefix = @prefix@
+prefix = /usr/X11R6
+exec_prefix = /usr/X11R6
bindir = $(exec_prefix)/bin
-datadir = $(prefix)/lib
+datadir = $(prefix)/share
incdir = $(prefix)/include
libdir = $(prefix)/lib
exe2dir = $(prefix)bin
mandir = $(prefix)/man
-SYS_CONFIG = @sysconfdir@
DEFS = -DDJPEG_PROG=\"@DJPEG_PROG@\" -DCJPEG_PROG=\"@CJPEG_PROG@\" \
--- Imlib/Makefile.in.orig Wed Apr 22 07:47:28 1998
+++ Imlib/Makefile.in Thu Apr 30 05:15:06 1998
@@ -109,7 +109,7 @@
utils.c \
save.c
LN_S = @LN_S@
RANLIB = @RANLIB@
@@ -93,7 +92,7 @@
-libImlib_la_LDFLAGS = -version-info 4:0:3
+libImlib_la_LDFLAGS = -version-info 1:3:0
libImlib_la_LDDADD = $(LIBS)
LIB = \
-lm \
--ltiff \
+-ltiff34 \
-ljpeg \
-lpng \
-lgif \
@@ -101,6 +100,7 @@
XLIB = \
-lX11 \
+-L/usr/local/lib \
-lXext
LIBS = \
@@ -122,11 +122,11 @@
CFLAGS = \
-fPIC \
--shared \
-I. \
@CFLAGS@ \
@X_CFLAGS@ \
@INCLUDES@ \
+-I/usr/local/include \
$(OPT)
all: $(lib)
@@ -136,6 +136,9 @@
$(INSTALLBIN) $(lib) $(libdir)/$(lib)
/bin/ln -sf $(libdir)/$(lib) $(libdir)/$(libname2)
/bin/ln -sf $(libdir)/$(lib) $(libdir)/$(libname).so
+ if [ ! -d $(SYS_CONFIG) ]; then \
+ mkdir $(SYS_CONFIG); \
+ fi
$(INSTALL) $(conf_dir)/im_palette.pal $(SYS_CONFIG)/im_palette.pal
sed s@/etc/@$(SYS_CONFIG)/@g< $(conf_dir)/imrc > $(SYS_CONFIG)/imrc
$(INSTALL) Imlib.h $(incdir)/Imlib.h
@@ -159,8 +162,8 @@
.c.o:
$(CC) -c $(CPPFLAGS) $(CFLAGS) $<
-$(lib): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(OBJS) $(LIBS) $(SONAME)
+$(lib): $(OBJS)
+ ld -Bshareable -o libImlib.so.1.1 $(OBJS) /usr/lib/c++rt0.o
@echo "--------------------------------------------------------------------------------"
@echo "Imlib compiled."
@echo ""
DEFS = -DDJPEG_PROG=\"@DJPEG_PROG@\" -DCJPEG_PROG=\"@CJPEG_PROG@\" \
--- config/Makefile.in.orig Thu Apr 30 05:14:05 1998
+++ config/Makefile.in Thu Apr 30 05:14:35 1998
@@ -23,7 +23,7 @@
sbindir = @sbindir@
libexecdir = @libexecdir@
datadir = @datadir@
-sysconfdir = @sysconfdir@
+sysconfdir = @sysconfdir@/imlib
sharedstatedir = @sharedstatedir@
localstatedir = @localstatedir@
libdir = @libdir@

View File

@ -1,9 +1,18 @@
bin/imlib_config
etc/imlib/im_palette.pal
etc/imlib/imrc
include/Imlib.h
include/Imlib_private.h
include/Imlib_types.h
include/gdk_imlib.h
include/gdk_imlib_private.h
include/gdk_imlib_types.h
lib/libImlib.a
lib/libImlib.la
lib/libImlib.so
lib/libImlib.so.1
lib/libImlib.so.1.1
lib/libImlib.so.1.3
lib/libgdk_imlib.a
lib/libgdk_imlib.la
lib/libgdk_imlib.so
lib/libgdk_imlib.so.1.3
@dirrm etc/imlib

View File

@ -1,13 +1,12 @@
# New ports collection makefile for: imlib
# Version required: 1.1
# Version required: 1.3
# Date created: 10 June 1997
# Whom: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
#
# $Id: Makefile,v 1.17 1998/03/28 19:49:58 ache Exp $
# $Id: Makefile,v 1.18 1998/04/15 22:17:56 jseger Exp $
#
DISTNAME= Imlib-1.1
PKGNAME= imlib-1.1
DISTNAME= imlib-1.3
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.enlightenment.org/pub/imlib/TAR/ \
ftp://ftp.labs.redhat.com/pub/imlib/TAR/
@ -17,12 +16,16 @@ MAINTAINER= vanilla@FreeBSD.ORG
LIB_DEPENDS= png\\.2\\.:${PORTSDIR}/graphics/png \
jpeg\\.8\\.:${PORTSDIR}/graphics/jpeg \
tiff34\\.1\\.:${PORTSDIR}/graphics/tiff34 \
gif\\.3\\.:${PORTSDIR}/graphics/giflib
gif\\.3\\.:${PORTSDIR}/graphics/giflib \
gtk\\.1\\.:${PORTSDIR}/x11/gtk
USE_GMAKE= yes
USE_X11= ues
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/imlib/Imlib
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
LIBS=-L${LOCALBASE}/lib \
INSTALL="/usr/bin/install -c"
WRKSRC= ${WRKDIR}/imlib
post-install:
${LDCONFIG} -m ${PREFIX}/lib

View File

@ -1 +1 @@
MD5 (Imlib-1.1.tar.gz) = 27f85550e7eb6b2c8ed6e72e962931b7
MD5 (imlib-1.3.tar.gz) = 6b672e10e70c0a8b0a51de823c6f6859

View File

@ -1,40 +1,25 @@
--- configure.orig Fri Feb 20 09:42:49 1998
+++ configure Tue Mar 10 09:40:36 1998
@@ -826,6 +826,7 @@
# AFS /usr/afsws/bin/install, which mishandles nonexistent args
# SVR4 /usr/ucb/install, which tries to use the nonexistent group "staff"
# ./install, which can be erroneously created by make from ./install.sh.
+INSTALL='/usr/bin/install -c'
echo $ac_n "checking for a BSD compatible install""... $ac_c" 1>&6
echo "configure:831: checking for a BSD compatible install" >&5
if test -z "$INSTALL"; then
@@ -2590,14 +2591,14 @@
fi
--- configure.orig Wed Apr 22 07:47:30 1998
+++ configure Thu Apr 30 05:05:50 1998
@@ -3215,14 +3215,14 @@
GX_LIBS="$GTK_LIBS"
fi
- echo $ac_n "checking for TIFFOpen in -ltiff""... $ac_c" 1>&6
-echo "configure:2595: checking for TIFFOpen in -ltiff" >&5
-ac_lib_var=`echo tiff'_'TIFFOpen | sed 'y%./+-%__p_%'`
+ echo $ac_n "checking for TIFFOpen in -ltiff34""... $ac_c" 1>&6
+echo "configure:2595: checking for TIFFOpen in -ltiff34" >&5
+ac_lib_var=`echo tiff34'_'TIFFOpen | sed 'y%./+-%__p_%'`
-echo $ac_n "checking for main in -ltiff""... $ac_c" 1>&6
-echo "configure:3220: checking for main in -ltiff" >&5
-ac_lib_var=`echo tiff'_'main | sed 'y%./+-%__p_%'`
+echo $ac_n "checking for main in -ltiff34""... $ac_c" 1>&6
+echo "configure:3220: checking for main in -ltiff34" >&5
+ac_lib_var=`echo tiff34'_'main | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-ltiff \
+LIBS="-ltiff34 \
-L/usr/lib -L/lib -L/usr/local/lib -L/usr/X11/lib -L/usr/X11R6/lib \
-L/usr/local/X11/lib -L/usr/openwin/lib -lc -lm $LIBS"
-LIBS="-ltiff $GX_LIBS $LIBS"
+LIBS="-ltiff34 $GX_LIBS $LIBS"
cat > conftest.$ac_ext <<EOF
@@ -2627,13 +2628,13 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
- ac_tr_lib=HAVE_LIB`echo tiff | sed -e 's/[^a-zA-Z0-9_]/_/g' \
+ ac_tr_lib=HAVE_LIB`echo tiff34 | sed -e 's/[^a-zA-Z0-9_]/_/g' \
-e 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/'`
cat >> confdefs.h <<EOF
#line 3228 "configure"
#include "confdefs.h"
@@ -3252,7 +3252,7 @@
#define $ac_tr_lib 1
EOF
@ -43,26 +28,3 @@
else
echo "$ac_t""no" 1>&6
@@ -2642,7 +2643,7 @@
if test "" != ""; then
enl_lib_subdir=
else
- enl_lib_subdir=tiff
+ enl_lib_subdir=tiff34
fi
enl_cur_var=tiff_TIFFOpen
echo $ac_n "checking for tiffio.h""... $ac_c" 1>&6
@@ -2673,11 +2674,11 @@
fi
echo "$ac_t""$enl_tmp_var" 1>&6
\
-extras="$extras -DBUILTIN_TIFF"; LIBS="$LIBS -lm -ltiff"
+extras="$extras -DBUILTIN_TIFF"; LIBS="$LIBS -lm -ltiff34"
else
echo "$ac_t""no" 1>&6
\
-{ echo "configure: error: ********** Disabling libtiff support ************" 1>&2; exit 1; }
+{ echo "configure: error: ********** Disabling libtiff34 support ************" 1>&2; exit 1; }
fi

View File

@ -1,9 +1,18 @@
bin/imlib_config
etc/imlib/im_palette.pal
etc/imlib/imrc
include/Imlib.h
include/Imlib_private.h
include/Imlib_types.h
include/gdk_imlib.h
include/gdk_imlib_private.h
include/gdk_imlib_types.h
lib/libImlib.a
lib/libImlib.la
lib/libImlib.so
lib/libImlib.so.1
lib/libImlib.so.1.1
lib/libImlib.so.1.3
lib/libgdk_imlib.a
lib/libgdk_imlib.la
lib/libgdk_imlib.so
lib/libgdk_imlib.so.1.3
@dirrm etc/imlib

View File

@ -1,13 +1,12 @@
# New ports collection makefile for: imlib
# Version required: 1.1
# Version required: 1.3
# Date created: 10 June 1997
# Whom: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
#
# $Id: Makefile,v 1.17 1998/03/28 19:49:58 ache Exp $
# $Id: Makefile,v 1.18 1998/04/15 22:17:56 jseger Exp $
#
DISTNAME= Imlib-1.1
PKGNAME= imlib-1.1
DISTNAME= imlib-1.3
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.enlightenment.org/pub/imlib/TAR/ \
ftp://ftp.labs.redhat.com/pub/imlib/TAR/
@ -17,12 +16,16 @@ MAINTAINER= vanilla@FreeBSD.ORG
LIB_DEPENDS= png\\.2\\.:${PORTSDIR}/graphics/png \
jpeg\\.8\\.:${PORTSDIR}/graphics/jpeg \
tiff34\\.1\\.:${PORTSDIR}/graphics/tiff34 \
gif\\.3\\.:${PORTSDIR}/graphics/giflib
gif\\.3\\.:${PORTSDIR}/graphics/giflib \
gtk\\.1\\.:${PORTSDIR}/x11/gtk
USE_GMAKE= yes
USE_X11= ues
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/imlib/Imlib
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
LIBS=-L${LOCALBASE}/lib \
INSTALL="/usr/bin/install -c"
WRKSRC= ${WRKDIR}/imlib
post-install:
${LDCONFIG} -m ${PREFIX}/lib

View File

@ -1 +1 @@
MD5 (Imlib-1.1.tar.gz) = 27f85550e7eb6b2c8ed6e72e962931b7
MD5 (imlib-1.3.tar.gz) = 6b672e10e70c0a8b0a51de823c6f6859

View File

@ -1,40 +1,25 @@
--- configure.orig Fri Feb 20 09:42:49 1998
+++ configure Tue Mar 10 09:40:36 1998
@@ -826,6 +826,7 @@
# AFS /usr/afsws/bin/install, which mishandles nonexistent args
# SVR4 /usr/ucb/install, which tries to use the nonexistent group "staff"
# ./install, which can be erroneously created by make from ./install.sh.
+INSTALL='/usr/bin/install -c'
echo $ac_n "checking for a BSD compatible install""... $ac_c" 1>&6
echo "configure:831: checking for a BSD compatible install" >&5
if test -z "$INSTALL"; then
@@ -2590,14 +2591,14 @@
fi
--- configure.orig Wed Apr 22 07:47:30 1998
+++ configure Thu Apr 30 05:05:50 1998
@@ -3215,14 +3215,14 @@
GX_LIBS="$GTK_LIBS"
fi
- echo $ac_n "checking for TIFFOpen in -ltiff""... $ac_c" 1>&6
-echo "configure:2595: checking for TIFFOpen in -ltiff" >&5
-ac_lib_var=`echo tiff'_'TIFFOpen | sed 'y%./+-%__p_%'`
+ echo $ac_n "checking for TIFFOpen in -ltiff34""... $ac_c" 1>&6
+echo "configure:2595: checking for TIFFOpen in -ltiff34" >&5
+ac_lib_var=`echo tiff34'_'TIFFOpen | sed 'y%./+-%__p_%'`
-echo $ac_n "checking for main in -ltiff""... $ac_c" 1>&6
-echo "configure:3220: checking for main in -ltiff" >&5
-ac_lib_var=`echo tiff'_'main | sed 'y%./+-%__p_%'`
+echo $ac_n "checking for main in -ltiff34""... $ac_c" 1>&6
+echo "configure:3220: checking for main in -ltiff34" >&5
+ac_lib_var=`echo tiff34'_'main | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-ltiff \
+LIBS="-ltiff34 \
-L/usr/lib -L/lib -L/usr/local/lib -L/usr/X11/lib -L/usr/X11R6/lib \
-L/usr/local/X11/lib -L/usr/openwin/lib -lc -lm $LIBS"
-LIBS="-ltiff $GX_LIBS $LIBS"
+LIBS="-ltiff34 $GX_LIBS $LIBS"
cat > conftest.$ac_ext <<EOF
@@ -2627,13 +2628,13 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
- ac_tr_lib=HAVE_LIB`echo tiff | sed -e 's/[^a-zA-Z0-9_]/_/g' \
+ ac_tr_lib=HAVE_LIB`echo tiff34 | sed -e 's/[^a-zA-Z0-9_]/_/g' \
-e 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/'`
cat >> confdefs.h <<EOF
#line 3228 "configure"
#include "confdefs.h"
@@ -3252,7 +3252,7 @@
#define $ac_tr_lib 1
EOF
@ -43,26 +28,3 @@
else
echo "$ac_t""no" 1>&6
@@ -2642,7 +2643,7 @@
if test "" != ""; then
enl_lib_subdir=
else
- enl_lib_subdir=tiff
+ enl_lib_subdir=tiff34
fi
enl_cur_var=tiff_TIFFOpen
echo $ac_n "checking for tiffio.h""... $ac_c" 1>&6
@@ -2673,11 +2674,11 @@
fi
echo "$ac_t""$enl_tmp_var" 1>&6
\
-extras="$extras -DBUILTIN_TIFF"; LIBS="$LIBS -lm -ltiff"
+extras="$extras -DBUILTIN_TIFF"; LIBS="$LIBS -lm -ltiff34"
else
echo "$ac_t""no" 1>&6
\
-{ echo "configure: error: ********** Disabling libtiff support ************" 1>&2; exit 1; }
+{ echo "configure: error: ********** Disabling libtiff34 support ************" 1>&2; exit 1; }
fi

View File

@ -1,9 +1,18 @@
bin/imlib_config
etc/imlib/im_palette.pal
etc/imlib/imrc
include/Imlib.h
include/Imlib_private.h
include/Imlib_types.h
include/gdk_imlib.h
include/gdk_imlib_private.h
include/gdk_imlib_types.h
lib/libImlib.a
lib/libImlib.la
lib/libImlib.so
lib/libImlib.so.1
lib/libImlib.so.1.1
lib/libImlib.so.1.3
lib/libgdk_imlib.a
lib/libgdk_imlib.la
lib/libgdk_imlib.so
lib/libgdk_imlib.so.1.3
@dirrm etc/imlib