Fix on 6.x

PR:		92828
Submitted by:	rik
This commit is contained in:
Erwin Lansing 2006-04-28 08:32:23 +00:00
parent d1c53397c2
commit 4b54e19fce
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=160650
6 changed files with 52 additions and 2 deletions

View File

@ -27,7 +27,7 @@ LATEST_LINK= rat30
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 501000
.if ${OSVERSION} >= 700000
BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
.endif

View File

@ -0,0 +1,9 @@
--- Makefile_FreeBSD_6.orig Sun Oct 20 14:03:11 2002
+++ Makefile_FreeBSD_6 Sun Oct 20 14:03:06 2002
@@ -0,0 +1,6 @@
+TCL_INC = /usr/local/include/tcl8.2
+TK_INC = /usr/local/include/tk8.2
+INCS = -I/usr/X11R6/include \
+ -I$(TCL_INC)/generic -I$(TK_INC)/generic
+LDLIBS = -L/usr/local/lib \
+ -L/usr/X11R6/lib -ltk82 -ltcl82 -lXext -lX11 -lm

View File

@ -0,0 +1,16 @@
--- src/main.c.orig Fri Feb 3 00:23:21 2006
+++ src/main.c Fri Feb 3 00:23:37 2006
@@ -118,11 +118,11 @@
NEW_QUEUE(pckt_queue_struct, rtcp_pckt_queue)
NEW_QUEUE(rx_queue_struct, rx_unit_queue)
-#define INIT_QUEUE(T,Q) Q##_ptr[0] = &Q##[0]; \
+#define INIT_QUEUE(T,Q) Q##_ptr[0] = &Q[0]; \
Q##_ptr[0]->queue_empty_flag = 1; \
Q##_ptr[0]->head_ptr = NULL; \
Q##_ptr[0]->tail_ptr = NULL; \
- Q##_ptr[1] = &Q##[1]; \
+ Q##_ptr[1] = &Q[1]; \
Q##_ptr[1]->queue_empty_flag = 1; \
Q##_ptr[1]->head_ptr = NULL; \
Q##_ptr[1]->tail_ptr = NULL;

View File

@ -27,7 +27,7 @@ LATEST_LINK= rat30
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 501000
.if ${OSVERSION} >= 700000
BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
.endif

View File

@ -0,0 +1,9 @@
--- Makefile_FreeBSD_6.orig Sun Oct 20 14:03:11 2002
+++ Makefile_FreeBSD_6 Sun Oct 20 14:03:06 2002
@@ -0,0 +1,6 @@
+TCL_INC = /usr/local/include/tcl8.2
+TK_INC = /usr/local/include/tk8.2
+INCS = -I/usr/X11R6/include \
+ -I$(TCL_INC)/generic -I$(TK_INC)/generic
+LDLIBS = -L/usr/local/lib \
+ -L/usr/X11R6/lib -ltk82 -ltcl82 -lXext -lX11 -lm

View File

@ -0,0 +1,16 @@
--- src/main.c.orig Fri Feb 3 00:23:21 2006
+++ src/main.c Fri Feb 3 00:23:37 2006
@@ -118,11 +118,11 @@
NEW_QUEUE(pckt_queue_struct, rtcp_pckt_queue)
NEW_QUEUE(rx_queue_struct, rx_unit_queue)
-#define INIT_QUEUE(T,Q) Q##_ptr[0] = &Q##[0]; \
+#define INIT_QUEUE(T,Q) Q##_ptr[0] = &Q[0]; \
Q##_ptr[0]->queue_empty_flag = 1; \
Q##_ptr[0]->head_ptr = NULL; \
Q##_ptr[0]->tail_ptr = NULL; \
- Q##_ptr[1] = &Q##[1]; \
+ Q##_ptr[1] = &Q[1]; \
Q##_ptr[1]->queue_empty_flag = 1; \
Q##_ptr[1]->head_ptr = NULL; \
Q##_ptr[1]->tail_ptr = NULL;