games/supertux2:

- Update to 0.6.0
- Remove stale patches
- Build breaks with ninja, disable it
- Require C++14 compiler for build
- Take maintainership
This commit is contained in:
Max Brazhnikov 2019-05-03 10:43:02 +00:00
parent 0c7dd91225
commit 4b3a032cd3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=500713
8 changed files with 394 additions and 226 deletions

View File

@ -1,37 +1,38 @@
# $FreeBSD$
PORTNAME= supertux
PORTVERSION= 0.4.0
PORTREVISION= 17
DISTVERSIONPREFIX= v
DISTVERSION= 0.6.0
DISTVERSIONSUFFIX= -Source
CATEGORIES= games
MASTER_SITES= https://github.com/SuperTux/supertux/releases/download/v${PORTVERSION}/
PKGNAMESUFFIX= 2
DISTNAME= SuperTux-${DISTVERSIONFULL}
MAINTAINER= ports@FreeBSD.org
MAINTAINER= makc@FreeBSD.org
COMMENT= Side-scroller game similar to Super Mario Brothers
BUILD_DEPENDS= ${LOCALBASE}/include/boost/smart_ptr.hpp:devel/boost-libs
LIB_DEPENDS= libphysfs.so:devel/physfs \
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libfreetype.so:print/freetype2 \
libogg.so:audio/libogg \
libphysfs.so:devel/physfs \
libpng16.so:graphics/png \
libcurl.so:ftp/curl \
libvorbis.so:audio/libvorbis
LLD_UNSAFE= yes
USE_SDL= sdl2 image2
USE_GL= glew
USES= cmake compiler:c++11-lib dos2unix iconv \
openal:al pkgconfig tar:bzip2
# Unhide std::to_string() to fix build with GCC (see ports/193528 for details)
CFLAGS+= -D_GLIBCXX_USE_C99
USES= cmake:noninja compiler:c++14-lang dos2unix gl iconv \
openal:al pkgconfig sdl
USE_GL= gl glew glu
USE_SDL= sdl2 image2 ttf2
CMAKE_ARGS= -DINSTALL_SUBDIR_BIN=bin \
-DBUILD_SHARED_LIBS=off
LLD_UNSAFE= yes
DOS2UNIX_FILES= external/squirrel/CMakeLists.txt \
external/squirrel/squirrel/sqvm.cpp
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
OPTIONS_DEFINE= DOCS
post-patch:
${REINPLACE_CMD} -e '/^Icon=/s,supertux.png,supertux2,' \
${WRKSRC}/supertux2.desktop
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
SHA256 (supertux-0.4.0.tar.bz2) = d18dde3c415e619b4bb035e694ffc384be16576250c9df16929d9ec38daff782
SIZE (supertux-0.4.0.tar.bz2) = 79713147
TIMESTAMP = 1546855404
SHA256 (SuperTux-v0.6.0-Source.tar.gz) = c4c3e5fa6f90e87b8c5ad6b22a179e9a9839bf997e7f219e22bbcd1c97223ac0
SIZE (SuperTux-v0.6.0-Source.tar.gz) = 131203604

View File

@ -1,12 +1,12 @@
--- CMakeLists.txt.orig 2015-12-20 14:50:39 UTC
--- CMakeLists.txt.orig 2018-12-23 19:11:31 UTC
+++ CMakeLists.txt
@@ -572,7 +572,8 @@ ELSE(${CMAKE_SYSTEM_NAME} MATCHES "Darwi
@@ -880,7 +880,8 @@ else(WIN32 AND NOT UNIX)
SET(APPS "\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${INSTALL_SUBDIR_BIN}/supertux2")
set(APPS "\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${INSTALL_SUBDIR_BIN}/supertux2")
- INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/images/engine/icons/supertux.png ${CMAKE_CURRENT_SOURCE_DIR}/data/images/engine/icons/supertux.xpm DESTINATION "share/pixmaps/")
+ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/images/engine/icons/supertux.png DESTINATION "share/pixmaps/" RENAME supertux2.png)
+ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/images/engine/icons/supertux.xpm DESTINATION "share/pixmaps/" RENAME supertux2.xpm)
- install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/images/engine/icons/supertux.png ${CMAKE_CURRENT_SOURCE_DIR}/data/images/engine/icons/supertux.xpm DESTINATION "share/pixmaps/")
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/images/engine/icons/supertux.png DESTINATION "share/pixmaps/" RENAME supertux2.png)
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/images/engine/icons/supertux.xpm DESTINATION "share/pixmaps/" RENAME supertux2.xpm)
install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/supertux2.svg DESTINATION "share/icons/hicolor/scalable/apps")
ENDIF(${CMAKE_SYSTEM_NAME} MATCHES "Darwin" AND DISABLE_CPACK_BUNDLING)
ENDIF(WIN32 AND NOT UNIX)
endif(${CMAKE_SYSTEM_NAME} MATCHES "Darwin" AND DISABLE_CPACK_BUNDLING)

View File

@ -1,11 +0,0 @@
--- external/squirrel/CMakeLists.txt.orig 2015-12-20 14:56:35 UTC
+++ external/squirrel/CMakeLists.txt
@@ -82,8 +82,3 @@ GENERATE_EXPORT_HEADER( squirrel
set(LIB_SUBDIR "lib${LIB_SUFFIX}"
CACHE STRING "Subdirectory of prefix into which libraries are installed (e.g., lib32, lib64)")
-INSTALL(TARGETS squirrel
- RUNTIME DESTINATION bin
- ARCHIVE DESTINATION ${LIB_SUBDIR}
- LIBRARY DESTINATION ${LIB_SUBDIR}
- COMPONENT squirrel)

View File

@ -10,11 +10,11 @@ In file included from /usr/include/c++/v1/math.h:310:
#define type(obj) ((obj)._type)
--- external/squirrel/squirrel/sqvm.cpp.orig 2018-03-20 18:48:11.028369000 +0000
+++ external/squirrel/squirrel/sqvm.cpp 2018-03-20 18:48:32.059836000 +0000
--- external/squirrel/squirrel/sqvm.cpp.orig 2019-05-03 09:52:24 UTC
+++ external/squirrel/squirrel/sqvm.cpp
@@ -1,8 +1,8 @@
/*
see copyright notice in squirrel.h
see copyright notice in squirrel.h
*/
-#include "sqpcheader.h"
#include <math.h>

View File

@ -1,16 +0,0 @@
--- external/tinygettext/CMakeLists.txt.orig 2015-12-20 14:56:35 UTC
+++ external/tinygettext/CMakeLists.txt
@@ -203,13 +203,5 @@ set(LIB_SUBDIR "lib${LIB_SUFFIX}"
## prepare tinygettext.pc
configure_file(tinygettext.pc.in tinygettext.pc @ONLY)
-install(TARGETS tinygettext
- RUNTIME DESTINATION bin
- ARCHIVE DESTINATION ${LIB_SUBDIR}
- LIBRARY DESTINATION ${LIB_SUBDIR})
-install(FILES ${TINYGETTEXT_HEADERS}
- DESTINATION include/tinygettext)
-install(FILES ${tinygettext_BINARY_DIR}/tinygettext.pc
- DESTINATION ${LIB_SUBDIR}/pkgconfig)
# EOF #

View File

@ -1,4 +1,4 @@
SuperTux is a 2D jump and run side-scroller game in a style similar
to the original Super Mario games.
WWW: http://supertuxproject.org/
WWW: https://supertuxproject.org/

File diff suppressed because it is too large Load Diff