- Update to 1.5.0

- Removed FreeBSD 10 check for libevent, because of upstream fixes (as stated in changelog)
- Converted files/patch-Makefile.in to sed patch, which is position independent

PR:		195674
Submitted by:	lightside@gmx.com
This commit is contained in:
Sergey Matveychuk 2014-12-05 18:52:53 +00:00
parent b885ea4f8e
commit 4b1e4f7dc4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=374077
5 changed files with 9 additions and 25 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= unbound
PORTVERSION= 1.4.22
PORTREVISION= 5
PORTVERSION= 1.5.0
CATEGORIES= dns
MASTER_SITES= http://unbound.net/downloads/
@ -32,7 +31,7 @@ PLIST_SUB+= PYTHON=${PYTHON} MUNIN=${MUNIN}
OPTIONS_DEFINE= THREADS PYTHON GOST ECDSA MUNIN DOCS LIBEVENT
OPTIONS_DEFAULT=THREADS ECDSA
LIBEVENT_DESC= Build against libevent (BROKEN on =10.0-RELEASE)
LIBEVENT_DESC= Build against libevent
GOST_DESC= Enable GOST support (requires OpenSSL >= 1.0)
ECDSA_DESC= Enable ECDSA (elliptic curve) support (OpenSSL >= 1.0)
MUNIN_DESC= Install Munin plugin
@ -79,11 +78,6 @@ MUNIN= "@comment "
.endif
.if ${PORT_OPTIONS:MLIBEVENT}
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000015
SUB_LIST+= BROKEN="WARNING: Unbound with LIBEVENT crashes if run on FreeBSD 10.0-RELEASE. Update to 10.1-RELEASE or stable/10 after r273137."
.else
SUB_LIST+= BROKEN=""
.endif
LIB_DEPENDS+= libevent.so:${PORTSDIR}/devel/libevent2
USES+= pkgconfig
CONFIGURE_ARGS+=--with-libevent
@ -100,6 +94,9 @@ CONFIGURE_ARGS+=--without-pthreads
post-patch:
@${MKDIR} ${WRKSRC}/balancer
@${RM} ${WRKSRC}/util/configlexer.c
@${REINPLACE_CMD} -e 's|if test ! -e $$(DESTDIR)$$(configfile); then || ; \
s|$$(configfile); fi|$$(configfile).sample|' \
${WRKSRC}/Makefile.in
post-build:
@for s in ${STRIP_FILES}; do ${STRIP_CMD} ${WRKSRC}/$$s; done

View File

@ -1,2 +1,2 @@
SHA256 (unbound-1.4.22.tar.gz) = 1caf5081b2190ecdb23fc4d998b7999e28640c941f53baff7aee03c092a7d29f
SIZE (unbound-1.4.22.tar.gz) = 4735801
SHA256 (unbound-1.5.0.tar.gz) = 9fde4aeb8258bc864cd5e5d6d9b8bcf8fa12a57059424fece1c6adcc6387b876
SIZE (unbound-1.5.0.tar.gz) = 4811349

View File

@ -1,11 +0,0 @@
--- Makefile.in.orig 2014-01-31 14:19:01.000000000 +0400
+++ Makefile.in 2014-03-13 14:27:03.613703943 +0400
@@ -497,7 +497,7 @@
$(INSTALL) -c -m 644 doc/unbound.conf.5 $(DESTDIR)$(mandir)/man5
$(INSTALL) -c -m 644 $(srcdir)/doc/unbound-host.1 $(DESTDIR)$(mandir)/man1
$(INSTALL) -c -m 755 unbound-control-setup $(DESTDIR)$(sbindir)/unbound-control-setup
- if test ! -e $(DESTDIR)$(configfile); then $(INSTALL) -d `dirname $(DESTDIR)$(configfile)`; $(INSTALL) -c -m 644 doc/example.conf $(DESTDIR)$(configfile); fi
+ $(INSTALL) -d `dirname $(DESTDIR)$(configfile)`; $(INSTALL) -c -m 644 doc/example.conf $(DESTDIR)$(configfile).sample
pythonmod-uninstall:
rm -f -- $(DESTDIR)$(PYTHON_SITE_PKG)/unboundmodule.py

View File

@ -8,5 +8,3 @@ env.unbound_conf %%PREFIX%%/etc/unbound/unbound.conf
env.unbound_control %%PREFIX%%/sbin/unbound-control
env.spoof_warn 1000
env.spoof_crit 100000
%%BROKEN%%

View File

@ -1,6 +1,6 @@
etc/unbound/unbound.conf.sample
include/unbound.h
lib/libunbound.so.2.2.1
lib/libunbound.so.2.3.3
lib/libunbound.so.2
lib/libunbound.so
lib/libunbound.a
@ -51,7 +51,7 @@ sbin/unbound-host
%%PYTHON%%%%PYTHON_SITELIBDIR%%/_unbound.a
%%PYTHON%%%%PYTHON_SITELIBDIR%%/_unbound.so
%%PYTHON%%%%PYTHON_SITELIBDIR%%/_unbound.so.2
%%PYTHON%%%%PYTHON_SITELIBDIR%%/_unbound.so.2.2.1
%%PYTHON%%%%PYTHON_SITELIBDIR%%/_unbound.so.2.3.3
%%PYTHON%%%%PYTHON_SITELIBDIR%%/unbound.py
%%PYTHON%%%%PYTHON_SITELIBDIR%%/unboundmodule.py
%%MUNIN%%etc/munin/plugins/unbound_munin_by_class