- Update to 3.2.4

Changes:

2009-11-23:
- src/imager.cpp (imager::start_imaging): fixed for threaded_hash.

20091022:
- configure.ac: updated to version 3.2.3
- configure.ac: fixed the optimization flag stuff.
- imager.cpp & imager.h: modified to work with threaded_hash and EVP system

20090905:
- configure.ac: minor changes to compile under GCC +4.4

PR:		ports/151683
Submitted by:	Herbert J. Skuhra <h.skuhra@gmail.com> (maintainer)
Approved by:	pgollucci (mentor, implicit)
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2010-10-26 04:07:25 +00:00
parent 39640c56a8
commit 4b169f7e54
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=263600
3 changed files with 4 additions and 22 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= aimage
PORTVERSION= 3.2.1
PORTREVISION= 1
PORTVERSION= 3.2.4
CATEGORIES= sysutils
MASTER_SITES= http://afflib.org/downloads/
@ -16,16 +15,10 @@ COMMENT= Advanced Disk Imager
LIB_DEPENDS= afflib:${PORTSDIR}/sysutils/afflib
BROKEN= does not compile
USE_OPENSSL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf:268
PLIST_FILES= bin/aimage
post-patch:
@${REINPLACE_CMD} -e 's|2.61|2.68|g' ${WRKSRC}/aclocal.m4
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (aimage-3.2.1.tar.gz) = 0afd3376fe2c8dd8e43571282505a9fb
SHA256 (aimage-3.2.1.tar.gz) = b647291ae743327ab8d351f5a1d3cdc494bc527d652f08c60b996ec7d6d307a5
SIZE (aimage-3.2.1.tar.gz) = 342270
MD5 (aimage-3.2.4.tar.gz) = bb6e4e91524612570a481b6470fe7cd1
SHA256 (aimage-3.2.4.tar.gz) = 443a98f8820e86504d0036e0075d4a8324d01acc6451c529a2f381cffc23b7b4
SIZE (aimage-3.2.4.tar.gz) = 144764

View File

@ -1,11 +0,0 @@
--- src/imager.cpp.orig Sat Mar 29 14:13:35 2008
+++ src/imager.cpp Sat Mar 29 14:34:37 2008
@@ -10,6 +10,8 @@
#include <stdlib.h>
#include <err.h>
#include <sys/types.h>
+#include <sys/socket.h>
+#include <netinet/in.h>
#include <sys/stat.h>
#include <sys/time.h>
#include <fcntl.h>