science/axom: Update 0.6.1 -> 0.6.1-1671
Reason: science/serac needs latest Axom code.
This commit is contained in:
parent
7613a34ed1
commit
4af6d519a7
@ -1,7 +1,7 @@
|
||||
PORTNAME= axom
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.6.1
|
||||
PORTREVISION= 3
|
||||
DISTVERSION= 0.6.1-1671
|
||||
DISTVERSIONSUFFIX= -g88cac2607
|
||||
CATEGORIES= science
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
@ -28,7 +28,7 @@ GH_TUPLE= LLNL:axom_data:b3d8e6f:axom_data/../data \
|
||||
LLNL:blt:ddd5a0c:blt/cmake/blt \
|
||||
LLNL:uberenv:a121a45:uberenv/scripts/uberenv
|
||||
|
||||
CMAKE_OFF= AXOM_ENABLE_DOCS AXOM_ENABLE_EXAMPLES AXOM_ENABLE_TESTS FREEBSD_ENABLE_EXAMPLES
|
||||
CMAKE_OFF= AXOM_ENABLE_DOCS AXOM_ENABLE_EXAMPLES AXOM_ENABLE_TESTS AXOM_ENABLE_EXAMPLES
|
||||
CMAKE_ON= BUILD_SHARED_LIBS
|
||||
CMAKE_TESTING_ON= AXOM_ENABLE_TESTS
|
||||
CMAKE_ARGS= -DCONDUIT_DIR=${LOCALBASE} \
|
||||
|
@ -1,6 +1,6 @@
|
||||
TIMESTAMP = 1638812352
|
||||
SHA256 (LLNL-axom-v0.6.1_GH0.tar.gz) = 405b524905f64840db37953df2f60eecacc653383f4c71917aeda24fb9453c2e
|
||||
SIZE (LLNL-axom-v0.6.1_GH0.tar.gz) = 12219852
|
||||
TIMESTAMP = 1661113698
|
||||
SHA256 (LLNL-axom-v0.6.1-1671-g88cac2607_GH0.tar.gz) = 22ee241cb429c6e1d39769270f278552518c12eb1519e386bc79fe6548152846
|
||||
SIZE (LLNL-axom-v0.6.1-1671-g88cac2607_GH0.tar.gz) = 12481116
|
||||
SHA256 (LLNL-axom_data-b3d8e6f_GH0.tar.gz) = 3b6f9c5d12c2ea4f5ecc3e946264eddb8b8afb69bd05af6b93202fe60d9eacca
|
||||
SIZE (LLNL-axom_data-b3d8e6f_GH0.tar.gz) = 46238341
|
||||
SHA256 (LLNL-blt-ddd5a0c_GH0.tar.gz) = 5c235a9b160f1cc3f6ce4d7c80bf72772ac10839909f4f96075d08b3edd8f540
|
||||
|
@ -1,12 +0,0 @@
|
||||
--- CMakeLists.txt.orig 2021-11-03 19:31:10 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -122,7 +122,9 @@ if(AXOM_ENABLE_TOOLS)
|
||||
endif()
|
||||
|
||||
# Using Axom install examples
|
||||
+if (FREEBSD_ENABLE_EXAMPLES)
|
||||
add_subdirectory(examples)
|
||||
+endif()
|
||||
|
||||
if(AXOM_ENABLE_DOCS)
|
||||
if(SPHINX_FOUND)
|
@ -17,6 +17,7 @@ include/axom/core/Types.hpp
|
||||
include/axom/core/execution/execution_space.hpp
|
||||
include/axom/core/execution/for_all.hpp
|
||||
include/axom/core/execution/internal/cuda_exec.hpp
|
||||
include/axom/core/execution/internal/hip_exec.hpp
|
||||
include/axom/core/execution/internal/omp_exec.hpp
|
||||
include/axom/core/execution/internal/seq_exec.hpp
|
||||
include/axom/core/execution/synchronize.hpp
|
||||
@ -34,6 +35,7 @@ include/axom/core/numerics/matvecops.hpp
|
||||
include/axom/core/numerics/polynomial_solvers.hpp
|
||||
include/axom/core/utilities/About.hpp
|
||||
include/axom/core/utilities/AnnotationMacros.hpp
|
||||
include/axom/core/utilities/BitUtilities.hpp
|
||||
include/axom/core/utilities/FileUtilities.hpp
|
||||
include/axom/core/utilities/StringUtilities.hpp
|
||||
include/axom/core/utilities/System.hpp
|
||||
@ -137,14 +139,20 @@ include/axom/mint/mesh/UniformMesh.hpp
|
||||
include/axom/mint/mesh/UnstructuredMesh.hpp
|
||||
include/axom/mint/mesh/blueprint.hpp
|
||||
include/axom/mint/mesh/internal/ConnectivityArrayHelpers.hpp
|
||||
include/axom/mint/mesh/internal/ConnectivityArray_indirection.hpp
|
||||
include/axom/mint/mesh/internal/ConnectivityArray_typed_indirection.hpp
|
||||
include/axom/mint/mesh/internal/MeshHelpers.hpp
|
||||
include/axom/mint/utils/ExternalArray.hpp
|
||||
include/axom/mint/utils/su2_utils.hpp
|
||||
include/axom/mint/utils/vtk_utils.hpp
|
||||
include/axom/multimat.hpp
|
||||
include/axom/multimat/mmfield.hpp
|
||||
include/axom/multimat/mmsubfield.hpp
|
||||
include/axom/multimat/multimat.hpp
|
||||
include/axom/primal.hpp
|
||||
include/axom/primal/constants.hpp
|
||||
include/axom/primal/geometry/BezierCurve.hpp
|
||||
include/axom/primal/geometry/BoundingBox.hpp
|
||||
include/axom/primal/geometry/CurvedPolygon.hpp
|
||||
include/axom/primal/geometry/NumericArray.hpp
|
||||
include/axom/primal/geometry/Octahedron.hpp
|
||||
include/axom/primal/geometry/OrientationResult.hpp
|
||||
@ -162,13 +170,21 @@ include/axom/primal/geometry/Vector.hpp
|
||||
include/axom/primal/operators/clip.hpp
|
||||
include/axom/primal/operators/closest_point.hpp
|
||||
include/axom/primal/operators/compute_bounding_box.hpp
|
||||
include/axom/primal/operators/compute_moments.hpp
|
||||
include/axom/primal/operators/detail/clip_impl.hpp
|
||||
include/axom/primal/operators/detail/compute_moments_impl.hpp
|
||||
%%MFEM%%include/axom/primal/operators/detail/evaluate_integral_impl.hpp
|
||||
include/axom/primal/operators/detail/in_curved_polygon_impl.hpp
|
||||
include/axom/primal/operators/detail/intersect_bezier_impl.hpp
|
||||
include/axom/primal/operators/detail/intersect_bounding_box_impl.hpp
|
||||
include/axom/primal/operators/detail/intersect_impl.hpp
|
||||
include/axom/primal/operators/detail/intersect_ray_impl.hpp
|
||||
%%MFEM%%include/axom/primal/operators/evaluate_integral.hpp
|
||||
include/axom/primal/operators/in_curved_polygon.hpp
|
||||
include/axom/primal/operators/in_polygon.hpp
|
||||
include/axom/primal/operators/in_sphere.hpp
|
||||
include/axom/primal/operators/intersect.hpp
|
||||
include/axom/primal/operators/is_convex.hpp
|
||||
include/axom/primal/operators/orientation.hpp
|
||||
include/axom/primal/operators/split.hpp
|
||||
include/axom/primal/operators/squared_distance.hpp
|
||||
@ -179,16 +195,20 @@ include/axom/primal/utils/ZipRay.hpp
|
||||
include/axom/primal/utils/ZipVector.hpp
|
||||
include/axom/quest.hpp
|
||||
include/axom/quest/AllNearestNeighbors.hpp
|
||||
include/axom/quest/Delaunay.hpp
|
||||
include/axom/quest/Discretize.hpp
|
||||
%%MPI%%include/axom/quest/DistributedClosestPoint.hpp
|
||||
include/axom/quest/InOutOctree.hpp
|
||||
%%MFEM%%include/axom/quest/IntersectionShaper.hpp
|
||||
include/axom/quest/MeshTester.hpp
|
||||
include/axom/quest/PointInCell.hpp
|
||||
%%MFEM%%include/axom/quest/SamplingShaper.hpp
|
||||
include/axom/quest/ScatteredInterpolation.hpp
|
||||
%%MFEM%%include/axom/quest/Shaper.hpp
|
||||
include/axom/quest/SignedDistance.hpp
|
||||
include/axom/quest/detail/AllNearestNeighbors_detail.hpp
|
||||
include/axom/quest/detail/Discretize_detail.hpp
|
||||
include/axom/quest/detail/MeshTester_detail.hpp
|
||||
include/axom/quest/detail/PointFinder.hpp
|
||||
include/axom/quest/detail/PointInCellMeshWrapper_mfem.hpp
|
||||
include/axom/quest/detail/inout/BlockData.hpp
|
||||
@ -210,15 +230,14 @@ include/axom/sidre/core/Attribute.hpp
|
||||
include/axom/sidre/core/Buffer.hpp
|
||||
include/axom/sidre/core/DataStore.hpp
|
||||
include/axom/sidre/core/Group.hpp
|
||||
include/axom/sidre/core/IndexedCollection.hpp
|
||||
include/axom/sidre/core/ItemCollection.hpp
|
||||
include/axom/sidre/core/Iterator.hpp
|
||||
include/axom/sidre/core/ListCollection.hpp
|
||||
%%MFEM%%include/axom/sidre/core/MFEMSidreDataCollection.hpp
|
||||
include/axom/sidre/core/MapCollection.hpp
|
||||
include/axom/sidre/core/SidreDataTypeIds.h
|
||||
include/axom/sidre/core/SidreTypes.hpp
|
||||
include/axom/sidre/core/View.hpp
|
||||
include/axom/sidre/core/sidre.hpp
|
||||
%%MPI%%include/axom/sidre/spio/IOBaton.hpp
|
||||
%%MPI%%include/axom/sidre/spio/IOManager.hpp
|
||||
include/axom/slam.hpp
|
||||
@ -244,7 +263,8 @@ include/axom/slam/Set.hpp
|
||||
include/axom/slam/StaticRelation.hpp
|
||||
include/axom/slam/SubMap.hpp
|
||||
include/axom/slam/Utilities.hpp
|
||||
include/axom/slam/internal/BitTwiddle.hpp
|
||||
include/axom/slam/mesh_struct/IA.hpp
|
||||
include/axom/slam/mesh_struct/IA_impl.hpp
|
||||
include/axom/slam/policies/CardinalityPolicies.hpp
|
||||
include/axom/slam/policies/IndirectionPolicies.hpp
|
||||
include/axom/slam/policies/OffsetPolicies.hpp
|
||||
@ -264,6 +284,7 @@ include/axom/slic/streams/GenericOutputStream.hpp
|
||||
%%MPI%%include/axom/slic/streams/LumberjackStream.hpp
|
||||
%%MPI%%include/axom/slic/streams/SynchronizedStream.hpp
|
||||
%%LUA%%include/axom/sol.hpp
|
||||
%%LUA%%include/axom/sol_forward.hpp
|
||||
include/axom/sparsehash/README
|
||||
include/axom/sparsehash/dense_hash_map
|
||||
include/axom/sparsehash/dense_hash_set
|
||||
@ -296,6 +317,7 @@ include/axom/spin/internal/linear_bvh/build_radix_tree.hpp
|
||||
include/axom/spin/internal/linear_bvh/bvh_traverse.hpp
|
||||
include/axom/spin/internal/linear_bvh/bvh_vtkio.hpp
|
||||
include/axom/spin/policy/LinearBVH.hpp
|
||||
include/axom/spin/policy/UniformGridStorage.hpp
|
||||
lib/cmake/axom-config-version.cmake
|
||||
lib/cmake/axom-config.cmake
|
||||
lib/cmake/axom-targets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
|
Loading…
Reference in New Issue
Block a user