- Update to 0.6
Obtained from: FreeBSD Haskell
This commit is contained in:
parent
c5beeb87bc
commit
4aef278920
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=291182
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= smallcheck
|
||||
PORTVERSION= 0.4
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.6
|
||||
CATEGORIES= devel haskell
|
||||
|
||||
MAINTAINER= haskell@FreeBSD.org
|
||||
@ -17,8 +16,6 @@ LICENSE= BSD
|
||||
|
||||
CABAL_SETUP= Setup.hs
|
||||
|
||||
PORTDATA= *
|
||||
PORTEXAMPLES= *
|
||||
INSTALL_PORTEXAMPLES= @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
|
||||
|
||||
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (cabal/smallcheck-0.4.tar.gz) = aa86853b3c480fb3d13115823a7b70126c136ed4913261cd7c354f35aa1c015b
|
||||
SIZE (cabal/smallcheck-0.4.tar.gz) = 21543
|
||||
SHA256 (cabal/smallcheck-0.6.tar.gz) = 3b2d49ff08f9146c3ae70e9d1821977233fa5715f682835751a2fbbca46f62a5
|
||||
SIZE (cabal/smallcheck-0.6.tar.gz) = 22364
|
||||
|
@ -1,29 +1,13 @@
|
||||
--- smallcheck.cabal.orig 2009-12-25 17:11:58.000000000 +0000
|
||||
+++ smallcheck.cabal 2009-12-25 17:17:57.000000000 +0000
|
||||
@@ -16,17 +16,19 @@
|
||||
Build-Depends: base, haskell98
|
||||
Build-Type: Simple
|
||||
--- ./smallcheck.cabal.orig 2011-12-11 12:08:40.000000000 +0100
|
||||
+++ ./smallcheck.cabal 2011-12-16 17:57:48.000000000 +0100
|
||||
@@ -27,9 +27,9 @@
|
||||
examples/numeric/README, examples/logical/README, examples/imperative/README,
|
||||
examples/listy/README, examples/regular/README, examples/circuits/README,
|
||||
examples/binarytries/README,
|
||||
- README.md, CREDITS.md, CHANGES.md,
|
||||
examples/run-examples.sh
|
||||
|
||||
-Extra-source-files: examples/numeric/NumProps.hs, examples/logical/LogicProps.hs,
|
||||
+Extra-source-files: examples/numeric/NumProps.hs, examples/numeric/README,
|
||||
+ examples/logical/LogicProps.hs, examples/logical/README,
|
||||
examples/imperative/Interpreter.hs, examples/imperative/Syntax.hs,
|
||||
examples/imperative/Machine.hs, examples/imperative/Behaviour.hs,
|
||||
examples/imperative/Properties.hs, examples/imperative/Value.hs,
|
||||
examples/imperative/StackMap.hs, examples/imperative/Compiler.hs,
|
||||
- examples/listy/ListProps.hs, examples/regular/Regular.hs,
|
||||
- examples/circuits/BitAdd.hs, examples/circuits/Mux.hs, examples/circuits/Sad.hs,
|
||||
- examples/binarytries/BinaryTries.hs
|
||||
+ examples/imperative/README, examples/listy/ListProps.hs,
|
||||
+ examples/listy/README, examples/regular/Regular.hs,
|
||||
+ examples/regular/README, examples/circuits/BitAdd.hs,
|
||||
+ examples/circuits/Mux.hs, examples/circuits/Sad.hs,
|
||||
+ examples/circuits/README, examples/binarytries/BinaryTries.hs,
|
||||
+ examples/binarytries/README
|
||||
+Data-files: README.md CREDITS.md CHANGES.md
|
||||
|
||||
-Data-files: examples/numeric/README, examples/logical/README, examples/imperative/README,
|
||||
- examples/listy/README, examples/regular/README, examples/circuits/README,
|
||||
- examples/binarytries/README, README
|
||||
+Data-files: README
|
||||
|
||||
Exposed-modules: Test.SmallCheck
|
||||
Source-repository head
|
||||
|
@ -3,4 +3,4 @@ instead of testing for a sample of randomly generated values, SmallCheck
|
||||
tests properties for all the finitely many values up to some depth,
|
||||
progressively increasing the depth used.
|
||||
|
||||
WWW: http://hackage.haskell.org/package/smallcheck
|
||||
WWW: https://github.com/feuerbach/smallcheck
|
||||
|
Loading…
Reference in New Issue
Block a user