- Update to version 1.6.2
- Remove description for DOXYGEN option
This commit is contained in:
parent
5e8fb43b19
commit
4aeaf60c59
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=299969
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= lives
|
||||
PORTVERSION= 1.6.1
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.6.2
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= http://salsaman.home.xs4all.nl/lives/current/
|
||||
DISTNAME= LiVES-${PORTVERSION}
|
||||
@ -69,7 +68,6 @@ DOC_FILES= AUTHORS BUGS ChangeLog FEATURES GETTING.STARTED README \
|
||||
PORT_VERBS= lives LiVES _encoder.py midistart midistop smogrify sendOSC
|
||||
|
||||
OPTIONS_DEFINE= DOXYGEN FREI0R
|
||||
DOXYGEN_DESC= Build Doxygen documentation
|
||||
FREI0R_DESC= Enable frei0r support
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (LiVES-1.6.1.tar.bz2) = cb0dc4e909e78db79e33f3dbd0464522cdc494442bd79670d05756ad4d5b9cb7
|
||||
SIZE (LiVES-1.6.1.tar.bz2) = 3372854
|
||||
SHA256 (LiVES-1.6.2.tar.bz2) = 39135d7d79a357f70b340fc1ad34f4c1dccc51e1d34577810d525c8cc134efc1
|
||||
SIZE (LiVES-1.6.2.tar.bz2) = 3491550
|
||||
|
@ -0,0 +1,14 @@
|
||||
--- ./lives-plugins/plugins/decoders/asf_decoder.c.orig 2012-06-25 19:53:28.000000000 +0200
|
||||
+++ ./lives-plugins/plugins/decoders/asf_decoder.c 2012-06-25 19:57:21.000000000 +0200
|
||||
@@ -30,11 +30,6 @@
|
||||
#include <fcntl.h>
|
||||
#include <unistd.h>
|
||||
#include <stdlib.h>
|
||||
-#ifndef IS_MINGW
|
||||
-#ifndef IS_SOLARIS
|
||||
-#include <endian.h>
|
||||
-#endif
|
||||
-#endif
|
||||
#include <sys/stat.h>
|
||||
|
||||
const char *plugin_version="LiVES asf/wmv decoder version 1.0";
|
@ -0,0 +1,12 @@
|
||||
--- ./lives-plugins/plugins/decoders/mpegts_decoder.c.orig 2012-06-25 19:55:35.000000000 +0200
|
||||
+++ ./lives-plugins/plugins/decoders/mpegts_decoder.c 2012-06-25 19:57:03.000000000 +0200
|
||||
@@ -29,9 +29,6 @@
|
||||
#include <stdlib.h>
|
||||
#include <sys/stat.h>
|
||||
|
||||
-#ifndef IS_MINGW
|
||||
-#include <endian.h>
|
||||
-#endif
|
||||
|
||||
const char *plugin_version="LiVES mpegts decoder version 1.0";
|
||||
|
@ -1,13 +1,11 @@
|
||||
--- lives-plugins/plugins/playback/video/lives2lives_stream.c.orig 2009-08-12 05:42:46.000000000 +0900
|
||||
+++ lives-plugins/plugins/playback/video/lives2lives_stream.c 2009-09-30 00:31:51.000000000 +0900
|
||||
@@ -41,7 +41,10 @@
|
||||
#include <unistd.h>
|
||||
#include <stdlib.h>
|
||||
#include <netdb.h>
|
||||
+#include <sys/types.h>
|
||||
--- ./lives-plugins/plugins/playback/video/lives2lives_stream.c.orig 2012-06-25 19:50:48.000000000 +0200
|
||||
+++ ./lives-plugins/plugins/playback/video/lives2lives_stream.c 2012-06-25 19:51:14.000000000 +0200
|
||||
@@ -8,7 +8,7 @@
|
||||
#include <inttypes.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
-
|
||||
+#include <netinet/in.h>
|
||||
+#include <arpa/inet.h>
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
||||
//////////////////////////////////////
|
||||
|
||||
static int palette_list[3];
|
||||
|
@ -1,11 +1,11 @@
|
||||
--- src/htmsocket.c.orig 2012-01-17 04:02:52.000000000 +0100
|
||||
+++ src/htmsocket.c 2012-04-13 23:32:15.000000000 +0200
|
||||
@@ -12,6 +12,8 @@
|
||||
|
||||
#include <sys/socket.h>
|
||||
#include <sys/ioctl.h>
|
||||
+#include <sys/types.h>
|
||||
--- ./src/htmsocket.c.orig 2012-06-25 19:47:03.000000000 +0200
|
||||
+++ ./src/htmsocket.c 2012-06-25 19:48:09.000000000 +0200
|
||||
@@ -8,7 +8,7 @@
|
||||
#include <stdio.h>
|
||||
#include <unistd.h>
|
||||
#include <errno.h>
|
||||
-
|
||||
+#include <netinet/in.h>
|
||||
|
||||
#if defined(__sun)
|
||||
#include <sys/filio.h>
|
||||
#ifndef IS_MINGW
|
||||
#include <netdb.h>
|
||||
#include <sys/socket.h>
|
||||
|
@ -1,7 +1,7 @@
|
||||
--- ./src/main.h.orig Mon Dec 18 04:51:33 2006
|
||||
+++ ./src/main.h Fri Jan 26 12:48:23 2007
|
||||
@@ -57,6 +57,7 @@
|
||||
#include <gdk/gdkkeysyms.h>
|
||||
--- ./src/main.h.orig 2012-06-24 16:20:15.000000000 +0200
|
||||
+++ ./src/main.h 2012-06-25 19:43:27.000000000 +0200
|
||||
@@ -98,6 +98,7 @@
|
||||
#endif // GUI_GTK
|
||||
|
||||
#include <stdlib.h>
|
||||
+#include <sys/stat.h>
|
||||
|
19
multimedia/lives/files/patch-src__plugins.h
Normal file
19
multimedia/lives/files/patch-src__plugins.h
Normal file
@ -0,0 +1,19 @@
|
||||
--- ./src/plugins.h.orig 2012-06-25 19:44:08.000000000 +0200
|
||||
+++ ./src/plugins.h 2012-06-25 19:46:11.000000000 +0200
|
||||
@@ -12,7 +12,7 @@
|
||||
#include <string.h>
|
||||
#include <fcntl.h>
|
||||
#include <stdlib.h>
|
||||
-
|
||||
+#include "../libweed/weed-effects.h"
|
||||
|
||||
// generic plugins
|
||||
|
||||
@@ -36,7 +36,6 @@
|
||||
GList *plugin_request_by_space (const gchar *plugin_type, const gchar *plugin_name, const gchar *request);
|
||||
GList *plugin_request_common (const gchar *plugin_type, const gchar *plugin_name, const gchar *request, const gchar *delim, gboolean allow_blanks);
|
||||
|
||||
-typedef weed_plant_t *(*weed_bootstrap_f) (weed_default_getter_f *value, int num_versions, int *plugin_versions);
|
||||
|
||||
/// video playback plugins
|
||||
typedef gboolean (*plugin_keyfunc) (gboolean down, guint16 unicode, guint16 keymod);
|
@ -47,8 +47,16 @@ lib/libweed.so.0
|
||||
lib/libweed_slice.la
|
||||
lib/libweed_slice.so
|
||||
lib/libweed_slice.so.0
|
||||
lib/lives/plugins/decoders/asf_decoder.la
|
||||
lib/lives/plugins/decoders/asf_decoder.so
|
||||
lib/lives/plugins/decoders/dv_decoder.la
|
||||
lib/lives/plugins/decoders/dv_decoder.so
|
||||
lib/lives/plugins/decoders/flv_decoder.la
|
||||
lib/lives/plugins/decoders/flv_decoder.so
|
||||
lib/lives/plugins/decoders/mkv_decoder.la
|
||||
lib/lives/plugins/decoders/mkv_decoder.so
|
||||
lib/lives/plugins/decoders/mpegts_decoder.la
|
||||
lib/lives/plugins/decoders/mpegts_decoder.so
|
||||
lib/lives/plugins/decoders/ogg_decoder.la
|
||||
lib/lives/plugins/decoders/ogg_decoder.so
|
||||
lib/lives/plugins/effects/realtime/weed/RGBdelay.la
|
||||
@ -59,6 +67,8 @@ lib/lives/plugins/effects/realtime/weed/audio_transition.la
|
||||
lib/lives/plugins/effects/realtime/weed/audio_transition.so
|
||||
lib/lives/plugins/effects/realtime/weed/audio_volume.la
|
||||
lib/lives/plugins/effects/realtime/weed/audio_volume.so
|
||||
lib/lives/plugins/effects/realtime/weed/blank_frame_detector.la
|
||||
lib/lives/plugins/effects/realtime/weed/blank_frame_detector.so
|
||||
lib/lives/plugins/effects/realtime/weed/blurzoom.la
|
||||
lib/lives/plugins/effects/realtime/weed/blurzoom.so
|
||||
lib/lives/plugins/effects/realtime/weed/bump2d.la
|
||||
@ -83,6 +93,8 @@ lib/lives/plugins/effects/realtime/weed/fireTV.so
|
||||
%%FREI0R%%lib/lives/plugins/effects/realtime/weed/frei0r/frei0r.so
|
||||
lib/lives/plugins/effects/realtime/weed/gdk_fast_resize.la
|
||||
lib/lives/plugins/effects/realtime/weed/gdk_fast_resize.so
|
||||
lib/lives/plugins/effects/realtime/weed/haar_analyser.la
|
||||
lib/lives/plugins/effects/realtime/weed/haar_analyser.so
|
||||
lib/lives/plugins/effects/realtime/weed/haip.la
|
||||
lib/lives/plugins/effects/realtime/weed/haip.so
|
||||
lib/lives/plugins/effects/realtime/weed/layout_blends.la
|
||||
@ -129,6 +141,8 @@ lib/lives/plugins/effects/realtime/weed/targeted_zoom.la
|
||||
lib/lives/plugins/effects/realtime/weed/targeted_zoom.so
|
||||
lib/lives/plugins/effects/realtime/weed/textfun.la
|
||||
lib/lives/plugins/effects/realtime/weed/textfun.so
|
||||
lib/lives/plugins/effects/realtime/weed/tone_gen.la
|
||||
lib/lives/plugins/effects/realtime/weed/tone_gen.so
|
||||
lib/lives/plugins/effects/realtime/weed/tvpic.la
|
||||
lib/lives/plugins/effects/realtime/weed/tvpic.so
|
||||
lib/lives/plugins/effects/realtime/weed/vertigo.la
|
||||
|
Loading…
Reference in New Issue
Block a user