Update to version 0.7.

This commit is contained in:
Koop Mast 2005-01-09 17:53:38 +00:00
parent d19ce79279
commit 4abe3a7b84
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=125978
12 changed files with 83 additions and 177 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= polypaudio
PORTVERSION= 0.6
PORTVERSION= 0.7
CATEGORIES= audio
MASTER_SITES= http://0pointer.de/lennart/projects/polypaudio/
@ -45,6 +45,11 @@ post-patch:
${WRKSRC}/polyp/default.pa.in
@${REINPLACE_CMD} -e 's|seq|jot|' \
${WRKSRC}/polyp/esdcompat.sh.in
# 4.x doesn't have float_t
.if ${OSVERSION} < 500000
@${REINPLACE_CMD} -e 's|float_t|float|g' \
${WRKSRC}/polyp/sample-util.c
.endif
post-install:
.for ii in default.pa daemon.conf client.conf

View File

@ -1,2 +1,2 @@
MD5 (polypaudio-0.6.tar.gz) = 872fef6a0b92de0ba53f874c4e0318ec
SIZE (polypaudio-0.6.tar.gz) = 458557
MD5 (polypaudio-0.7.tar.gz) = 1c3693ab9c6904dbed6dfa7656778de4
SIZE (polypaudio-0.7.tar.gz) = 945775

View File

@ -1,11 +1,11 @@
--- configure.orig Sat Oct 30 01:23:23 2004
+++ configure Sat Oct 30 01:24:26 2004
@@ -12745,7 +12745,7 @@
--- configure.orig Fri Dec 31 14:10:44 2004
+++ configure Fri Dec 31 14:12:12 2004
@@ -24488,7 +24488,7 @@
-for ac_func in gethostname gettimeofday memchr memmove memset mkdir mkfifo munmap rmdir socket strcspn strerror strrchr strspn strstr strtol strtoul pow strcasecmp putenv strchr strpbrk strdup
+for ac_func in gethostname gettimeofday memchr memmove memset mkdir mkfifo munmap rmdir socket strcspn strerror strrchr strspn strstr strtol strtoul pow strcasecmp putenv strchr strpbrk strdup getgrgid_r getpwuid_r
-for ac_func in gethostname gettimeofday memchr memmove memset mkdir mkfifo munmap rmdir socket strcspn strerror strrchr strspn strstr strtol strtoul strcasecmp putenv strchr strpbrk strdup getgrgid_r getpwuid_r regcomp ftruncate select
+for ac_func in gethostname gettimeofday memchr memmove memset mkdir mkfifo munmap rmdir socket strcspn strerror strrchr strspn strstr strtol strtoul strcasecmp putenv strchr strpbrk strdup regcomp ftruncate select
do
as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
echo "$as_me:$LINENO: checking for $ac_func" >&5

View File

@ -1,20 +0,0 @@
--- polyp/Makefile.in.orig Fri Oct 29 17:20:45 2004
+++ polyp/Makefile.in Fri Oct 29 17:23:24 2004
@@ -5811,7 +5811,7 @@
### Some minor stuff
suid: polypaudio
- chown root:root $<
+ chown root:wheel $<
chmod u+s $<
esdcompat.sh: esdcompat.sh.in Makefile
@@ -5830,7 +5830,7 @@
-e 's,@DEFAULT_CONFIG_FILE\@,$(polypconfdir)/daemon.conf,g' < $< > $@
install-exec-hook:
- chown root:root $(DESTDIR)$(bindir)/polypaudio
+ chown root:wheel $(DESTDIR)$(bindir)/polypaudio
chmod u+s $(DESTDIR)$(bindir)/polypaudio
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.

View File

@ -1,20 +1,11 @@
--- polyp/default.pa.in.orig Fri Oct 29 22:16:24 2004
+++ polyp/default.pa.in Fri Oct 29 22:17:43 2004
@@ -21,7 +21,7 @@
# Load audio drivers statically
#load-module module-alsa-sink
-load-module module-alsa-source device=plughw:1,0
+#load-module module-alsa-source device=plughw:1,0
load-module module-oss device="/dev/dsp" sink_name=output source_name=input record=0
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
load-module module-null-sink
--- polyp/default.pa.in.orig Sun Nov 21 22:27:41 2004
+++ polyp/default.pa.in Fri Dec 31 14:16:34 2004
@@ -53,7 +53,7 @@
.nofail
# Load something to the sample cache
-load-sample x11-bell /usr/share/sounds/KDE_Notify.wav
+load-sample x11-bell %%LOCALBASE%%/share/sounds/KDE_Notify.wav
load-sample-dir-lazy /usr/share/sounds/*.wav
# Load X11 bell module
load-module module-x11-bell sample=x11-bell sink=output

View File

@ -0,0 +1,10 @@
--- polyp/module-protocol-stub.c.orig Fri Dec 31 15:22:48 2004
+++ polyp/module-protocol-stub.c Fri Dec 31 15:34:51 2004
@@ -28,6 +28,7 @@
#include <stdio.h>
#include <assert.h>
#include <arpa/inet.h>
+#include <sys/syslimits.h>
#include <unistd.h>
#include <netinet/in.h>

View File

@ -1,17 +0,0 @@
--- polyp/packet.h.orig Fri Oct 29 23:30:28 2004
+++ polyp/packet.h Fri Oct 29 23:31:05 2004
@@ -22,8 +22,14 @@
USA.
***/
+#ifdef HAVE_CONFIG_H
+#include <config.h>
+#endif
+
#include <sys/types.h>
+#ifdef HAVE_STDINT_H
#include <stdint.h>
+#endif
struct pa_packet {
enum { PA_PACKET_APPENDED, PA_PACKET_DYNAMIC } type;

View File

@ -0,0 +1,10 @@
--- polyp/pid.c.orig Fri Dec 31 15:36:25 2004
+++ polyp/pid.c Fri Dec 31 15:36:37 2004
@@ -32,6 +32,7 @@
#include <assert.h>
#include <stdlib.h>
#include <limits.h>
+#include <sys/stat.h>
#include <signal.h>
#include "pid.h"

View File

@ -1,10 +1,10 @@
--- polyp/polyplib-context.c.orig Fri Oct 29 17:05:24 2004
+++ polyp/polyplib-context.c Fri Oct 29 17:05:39 2004
@@ -34,6 +34,7 @@
--- polyp/polyplib-context.c.orig Fri Dec 31 14:39:40 2004
+++ polyp/polyplib-context.c Fri Dec 31 14:40:00 2004
@@ -29,6 +29,7 @@
#include <string.h>
#include <sys/types.h>
#include <sys/socket.h>
+#include <sys/syslimits.h>
#include <netdb.h>
#include <unistd.h>
#include <sys/stat.h>
#include <errno.h>
#include <sys/wait.h>
+#include <signal.h>
#include "polyplib-internal.h"
#include "polyplib-context.h"

View File

@ -1,58 +0,0 @@
--- polyp/socket-util.c.orig Fri Oct 29 16:48:42 2004
+++ polyp/socket-util.c Fri Oct 29 17:04:57 2004
@@ -30,13 +30,16 @@
#include <assert.h>
#include <string.h>
#include <stdio.h>
+#include <sys/types.h>
#include <sys/un.h>
#include <netinet/in.h>
#include <fcntl.h>
#include <unistd.h>
-#include <sys/types.h>
+#include <netinet/in_systm.h>
#include <netinet/tcp.h>
#include <netinet/ip.h>
+#include <sys/socket.h>
+#include <sys/stat.h>
#include <netdb.h>
#include "socket-util.h"
@@ -94,9 +97,11 @@
int priority;
assert(fd >= 0);
+#ifdef SO_PRIORITY
priority = 7;
if (setsockopt(fd, SOL_SOCKET, SO_PRIORITY, &priority, sizeof(priority)) < 0)
return -1;
+#endif
return 0;
}
@@ -109,12 +114,25 @@
ret = pa_socket_low_delay(fd);
on = 1;
+#if defined(SOL_TCP) || defined(IPPROTO_TCP)
+#if defined(SOL_TCP)
if (setsockopt(fd, SOL_TCP, TCP_NODELAY, &on, sizeof(on)) < 0)
+#else
+ if (setsockopt(fd, IPPROTO_TCP, TCP_NODELAY, &on, sizeof(on)) < 0)
+#endif
ret = -1;
+#endif
+#if defined(IPTOS_LOWDELAY) && defined(IP_TOS) && (defined(SOL_IP) || \
+ defined(IPPROTO_IP))
tos = IPTOS_LOWDELAY;
+#ifdef SOL_IP
if (setsockopt(fd, SOL_IP, IP_TOS, &tos, sizeof(tos)) < 0)
+#else
+ if (setsockopt(fd, IPPROTO_IP, IP_TOS, &tos, sizeof(tos)) < 0)
+#endif
ret = -1;
+#endif
return ret;

View File

@ -1,56 +1,24 @@
--- polyp/util.c.orig Tue Oct 26 20:10:13 2004
+++ polyp/util.c Sat Oct 30 01:22:54 2004
@@ -209,7 +209,13 @@
if (!(p = getenv("LOGNAME")))
if (!(p = getenv("USERNAME"))) {
--- polyp/util.c.orig Sun Nov 21 16:27:41 2004
+++ polyp/util.c Tue Jan 4 17:13:51 2005
@@ -34,6 +34,7 @@
#include <unistd.h>
#include <sys/types.h>
#include <sys/stat.h>
+#include <sys/socket.h>
#include <pwd.h>
#include <signal.h>
#include <pthread.h>
@@ -285,7 +286,13 @@
if ((e = getenv("HOME")))
return pa_strlcpy(s, e, l);
+#ifdef HAVE_GETPWUID_R
if (getpwuid_r(getuid(), &pw, buf, sizeof(buf), &r) != 0 || !r) {
if (getpwuid_r(getuid(), &pw, buf, sizeof(buf), &r) != 0 || !r) {
+#else
+ /* XXX Not thread-safe, but needed on OSes (e.g. FreeBSD 4.X)
+ * that do not support getpwuid_r. */
+ if ((r = getpwuid(getuid())) == NULL) {
+ /* XXX Not thead-safe, but needed on OSes (e.g. FreeBSD 4.X)
+ * that do not support getpwuid_r. */
+ if ((r = getpwuid(getuid())) == NULL) {
+#endif
snprintf(s, l, "%lu", (unsigned long) getuid());
return s;
}
@@ -445,11 +451,17 @@
static int is_group(gid_t gid, const char *name) {
struct group group, *result = NULL;
- long n = sysconf(_SC_GETGR_R_SIZE_MAX);
+ long n;
void *data;
int r = -1;
-
- assert(n > 0);
+
+#ifdef HAVE_GETGRGID_R
+#ifdef _SC_GETGR_R_SIZE_MAX
+ n = sysconf(_SC_GETGR_R_SIZE_MAX);
+#else
+ n = -1;
+#endif
+ if (n < 0) n = 512;
data = pa_xmalloc(n);
if (getgrgid_r(gid, &group, data, n, &result) < 0 || !result) {
@@ -462,6 +474,18 @@
finish:
pa_xfree(data);
+#else
+ /* XXX Not thread-safe, but needed on OSes (e.g. FreeBSD 4.X) that do not
+ * support getgrgid_r. */
+ if ((result = getgrgid(gid)) == NULL) {
+ pa_log(__FILE__ ": getgrgid(%u) failed: %s\n", gid, strerror(errno));
+ goto finish;
+ }
+
+ r = strcmp(name, result->gr_name) == 0;
+
+finish:
+#endif
return r;
}
pa_log(__FILE__": getpwuid_r() failed\n");
return NULL;
}

View File

@ -1,7 +1,10 @@
bin/esdcompat.sh
bin/pacat
bin/pacmd
bin/pactl
bin/paplay
bin/parec
bin/pax11publish
bin/polypaudio
@unexec if cmp -s %D/etc/polypaudio/client.conf %D/etc/polypaudio/client.conf-dist; then rm -f %D/etc/polypaudio/client.conf; fi
etc/polypaudio/client.conf-dist
@ -44,6 +47,8 @@ lib/libpolyp-mainloop-glib-%%VERSION%%.so.0
lib/libpolyp-simple-%%VERSION%%.a
lib/libpolyp-simple-%%VERSION%%.so
lib/libpolyp-simple-%%VERSION%%.so.0
lib/polypaudio-%%VERSION%%/libauthkey-prop.a
lib/polypaudio-%%VERSION%%/libauthkey-prop.so
lib/polypaudio-%%VERSION%%/libauthkey.a
lib/polypaudio-%%VERSION%%/libauthkey.so
lib/polypaudio-%%VERSION%%/libcli.a
@ -76,19 +81,29 @@ lib/polypaudio-%%VERSION%%/libsocket-server.a
lib/polypaudio-%%VERSION%%/libsocket-server.so
lib/polypaudio-%%VERSION%%/libsocket-util.a
lib/polypaudio-%%VERSION%%/libsocket-util.so
lib/polypaudio-%%VERSION%%/libstrlist.a
lib/polypaudio-%%VERSION%%/libstrlist.so
lib/polypaudio-%%VERSION%%/libtagstruct.a
lib/polypaudio-%%VERSION%%/libtagstruct.so
lib/polypaudio-%%VERSION%%/libx11prop.a
lib/polypaudio-%%VERSION%%/libx11prop.so
lib/polypaudio-%%VERSION%%/libx11wrap.a
lib/polypaudio-%%VERSION%%/libx11wrap.so
lib/polypaudio-%%VERSION%%/module-cli-protocol-tcp.so
lib/polypaudio-%%VERSION%%/module-cli-protocol-tcp6.so
lib/polypaudio-%%VERSION%%/module-cli-protocol-unix.so
lib/polypaudio-%%VERSION%%/module-cli.so
lib/polypaudio-%%VERSION%%/module-combine.so
lib/polypaudio-%%VERSION%%/module-esound-compat-spawnfd.so
lib/polypaudio-%%VERSION%%/module-esound-compat-spawnpid.so
lib/polypaudio-%%VERSION%%/module-esound-protocol-tcp.so
lib/polypaudio-%%VERSION%%/module-esound-protocol-tcp6.so
lib/polypaudio-%%VERSION%%/module-esound-protocol-unix.so
lib/polypaudio-%%VERSION%%/module-esound-sink.so
lib/polypaudio-%%VERSION%%/module-match.so
lib/polypaudio-%%VERSION%%/module-native-protocol-fd.so
lib/polypaudio-%%VERSION%%/module-native-protocol-tcp.so
lib/polypaudio-%%VERSION%%/module-native-protocol-tcp6.so
lib/polypaudio-%%VERSION%%/module-native-protocol-unix.so
lib/polypaudio-%%VERSION%%/module-null-sink.so
lib/polypaudio-%%VERSION%%/module-oss-mmap.so
@ -96,11 +111,13 @@ lib/polypaudio-%%VERSION%%/module-oss.so
lib/polypaudio-%%VERSION%%/module-pipe-sink.so
lib/polypaudio-%%VERSION%%/module-pipe-source.so
lib/polypaudio-%%VERSION%%/module-simple-protocol-tcp.so
lib/polypaudio-%%VERSION%%/module-simple-protocol-tcp6.so
lib/polypaudio-%%VERSION%%/module-simple-protocol-unix.so
lib/polypaudio-%%VERSION%%/module-sine.so
lib/polypaudio-%%VERSION%%/module-tunnel-sink.so
lib/polypaudio-%%VERSION%%/module-tunnel-source.so
lib/polypaudio-%%VERSION%%/module-x11-bell.so
lib/polypaudio-%%VERSION%%/module-x11-publish.so
libdata/pkgconfig/polyplib-error.pc
libdata/pkgconfig/polyplib-glib-mainloop.pc
%%GLIB12%%libdata/pkgconfig/polyplib-glib12-mainloop.pc