Upgrade GDL to 0.9.3.

Change log at
 <http://sourceforge.net/projects/gnudatalanguage/files/gdl/0.9.3/README>
This commit is contained in:
Thierry Thomas 2013-01-01 20:11:43 +00:00
parent 411574f178
commit 4ab4d2f73e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=309782
12 changed files with 140 additions and 67 deletions

View File

@ -1,13 +1,8 @@
# New ports collection makefile for: gnudatalanguage
# Date created: Sat 22 oct 2005
# Whom: thierry@pompo.net
#
# Created by: thierry@pompo.net
# $FreeBSD$
#
PORTNAME= gnudatalanguage
DISTVERSION= 0.9.2
PORTREVISION= 3
DISTVERSION= 0.9.3
CATEGORIES= science lang
MASTER_SITES= SF/${PORTNAME}/gdl/${DISTVERSION}
.if defined(BUILD_PYTHON_MODULE)

View File

@ -1,2 +1,2 @@
SHA256 (gdl-0.9.2.tar.gz) = 59907d941877327e9653a9cda5d801ea0b45f67af4c7da22acfcdd7cad291acf
SIZE (gdl-0.9.2.tar.gz) = 2436946
SHA256 (gdl-0.9.3.tar.gz) = 6d3c30c06ce2772a1017b3685dfc8fb74308e5f9d258fcb764b765c33d20f500
SIZE (gdl-0.9.3.tar.gz) = 2540106

View File

@ -1,23 +1,17 @@
--- Makefile.in.orig 2011-03-11 17:49:13.000000000 +0100
+++ Makefile.in 2011-04-05 21:20:28.000000000 +0200
@@ -39,15 +39,11 @@
build_triplet = @build@
host_triplet = @host@
subdir = .
-DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \
+DIST_COMMON = README $(srcdir)/Makefile.am \
$(srcdir)/Makefile.in $(srcdir)/config.h.in \
--- Makefile.in.orig 2012-12-27 17:22:44.000000000 +0100
+++ Makefile.in 2012-12-31 15:37:43.000000000 +0100
@@ -44,10 +44,6 @@
$(top_srcdir)/configure AUTHORS COPYING ChangeLog INSTALL NEWS \
TODO config.guess config.sub depcomp install-sh ltmain.sh \
missing mkinstalldirs
missing
-ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
-am__aclocal_m4_deps = $(top_srcdir)/configure.in
-am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
- $(ACLOCAL_M4)
am__CONFIG_DISTCLEAN_FILES = config.status config.cache config.log \
configure.lineno config.status.lineno
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
@@ -271,55 +267,6 @@
mkinstalldirs = $(install_sh) -d
@@ -274,55 +270,6 @@
all: config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive

View File

@ -1,5 +1,5 @@
--- ./doc/Makefile.in.orig 2011-03-11 17:49:14.000000000 +0100
+++ ./doc/Makefile.in 2011-04-05 21:38:51.000000000 +0200
--- doc/Makefile.in.orig 2012-12-27 17:22:45.000000000 +0100
+++ doc/Makefile.in 2012-12-31 15:41:46.000000000 +0100
@@ -35,10 +35,6 @@
host_triplet = @host@
subdir = doc
@ -8,10 +8,10 @@
-am__aclocal_m4_deps = $(top_srcdir)/configure.in
-am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
- $(ACLOCAL_M4)
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = $(top_builddir)/config.h
CONFIG_CLEAN_FILES =
@@ -210,36 +206,6 @@
@@ -213,36 +209,6 @@
all: all-am
.SUFFIXES:

View File

@ -1,5 +1,5 @@
--- src/Makefile.in.orig 2011-11-07 04:07:18.000000000 +0100
+++ src/Makefile.in 2011-11-13 11:42:41.000000000 +0100
--- src/Makefile.in.orig 2012-12-27 17:22:44.000000000 +0100
+++ src/Makefile.in 2012-12-31 15:43:57.000000000 +0100
@@ -38,10 +38,6 @@
@BUILDASLIBRARY_FALSE@bin_PROGRAMS = gdl$(EXEEXT)
subdir = src
@ -8,10 +8,10 @@
-am__aclocal_m4_deps = $(top_srcdir)/configure.in
-am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
- $(ACLOCAL_M4)
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = $(top_builddir)/config.h
CONFIG_CLEAN_FILES =
@@ -541,35 +537,7 @@
@@ -551,35 +547,7 @@
.SUFFIXES:
.SUFFIXES: .cpp .lo .o .obj

View File

@ -1,20 +0,0 @@
--- src/basic_fun.cpp.orig Mon Oct 17 10:22:04 2005
+++ src/basic_fun.cpp Mon Oct 24 21:08:57 2005
@@ -32,6 +32,9 @@
#else
#include <unistd.h>
#endif
+#if defined(__FreeBSD__)
+ extern "C" char **environ;
+#endif
#include "datatypes.hpp"
#include "envt.hpp"
@@ -2903,6 +2906,7 @@
BaseGDL* getenv_fun( EnvT* e)
{
+
SizeT nParam=e->NParam();
static int environmentIx = e->KeywordIx( "ENVIRONMENT" );

View File

@ -1,5 +1,5 @@
--- src/antlr/Makefile.in.orig 2011-03-11 17:49:14.000000000 +0100
+++ src/antlr/Makefile.in 2011-04-05 21:30:17.000000000 +0200
--- src/antlr/Makefile.in.orig 2012-12-27 17:22:44.000000000 +0100
+++ src/antlr/Makefile.in 2012-12-31 15:50:35.000000000 +0100
@@ -37,10 +37,6 @@
host_triplet = @host@
subdir = src/antlr
@ -8,10 +8,10 @@
-am__aclocal_m4_deps = $(top_srcdir)/configure.in
-am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
- $(ACLOCAL_M4)
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = $(top_builddir)/config.h
CONFIG_CLEAN_FILES =
@@ -352,36 +348,6 @@
@@ -355,36 +351,6 @@
.SUFFIXES:
.SUFFIXES: .cpp .lo .o .obj

View File

@ -1,5 +1,5 @@
--- ./src/pro/Makefile.in.orig 2011-03-29 21:51:27.000000000 +0200
+++ ./src/pro/Makefile.in 2011-04-05 21:37:02.000000000 +0200
--- ./src/pro/Makefile.in.orig 2012-12-27 17:22:44.000000000 +0100
+++ ./src/pro/Makefile.in 2012-12-31 15:53:23.000000000 +0100
@@ -36,10 +36,6 @@
host_triplet = @host@
subdir = src/pro
@ -8,10 +8,10 @@
-am__aclocal_m4_deps = $(top_srcdir)/configure.in
-am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
- $(ACLOCAL_M4)
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = $(top_builddir)/config.h
CONFIG_CLEAN_FILES =
@@ -362,36 +358,6 @@
@@ -369,36 +365,6 @@
all: all-recursive
.SUFFIXES:

View File

@ -1,5 +1,5 @@
--- ./src/pro/dicom/Makefile.in.orig 2011-03-11 17:49:14.000000000 +0100
+++ ./src/pro/dicom/Makefile.in 2011-04-05 21:35:14.000000000 +0200
--- ./src/pro/dicom/Makefile.in.orig 2012-12-27 17:22:44.000000000 +0100
+++ ./src/pro/dicom/Makefile.in 2012-12-31 15:55:35.000000000 +0100
@@ -36,10 +36,6 @@
host_triplet = @host@
subdir = src/pro/dicom
@ -8,10 +8,10 @@
-am__aclocal_m4_deps = $(top_srcdir)/configure.in
-am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
- $(ACLOCAL_M4)
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = $(top_builddir)/config.h
CONFIG_CLEAN_FILES =
@@ -221,36 +217,6 @@
@@ -224,36 +220,6 @@
all: all-am
.SUFFIXES:

View File

@ -0,0 +1,54 @@
--- src/pro/envi/Makefile.in.orig 2012-12-27 17:22:44.000000000 +0100
+++ src/pro/envi/Makefile.in 2012-12-31 16:30:42.000000000 +0100
@@ -36,14 +36,6 @@
host_triplet = @host@
subdir = src/pro/envi
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
-ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
-am__aclocal_m4_deps = $(top_srcdir)/configure.in
-am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
- $(ACLOCAL_M4)
-mkinstalldirs = $(install_sh) -d
-CONFIG_HEADER = $(top_builddir)/config.h
-CONFIG_CLEAN_FILES =
-CONFIG_CLEAN_VPATH_FILES =
SOURCES =
DIST_SOURCES =
am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
@@ -217,36 +209,6 @@
all: all-am
.SUFFIXES:
-$(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(am__configure_deps)
- @for dep in $?; do \
- case '$(am__configure_deps)' in \
- *$$dep*) \
- ( cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh ) \
- && { if test -f $@; then exit 0; else break; fi; }; \
- exit 1;; \
- esac; \
- done; \
- echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu src/pro/envi/Makefile'; \
- $(am__cd) $(top_srcdir) && \
- $(AUTOMAKE) --gnu src/pro/envi/Makefile
-.PRECIOUS: Makefile
-Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
- @case '$?' in \
- *config.status*) \
- cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh;; \
- *) \
- echo ' cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)'; \
- cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe);; \
- esac;
-
-$(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
- cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
-
-$(top_srcdir)/configure: $(am__configure_deps)
- cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
-$(ACLOCAL_M4): $(am__aclocal_m4_deps)
- cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
-$(am__aclocal_m4_deps):
mostlyclean-libtool:
-rm -f *.lo

View File

@ -1,5 +1,5 @@
--- testsuite/Makefile.in.orig 2011-03-29 21:51:27.000000000 +0200
+++ testsuite/Makefile.in 2011-04-05 22:18:39.000000000 +0200
--- testsuite/Makefile.in.orig 2012-12-27 17:22:44.000000000 +0100
+++ testsuite/Makefile.in 2012-12-31 16:10:06.000000000 +0100
@@ -35,10 +35,6 @@
host_triplet = @host@
subdir = testsuite
@ -8,10 +8,10 @@
-am__aclocal_m4_deps = $(top_srcdir)/configure.in
-am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
- $(ACLOCAL_M4)
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = $(top_builddir)/config.h
CONFIG_CLEAN_FILES =
@@ -311,36 +307,6 @@
@@ -344,36 +340,6 @@
.SUFFIXES:
.SUFFIXES: .cpp .lo .o .obj

View File

@ -8,6 +8,7 @@
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/checks
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/example.grib
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/image_test.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/launchtest.c
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/libtest_ce.cpp
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/nc_test.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test-read_ascii.pro
@ -48,6 +49,7 @@
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3147181.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3147733.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3151760.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3152892.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3152899.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3189072.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3199465.pro
@ -61,12 +63,19 @@
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3300626.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3313522.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3376577.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3453775.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3483402.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3488003.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_bug_3559291.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_byte_conversion.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_call_function.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_call_procedure.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_ce.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_check_math.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_clip.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_colors.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_common.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_congrid.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_constants.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_contour_basic.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_contour_extra.pro
@ -74,14 +83,18 @@
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_cursor.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_deriv.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_device.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_diag_matrix.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_dialog_message.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_dicom.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_dims_of_arrays.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_erfinv.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_erfs.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_execute.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_expint.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_extra_keywords.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_factorial.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_fft.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_fft_dim.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_fft_leak.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_file_basename.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_file_copy.pro
@ -89,25 +102,32 @@
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_file_dirname.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_file_search.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_file_which.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_finite.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_fix.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_fixprint.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_float2string.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_fx_root.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_fz_roots.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_gammas.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_gc.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_get_kbrd.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_get_lun.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_get_screen_size.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_greek_letters.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_grib.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_healpix.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_hist_2d.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_hist_equal.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_histo.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_idl8.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_idl_validname.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_image_statistics.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_interpol.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_interpolate_missing.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_invert_matrix.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_jd_op_tut.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_known_bugs.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_ludc_lusol.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_map.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_memory.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_minmax.pro
@ -133,11 +153,16 @@
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_postscript.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_product.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_ps_decomposed.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_ptrarr.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_python.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_python_module_0.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_python_module_1.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_python_module_2.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_qromb.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_qromo.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_random.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_read_jpeg.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_read_standard_images.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_readf.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_rebin.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_restore.pro
@ -150,18 +175,23 @@
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_spawn_unit.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_spher_harm.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_spl_init.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_standardize.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_step.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_str_functions.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_str_sep.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_stregex.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_strmatch.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_strsplit.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_suite.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_surface_basic.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_systime.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_titles.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_trisol.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_tv.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_tvlct.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_uf77.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_url.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_usersym.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_valgrind.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_voigt.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_wait.pro
@ -169,6 +199,7 @@
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_widgets.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_zeropoly.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/test_zip.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/testsuite/launchtest.c
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/try
%%MASTER%%%%DATADIR%%/AUTHORS
%%MASTER%%%%DATADIR%%/README
@ -176,9 +207,12 @@
%%MASTER%%%%DATADIR%%/lib/STATUS
%%MASTER%%%%DATADIR%%/lib/appleman.pro
%%MASTER%%%%DATADIR%%/lib/array_indices.pro
%%MASTER%%%%DATADIR%%/lib/bilinear.pro
%%MASTER%%%%DATADIR%%/lib/calendar.pro
%%MASTER%%%%DATADIR%%/lib/congrid.pro
%%MASTER%%%%DATADIR%%/lib/correlate.pro
%%MASTER%%%%DATADIR%%/lib/deriv.pro
%%MASTER%%%%DATADIR%%/lib/diag_matrix.pro
%%MASTER%%%%DATADIR%%/lib/dialog_message.pro
%%MASTER%%%%DATADIR%%/lib/dialog_pickfile.pro
%%MASTER%%%%DATADIR%%/lib/dicom/gdlffdicom__assoc__define.pro
@ -192,6 +226,9 @@
%%MASTER%%%%DATADIR%%/lib/dicom/gdlffdicom_time.pro
%%MASTER%%%%DATADIR%%/lib/dicom/gdlffdicom_trim.pro
%%MASTER%%%%DATADIR%%/lib/dist.pro
%%MASTER%%%%DATADIR%%/lib/envi/read_envi_file.pro
%%MASTER%%%%DATADIR%%/lib/envi/test_write_read_envi.pro
%%MASTER%%%%DATADIR%%/lib/envi/write_envi_file.pro
%%MASTER%%%%DATADIR%%/lib/escape_special_char.pro
%%MASTER%%%%DATADIR%%/lib/factorial.pro
%%MASTER%%%%DATADIR%%/lib/file_basename.pro
@ -204,20 +241,23 @@
%%MASTER%%%%DATADIR%%/lib/filepath.pro
%%MASTER%%%%DATADIR%%/lib/findex.pro
%%MASTER%%%%DATADIR%%/lib/findfile.pro
%%MASTER%%%%DATADIR%%/lib/get_login_info.pro
%%MASTER%%%%DATADIR%%/lib/helpform.pro
%%MASTER%%%%DATADIR%%/lib/hist_2d.pro
%%MASTER%%%%DATADIR%%/lib/hist_equal.pro
%%MASTER%%%%DATADIR%%/lib/hist_nd.pro
%%MASTER%%%%DATADIR%%/lib/identity.pro
%%MASTER%%%%DATADIR%%/lib/idl_validname.pro
%%MASTER%%%%DATADIR%%/lib/image_statistics.pro
%%MASTER%%%%DATADIR%%/lib/imsl_erf.pro
%%MASTER%%%%DATADIR%%/lib/imsl_zerosys.pro
%%MASTER%%%%DATADIR%%/lib/interpol.pro
%%MASTER%%%%DATADIR%%/lib/ishft.pro
%%MASTER%%%%DATADIR%%/lib/kurtosis.pro
%%MASTER%%%%DATADIR%%/lib/la_invert.pro
%%MASTER%%%%DATADIR%%/lib/last_item.pro
%%MASTER%%%%DATADIR%%/lib/lmgr.pro
%%MASTER%%%%DATADIR%%/lib/loadct.pro
%%MASTER%%%%DATADIR%%/lib/ludc.pro
%%MASTER%%%%DATADIR%%/lib/map_clip_set.pro
%%MASTER%%%%DATADIR%%/lib/matrix_multiply.pro
%%MASTER%%%%DATADIR%%/lib/mean.pro
@ -247,6 +287,8 @@
%%MASTER%%%%DATADIR%%/lib/read_binary.pro
%%MASTER%%%%DATADIR%%/lib/read_bmp.pro
%%MASTER%%%%DATADIR%%/lib/read_dicom.pro
%%MASTER%%%%DATADIR%%/lib/read_gif.pro
%%MASTER%%%%DATADIR%%/lib/read_image.pro
%%MASTER%%%%DATADIR%%/lib/read_jpeg.pro
%%MASTER%%%%DATADIR%%/lib/read_pict.pro
%%MASTER%%%%DATADIR%%/lib/read_png.pro
@ -254,17 +296,19 @@
%%MASTER%%%%DATADIR%%/lib/read_xwd.pro
%%MASTER%%%%DATADIR%%/lib/real_part.pro
%%MASTER%%%%DATADIR%%/lib/restore.pro
%%MASTER%%%%DATADIR%%/lib/rot.pro
%%MASTER%%%%DATADIR%%/lib/rstrpos.pro
%%MASTER%%%%DATADIR%%/lib/save.pro
%%MASTER%%%%DATADIR%%/lib/scope_varfetch.pro
%%MASTER%%%%DATADIR%%/lib/showfont.pro
%%MASTER%%%%DATADIR%%/lib/skewness.pro
%%MASTER%%%%DATADIR%%/lib/skip_lun.pro
%%MASTER%%%%DATADIR%%/lib/smooth.pro
%%MASTER%%%%DATADIR%%/lib/spl_init_old.pro
%%MASTER%%%%DATADIR%%/lib/spl_interp_old.pro
%%MASTER%%%%DATADIR%%/lib/standardize.pro
%%MASTER%%%%DATADIR%%/lib/stddev.pro
%%MASTER%%%%DATADIR%%/lib/str_sep.pro
%%MASTER%%%%DATADIR%%/lib/strmatch.pro
%%MASTER%%%%DATADIR%%/lib/strsplit.pro
%%MASTER%%%%DATADIR%%/lib/swap_endian.pro
%%MASTER%%%%DATADIR%%/lib/swap_endian_inplace.pro
@ -275,12 +319,18 @@
%%MASTER%%%%DATADIR%%/lib/uniq.pro
%%MASTER%%%%DATADIR%%/lib/value_locate.pro
%%MASTER%%%%DATADIR%%/lib/variance.pro
%%MASTER%%%%DATADIR%%/lib/wmenu.pro
%%MASTER%%%%DATADIR%%/lib/write_bmp.pro
%%MASTER%%%%DATADIR%%/lib/write_gif.pro
%%MASTER%%%%DATADIR%%/lib/write_image.pro
%%MASTER%%%%DATADIR%%/lib/write_jpeg.pro
%%MASTER%%%%DATADIR%%/lib/write_pict.pro
%%MASTER%%%%DATADIR%%/lib/write_png.pro
%%MASTER%%%%DATADIR%%/lib/zenity_check.pro
%%MASTER%%@dirrm %%DATADIR%%/lib/envi
%%MASTER%%@dirrm %%DATADIR%%/lib/dicom
%%MASTER%%@dirrm %%DATADIR%%/lib
%%MASTER%%@dirrm %%DATADIR%%
%%MASTER%%%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/testsuite/testsuite
%%MASTER%%%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/testsuite
%%MASTER%%%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%