Update to 0.6.0, including:
- XML dump format now takes advantage of ID/IDREF rules for referencing. Backward compatibility has been maintained. - Command line now supports GCC preprocessing flags like -E and -M. - Single source tree for GCC-XML and the patched GCC with one CMake build process to configure everything Approved by: linimon (mentor)
This commit is contained in:
parent
4d81216c50
commit
4a84f84e1e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=103637
@ -6,10 +6,9 @@
|
||||
#
|
||||
|
||||
PORTNAME= gccxml
|
||||
PORTVERSION= 0.4.2
|
||||
PORTVERSION= 0.6.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.gccxml.org/files/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}-cc1plus-304${EXTRACT_SUFX}
|
||||
MASTER_SITES= http://www.gccxml.org/files/v0.6/
|
||||
|
||||
MAINTAINER= vs@FreeBSD.org
|
||||
COMMENT= XML output extension to GCC
|
||||
@ -18,38 +17,18 @@ BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
|
||||
|
||||
NOT_FOR_ARCHS= amd64 sparc64 ia64 # cf. lang/gcc30
|
||||
|
||||
# This one's neat: We have to build things in two subdirectories,
|
||||
# but only need to invoke configure in one of them. This means we
|
||||
# only have to override the build-stage entirely but can keep the
|
||||
# other stages:
|
||||
|
||||
CONFIGURE_WRKSRC= ${WRKDIR}/${DISTNAME}-cc1plus-304-build
|
||||
CONFIGURE_SCRIPT= ../${DISTNAME}-cc1plus-304/configure
|
||||
INSTALL_WRKSRC= ${WRKDIR}/${DISTNAME}-build
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
CONFIGURE_ARGS= --enable-languages=c++ --without-libstdcxx -disable-nls --without-libstdc
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-build
|
||||
|
||||
MAN1= gccxml.1
|
||||
|
||||
PLIST_SUB= PORTVERSION=${PORTVERSION}
|
||||
PLIST_SUB= PORTVERSION=0.6
|
||||
|
||||
pre-configure:
|
||||
${MKDIR} ${CONFIGURE_WRKSRC}
|
||||
${MKDIR} ${WRKDIR}/${DISTNAME}-build
|
||||
cd ${WRKDIR}/${DISTNAME}-build && \
|
||||
${LOCALBASE}/bin/cmake ../${DISTNAME} -DCMAKE_INSTALL_PREFIX:PATH=${PREFIX}
|
||||
post-extract:
|
||||
${MKDIR} ${WRKSRC}
|
||||
|
||||
do-build:
|
||||
cd ${CONFIGURE_WRKSRC}/libiberty && ${MAKE} libiberty.a
|
||||
cd ${CONFIGURE_WRKSRC}/gcc && ${MAKE} tm.h tm_p.h cc1plus
|
||||
cd ${WRKDIR}/${DISTNAME}-build && ${MAKE}
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/Copyright.txt ${DOCSDIR}
|
||||
.endif
|
||||
${INSTALL_PROGRAM} ${WRKDIR}/${DISTNAME}-cc1plus-304-build/gcc/cc1plus ${PREFIX}/bin/gccxml_cc1plus
|
||||
do-configure:
|
||||
cd ${WRKSRC} && \
|
||||
${LOCALBASE}/bin/cmake ../${DISTNAME} -DCMAKE_INSTALL_PREFIX:PATH=${PREFIX} \
|
||||
-DGCCXML_MAN_DIR:PATH="/man"
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (gccxml-0.4.2.tar.gz) = 8b1a05c23cb0ed728bcbd1816198a3ed
|
||||
MD5 (gccxml-0.4.2-cc1plus-304.tar.gz) = bb73cf5bc7a895c47c59e2c8bdd90887
|
||||
MD5 (gccxml-0.6.0.tar.gz) = d828349c76ca055955d0af84e8381093
|
||||
SIZE (gccxml-0.6.0.tar.gz) = 9740448
|
||||
|
@ -1,16 +0,0 @@
|
||||
--- CMakeLists.txt.orig Wed Mar 5 14:52:19 2003
|
||||
+++ CMakeLists.txt Fri Aug 1 21:36:40 2003
|
||||
@@ -51,11 +51,11 @@
|
||||
# Installation rules for UNIX.
|
||||
SET(GCCXML_ROOT ${GCCXML_SOURCE_DIR})
|
||||
SET(GCCXML_SHARE "/share/gccxml-${GCCXML_VERSION_STRING}")
|
||||
- SET(GCCXML_DOC "/share/doc/gccxml-${GCCXML_VERSION_STRING}")
|
||||
+# SET(GCCXML_DOC "/share/doc/gccxml-${GCCXML_VERSION_STRING}")
|
||||
INSTALL_TARGETS(/bin gccxml)
|
||||
INSTALL_PROGRAMS(${GCCXML_SHARE} gccxml_find_flags)
|
||||
INSTALL_FILES(/man/man1 .1 gccxml)
|
||||
- INSTALL_FILES(${GCCXML_DOC} .txt Copyright)
|
||||
+# INSTALL_FILES(${GCCXML_DOC} .txt Copyright)
|
||||
SUBDIRS (GccInclude MproInclude)
|
||||
ELSE(UNIX)
|
||||
# Include file patch program for Windows.
|
@ -1,24 +1,77 @@
|
||||
bin/gccxml_cc1plus
|
||||
bin/gccxml
|
||||
share/gccxml-%%PORTVERSION%%/GccInclude/2_95/std/complext.h
|
||||
@dirrm share/gccxml-%%PORTVERSION%%/GccInclude/2_95/std
|
||||
@dirrm share/gccxml-%%PORTVERSION%%/GccInclude/2_95
|
||||
share/gccxml-%%PORTVERSION%%/GccInclude/find_gcc_options
|
||||
@dirrm share/gccxml-%%PORTVERSION%%/GccInclude
|
||||
share/gccxml-%%PORTVERSION%%/MproInclude/7_3/stl_config.h
|
||||
share/gccxml-%%PORTVERSION%%/MproInclude/7_3/stl_numeric_facets.h
|
||||
share/gccxml-%%PORTVERSION%%/MproInclude/7_3/exception
|
||||
share/gccxml-%%PORTVERSION%%/MproInclude/7_3/stl_monetary.h
|
||||
share/gccxml-%%PORTVERSION%%/MproInclude/7_3/stl_locale.h
|
||||
share/gccxml-%%PORTVERSION%%/MproInclude/7_3/stl_threads.h
|
||||
share/gccxml-%%PORTVERSION%%/MproInclude/7_3/gccxml_mpro_internals.h
|
||||
share/gccxml-%%PORTVERSION%%/MproInclude/7_3/string
|
||||
share/gccxml-%%PORTVERSION%%/MproInclude/7_3/stddef.h
|
||||
share/gccxml-%%PORTVERSION%%/MproInclude/7_3/ostream
|
||||
share/gccxml-%%PORTVERSION%%/MproInclude/find_mpro_options
|
||||
share/doc/gccxml-%%PORTVERSION%%/Copyright.txt
|
||||
share/doc/gccxml-%%PORTVERSION%%/gccxml.html
|
||||
share/doc/gccxml-%%PORTVERSION%%/gccxml.txt
|
||||
@dirrm share/doc/gccxml-%%PORTVERSION%%
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/std/complext.h
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/std/gslice_array.h
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/std/indirect_array.h
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/std/mask_array.h
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/std/slice_array.h
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/std/std_valarray.h
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/std/valarray_meta.h
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/algorithm
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/bitset
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/cctype
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/clocale
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/cmath
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/complex
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/csetjmp
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/csignal
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/cstdarg
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/cstddef
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/cstdio
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/cstdlib
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/cstring
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/ctime
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/cwchar
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/cwctype
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/deque
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/exception
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/fstream
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/functional
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/iomanip
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/iosfwd
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/iostream
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/iterator
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/list
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/map
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/memory
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/new
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/numeric
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/queue
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/set
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/sstream
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/stack
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/stdexcept
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/string
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/strstream
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/typeinfo
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/utility
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/valarray
|
||||
share/gccxml-%%PORTVERSION%%/GCC/2.95/vector
|
||||
share/gccxml-%%PORTVERSION%%/GCC/3.3/gccxml_builtins.h
|
||||
share/gccxml-%%PORTVERSION%%/GCC/find_flags
|
||||
share/gccxml-%%PORTVERSION%%/Intel/find_flags
|
||||
share/gccxml-%%PORTVERSION%%/MIPSpro/7.3/exception
|
||||
share/gccxml-%%PORTVERSION%%/MIPSpro/7.3/gccxml_mpro_internals.h
|
||||
share/gccxml-%%PORTVERSION%%/MIPSpro/7.3/ostream
|
||||
share/gccxml-%%PORTVERSION%%/MIPSpro/7.3/stddef.h
|
||||
share/gccxml-%%PORTVERSION%%/MIPSpro/7.3/stl_config.h
|
||||
share/gccxml-%%PORTVERSION%%/MIPSpro/7.3/stl_locale.h
|
||||
share/gccxml-%%PORTVERSION%%/MIPSpro/7.3/stl_monetary.h
|
||||
share/gccxml-%%PORTVERSION%%/MIPSpro/7.3/stl_numeric_facets.h
|
||||
share/gccxml-%%PORTVERSION%%/MIPSpro/7.3/stl_threads.h
|
||||
share/gccxml-%%PORTVERSION%%/MIPSpro/7.3/string
|
||||
share/gccxml-%%PORTVERSION%%/MIPSpro/find_flags
|
||||
share/gccxml-%%PORTVERSION%%/gccxml_find_flags
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Copyright.txt
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm share/gccxml-%%PORTVERSION%%/MproInclude/7_3
|
||||
@dirrm share/gccxml-%%PORTVERSION%%/MproInclude
|
||||
@dirrm share/gccxml-%%PORTVERSION%%/
|
||||
share/gccxml-%%PORTVERSION%%/gccxml_config
|
||||
@dirrm share/gccxml-%%PORTVERSION%%/GCC/2.95/std
|
||||
@dirrm share/gccxml-%%PORTVERSION%%/GCC/2.95
|
||||
@dirrm share/gccxml-%%PORTVERSION%%/GCC/3.3
|
||||
@dirrm share/gccxml-%%PORTVERSION%%/GCC
|
||||
@dirrm share/gccxml-%%PORTVERSION%%/Intel
|
||||
@dirrm share/gccxml-%%PORTVERSION%%/MIPSpro/7.3
|
||||
@dirrm share/gccxml-%%PORTVERSION%%/MIPSpro
|
||||
@dirrm share/gccxml-%%PORTVERSION%%
|
||||
|
Loading…
Reference in New Issue
Block a user