Muttzilla allows you to use an alternate MUA (Mutt in this case) with

both Netscape Communicator and Navigator when following "mailto:" URL's.

Requested by:	ports@freebsd.org
This commit is contained in:
David E. O'Brien 2000-02-05 00:01:06 +00:00
parent 1726c975d2
commit 4a463f0ebb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=25479
6 changed files with 80 additions and 0 deletions

24
mail/muttzilla/Makefile Normal file
View File

@ -0,0 +1,24 @@
# ex:ts=8
# Ports collection makefile for: foo
# Version required: 0.40
# Date created: Mon Feb 03, 1998
# Whom: David O'Brien (obrien@NUXI.com)
#
# $FreeBSD$
#
DISTNAME= muttzilla-0.40
CATEGORIES= mail www
MASTER_SITES= http://www3.bc.sympatico.ca/brian_winters/mutt/
MAINTAINER= obrien@FreeBSD.org
RUN_DEPENDS= mutt:${PORTSDIR}/mail/mutt
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/muttzilla
@${INSTALL_DATA} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/muttzilla
.endif
.include <bsd.port.mk>

1
mail/muttzilla/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (muttzilla-0.40.tar.gz) = e87bd9e6afdcd2efec0cf02fe9d2f34c

View File

@ -0,0 +1,35 @@
--- Makefile.orig Wed Jan 26 23:11:08 2000
+++ Makefile Fri Feb 4 15:52:52 2000
@@ -1,12 +1,11 @@
-CFLAGS = -O2 -Wall
LDFLAGS = -G -lc
OBJS = muttzilla.o mzargs.o mzbase.o mzmail.o mznews.o nsapi.o
TARGET = muttzilla.so
-BINDIR = /usr/local/bin
-LIBDIR = /usr/local/lib
-ETCDIR = /etc
+BINDIR = ${PREFIX}/bin
+LIBDIR = ${PREFIX}/lib
+ETCDIR = ${PREFIX}/etc
MZLIBDIR = $(LIBDIR)/muttzilla
MAILERLIBS = mutt pine dtmail VM tin
@@ -24,11 +23,11 @@
rm -f $(TARGET)
install: $(TARGET)
- install --mode=0755 muttzilla.so $(LIBDIR)
- install --mode=0755 -d $(MZLIBDIR)
- install --mode=0755 mzmail.sh mzmail.py mznews.sh mznews.py $(BINDIR)
- install --mode=0644 $(MAILERLIBS) $(MZLIBDIR)
- install --mode=0644 -b muttzilla.conf $(ETCDIR)
+ install -m 0755 -c muttzilla.so $(LIBDIR)
+ install -m 0755 -d $(MZLIBDIR)
+ install -m 0755 -c mzmail.sh mzmail.py mznews.sh mznews.py $(BINDIR)
+ install -m 0644 -c $(MAILERLIBS) $(MZLIBDIR)
+ install -m 0644 -c muttzilla.conf $(ETCDIR)
muttzilla.o: muttzilla.c
mzargs.o: mzargs.c muttzilla.h

View File

@ -0,0 +1 @@
Mutt MUA plugin for Netscape for use on "mailto:" URL's

5
mail/muttzilla/pkg-descr Normal file
View File

@ -0,0 +1,5 @@
Do you want to use an alternate e-mail client for "mailto:" links in
Netscape Communicator? Muttzilla allows you to do this. With this port
the Mutt MUA is used on "mailto:" URL's rather than Communicator's built-in
mail client. Muttzilla works with Communicator 4.04 or greater, and
Navigator 4.6 or greater.

14
mail/muttzilla/pkg-plist Normal file
View File

@ -0,0 +1,14 @@
@comment $FreeBSD$
bin/mzmail.sh
bin/mzmail.py
bin/mznews.sh
bin/mznews.py
lib/muttzilla.so
lib/muttzilla/mutt
lib/muttzilla/pine
lib/muttzilla/dtmail
lib/muttzilla/VM
lib/muttzilla/tin
etc/muttzilla.conf
share/doc/muttzilla/INSTALL
@dirrm lib/muttzilla