This is a small licq-plugin, which uses libxosd2 to display new arriving

messages as OSD (On Screen Display) text on your desktop.  I wrote this, as I
saw this feature in sim and wanted to have the same functionality in licq.

PR:		54537
Submitted by:	nm@web.am
This commit is contained in:
Dirk Meyer 2003-07-26 18:32:34 +00:00
parent 39dfbd111c
commit 4a2afaa908
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=85638
13 changed files with 119 additions and 0 deletions

30
net-im/licq-osd/Makefile Normal file
View File

@ -0,0 +1,30 @@
# New ports collection makefile for: licq-osd
# Date created: 2003-07-15
# Whom: nm@web.am
#
# $FreeBSD$
#
#
PORTNAME= licq_osd_plugin
PORTVERSION= 1.2.7.2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=/sourceforge/licq-osd
DISTNAME= licq_osd_plugin-${PORTVERSION}
MAINTAINER= nm@web.am
COMMENT= OnScreenDisplay messages in licq (like in SIM and more)
BUILD_DEPENDS=${X11BASE}/lib/libxosd.so.4:${PORTSDIR}/misc/xosd
RUN_DEPENDS=${LOCALBASE}/lib/licq/licq_qt-gui.so:${PORTSDIR}/net/licq-qt-gui
# run dependency may be too strict, delete it if you use another
# plugin (gtk+) and wish run osd with it. i've not tested with
# plugins other than qt-gui
GNU_CONFIGURE=yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" LIBS="-liconv"
USE_LIBTOOL=yes
.include <bsd.port.mk>

1
net-im/licq-osd/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (licq_osd_plugin-1.2.7.2.tar.gz) = 59621561c391f3c85fecdd5f8ec562c8

View File

@ -0,0 +1,11 @@
--- src/licq-osd.cpp.orig Wed Jul 16 13:00:53 2003
+++ src/licq-osd.cpp Wed Jul 16 12:55:10 2003
@@ -675,7 +675,7 @@
while ((fromsize>0) && (tosize>0))
{
- if ((int)iconv(conv, &msgptr, &fromsize, &resptr, &tosize)==-1)
+ if ((int)iconv(conv, (const char**)(&msgptr), &fromsize, &resptr, &tosize)==-1)
{
// array is not enough
if (errno == E2BIG)

View File

@ -0,0 +1,7 @@
This is a small licq-plugin, which uses libxosd2 to display new arriving
messages as OSD (On Screen Display) text on your desktop. I wrote this, as I
saw this feature in sim and wanted to have the same functionality in licq.
Martin Maurer, martinmaurer@gmx.at
WWW: http://sourceforge.net/projects/licq-osd

View File

@ -0,0 +1,8 @@
Russian-speaking users!
Please run licq in this way to force russian messages display correctly
env LANG=ru_RU.KOI8-R MM_CHARSET=KOI8-R licq
also change font in ~/.licq/licq_osd.conf
to something like this:
Font=-*-*-bold-r-*-*-25-*-*-*-*-*-koi8-*

View File

@ -0,0 +1,2 @@
lib/licq/licq_osd.la
lib/licq/licq_osd.so

View File

@ -298,6 +298,7 @@
SUBDIR += licq
SUBDIR += licq-console
SUBDIR += licq-jons-gtk-gui
SUBDIR += licq-osd
SUBDIR += licq-qt-gui
SUBDIR += limewire
SUBDIR += linc

30
net/licq-osd/Makefile Normal file
View File

@ -0,0 +1,30 @@
# New ports collection makefile for: licq-osd
# Date created: 2003-07-15
# Whom: nm@web.am
#
# $FreeBSD$
#
#
PORTNAME= licq_osd_plugin
PORTVERSION= 1.2.7.2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=/sourceforge/licq-osd
DISTNAME= licq_osd_plugin-${PORTVERSION}
MAINTAINER= nm@web.am
COMMENT= OnScreenDisplay messages in licq (like in SIM and more)
BUILD_DEPENDS=${X11BASE}/lib/libxosd.so.4:${PORTSDIR}/misc/xosd
RUN_DEPENDS=${LOCALBASE}/lib/licq/licq_qt-gui.so:${PORTSDIR}/net/licq-qt-gui
# run dependency may be too strict, delete it if you use another
# plugin (gtk+) and wish run osd with it. i've not tested with
# plugins other than qt-gui
GNU_CONFIGURE=yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" LIBS="-liconv"
USE_LIBTOOL=yes
.include <bsd.port.mk>

1
net/licq-osd/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (licq_osd_plugin-1.2.7.2.tar.gz) = 59621561c391f3c85fecdd5f8ec562c8

View File

@ -0,0 +1,11 @@
--- src/licq-osd.cpp.orig Wed Jul 16 13:00:53 2003
+++ src/licq-osd.cpp Wed Jul 16 12:55:10 2003
@@ -675,7 +675,7 @@
while ((fromsize>0) && (tosize>0))
{
- if ((int)iconv(conv, &msgptr, &fromsize, &resptr, &tosize)==-1)
+ if ((int)iconv(conv, (const char**)(&msgptr), &fromsize, &resptr, &tosize)==-1)
{
// array is not enough
if (errno == E2BIG)

7
net/licq-osd/pkg-descr Normal file
View File

@ -0,0 +1,7 @@
This is a small licq-plugin, which uses libxosd2 to display new arriving
messages as OSD (On Screen Display) text on your desktop. I wrote this, as I
saw this feature in sim and wanted to have the same functionality in licq.
Martin Maurer, martinmaurer@gmx.at
WWW: http://sourceforge.net/projects/licq-osd

8
net/licq-osd/pkg-message Normal file
View File

@ -0,0 +1,8 @@
Russian-speaking users!
Please run licq in this way to force russian messages display correctly
env LANG=ru_RU.KOI8-R MM_CHARSET=KOI8-R licq
also change font in ~/.licq/licq_osd.conf
to something like this:
Font=-*-*-bold-r-*-*-25-*-*-*-*-*-koi8-*

2
net/licq-osd/pkg-plist Normal file
View File

@ -0,0 +1,2 @@
lib/licq/licq_osd.la
lib/licq/licq_osd.so