1. Upgrade to 1.1.2. They recommend 1.0.1, but 1.1.2 has been out for a

while and appears to work better.

2. INSTALL_SCRIPT for the rc.d script rather than INSTALL_DATA. That way
it actually gets run at startup.
This commit is contained in:
Nick Sayer 2001-09-08 16:28:00 +00:00
parent 4f028cfd2d
commit 4a0cd50687
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=47541
3 changed files with 21 additions and 3 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= poptop
PORTVERSION= 1.0.1
PORTVERSION= 1.1.2
CATEGORIES= net
MASTER_SITES= http://poptop.lineo.com/releases/
DISTNAME= pptpd-${PORTVERSION}
@ -21,6 +21,6 @@ MAN8= pptpd.8 pptpctrl.8
post-install:
${INSTALL_DATA} ${WRKSRC}/samples/pptpd.conf ${PREFIX}/etc/pptpd.conf.sample
${INSTALL_DATA} ${FILESDIR}/pptpd.sh ${PREFIX}/etc/rc.d/pptpd.sh
${INSTALL_SCRIPT} ${FILESDIR}/pptpd.sh ${PREFIX}/etc/rc.d/pptpd.sh
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (pptpd-1.0.1.tar.gz) = 67fbb621e1de325012feeb105846fe7d
MD5 (pptpd-1.1.2.tar.gz) = 03f7106c6fd7f22bd904b5c66aedbe92

18
net/poptop/files/patch-ae Normal file
View File

@ -0,0 +1,18 @@
--- pptpgre.c.orig Sat Sep 8 09:12:30 2001
+++ pptpgre.c Sat Sep 8 09:13:11 2001
@@ -114,6 +114,7 @@
strerror (errno));
}
+#if 0
/* Tell kernel we do not want headers with our IP packets. I was
hoping this would eliminate the need to strip them from received
packets, but instead it appears to only affect transmission.
@@ -131,6 +132,7 @@
syslog (LOG_ERR, "Couldn't set hdrincl to false");
}
}
+#endif
gre->pty_fd = pty_fd;
gre->call_id_pair = call_id_pair; /* network byte order */