- Update to 0.22

PR:		141722 141723 141724
Submitted by:	Bernhard Froehlich <decke@bluelife.at> (maintainer)
This commit is contained in:
Martin Wilke 2009-12-19 13:03:53 +00:00
parent 6e826d79dd
commit 49efbac1af
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=246236
46 changed files with 7268 additions and 2420 deletions

View File

@ -6,8 +6,7 @@
# $FreeBSD$
PORTNAME= mythtv-frontend
PORTVERSION= 0.21
PORTREVISION= 3
PORTVERSION= 0.22
CATEGORIES= multimedia
MASTER_SITES= http://ftp.osuosl.org/pub/mythtv/ \
http://ftp.oregonstate.edu/pub/mythtv/
@ -18,18 +17,20 @@ COMMENT= MythTV is a homebrew PVR project
LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
freetype.9:${PORTSDIR}/print/freetype2
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
RUN_DEPENDS= ${LOCALBASE}/lib/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt-mysql-plugin
RUN_DEPENDS= ${QT_PREFIX}/lib/qt4/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt4-mysql-plugin
CONFLICTS= mythtv-[0-9]*
ONLY_FOR_ARCHS= i386 amd64
USE_BZIP2= yes
USE_QT_VER= 3
USE_QT_VER= 4
QT_COMPONENTS= gui sql network script linguist_build l10n \
moc_build qmake_build rcc_build uic_build
QT_NONSTANDARD= yes
USE_GMAKE= yes
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
REINPLACE_ARGS= -i ""
DATADIR= ${PREFIX}/share/mythtv
@ -41,32 +42,20 @@ CONFIGURE_ENV+= QMAKESPEC="${QMAKESPEC}" MOC="${MOC}" CPPFLAGS="${CPPFLAGS} ${Q
CONFIGURE_ARGS= --prefix="${PREFIX}" --disable-v4l --disable-ivtv --disable-firewire \
--disable-dvb --disable-dbox2 --disable-hdhomerun --disable-iptv \
--without-bindings=perl,python --enable-xvmc --enable-xvmc-pro --disable-xvmcw \
--enable-glx-procaddrarb
--disable-hdpvr --without-bindings=perl,python \
--enable-xvmc --enable-xvmc-pro --disable-xvmcw --enable-glx-procaddrarb
QMAKESPEC?= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
QMAKESPEC?= ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++
DESKTOP_ENTRIES="MythTV Frontend" "MythTV is a homebrew PVR project" "" \
"mythfrontend" "AudioVideo;Video;" false
OPTIONS= ARTS "arts sound driver" off \
JACK "JACK sound driver" off \
OPENGL "OpenGL video support (see pre-build message)" off
OPENGL "OpenGL support" on
.include <bsd.port.pre.mk>
pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} "Please hit Ctrl-C right now and install QT 3.3 with"
@${ECHO_MSG} "OpenGL support with the following command, if it isn't"
@${ECHO_MSG} "already:"
@${ECHO_MSG}
@${ECHO_MSG} " cd /usr/ports/x11-toolkits/qt33"
@${ECHO_MSG} " make WITH_OPENGL=yes install clean"
@${ECHO_MSG}
@sleep 3
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/configure
.if defined(WITH_ARTS)
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
CONFIGURE_ARGS+= --enable-audio-arts
@ -87,4 +76,12 @@ CONFIGURE_ARGS+= --enable-opengl-video
CONFIGURE_ARGS+= --disable-opengl-video
.endif
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/libs/libmythtv/libmythtv.pro \
${WRKSRC}/libs/libavformat/libavformat.pro \
${WRKSRC}/bindings/perl/MythTV/Recording.pm \
${WRKSRC}/programs/mythtranscode/replex/Makefile.standalone \
${WRKSRC}/programs/scripts/database/mythconverg_backup.pl
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (mythtv-0.21.tar.bz2) = 49fc135e1cde90cd935c1229467fa37e
SHA256 (mythtv-0.21.tar.bz2) = 33a878a8fc3efdd74519b09b4ec3d16fa9d3a0436b321c13344e5f3ab723c5e4
SIZE (mythtv-0.21.tar.bz2) = 14230687
MD5 (mythtv-0.22.tar.bz2) = e8f8b5b6a51cd7be700e215b2a1bf2c0
SHA256 (mythtv-0.22.tar.bz2) = bb7212bac2cfc792c59a15a80caee8bbf469e250e6f48dc6b0856a60cb07b6fb
SIZE (mythtv-0.22.tar.bz2) = 21895073

View File

@ -1,63 +1,36 @@
--- configure.orig 2009-04-22 21:32:14.000000000 -0400
+++ configure 2009-04-22 21:32:19.000000000 -0400
@@ -163,6 +163,7 @@
echo " directory with frontend.h [$dvb_path]"
echo " --disable-x11 disable X11 support"
echo " --x11-path=X11LOC location of X11 include files [$x11_include_path-path]"
+# echo " --enable-glx-procaddrarb use glXGetProcAddressARB() instead of glXGetProcAddress()"
echo " --disable-xrandr disable X11 resolution switching"
echo " --disable-xv disable XVideo (X11 video output accel.)"
echo " --disable-xvmc disable XvMC (Linux/BSD MPEG accel.)"
@@ -273,13 +274,13 @@
exit 1
--- configure.orig 2009-10-09 00:30:46.000000000 +0200
+++ configure 2009-11-22 23:33:55.000000000 +0100
@@ -633,21 +633,21 @@
log check_cc "$@"
cat > $TMPC
log_file $TMPC
- check_cmd $cc $CFLAGS $ECFLAGS $OPTFLAGS "$@" -c -o $TMPO $TMPC
+ check_cmd $cc $CFLAGS $ECFLAGS $OPTFLAGS -I${prefix}/include "$@" -c -o $TMPO $TMPC
}
-# "tr '[a-z]' '[A-Z]'" is a workaround for Solaris tr not grokking "tr a-z A-Z"
+# Avoid locale weirdness, besides we really just want to translate ASCII.
toupper(){
- echo "$@" | tr '[a-z]' '[A-Z]'
+ echo "$@" | tr abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ
check_cpp(){
log check_cpp "$@"
cat > $TMPC
log_file $TMPC
- check_cmd $cc $CFLAGS $ECFLAGS $OPTFLAGS "$@" -E -o $TMPO $TMPC
+ check_cmd $cc $CFLAGS $ECFLAGS $OPTFLAGS -I${prefix}/include "$@" -E -o $TMPO $TMPC
}
tolower(){
- echo "$@" | tr '[A-Z]' '[a-z]'
+ echo "$@" | tr ABCDEFGHIJKLMNOPQRSTUVWXYZ abcdefghijklmnopqrstuvwxyz
check_cxx(){
log check_cxx "$@"
cat > $TMPCXX
log_file $TMPCXX
- check_cmd $cxx $ECXXFLAGS "$@" -c -o $TMPO $TMPCXX
+ check_cmd $cxx $ECXXFLAGS -I${prefix}/include "$@" -c -o $TMPO $TMPCXX
}
set_all(){
@@ -904,6 +905,7 @@
xvmc_vld
dvdv
fribidi
+ glx_proc_addr_arb
'
check_as(){
@@ -4254,6 +4254,8 @@
# directories, it cannot be modified.
QMAKE_LIBDIR_QT -= $libdir
LATE_LIBS += -L$libdir
+CONFIG_INCLUDEPATH=
+FREETYPE_CFLAGS -= -I/usr/local/include
EOF
MYTHTV_LIST='
@@ -1189,6 +1191,7 @@
xvmc_opengl="yes"
xvmc_vld="yes"
xvmcw="yes"
+glx_proc_addr_arb="no"
# libraries
enable zlib
@@ -1353,6 +1356,10 @@
;;
--xvmc-lib=*) xvmc_lib="$optval"
;;
+ --enable-glx-procaddrarb) glx_proc_addr_arb="yes"
+ ;;
+ --disable-glx-procaddrarb) glx_proc_addr_arb="no"
+ ;;
--enable-mac-accel) dvdv="yes"
;;
--disable-mac-accel) dvdv="no"
@@ -1466,7 +1473,7 @@
x86_64|amd64)
arch="x86_32"
enable fast_unaligned
- canon_arch="`$cc -dumpmachine | sed -e 's,\([^-]*\)-.*,\1,'`"
+ canon_arch="`$cxx -dumpmachine | sed -e 's,\([^-]*\)-.*,\1,'`"
if [ x"$canon_arch" = x"x86_64" -o x"$canon_arch" = x"amd64" ]; then
if [ -z "`echo $CFLAGS | grep -- -m32`" ]; then
arch="x86_64"
diff $TMPH $MYTH_CONFIG_H >/dev/null 2>&1

View File

@ -1,11 +0,0 @@
--- ./libs/libavcodec/h264.c.orig 2008-03-04 16:05:31.000000000 -0500
+++ ./libs/libavcodec/h264.c 2009-04-22 21:05:20.000000000 -0400
@@ -5366,7 +5366,7 @@
return ctx + 4 * cat;
}
-static const attribute_used uint8_t last_coeff_flag_offset_8x8[63] = {
+const attribute_used uint8_t last_coeff_flag_offset_8x8[63] = {
0, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2,
3, 3, 3, 3, 3, 3, 3, 3, 4, 4, 4, 4, 4, 4, 4, 4,

View File

@ -1,13 +0,0 @@
--- ./libs/libavcodec/libavcodec.pro.orig 2008-02-05 22:02:47.000000000 -0500
+++ ./libs/libavcodec/libavcodec.pro 2009-04-22 21:05:20.000000000 -0400
@@ -13,6 +13,10 @@
DEFINES -= MMX
DEFINES += HAVE_AV_CONFIG_H _LARGEFILE_SOURCE
+contains(ARCH_X86_64,yes) {
+ CFLAGS += -DBROKEN_RELOCATIONS
+}
+
# Debug mode on x86 must compile without -fPIC and with -O,
# otherwise gcc runs out of registers.
# libavcodec rev 7671 needs another register

View File

@ -1,25 +0,0 @@
--- ./libs/libmyth/libmyth.pro.orig 2008-03-04 12:08:41.000000000 -0500
+++ ./libs/libmyth/libmyth.pro 2009-04-22 21:05:20.000000000 -0400
@@ -43,14 +43,14 @@
SOURCES += volumebase.cpp volumecontrol.cpp virtualkeyboard.cpp xmlparse.cpp
SOURCES += mythhdd.cpp mythcdrom.cpp storagegroup.cpp dbutil.cpp
-INCLUDEPATH += ../libmythsamplerate ../libmythsoundtouch ../libmythfreesurround
-INCLUDEPATH += ../libavcodec ../libavutil
-INCLUDEPATH += ../.. ../ ./
-DEPENDPATH += ../libmythsamplerate ../libmythsoundtouch
-DEPENDPATH += ../libmythfreesurround
-DEPENDPATH += ../libavcodec ../libavutil
-DEPENDPATH += ../ ../libmythui
-DEPENDPATH += ../libmythupnp
+INCLUDEPATH = ../libmythsamplerate ../libmythsoundtouch ../libmythfreesurround $${INCLUDEPATH}
+INCLUDEPATH = ../libavcodec ../libavutil $${INCLUDEPATH}
+INCLUDEPATH = ../.. ../ ./ $${INCLUDEPATH}
+DEPENDPATH = ../libmythsamplerate ../libmythsoundtouch $${DEPENDPATH}
+DEPENDPATH = ../libmythfreesurround $${DEPENDPATH}
+DEPENDPATH = ../libavcodec ../libavutil $${DEPENDPATH}
+DEPENDPATH = ../ ../libmythui $${DEPENDPATH}
+DEPENDPATH = ../libmythupnp $${DEPENDPATH}
LIBS += -L../libmythsamplerate -lmythsamplerate-$${LIBVERSION}

View File

@ -1,13 +0,0 @@
--- ./libs/libmyth/util.cpp.orig 2008-02-24 10:19:20.000000000 -0500
+++ ./libs/libmyth/util.cpp 2009-04-22 21:05:20.000000000 -0400
@@ -54,6 +54,10 @@
#include <sys/mount.h> // for struct statfs
#endif
+#ifdef __FreeBSD__
+#include <sys/mount.h>
+#endif
+
#ifdef USE_LIRC
#include "lircevent.h"
#endif

View File

@ -0,0 +1,11 @@
--- libs/libmythdb/lcddevice.cpp.orig 2009-08-15 12:38:39.000000000 +0200
+++ libs/libmythdb/lcddevice.cpp 2009-12-18 12:22:32.000000000 +0100
@@ -19,6 +19,7 @@
# include <sys/sysinfo.h>
# else
# ifdef __FreeBSD__
+# include <sys/param.h>
# include <sys/mount.h>
# endif
# if CONFIG_CYGWIN

View File

@ -1,12 +0,0 @@
--- ./libs/libmythdvdnav/dvd_input.c.orig 2008-01-27 14:27:40.000000000 -0500
+++ ./libs/libmythdvdnav/dvd_input.c 2009-04-22 21:05:20.000000000 -0400
@@ -24,6 +24,9 @@
#include <fcntl.h>
#include <unistd.h>
+#define off64_t off_t
+#define lseek64 lseek
+
#include "dvd_reader.h"
#include "dvd_input.h"

View File

@ -1,13 +0,0 @@
--- ./libs/libmythfreemheg/Programs.cpp.orig 2007-03-29 15:44:23.000000000 -0400
+++ ./libs/libmythfreemheg/Programs.cpp 2009-04-22 21:05:20.000000000 -0400
@@ -32,6 +32,10 @@
#include <sys/timeb.h>
#include <time.h>
+#ifdef __FreeBSD__
+#include <sys/time.h>
+#endif
+
#include "../../config.h"
/*

View File

@ -1,19 +0,0 @@
--- libs/libmythtv/libmythtv.pro.orig 2009-04-22 21:32:52.000000000 -0400
+++ libs/libmythtv/libmythtv.pro 2009-04-22 21:33:01.000000000 -0400
@@ -49,6 +49,7 @@
DEFINES += _LARGEFILE_SOURCE
+QMAKE_CXXFLAGS = -I../libmyth -I../libavcodec -I../libavutil -I../libmythmpeg2 $${QMAKE_CXXFLAGS}
QMAKE_CXXFLAGS += $${FREETYPE_CFLAGS}
QMAKE_LFLAGS_SHLIB += $${FREETYPE_LIBS}
@@ -312,6 +313,8 @@
using_opengl_video:HEADERS += openglvideo.h
using_opengl_video:SOURCES += openglvideo.cpp
+ using_glx_proc_addr_arb:DEFINES += USING_GLX_PROC_ADDR_ARB
+
# Misc. frontend
HEADERS += guidegrid.h infostructs.h
HEADERS += progfind.h ttfont.h

View File

@ -1,13 +0,0 @@
--- ./libs/libmythtv/util-opengl.cpp.orig 2007-12-11 23:51:42.000000000 -0500
+++ ./libs/libmythtv/util-opengl.cpp 2009-04-22 21:05:20.000000000 -0400
@@ -306,7 +306,9 @@
{
__GLXextFuncPtr ret = NULL;
-#if GLX_VERSION_1_4
+#if USING_GLX_PROC_ADDR_ARB
+ X11S(ret = glXGetProcAddressARB((const GLubyte*)procName.latin1()));
+#elif GLX_VERSION_1_4
X11S(ret = glXGetProcAddress((const GLubyte*)procName.latin1()));
#elif GLX_ARB_get_proc_address
X11S(ret = glXGetProcAddressARB((const GLubyte*)procName.latin1()));

View File

@ -1,11 +0,0 @@
--- ./programs/mythfrontend/main.cpp.orig 2008-02-23 22:25:03.000000000 -0500
+++ ./programs/mythfrontend/main.cpp 2009-04-22 21:05:21.000000000 -0400
@@ -577,7 +577,7 @@
void haltnow()
{
QString halt_cmd = gContext->GetSetting("HaltCommand",
- "sudo /sbin/halt -p");
+ "/sbin/shutdown -p now");
if (!halt_cmd.isEmpty())
system(halt_cmd.ascii());
}

View File

@ -0,0 +1,13 @@
--- programs/mythtranscode/mpeg2fix.cpp.orig 2009-11-02 20:52:39.000000000 +0100
+++ programs/mythtranscode/mpeg2fix.cpp 2009-11-02 20:53:08.000000000 +0100
@@ -12,6 +12,10 @@
#include <getopt.h>
#include <stdint.h>
+#ifdef __FreeBSD__
+#include <sys/stat.h>
+#endif
+
#include "config.h"
#include "mpeg2fix.h"

View File

@ -1,10 +0,0 @@
--- ./programs/mythtranscode/mythtranscode.pro.orig 2007-02-24 12:44:00.000000000 -0500
+++ ./programs/mythtranscode/mythtranscode.pro 2009-04-22 21:05:21.000000000 -0400
@@ -20,3 +20,7 @@
INCLUDEPATH += replex
INCLUDEPATH += ../../libs/libavcodec ../../libs/libavformat \
../../libs/libavutil ../../libs/libmythmpeg2
+
+QMAKE_CXXFLAGS = -I../../libs/libavcodec -I../../libs/libavformat \
+ -I../../libs/libavutil -I../../libs/libmythmpeg2 \
+ $${QMAKE_CXXFLAGS}

View File

@ -1,11 +1,11 @@
--- ./programs/programs.pro.orig 2008-01-29 15:17:31.000000000 -0500
+++ ./programs/programs.pro 2009-04-22 21:05:21.000000000 -0400
@@ -10,10 +10,6 @@
--- programs/programs.pro.orig 2009-10-15 23:39:07.000000000 +0000
+++ programs/programs.pro 2009-10-15 23:39:19.000000000 +0000
@@ -9,10 +9,6 @@
SUBDIRS += mythwelcome mythshutdown mythtranscode/replex
}
-using_backend {
- SUBDIRS += mythbackend mythfilldatabase mythtv-setup
- SUBDIRS += mythbackend mythfilldatabase mythtv-setup scripts
-}
-
using_frontend:using_backend {

File diff suppressed because it is too large Load Diff

View File

@ -1,13 +0,0 @@
--- settings.pro.orig 2008-02-05 12:18:34.000000000 +0100
+++ settings.pro 2008-09-17 14:29:22.000000000 +0200
@@ -50,8 +50,8 @@
# and we do that in their Makefiles if CONFIG has mac_bundle
macx: CONFIG += console
-INCLUDEPATH += $${PREFIX}/include
-INCLUDEPATH += $$CONFIG_INCLUDEPATH
+#INCLUDEPATH += $${PREFIX}/include
+#INCLUDEPATH += $$CONFIG_INCLUDEPATH
# remove warn_{on|off} from CONFIG since we set it in our CFLAGS
CONFIG -= warn_on warn_off

File diff suppressed because it is too large Load Diff

View File

@ -6,8 +6,7 @@
# $FreeBSD$
PORTNAME= mythtv
PORTVERSION= 0.21
PORTREVISION= 1
PORTVERSION= 0.22
CATEGORIES= multimedia
MASTER_SITES= http://ftp.osuosl.org/pub/mythtv/ \
http://ftp.oregonstate.edu/pub/mythtv/
@ -17,16 +16,17 @@ DISTNAME= myththemes-${PORTVERSION}
MAINTAINER= decke@bluelife.at
COMMENT= The official MythTV Themes for your PVR
BUILD_DEPENDS= mythfrontend:${PORTSDIR}/multimedia/mythtv-frontend \
qmake:${PORTSDIR}/devel/qmake
BUILD_DEPENDS= mythfrontend:${PORTSDIR}/multimedia/mythtv-frontend
USE_BZIP2= yes
HAS_CONFIGURE= yes
USE_QT_VER= 4
QT_COMPONENTS= qmake_build
CONFIGURE_ENV+= QMAKESPEC="${QMAKESPEC}"
CONFIGURE_ARGS= --prefix="${PREFIX}"
QMAKESPEC?= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
QMAKESPEC?= ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (myththemes-0.21.tar.bz2) = 9a569ab5561f348fdbf82cdc46a1df9b
SHA256 (myththemes-0.21.tar.bz2) = 7c4197bcd3f3fa6a59d841cb2bc967c297a0133c6bd4291462401197cae9df1a
SIZE (myththemes-0.21.tar.bz2) = 14554212
MD5 (myththemes-0.22.tar.bz2) = a5f00f152fb430a20c70aaa3bf456347
SHA256 (myththemes-0.22.tar.bz2) = 6720a16a0bdfb9bfb95bd729b50d95f75f8494b932a7dc44ad4014f06ecd36c2
SIZE (myththemes-0.22.tar.bz2) = 16326701

File diff suppressed because it is too large Load Diff

View File

@ -7,8 +7,7 @@
# $FreeBSD$
PORTNAME= mythtv
PORTVERSION= 0.21
PORTREVISION= 2
PORTVERSION= 0.22
CATEGORIES= multimedia
MASTER_SITES= ftp://ftp.osuosl.org/pub/mythtv/ \
LOCAL/glarkin
@ -18,25 +17,32 @@ COMMENT= MythTV is a homebrew PVR project
LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
freetype.9:${PORTSDIR}/print/freetype2
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake \
${SITE_PERL}/${PERL_ARCH}/XML/Parser/Expat.pm:${PORTSDIR}/textproc/p5-XML-SAX-Expat
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser/Expat.pm:${PORTSDIR}/textproc/p5-XML-SAX-Expat
RUN_DEPENDS= tv_check:${PORTSDIR}/textproc/p5-xmltv \
${LOCALBASE}/lib/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt-mysql-plugin \
${QT_PREFIX}/lib/qt4/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt4-mysql-plugin \
wget:${PORTSDIR}/ftp/wget
ONLY_FOR_ARCHS= i386 amd64
USE_BZIP2= yes
USE_QT_VER= 3
USE_QT_VER= 4
QT_COMPONENTS= gui sql network script linguist_build l10n \
moc_build qmake_build rcc_build uic_build
USE_MYSQL= 51
USE_GMAKE= yes
GNU_CONFIGURE= yes
LOCALE_CLEANUP= LANG="" LC_ALL="" LC_COLLATE="" LC_CTYPE="" \
LC_MESSAGES="" LC_MONETARY="" LC_NUMERIC="" \
LC_TIME=""
CONFIGURE_ENV= QMAKESPEC="${QMAKESPEC}" \
CFLAGS="${CFLAGS}" ${LOCALE_CLEANUP}
MAKE_ENV= QTDIR="${QT_PREFIX}" QMAKESPEC="${QMAKESPEC}" \
${LOCALE_CLEANUP}
HAS_CONFIGURE= yes
QT_NONSTANDARD= yes
USE_PERL= yes
USE_PYTHON= yes
INSTALLS_EGGINFO=yes
PYDISTUTILS_PKGNAME=MythTV
REINPLACE_ARGS= -i ""
MAKE_ENV= QTDIR="${QT_PREFIX}" \
QMAKESPEC="${QMAKESPEC}"
CONFIGURE_ENV+= QMAKESPEC="${QMAKESPEC}" MOC="${MOC}" CPPFLAGS="${CPPFLAGS} ${QTCPPFLAGS}" \
QTDIR="${QT_PREFIX}" LDFLAGS="-L${LOCALBASE}/lib"
USE_RC_SUBR= mythbackend
USE_LDCONFIG= ${PREFIX}/lib/mythtv/filters
@ -48,14 +54,11 @@ MYTHTVUID?= 119
MYTHTVGID?= ${MYTHTVUID}
MYTHTVDIR?= /nonexistent
CONFIG= --enable-xvmc --enable-opengl-vsync --disable-directfb \
--disable-ivtv \
--disable-xvmc-pro --disable-xvmc-vld --disable-xvmcw \
CONFIGURE_ARGS= --enable-xvmc --enable-opengl-vsync --disable-directfb --enable-ivtv \
--disable-xvmc-pro --disable-xvmc-vld --disable-xvmcw \
--prefix=${PREFIX} --extra-cflags=-g --extra-cxxflags=-g
CONFIGURE_ARGS= --with-qt-dir=${LOCALBASE} ${CONFIG}
QMAKESPEC?= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
QMAKESPEC?= ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++
OPTIONS= LIRC "Native LIRC Support" Off \
MYSQL_LOCAL "RUN_DEPEND on selected MySQL server" Off
@ -83,19 +86,11 @@ RUN_DEPENDS+= mysqld_safe:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/configure
post-extract:
@${ECHO_CMD} export QMAKESPEC=${QMAKESPEC}
do-configure:
@${ECHO_CMD} CONFIGURE_ENV: ${CONFIGURE_ENV}
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
./configure ${CONFIG}
@${ECHO_CMD} MAKE_ENV: ${MAKE_ENV}
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake \
-spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
mythtv.pro
${WRKSRC}/libs/libmythtv/libmythtv.pro \
${WRKSRC}/libs/libavformat/libavformat.pro \
${WRKSRC}/bindings/perl/MythTV/Recording.pm \
${WRKSRC}/programs/mythtranscode/replex/Makefile.standalone \
${WRKSRC}/programs/scripts/database/mythconverg_backup.pl
post-install:
@${INSTALL} -d ${PREFIX}/share/mythtv/database

View File

@ -1,3 +1,3 @@
MD5 (mythtv-0.21.tar.bz2) = 49fc135e1cde90cd935c1229467fa37e
SHA256 (mythtv-0.21.tar.bz2) = 33a878a8fc3efdd74519b09b4ec3d16fa9d3a0436b321c13344e5f3ab723c5e4
SIZE (mythtv-0.21.tar.bz2) = 14230687
MD5 (mythtv-0.22.tar.bz2) = e8f8b5b6a51cd7be700e215b2a1bf2c0
SHA256 (mythtv-0.22.tar.bz2) = bb7212bac2cfc792c59a15a80caee8bbf469e250e6f48dc6b0856a60cb07b6fb
SIZE (mythtv-0.22.tar.bz2) = 21895073

View File

@ -7,23 +7,26 @@
# BEFORE: LOGIN
# KEYWORD: shutdown
# Define mythbackend_enable in one of these places:
# /etc/rc.conf
# /etc/rc.conf.local
# Define mythbackend_enable in /etc/rc.conf[.local] to enable mythbackend
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
mythbackend_enable=${mythbackend_enable-"NO"}
PATH=${PATH}:%%PREFIX%%/bin
# mythbackend_enable (bool): Set to "NO" by default.
# Set it to "YES" to enable mythbackend.
# mythbackend_logfile (str): Custom logfile for mythbackend.
# (default /var/log/mythbackend.log)
# mythbackend_flags (str): Additional flags for mythbackend.
. %%RC_SUBR%%
name="mythbackend"
rcvar=`set_rcvar`
command="%%PREFIX%%/bin/mythbackend &"
command="%%PREFIX%%/bin/${name}"
load_rc_config $name
start_cmd="echo \"Starting ${name}.\"; ${command}"
: ${mythbackend_enable="NO"}
: ${mythbackend_logfile="/var/log/${name}.log"}
: ${mythbackend_flags=""}
command_args="-d -l ${mythbackend_logfile}"
run_rc_command "$1"

View File

@ -1,29 +1,44 @@
--- configure.orig 2008-03-04 16:23:23.000000000 -0500
+++ configure 2009-03-03 18:10:09.000000000 -0500
@@ -1149,6 +1149,17 @@
fi
fi
--- configure.orig 2009-10-09 00:30:46.000000000 +0200
+++ configure 2009-12-02 19:24:10.000000000 +0100
@@ -633,21 +633,21 @@
log check_cc "$@"
cat > $TMPC
log_file $TMPC
- check_cmd $cc $CFLAGS $ECFLAGS $OPTFLAGS "$@" -c -o $TMPO $TMPC
+ check_cmd $cc $CFLAGS $ECFLAGS $OPTFLAGS -I${prefix}/include "$@" -c -o $TMPO $TMPC
}
+# BSD.
+if uname -s | grep BSD > 0; then
+ dmesg=/var/run/dmesg.boot
+ if test -f $dmesg ; then
+ processor=`grep ^CPU: $dmesg`
+# processor_flags is used only to determine whether the processor
+# supports MMX. The script expexts lower-case 'mmx'. Give it to it.
+ processor_flags=`grep '^ Features=' $dmesg | tr "[:upper:]" "[:lower:]"`
+ fi
+fi
+
# OS
targetos=$(tolower $(uname -s))
check_cpp(){
log check_cpp "$@"
cat > $TMPC
log_file $TMPC
- check_cmd $cc $CFLAGS $ECFLAGS $OPTFLAGS "$@" -E -o $TMPO $TMPC
+ check_cmd $cc $CFLAGS $ECFLAGS $OPTFLAGS -I${prefix}/include "$@" -E -o $TMPO $TMPC
}
@@ -1466,7 +1477,7 @@
x86_64|amd64)
arch="x86_32"
enable fast_unaligned
- canon_arch="`$cc -dumpmachine | sed -e 's,\([^-]*\)-.*,\1,'`"
+ canon_arch="`$cxx -dumpmachine | sed -e 's,\([^-]*\)-.*,\1,'`"
if [ x"$canon_arch" = x"x86_64" -o x"$canon_arch" = x"amd64" ]; then
if [ -z "`echo $CFLAGS | grep -- -m32`" ]; then
arch="x86_64"
check_cxx(){
log check_cxx "$@"
cat > $TMPCXX
log_file $TMPCXX
- check_cmd $cxx $ECXXFLAGS "$@" -c -o $TMPO $TMPCXX
+ check_cmd $cxx $ECXXFLAGS -I${prefix}/include "$@" -c -o $TMPO $TMPCXX
}
check_as(){
@@ -2174,7 +2174,6 @@
append CCONFIG "freebsd"
# Workaround compile errors from missing u_int/uint def
CFLAGS=`echo $CFLAGS | sed 's/-D_POSIX_C_SOURCE=200112//'`
- disable ivtv
disable need_memalign
enable backend
;;
@@ -4254,6 +4253,8 @@
# directories, it cannot be modified.
QMAKE_LIBDIR_QT -= $libdir
LATE_LIBS += -L$libdir
+CONFIG_INCLUDEPATH=
+FREETYPE_CFLAGS -= -I/usr/local/include
EOF
diff $TMPH $MYTH_CONFIG_H >/dev/null 2>&1

View File

@ -1,11 +0,0 @@
--- ./libs/libmyth/compat.h.orig 2008-02-18 02:35:01.000000000 -0500
+++ ./libs/libmyth/compat.h 2009-02-23 09:59:26.000000000 -0500
@@ -273,7 +273,7 @@
// Libdvdnav now uses off64_t lseek64(), which Darwin doesn't have.
// Luckily, its lseek() is already 64bit compatible
-#ifdef CONFIG_DARWIN
+#if defined(CONFIG_DARWIN) || defined(__FreeBSD__)
typedef off_t off64_t;
#define lseek64(f,o,w) lseek(f,o,w)
#endif

View File

@ -1,25 +0,0 @@
--- ./libs/libmyth/libmyth.pro.orig 2008-03-04 12:08:41.000000000 -0500
+++ ./libs/libmyth/libmyth.pro 2009-04-22 21:04:16.000000000 -0400
@@ -43,14 +43,14 @@
SOURCES += volumebase.cpp volumecontrol.cpp virtualkeyboard.cpp xmlparse.cpp
SOURCES += mythhdd.cpp mythcdrom.cpp storagegroup.cpp dbutil.cpp
-INCLUDEPATH += ../libmythsamplerate ../libmythsoundtouch ../libmythfreesurround
-INCLUDEPATH += ../libavcodec ../libavutil
-INCLUDEPATH += ../.. ../ ./
-DEPENDPATH += ../libmythsamplerate ../libmythsoundtouch
-DEPENDPATH += ../libmythfreesurround
-DEPENDPATH += ../libavcodec ../libavutil
-DEPENDPATH += ../ ../libmythui
-DEPENDPATH += ../libmythupnp
+INCLUDEPATH = ../libmythsamplerate ../libmythsoundtouch ../libmythfreesurround $${INCLUDEPATH}
+INCLUDEPATH = ../libavcodec ../libavutil $${INCLUDEPATH}
+INCLUDEPATH = ../.. ../ ./ $${INCLUDEPATH}
+DEPENDPATH = ../libmythsamplerate ../libmythsoundtouch $${DEPENDPATH}
+DEPENDPATH = ../libmythfreesurround $${DEPENDPATH}
+DEPENDPATH = ../libavcodec ../libavutil $${DEPENDPATH}
+DEPENDPATH = ../ ../libmythui $${DEPENDPATH}
+DEPENDPATH = ../libmythupnp $${DEPENDPATH}
LIBS += -L../libmythsamplerate -lmythsamplerate-$${LIBVERSION}

View File

@ -1,13 +0,0 @@
--- ./libs/libmyth/util.cpp.orig 2008-02-24 10:19:20.000000000 -0500
+++ ./libs/libmyth/util.cpp 2009-02-23 09:59:26.000000000 -0500
@@ -54,6 +54,10 @@
#include <sys/mount.h> // for struct statfs
#endif
+#if defined(__FreeBSD__)
+#include <sys/mount.h> // for struct statfs
+#endif
+
#ifdef USE_LIRC
#include "lircevent.h"
#endif

View File

@ -0,0 +1,11 @@
--- libs/libmythdb/lcddevice.cpp.orig 2009-08-15 12:38:39.000000000 +0200
+++ libs/libmythdb/lcddevice.cpp 2009-12-18 12:22:32.000000000 +0100
@@ -19,6 +19,7 @@
# include <sys/sysinfo.h>
# else
# ifdef __FreeBSD__
+# include <sys/param.h>
# include <sys/mount.h>
# endif
# if CONFIG_CYGWIN

View File

@ -1,12 +0,0 @@
--- ./libs/libmythdvdnav/dvd_input.c.orig 2008-01-27 14:27:40.000000000 -0500
+++ ./libs/libmythdvdnav/dvd_input.c 2009-02-23 09:59:26.000000000 -0500
@@ -27,6 +27,9 @@
#include "dvd_reader.h"
#include "dvd_input.h"
+#if defined(__FreeBSD__)
+#define lseek64 lseek
+#endif
/* The function pointers that is the exported interface of this file. */
dvd_input_t (*dvdinput_open) (const char *);

View File

@ -1,12 +0,0 @@
--- ./libs/libmythdvdnav/dvdnav_internal.h.orig 2008-03-07 20:03:12.000000000 -0500
+++ ./libs/libmythdvdnav/dvdnav_internal.h 2009-02-23 09:59:26.000000000 -0500
@@ -62,6 +62,9 @@
#else
#include <pthread.h>
+#if defined(__FreeBSD__)
+#define lseek64 lseek
+#endif
#endif /* WIN32 */

View File

@ -1,18 +0,0 @@
--- ./libs/libmythfreemheg/Programs.cpp.orig 2007-03-29 15:44:23.000000000 -0400
+++ ./libs/libmythfreemheg/Programs.cpp 2009-02-23 09:59:26.000000000 -0500
@@ -30,7 +30,15 @@
#include "freemheg.h"
#include <sys/timeb.h>
+#ifdef __FreeBSD__
+/*
+ * This file refers to the non-POSIX structure timezone, which is
+ * defined in sys/time.h.
+ */
+#include <sys/time.h>
+#else
#include <time.h>
+#endif
#include "../../config.h"

View File

@ -1,11 +0,0 @@
--- ./libs/libmythtv/cardutil.cpp.orig 2008-02-02 12:42:34.000000000 -0500
+++ ./libs/libmythtv/cardutil.cpp 2009-02-23 09:59:26.000000000 -0500
@@ -1473,7 +1473,7 @@
{
bool ok;
QStringList ret;
- int videofd = open(device.ascii(), O_RDWR);
+ int videofd = open(device.ascii(), O_RDONLY);
if (videofd < 0)
{
ret += QObject::tr("Could not open '%1' "

View File

@ -1,10 +0,0 @@
--- ./libs/libmythtv/libmythtv.pro.orig 2008-02-18 17:59:32.000000000 -0500
+++ ./libs/libmythtv/libmythtv.pro 2009-04-22 21:04:16.000000000 -0400
@@ -49,6 +49,7 @@
DEFINES += _LARGEFILE_SOURCE
+QMAKE_CXXFLAGS = -I../libmyth -I../libavcodec -I../libavutil -I../libmythmpeg2 $${QMAKE_CXXFLAGS}
QMAKE_CXXFLAGS += $${FREETYPE_CFLAGS}
QMAKE_LFLAGS_SHLIB += $${FREETYPE_LIBS}

View File

@ -0,0 +1,39 @@
--- libs/libmythtv/videodev_myth.h.orig 2009-07-06 22:42:28.000000000 +0200
+++ libs/libmythtv/videodev_myth.h 2009-11-15 13:08:20.000000000 +0100
@@ -11,6 +11,36 @@
typedef uint8_t __u8;
typedef uint32_t __u64;
typedef int32_t __s64; // HACK. Non 64bit FreeBSD kernels require this for ioctls
+
+typedef struct fb_var_screeninfo
+{
+ int xres;
+ int yres;
+ int bits_per_pixel;
+ int xres_virtual;
+ int yres_virtual;
+ int xoffset;
+ int yoffset;
+ int nonstd;
+ int activate;
+};
+
+typedef struct fb_fix_screeninfo
+{
+ int smem_start;
+};
+
+#define FB_ACTIVATE_NOW 0
+
+#define FBIOBLANK 0
+#define FBIOGET_FSCREENINFO 0
+#define FBIOGET_VSCREENINFO 0
+#define FBIOPAN_DISPLAY 0
+#define FBIOPUT_VSCREENINFO 0
+
+#define VESA_NO_BLANKING 0
+#define VESA_VSYNC_SUSPEND 0
+
#else
#include <linux/types.h>
#include <linux/version.h>

View File

@ -0,0 +1,12 @@
--- libs/libmythtv/videoout_ivtv.cpp.orig 2009-11-15 13:10:38.000000000 +0100
+++ libs/libmythtv/videoout_ivtv.cpp 2009-11-15 13:11:08.000000000 +0100
@@ -19,7 +19,9 @@
#include <sys/param.h>
// Linux headers
+#if defined(__linux__)
#include <linux/fb.h>
+#endif
// C++ headers
#include <map>

View File

@ -1,49 +0,0 @@
--- ./libs/libmythupnp/httprequest.cpp.orig 2008-03-03 22:14:01.000000000 -0500
+++ ./libs/libmythupnp/httprequest.cpp 2009-02-23 09:59:26.000000000 -0500
@@ -21,9 +21,13 @@
#if defined CONFIG_DARWIN || defined CONFIG_CYGWIN || defined(__FreeBSD__) || defined(USING_MINGW)
#include "darwin-sendfile.h"
#else
+#ifdef __FreeBSD__
+typedef off_t __off64_t;
+#else
#define USE_SETSOCKOPT
#include <sys/sendfile.h>
#endif
+#endif
#include <sys/types.h>
#include <sys/stat.h>
#include <unistd.h>
@@ -398,6 +402,24 @@
__off64_t offset = llStart;
int file = open( sFileName.ascii(), O_RDONLY | O_LARGEFILE );
ssize_t sent = 0;
+#ifdef __FreeBSD__
+
+ int error;
+ error = sendfile (file,
+ getSocketHandle (),
+ offset,
+ llSize,
+ NULL,
+ NULL,
+ NULL );
+ if (error)
+ fprintf (stderr,
+ "Can't transfer %s: %s (%d)\n",
+ sFileName.ascii(),
+ strerror (errno),
+ errno );
+
+#else
do
{
@@ -411,6 +433,7 @@
//VERBOSE(VB_UPNP, QString("SendResponseFile : --- size = %1, offset = %2, sent = %3").arg(llSize).arg(offset).arg(sent));
}
while (( sent >= 0 ) && ( llSize > 0 ));
+#endif
if (sent == -1)
{

View File

@ -1,34 +0,0 @@
--- ./programs/mythbackend/mainserver.cpp.orig 2008-03-02 23:47:04.000000000 -0500
+++ ./programs/mythbackend/mainserver.cpp 2009-02-23 09:59:26.000000000 -0500
@@ -251,7 +251,7 @@
return;
}
- readReadyLock.lock();
+ // readReadyLock.lock();
ProcessRequestThread *prt = NULL;
threadPoolLock.lock();
@@ -278,19 +278,19 @@
prt->setup(sock);
- readReadyLock.unlock();
+ // readReadyLock.unlock();
}
void MainServer::ProcessRequest(MythSocket *sock)
{
- sock->Lock();
+ // sock->Lock();
if (sock->bytesAvailable() > 0)
{
ProcessRequestWork(sock);
}
- sock->Unlock();
+ // sock->Unlock();
}
void MainServer::ProcessRequestWork(MythSocket *sock)

View File

@ -1,11 +0,0 @@
--- ./programs/mythbackend/scheduler.cpp.orig 2008-02-20 22:23:22.000000000 -0500
+++ ./programs/mythbackend/scheduler.cpp 2009-02-23 09:59:26.000000000 -0500
@@ -2054,7 +2054,7 @@
gContext->dispatch(me);
QString halt_cmd = gContext->GetSetting("ServerHaltCommand",
- "sudo /sbin/halt -p");
+ "/sbin/shutdown -p now");
if (!halt_cmd.isEmpty())
{

View File

@ -1,11 +0,0 @@
--- ./programs/mythfrontend/main.cpp.orig 2008-02-23 22:25:03.000000000 -0500
+++ ./programs/mythfrontend/main.cpp 2009-02-23 09:59:26.000000000 -0500
@@ -577,7 +577,7 @@
void haltnow()
{
QString halt_cmd = gContext->GetSetting("HaltCommand",
- "sudo /sbin/halt -p");
+ "/sbin/shutdown -p now");
if (!halt_cmd.isEmpty())
system(halt_cmd.ascii());
}

View File

@ -0,0 +1,13 @@
--- programs/mythtranscode/mpeg2fix.cpp.orig 2009-11-02 20:52:39.000000000 +0100
+++ programs/mythtranscode/mpeg2fix.cpp 2009-11-02 20:53:08.000000000 +0100
@@ -12,6 +12,10 @@
#include <getopt.h>
#include <stdint.h>
+#ifdef __FreeBSD__
+#include <sys/stat.h>
+#endif
+
#include "config.h"
#include "mpeg2fix.h"

View File

@ -1,10 +0,0 @@
--- ./programs/mythtranscode/mythtranscode.pro.orig 2007-02-24 12:44:00.000000000 -0500
+++ ./programs/mythtranscode/mythtranscode.pro 2009-04-22 21:04:16.000000000 -0400
@@ -20,3 +20,7 @@
INCLUDEPATH += replex
INCLUDEPATH += ../../libs/libavcodec ../../libs/libavformat \
../../libs/libavutil ../../libs/libmythmpeg2
+
+QMAKE_CXXFLAGS = -I../../libs/libavcodec -I../../libs/libavformat \
+ -I../../libs/libavutil -I../../libs/libmythmpeg2 \
+ $${QMAKE_CXXFLAGS}

View File

@ -1,11 +0,0 @@
--- ./programs/mythtv-setup/backendsettings.cpp.orig 2008-02-05 12:52:11.000000000 -0500
+++ ./programs/mythtv-setup/backendsettings.cpp 2009-02-23 09:59:26.000000000 -0500
@@ -425,7 +425,7 @@
{
GlobalLineEdit *gc = new GlobalLineEdit("ServerHaltCommand");
gc->setLabel(QObject::tr("Server halt command"));
- gc->setValue("sudo /sbin/halt -p");
+ gc->setValue("/sbin/shutdown -p now");
gc->setHelpText(QObject::tr("The command used to halt the backends."));
return gc;
};

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff