net-p2p/verlihub:

- Fix build with clang

net-p2p/verlihub-plugins*:
- Add USES=libtool and INSTALL_TARGET=install-strip
- Drop USE_GCC=any
- Avoid including bsd.port.pre.mk
This commit is contained in:
Tijl Coosemans 2014-09-08 17:04:04 +00:00
parent 6d9eb39f6a
commit 49786cfa02
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=367657
11 changed files with 52 additions and 49 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= chatroom
PORTVERSION= 1.1
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= net-p2p
MASTER_SITES= SF/verlihub/VH_Chatroom/${DISTVERSION}
@ -11,6 +11,5 @@ MAINTAINER= me@skylord.ru
PLUGIN_DESC= Chatroom
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/net-p2p/verlihub-plugins/Makefile.plugins"
.include <bsd.port.post.mk>
.include "../verlihub-plugins/Makefile.plugins"
.include <bsd.port.mk>

View File

@ -3,16 +3,15 @@
PORTNAME= floodprotect
PORTVERSION= 1.6
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= net-p2p
MASTER_SITES= SF/verlihub/OldFiles
DISTNAME= ${PLUGIN_NAME}
MAINTAINER= me@skylord.ru
PLUGIN_NAME= floodprot
PLUGIN_DESC= Floodprotect
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/net-p2p/verlihub-plugins/Makefile.plugins"
DISTNAME= ${PLUGIN_NAME}
.include <bsd.port.post.mk>
.include "../verlihub-plugins/Makefile.plugins"
.include <bsd.port.mk>

View File

@ -3,7 +3,7 @@
PORTNAME= forbid
PORTVERSION= 1.3
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= net-p2p
MASTER_SITES= SF/verlihub/VH_Forbid/${DISTVERSION}
@ -11,6 +11,5 @@ MAINTAINER= me@skylord.ru
PLUGIN_DESC= ForbiddenWords
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/net-p2p/verlihub-plugins/Makefile.plugins"
.include <bsd.port.post.mk>
.include "../verlihub-plugins/Makefile.plugins"
.include <bsd.port.mk>

View File

@ -3,7 +3,7 @@
PORTNAME= iplog
PORTVERSION= 1.1
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= net-p2p
MASTER_SITES= SF/verlihub/VH_IPLog/${DISTVERSION}
@ -11,6 +11,5 @@ MAINTAINER= me@skylord.ru
PLUGIN_DESC= IPLog
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/net-p2p/verlihub-plugins/Makefile.plugins"
.include <bsd.port.post.mk>
.include "../verlihub-plugins/Makefile.plugins"
.include <bsd.port.mk>

View File

@ -3,7 +3,7 @@
PORTNAME= isp
PORTVERSION= 1.1
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= net-p2p
MASTER_SITES= SF/verlihub/VH_ISP/${DISTVERSION}
@ -13,6 +13,5 @@ PLUGIN_DESC= ISP
PLIST_FILES= share/verlihub/default_pi_isp.sql
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/net-p2p/verlihub-plugins/Makefile.plugins"
.include <bsd.port.post.mk>
.include "../verlihub-plugins/Makefile.plugins"
.include <bsd.port.mk>

View File

@ -3,7 +3,7 @@
PORTNAME= luascript
PORTVERSION= 1.8.1
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= net-p2p
PKGNAMEPREFIX= verlihub-plugins-
MASTER_SITES= SF/verlihub/VH_Lua/${DISTVERSION}
@ -28,6 +28,7 @@ PLIST_DIRS= share/verlihub/scripts
OPTIONS_DEFINE= SOCKET
SOCKET_DESC= Build with LuaSocket support
.include "../verlihub-plugins/Makefile.plugins"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSOCKET}
@ -44,11 +45,6 @@ post-patch::
.endif
@${REINPLACE_CMD} -e 's|llua5\.1|llua-${LUA_VER}|g' \
${WRKSRC}/configure
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/net-p2p/verlihub-plugins/Makefile.plugins"
post-patch::
@${REINPLACE_CMD} -e 's|for libpath in /|for libpath in ${PREFIX} /|g' ${WRKSRC}/config_lua
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -3,7 +3,7 @@
PORTNAME= messanger
PORTVERSION= 1.2
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= net-p2p
MASTER_SITES= SF/verlihub/VH_Messanger/${DISTVERSION}
@ -11,6 +11,5 @@ MAINTAINER= me@skylord.ru
PLUGIN_DESC= Messanger
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/net-p2p/verlihub-plugins/Makefile.plugins"
.include <bsd.port.post.mk>
.include "../verlihub-plugins/Makefile.plugins"
.include <bsd.port.mk>

View File

@ -3,7 +3,7 @@
PORTNAME= stats
PORTVERSION= 1.1
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= net-p2p
MASTER_SITES= SF/verlihub/VH_Stats/${DISTVERSION}
@ -11,6 +11,5 @@ MAINTAINER= me@skylord.ru
PLUGIN_DESC= Statistics
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/net-p2p/verlihub-plugins/Makefile.plugins"
.include <bsd.port.post.mk>
.include "../verlihub-plugins/Makefile.plugins"
.include <bsd.port.mk>

View File

@ -6,30 +6,29 @@
PLUGIN_NAME?= ${PORTNAME}
PKGNAMEPREFIX= verlihub-plugins-
DISTNAME= ${PLUGIN_NAME}-${PORTVERSION}
DISTNAME?= ${PLUGIN_NAME}-${PORTVERSION}
WRKSRC?= ${WRKDIR}/${PLUGIN_NAME}
COMMENT?= ${PLUGIN_DESC} plugin for the VerliHub - a Direct Connect protocol server
COMMENT?= ${PLUGIN_DESC} plugin for VerliHub - a Direct Connect protocol server
BUILD_DEPENDS+= ${LOCALBASE}/bin/verlihub:${PORTSDIR}/net-p2p/verlihub
RUN_DEPENDS+= ${LOCALBASE}/bin/verlihub:${PORTSDIR}/net-p2p/verlihub
USE_GCC= any
GNU_CONFIGURE= yes
CFLAGS+= -fPIC
INSTALL_TARGET= install-strip
USES+= libtool
USE_GCC= any
PLIST_FILES+= lib/lib${PLUGIN_NAME}_pi.a \
lib/lib${PLUGIN_NAME}_pi.la \
lib/lib${PLUGIN_NAME}_pi.so \
lib/lib${PLUGIN_NAME}_pi.so.0 \
lib/lib${PLUGIN_NAME}_pi.so.0.0.0 \
etc/verlihub/plugins/lib${PLUGIN_NAME}_pi.so
PLIST_DIRSTRY+= etc/verlihub/plugins etc/verlihub
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGMESSAGE_TEMPLATE= ${PORTSDIR}/net-p2p/verlihub-plugins/pkg-message.plugins
post-patch::
@${REINPLACE_CMD} -e 's,echo aout,echo elf,' ${WRKSRC}/configure
post-build::
@${SED} -e 's,%%PLUGIN_DESC%%,${PLUGIN_DESC},' < \
${PKGMESSAGE_TEMPLATE} > ${PKGMESSAGE}
@ -38,5 +37,3 @@ post-install::
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/verlihub/plugins
${LN} -sf ../../../lib/lib${PLUGIN_NAME}_pi.so \
${STAGEDIR}${PREFIX}/etc/verlihub/plugins
@${ECHO_CMD} '@unexec rmdir %D/etc/verlihub/plugins 2>/dev/null || true' >> ${TMPPLIST}
@${ECHO_CMD} '@unexec rmdir %D/etc/verlihub 2>/dev/null || true' >> ${TMPPLIST}

View File

@ -3,7 +3,7 @@
PORTNAME= verlihub
DISTVERSION= 0.9.8e-r2
PORTREVISION= 5
PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME}/Verlihub/${DISTVERSION}
@ -18,9 +18,8 @@ LIB_DEPENDS= libGeoIP.so:${PORTSDIR}/net/GeoIP \
libpcre.so:${PORTSDIR}/devel/pcre
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
LDFLAGS+= -L${LOCALBASE}/lib
LIBS+= -L${LOCALBASE}/lib
USE_RC_SUBR= verlihub
USE_GCC= any
USES= libtool
USE_MYSQL= yes
GNU_CONFIGURE= yes

View File

@ -0,0 +1,18 @@
--- src/casyncconn.cpp.orig 2009-07-10 20:23:05.000000000 +0200
+++ src/casyncconn.cpp 2014-09-08 18:37:50.000000000 +0200
@@ -90,7 +90,6 @@
cAsyncConn::cAsyncConn(int desc, cAsyncSocketServer *s, tConnType ct):
cObj("cAsyncConn"),
mSockDesc(desc),
- mIterator(0),
ok(desc>0),
mWritable(true),
mExtraPoll(0),
@@ -147,7 +146,6 @@
mBufReadPos(0),
mRegFlag(0),
mCloseAfter(0,0),
- mIterator(0),
ok(false),
mWritable(true),
mExtraPoll(0),