Update to 0.55

Take out patches(unneeded)
Add scripts to be run
Add new WWW to pkg-descr

PR:		29604
Submitted by:	maxim@macomnet.ru
This commit is contained in:
David W. Chapman Jr. 2001-08-30 20:07:26 +00:00
parent 5dab8f6739
commit 49531122d7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=47176
12 changed files with 64 additions and 178 deletions

View File

@ -6,19 +6,27 @@
#
PORTNAME= flow-tools
PORTVERSION= 0.34
PORTVERSION= 0.55
CATEGORIES= net
MASTER_SITES= ftp://ftp.net.ohio-state.edu/users/maf/cisco/
MASTER_SITES= ftp://ftp.eng.oar.net/pub/flow-tools/ \
ftp://ftp.fu-berlin.de/unix/network/flow-tools/
MAINTAINER= .@babolo.ru
ALL_TARGET= i386-fbsd docs
SCRIPTS= flow-mirror flow-rsync flow-search
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAN1= flow-capture.1 flow-export.1 flow-stat.1 flow-cat.1 \
flow-fanout.1 flow-tools.1 flow-dscan.1 flow-filter.1 \
flow-print.1 flow-expire.1 flow-gen.1 flow-profile.1
flow-print.1 flow-expire.1 flow-gen.1 flow-profile.1 \
flow-mirror.1 flow-search.1
#MANCOMPRESSED= yes
post-install:
.for i in ${SCRIPTS}
@${INSTALL_SCRIPT} ${WRKSRC}/bin/${i} ${PREFIX}/bin
.endfor
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (flow-tools-0.34.tar.gz) = 994ba902972cea7497a9fa0f0b927275
MD5 (flow-tools-0.55.tar.gz) = 22ff761e6c13c10c19d12c12e30c44b7

View File

@ -1,8 +0,0 @@
--- asn2c.orig Fri May 1 19:35:11 1998
+++ asn2c Mon Jul 17 19:32:58 2000
@@ -1,4 +1,4 @@
-#!/usr/local/bin/perl
+#!/usr/bin/perl
#
# converts internic netinfo/asn.txt to C code

View File

@ -1,65 +0,0 @@
--- Makefile.orig Mon May 1 22:54:20 2000
+++ Makefile Tue Jul 25 19:30:16 2000
@@ -32,22 +32,29 @@
FL="flow-tools"
DIST=flow-tools-0.34
SHELL=/bin/sh
-BINDIR=/usr/local/netflow/bin
+PREFIX ?= /usr/local
+BINDIR ?= ${PREFIX}/bin
+MANDIR ?= ${PREFIX}/man
LEX=flex
CC=gcc
-INSTALL=install -c -m0755
+
+BINMODE ?= 0555
+MANMODE ?= 0444
+INSTALL_PROGRAM ?= install -c -s -o root -g wheel -m ${BINMODE}
+INSTALL_MAN ?= install -c -o root -g wheel -m ${MANMODE}
+
YACC=yacc -t -v
#YACC=bison -y
POD2MAN=pod2man
POD2HTML=pod2html
-P2MFLAGS = --center="OSU FLOW TOOLS" --date="2000-04-26"
+P2MFLAGS = --center="OSU FLOW TOOLS" --date="2000-04-26" --release="OSU flow tools 0.34"
#CFLAGS = -g -DPOSIX_SIGNALS -DDEBUG -DLIBWRAP -I/usr/local/include -L/usr/local/lib
-CFLAGS = -O2 -funroll-all-loops -ffast-math -I/usr/local/include -L/usr/local/lib -DPOSIX_SIGNALS -DLIBWRAP
+CFLAGS+= -O2 -funroll-all-loops -ffast-math -I/usr/local/include -L/usr/local/lib -DPOSIX_SIGNALS -DLIBWRAP
LIBS = -L. -lz
@@ -94,20 +101,23 @@
#flow-test
MAN = flow-capture.1 flow-export.1 flow-stat.1 flow-cat.1 \
- flow-fanout.1 flow-mirror.1 flow-tools.1 flow-dscan.1 flow-filter.1 \
- flow-print.1 flow-expire.1 flow-gen.1 flow-search.1 flow-profile.1
+ flow-fanout.1 flow-tools.1 flow-dscan.1 flow-filter.1 \
+ flow-print.1 flow-expire.1 flow-gen.1 flow-profile.1
HTML = flow-capture.html flow-export.html flow-stat.html \
- flow-cat.html flow-fanout.html flow-mirror.html flow-tools.html \
+ flow-cat.html flow-fanout.html flow-tools.html \
flow-dscan.html flow-filter.html flow-print.html flow-expire.html \
- flow-gen.html flow-search.html flow-profile.html
+ flow-gen.html flow-profile.html
all: ${BINS}
install:
mkdir -p ${BINDIR}
- ${INSTALL} ${BINS} flow-mirror ${BINDIR}
+ ${INSTALL_PROGRAM} ${BINS} ${BINDIR}
@echo files installed in ${BINDIR}
+ mkdir -p ${MANDIR}/man1
+ ${INSTALL_MAN} ${MAN} ${MANDIR}/man1
+ @echo files installed in ${MANDIR}/man1
clean:
/bin/rm -f ${BINS} *.o sym_asn.c *.1 *.html

View File

@ -1,4 +1,4 @@
Tools to capture, replicate, print, filter, send and other works
on Cisco's NetFlow Export.
WWW: http://www.usenix.org/publications/login/1999-9/osu.html
WWW: http://www.splintered.net/sw/flow-tools/

View File

@ -1,13 +1,21 @@
bin/flow-capture
bin/flow-stat
bin/flow-print
bin/flow-cat
bin/flow-dscan
bin/flow-export
bin/flow-filter
bin/flow-fanout
bin/flow-send
bin/flow-receive
bin/flow-gen
bin/flow-profile
bin/flow-expire
bin/flow-export
bin/flow-fanout
bin/flow-filter
bin/flow-gen
bin/flow-header
bin/flow-import
bin/flow-merge
bin/flow-print
bin/flow-receive
bin/flow-send
bin/flow-split
bin/flow-stat
bin/flow-xlate
bin/flow-mirror
bin/flow-rsync
bin/flow-search
@dirrm /var/ft

View File

@ -6,19 +6,27 @@
#
PORTNAME= flow-tools
PORTVERSION= 0.34
PORTVERSION= 0.55
CATEGORIES= net
MASTER_SITES= ftp://ftp.net.ohio-state.edu/users/maf/cisco/
MASTER_SITES= ftp://ftp.eng.oar.net/pub/flow-tools/ \
ftp://ftp.fu-berlin.de/unix/network/flow-tools/
MAINTAINER= .@babolo.ru
ALL_TARGET= i386-fbsd docs
SCRIPTS= flow-mirror flow-rsync flow-search
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAN1= flow-capture.1 flow-export.1 flow-stat.1 flow-cat.1 \
flow-fanout.1 flow-tools.1 flow-dscan.1 flow-filter.1 \
flow-print.1 flow-expire.1 flow-gen.1 flow-profile.1
flow-print.1 flow-expire.1 flow-gen.1 flow-profile.1 \
flow-mirror.1 flow-search.1
#MANCOMPRESSED= yes
post-install:
.for i in ${SCRIPTS}
@${INSTALL_SCRIPT} ${WRKSRC}/bin/${i} ${PREFIX}/bin
.endfor
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (flow-tools-0.34.tar.gz) = 994ba902972cea7497a9fa0f0b927275
MD5 (flow-tools-0.55.tar.gz) = 22ff761e6c13c10c19d12c12e30c44b7

View File

@ -1,8 +0,0 @@
--- asn2c.orig Fri May 1 19:35:11 1998
+++ asn2c Mon Jul 17 19:32:58 2000
@@ -1,4 +1,4 @@
-#!/usr/local/bin/perl
+#!/usr/bin/perl
#
# converts internic netinfo/asn.txt to C code

View File

@ -1,65 +0,0 @@
--- Makefile.orig Mon May 1 22:54:20 2000
+++ Makefile Tue Jul 25 19:30:16 2000
@@ -32,22 +32,29 @@
FL="flow-tools"
DIST=flow-tools-0.34
SHELL=/bin/sh
-BINDIR=/usr/local/netflow/bin
+PREFIX ?= /usr/local
+BINDIR ?= ${PREFIX}/bin
+MANDIR ?= ${PREFIX}/man
LEX=flex
CC=gcc
-INSTALL=install -c -m0755
+
+BINMODE ?= 0555
+MANMODE ?= 0444
+INSTALL_PROGRAM ?= install -c -s -o root -g wheel -m ${BINMODE}
+INSTALL_MAN ?= install -c -o root -g wheel -m ${MANMODE}
+
YACC=yacc -t -v
#YACC=bison -y
POD2MAN=pod2man
POD2HTML=pod2html
-P2MFLAGS = --center="OSU FLOW TOOLS" --date="2000-04-26"
+P2MFLAGS = --center="OSU FLOW TOOLS" --date="2000-04-26" --release="OSU flow tools 0.34"
#CFLAGS = -g -DPOSIX_SIGNALS -DDEBUG -DLIBWRAP -I/usr/local/include -L/usr/local/lib
-CFLAGS = -O2 -funroll-all-loops -ffast-math -I/usr/local/include -L/usr/local/lib -DPOSIX_SIGNALS -DLIBWRAP
+CFLAGS+= -O2 -funroll-all-loops -ffast-math -I/usr/local/include -L/usr/local/lib -DPOSIX_SIGNALS -DLIBWRAP
LIBS = -L. -lz
@@ -94,20 +101,23 @@
#flow-test
MAN = flow-capture.1 flow-export.1 flow-stat.1 flow-cat.1 \
- flow-fanout.1 flow-mirror.1 flow-tools.1 flow-dscan.1 flow-filter.1 \
- flow-print.1 flow-expire.1 flow-gen.1 flow-search.1 flow-profile.1
+ flow-fanout.1 flow-tools.1 flow-dscan.1 flow-filter.1 \
+ flow-print.1 flow-expire.1 flow-gen.1 flow-profile.1
HTML = flow-capture.html flow-export.html flow-stat.html \
- flow-cat.html flow-fanout.html flow-mirror.html flow-tools.html \
+ flow-cat.html flow-fanout.html flow-tools.html \
flow-dscan.html flow-filter.html flow-print.html flow-expire.html \
- flow-gen.html flow-search.html flow-profile.html
+ flow-gen.html flow-profile.html
all: ${BINS}
install:
mkdir -p ${BINDIR}
- ${INSTALL} ${BINS} flow-mirror ${BINDIR}
+ ${INSTALL_PROGRAM} ${BINS} ${BINDIR}
@echo files installed in ${BINDIR}
+ mkdir -p ${MANDIR}/man1
+ ${INSTALL_MAN} ${MAN} ${MANDIR}/man1
+ @echo files installed in ${MANDIR}/man1
clean:
/bin/rm -f ${BINS} *.o sym_asn.c *.1 *.html

View File

@ -1,4 +1,4 @@
Tools to capture, replicate, print, filter, send and other works
on Cisco's NetFlow Export.
WWW: http://www.usenix.org/publications/login/1999-9/osu.html
WWW: http://www.splintered.net/sw/flow-tools/

View File

@ -1,13 +1,21 @@
bin/flow-capture
bin/flow-stat
bin/flow-print
bin/flow-cat
bin/flow-dscan
bin/flow-export
bin/flow-filter
bin/flow-fanout
bin/flow-send
bin/flow-receive
bin/flow-gen
bin/flow-profile
bin/flow-expire
bin/flow-export
bin/flow-fanout
bin/flow-filter
bin/flow-gen
bin/flow-header
bin/flow-import
bin/flow-merge
bin/flow-print
bin/flow-receive
bin/flow-send
bin/flow-split
bin/flow-stat
bin/flow-xlate
bin/flow-mirror
bin/flow-rsync
bin/flow-search
@dirrm /var/ft