xpdf 0.4 -> 0.5 (old file gone from master site)
Also install man pages, for what it's worth.
This commit is contained in:
parent
467b3b64c6
commit
493c7ec4b9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=3151
@ -3,10 +3,10 @@
|
||||
# Date created: 02 Feb 1996
|
||||
# Whom: chuckr@glue.umd.edu
|
||||
#
|
||||
# $Id: Makefile,v 1.3 1996/03/06 08:20:03 asami Exp $
|
||||
# $Id: Makefile,v 1.4 1996/05/04 01:42:19 asami Exp $
|
||||
#
|
||||
|
||||
DISTNAME= xpdf-0.4
|
||||
DISTNAME= xpdf-0.5
|
||||
CATEGORIES+= graphics
|
||||
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/xpdf/
|
||||
|
||||
@ -14,4 +14,11 @@ MAINTAINER= chuckr@glue.umd.edu
|
||||
|
||||
USE_X11= yes
|
||||
|
||||
post-install:
|
||||
install -c -m 444 ${WRKSRC}/xpdf.1 ${PREFIX}/man/man1
|
||||
install -c -m 444 ${WRKSRC}/pdftops.1 ${PREFIX}/man/man1
|
||||
.if !defined(NOMANCOMPRESS)
|
||||
gzip -9nf ${PREFIX}/man/man1/xpdf.1 ${PREFIX}/man/man1/pdftops.1
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (xpdf-0.4.tar.gz) = 1320c735f99a375c61cb1bf9cb289823
|
||||
MD5 (xpdf-0.5.tar.gz) = 52eef2370042dda70c1ca49a26f2869f
|
||||
|
@ -1,7 +1,7 @@
|
||||
--- Makefile.orig Wed May 1 17:52:04 1996
|
||||
+++ Makefile Wed May 1 17:53:14 1996
|
||||
--- Makefile.orig Fri May 24 10:45:36 1996
|
||||
+++ Makefile Wed May 29 13:21:40 1996
|
||||
@@ -21,8 +21,8 @@
|
||||
cd xpdf; make pdftops
|
||||
cd xpdf; $(MAKE) pdftops
|
||||
|
||||
install:
|
||||
- install -c xpdf/xpdf $(PREFIX)/bin
|
||||
@ -10,4 +10,4 @@
|
||||
+ install -c xpdf/pdftops $(X11BASE)/bin
|
||||
|
||||
clean:
|
||||
cd goo; make clean
|
||||
cd goo; $(MAKE) clean
|
||||
|
@ -1,32 +1,34 @@
|
||||
--- Makefile.config.orig Wed May 1 17:36:22 1996
|
||||
+++ Makefile.config Wed May 1 17:37:41 1996
|
||||
@@ -74,13 +74,13 @@
|
||||
#CFLAGS2 =
|
||||
--- Makefile.config.dist Fri May 24 12:29:32 1996
|
||||
+++ Makefile.config Wed May 29 13:23:06 1996
|
||||
@@ -81,7 +81,7 @@
|
||||
#------------------------------------------------------------------------
|
||||
|
||||
# This will work for most systems:
|
||||
-CFLAGS2 = -O2 -Wall
|
||||
+#CFLAGS2 = -O2 -Wall
|
||||
|
||||
# If you're using g++ 2.7.x, you'll want to use -Wno-unused:
|
||||
-CFLAGS2 = -Wno-unused
|
||||
+#CFLAGS2 = -Wno-unused
|
||||
#CFLAGS2 = -O2 -Wall -Wno-unused
|
||||
@@ -90,7 +90,7 @@
|
||||
#CFLAGS2 = -O2 -Wall -I/usr/X11R6/include -Wno-unused
|
||||
|
||||
# For Linux systems using XFree86:
|
||||
#CFLAGS2 = -I/usr/X11/include -Wno-unused
|
||||
|
||||
# For FreeBSD systems using XFree86:
|
||||
-#CFLAGS2 = -I$(X11BASE)/include -Wno-unused
|
||||
+CFLAGS2 = -I$(X11BASE)/include -Wno-unused
|
||||
# For official FreeBSD port (using the FreeBSD makefiles):
|
||||
-#CFLAGS2 = -O2 -Wall -I$(X11BASE)/include -Wno-unused
|
||||
+CFLAGS2 = -O2 -Wall -I$(X11BASE)/include -Wno-unused
|
||||
|
||||
# For Solaris:
|
||||
#CFLAGS2 = -I/usr/openwin/include
|
||||
@@ -97,13 +97,13 @@
|
||||
#CFLAGS2 = -O2 -Wall -I/usr/openwin/include
|
||||
@@ -110,13 +110,13 @@
|
||||
#------------------------------------------------------------------------
|
||||
|
||||
# For most systems, just grab the X library:
|
||||
-XLIBS = -lX11
|
||||
+#XLIBS = -lX11
|
||||
|
||||
# For Linux systems using XFree86:
|
||||
#XLIBS = -L/usr/X11/lib -lX11
|
||||
# For Linux/FreeBSD/NetBSD systems using XFree86:
|
||||
#XLIBS = -L/usr/X11R6/lib -lX11
|
||||
|
||||
# For FreeBSD systems using XFree86:
|
||||
# For official FreeBSD port (using the FreeBSD makefiles):
|
||||
-#XLIBS = -L$(X11BASE)/lib -lX11
|
||||
+XLIBS = -L$(X11BASE)/lib -lX11
|
||||
|
||||
|
@ -1,2 +1,4 @@
|
||||
bin/xpdf
|
||||
bin/pdftops
|
||||
man/man1/xpdf.1.gz
|
||||
man/man1/pdftops.1.gz
|
||||
|
Loading…
Reference in New Issue
Block a user