new port: net-mgmt/netdata

NetData is scalable, distributed real-time performance and health monitoring.

PR:		216497
Submitted by:	Mahdi Mokhtari <mokhi64@gmail.com>
Reviewed by:	lifanov, matthew
Approved by:	matthew (mentor)
Differential Revision:	https://reviews.freebsd.org/D9351
This commit is contained in:
Nikolai Lifanov 2017-01-27 03:16:36 +00:00
parent adb7718379
commit 48f70e76d8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=432544
15 changed files with 3995 additions and 2 deletions

2
GIDs
View File

@ -243,7 +243,7 @@ ntopng:*:288:
# free: 299
backuppc:*:300:
# free: 301
# free: 302
netdata:*:302:
# free: 303
# free: 304
# free: 305

2
UIDs
View File

@ -248,7 +248,7 @@ ntopng:*:288:288::0:0:ntopng daemon user:/nonexistent:/usr/sbin/nologin
# free: 299
backuppc:*:300:300::0:0:BackupPC pseudo-user:/nonexistent:/usr/sbin/nologin
# free: 301
# free: 302
netdata:*:302:302::0:0:NetData Daemon:/var/cache/netdata:/usr/sbin/nologin
# free: 303
# free: 304
# free: 305

View File

@ -157,6 +157,7 @@
SUBDIR += nedi
SUBDIR += nefu
SUBDIR += net-snmp
SUBDIR += netdata
SUBDIR += netdisco
SUBDIR += netdisco-mibs
SUBDIR += netdot

63
net-mgmt/netdata/Makefile Normal file
View File

@ -0,0 +1,63 @@
# Created by: Mahdi Mokhtari <mokhi64@gmail.com>
# $FreeBSD$
PORTNAME= netdata
PORTVERSION= 1.5.0
CATEGORIES= net-mgmt
MAINTAINER= mokhi64@gmail.com
COMMENT= Scalable distributed realtime performance and health monitoring
LICENSE= GPLv3
BUILD_DEPENDS+= ${LOCALBASE}/include/uuid/uuid.h:misc/e2fsprogs-libuuid
LIB_DEPENDS+= libuuid.so:misc/e2fsprogs-libuuid
USE_GITHUB= yes
GH_ACCOUNT= firehol
GH_TAGNAME= 3bd41a0
NETDATA_CACHE= /var/cache/${PORTNAME}
NETDATA_LOG= /var/log/${PORTNAME}
NETDATA_PERST= /var/db/${PORTNAME}
USES= autoreconf pathfix pkgconfig:both python shebangfix
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
SUB_LIST+= NETDATA_CACHE=${NETDATA_CACHE} \
NETDATA_LOG=${NETDATA_LOG} \
NETDATA_PERST=${NETDATA_PERST}
PLIST_SUB+= NETDATA_CACHE=${NETDATA_CACHE} \
NETDATA_LOG=${NETDATA_LOG} \
NETDATA_PERST=${NETDATA_PERST}
USE_RC_SUBR= ${PORTNAME}
SUB_FILES= ${PORTNAME}.conf.sample
USERS= netdata
GROUPS= netdata
post-patch:
@${REINPLACE_CMD} -e 's|%%NETDATA_CACHE%%|${NETDATA_CACHE}|g' \
${PATCH_WRKSRC}/configure.ac
@${REINPLACE_CMD} -e 's|%%NETDATA_LOG%%|${NETDATA_LOG}|g' \
${PATCH_WRKSRC}/configure.ac
@${REINPLACE_CMD} -e 's|%%NETDATA_PERST%%|${NETDATA_PERST}|g' \
${PATCH_WRKSRC}/configure.ac
@${REINPLACE_CMD} -e 's|%%ETCDIR%%|${ETCDIR}|g' \
${PATCH_WRKSRC}/configure.ac
post-install:
${MKDIR} ${STAGEDIR}${ETCDIR}
${INSTALL_DATA} ${WRKDIR}/netdata.conf.sample ${STAGEDIR}${ETCDIR}/netdata.conf.sample
${MKDIR} ${STAGEDIR}${NETDATA_CACHE}
${MKDIR} ${STAGEDIR}${NETDATA_LOG}
${MKDIR} ${STAGEDIR}${NETDATA_PERST}
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1485268722
SHA256 (firehol-netdata-1.5.0-3bd41a0_GH0.tar.gz) = add4d6dceed43771deccf7388c9ff68fe72ca8f771f79b0a5fb19213d940888d
SIZE (firehol-netdata-1.5.0-3bd41a0_GH0.tar.gz) = 2257311

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,36 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: netdata
# REQUIRE: LOGIN
# KEYWORD: shutdown
#
# Add the following line to /etc/rc.conf to enable netdata:
# netdata_enable (bool): Set to "NO" by default.
# Set it to "YES" to enable netdata.
# netdata_args (str): Custom additional arguments to be passed
# to netdata (default empty).
#
. /etc/rc.subr
name="netdata"
rcvar=netdata_enable
load_rc_config $name
: ${netdata_enable="NO"}
netdata_user="netdata"
pidfile="%%NETDATA_PERST%%/${name}.pid"
procname="%%PREFIX%%/sbin/${name}"
command="/usr/sbin/daemon"
command_args="-c -f ${procname} -u ${netdata_user} -P ${pidfile} ${netdata_args}"
required_files="%%ETCDIR%%/${name}.conf"
run_rc_command "$1"

View File

@ -0,0 +1,31 @@
--- configure.ac.orig 2017-01-22 19:49:22 UTC
+++ configure.ac
@@ -162,7 +162,7 @@ PKG_CHECK_MODULES(
[UUID],
[uuid],
)
-test -z "${UUID_LIBS}" && AC_MSG_ERROR([libuuid required but not found. Try installing 'uuid-dev' or 'libuuid-devel'.])
+test -z "${UUID_LIBS}" && AC_MSG_ERROR([libuuid required but not found. Try installing 'misc/e2fsprogs-libuuid'.])
AC_DEFINE([NETDATA_WITH_UUID], [1], [uuid settings])
OPTIONAL_UUID_CLFAGS="${UUID_CFLAGS}"
OPTIONAL_UUID_LIBS="${UUID_LIBS}"
@@ -214,14 +214,14 @@ fi
AC_DEFINE_UNQUOTED([NETDATA_USER], ["${with_user}"], [use this user to drop privileged])
-AC_SUBST([varlibdir], ["\$(localstatedir)/lib/netdata"])
-AC_SUBST([registrydir], ["\$(localstatedir)/lib/netdata/registry"])
-AC_SUBST([cachedir], ["\$(localstatedir)/cache/netdata"])
+AC_SUBST([varlibdir], ["%%NETDATA_PERST%%"])
+AC_SUBST([registrydir], ["%%NETDATA_PERST%%/registry"])
+AC_SUBST([cachedir], ["%%NETDATA_CACHE%%"])
AC_SUBST([chartsdir], ["\$(libexecdir)/netdata/charts.d"])
AC_SUBST([nodedir], ["\$(libexecdir)/netdata/node.d"])
AC_SUBST([pythondir], ["\$(libexecdir)/netdata/python.d"])
-AC_SUBST([configdir], ["\$(sysconfdir)/netdata"])
-AC_SUBST([logdir], ["\$(localstatedir)/log/netdata"])
+AC_SUBST([configdir], ["%%ETCDIR%%"])
+AC_SUBST([logdir], ["%%NETDATA_LOG%%"])
AC_SUBST([pluginsdir], ["\$(libexecdir)/netdata/plugins.d"])
AC_SUBST([webdir])

View File

@ -0,0 +1,15 @@
--- src/Makefile.am.orig 2017-01-22 19:49:22 UTC
+++ src/Makefile.am
@@ -135,6 +135,12 @@ apps_plugin_SOURCES = \
web_buffer.c web_buffer.h \
$(NULL)
+if FREEBSD
+apps_plugin_SOURCES += \
+ plugin_freebsd.h \
+ $(NULL)
+endif
+
install-data-hook:
if [ `id -u` == 0 ]; then \
chown root '$(DESTDIR)$(pluginsdir)/apps.plugin' && \

View File

@ -0,0 +1,37 @@
--- src/common.c.orig 2017-01-22 19:49:22 UTC
+++ src/common.c
@@ -1111,6 +1111,16 @@ long get_system_cpus(void) {
}
return processors;
+ #elif __FreeBSD__
+ int32_t tmp_processors;
+
+ if (unlikely(GETSYSCTL("hw.ncpu", tmp_processors))) {
+ error("Assuming system has %d processors.", processors);
+ } else {
+ processors = tmp_processors;
+ }
+
+ return processors;
#else
char filename[FILENAME_MAX + 1];
@@ -1153,6 +1163,17 @@ pid_t get_system_pid_max(void) {
// we use the number defined in bsd/sys/proc_internal.h in XNU sources
pid_max = 99999;
return pid_max;
+ #elif __FreeBSD__
+ int32_t tmp_pid_max;
+
+ if (unlikely(GETSYSCTL("kern.pid_max", tmp_pid_max))) {
+ pid_max = 99999;
+ error("Assuming system's maximum pid is %d.", pid_max);
+ } else {
+ pid_max = tmp_pid_max;
+ }
+
+ return pid_max;
#else
char filename[FILENAME_MAX + 1];

View File

@ -0,0 +1,26 @@
--- src/freebsd_sysctl.c.orig 2017-01-22 19:49:22 UTC
+++ src/freebsd_sysctl.c
@@ -828,7 +828,11 @@ int do_freebsd_sysctl(int update_every,
if (unlikely(GETSYSCTL("vm.stats.vm.v_active_count", vmmeter_data.v_active_count) ||
GETSYSCTL("vm.stats.vm.v_inactive_count", vmmeter_data.v_inactive_count) ||
GETSYSCTL("vm.stats.vm.v_wire_count", vmmeter_data.v_wire_count) ||
+#if (__FreeBSD__ >= 12) && (__FreeBSD_version >= 1200016)
+ 0 ||
+#else
GETSYSCTL("vm.stats.vm.v_cache_count", vmmeter_data.v_cache_count) ||
+#endif
GETSYSCTL("vfs.bufspace", vfs_bufspace_count) ||
GETSYSCTL("vm.stats.vm.v_free_count", vmmeter_data.v_free_count))) {
do_ram = 0;
@@ -850,7 +854,11 @@ int do_freebsd_sysctl(int update_every,
rrddim_set(st, "active", vmmeter_data.v_active_count);
rrddim_set(st, "inactive", vmmeter_data.v_inactive_count);
rrddim_set(st, "wired", vmmeter_data.v_wire_count);
+#if (__FreeBSD__ >= 12) && (__FreeBSD_version >= 1200016)
+ rrddim_set(st, "cache", 0);
+#else
rrddim_set(st, "cache", vmmeter_data.v_cache_count);
+#endif
rrddim_set(st, "buffers", vfs_bufspace_count);
rrddim_set(st, "free", vmmeter_data.v_free_count);
rrdset_done(st);

View File

@ -0,0 +1,28 @@
--- src/plugin_freebsd.c.orig 2017-01-22 19:49:22 UTC
+++ src/plugin_freebsd.c
@@ -1,6 +1,6 @@
#include "common.h"
-void *freebsd_main(void *ptr) {
+extern void *freebsd_main(void *ptr) {
struct netdata_static_thread *static_thread = (struct netdata_static_thread *)ptr;
info("FREEBSD Plugin thread created with task id %d", gettid());
@@ -63,17 +63,3 @@ void *freebsd_main(void *ptr) {
return NULL;
}
-int getsysctl(const char *name, void *ptr, size_t len)
-{
- size_t nlen = len;
-
- if (unlikely(sysctlbyname(name, ptr, &nlen, NULL, 0) == -1)) {
- error("FREEBSD: sysctl(%s...) failed: %s", name, strerror(errno));
- return 1;
- }
- if (unlikely(nlen != len)) {
- error("FREEBSD: sysctl(%s...) expected %lu, got %lu", name, (unsigned long)len, (unsigned long)nlen);
- return 1;
- }
- return 0;
-}

View File

@ -0,0 +1,27 @@
--- src/plugin_freebsd.h.orig 2017-01-22 19:49:22 UTC
+++ src/plugin_freebsd.h
@@ -6,9 +6,22 @@
#define GETSYSCTL(name, var) getsysctl(name, &(var), sizeof(var))
void *freebsd_main(void *ptr);
+extern int do_freebsd_sysctl(int update_every, usec_t dt);
-int getsysctl(const char *name, void *ptr, size_t len);
+static inline
+int getsysctl(const char *name, void *ptr, size_t len)
+{
+ size_t nlen = len;
-extern int do_freebsd_sysctl(int update_every, usec_t dt);
+ if (unlikely(sysctlbyname(name, ptr, &nlen, NULL, 0) == -1)) {
+ error("FREEBSD: sysctl(%s...) failed: %s", name, strerror(errno));
+ return 1;
+ }
+ if (unlikely(nlen != len)) {
+ error("FREEBSD: sysctl(%s...) expected %lu, got %lu", name, (unsigned long)len, (unsigned long)nlen);
+ return 1;
+ }
+ return 0;
+}
#endif /* NETDATA_PLUGIN_FREEBSD_H */

View File

@ -0,0 +1,10 @@
Netdata is scalable distributed realtime performance & health monitoring system
netdata collects and visualizes metrics.
If it is a number and it can be collected somehow, netdata can visualize it.
Out of the box, it comes with plugins that collect hundreds of
system metrics and metrics of popular applications.
Netdata is very resource efficient and you can control its resource consumption.
It will use some spare CPU cycles, usually just 1-3% of a single core,
the RAM you want it have, and no disk I/O at all, apart its logging.
WWW: https://github.com/firehol/netdata

313
net-mgmt/netdata/pkg-plist Normal file
View File

@ -0,0 +1,313 @@
@mode 0640
@owner netdata
@group netdata
%%ETCDIR%%/apps_groups.conf
%%ETCDIR%%/charts.d.conf
%%ETCDIR%%/charts.d/ap.conf
%%ETCDIR%%/charts.d/apache.conf
%%ETCDIR%%/charts.d/apcupsd.conf
%%ETCDIR%%/charts.d/cpu_apps.conf
%%ETCDIR%%/charts.d/cpufreq.conf
%%ETCDIR%%/charts.d/example.conf
%%ETCDIR%%/charts.d/exim.conf
%%ETCDIR%%/charts.d/hddtemp.conf
%%ETCDIR%%/charts.d/load_average.conf
%%ETCDIR%%/charts.d/mem_apps.conf
%%ETCDIR%%/charts.d/mysql.conf
%%ETCDIR%%/charts.d/nginx.conf
%%ETCDIR%%/charts.d/nut.conf
%%ETCDIR%%/charts.d/opensips.conf
%%ETCDIR%%/charts.d/phpfpm.conf
%%ETCDIR%%/charts.d/postfix.conf
%%ETCDIR%%/charts.d/sensors.conf
%%ETCDIR%%/charts.d/squid.conf
%%ETCDIR%%/charts.d/tomcat.conf
%%ETCDIR%%/fping.conf
%%ETCDIR%%/health.d/apache.conf
%%ETCDIR%%/health.d/backend.conf
%%ETCDIR%%/health.d/bind_rndc.conf
%%ETCDIR%%/health.d/cpu.conf
%%ETCDIR%%/health.d/disks.conf
%%ETCDIR%%/health.d/elasticsearch.conf
%%ETCDIR%%/health.d/entropy.conf
%%ETCDIR%%/health.d/haproxy.conf
%%ETCDIR%%/health.d/ipc.conf
%%ETCDIR%%/health.d/ipfs.conf
%%ETCDIR%%/health.d/isc_dhcpd.conf
%%ETCDIR%%/health.d/mdstat.conf
%%ETCDIR%%/health.d/memcached.conf
%%ETCDIR%%/health.d/memory.conf
%%ETCDIR%%/health.d/mysql.conf
%%ETCDIR%%/health.d/named.conf
%%ETCDIR%%/health.d/net.conf
%%ETCDIR%%/health.d/netfilter.conf
%%ETCDIR%%/health.d/nginx.conf
%%ETCDIR%%/health.d/postgres.conf
%%ETCDIR%%/health.d/qos.conf
%%ETCDIR%%/health.d/ram.conf
%%ETCDIR%%/health.d/redis.conf
%%ETCDIR%%/health.d/retroshare.conf
%%ETCDIR%%/health.d/softnet.conf
%%ETCDIR%%/health.d/squid.conf
%%ETCDIR%%/health.d/swap.conf
%%ETCDIR%%/health.d/tcp_resets.conf
%%ETCDIR%%/health.d/udp_errors.conf
%%ETCDIR%%/health.d/varnish.conf
%%ETCDIR%%/health_alarm_notify.conf
%%ETCDIR%%/health_email_recipients.conf
%%ETCDIR%%/node.d.conf
%%ETCDIR%%/node.d/README.md
%%ETCDIR%%/node.d/named.conf.md
%%ETCDIR%%/node.d/sma_webbox.conf.md
%%ETCDIR%%/node.d/snmp.conf.md
%%ETCDIR%%/python.d.conf
%%ETCDIR%%/python.d/apache.conf
%%ETCDIR%%/python.d/apache_cache.conf
%%ETCDIR%%/python.d/bind_rndc.conf
%%ETCDIR%%/python.d/cpufreq.conf
%%ETCDIR%%/python.d/dovecot.conf
%%ETCDIR%%/python.d/elasticsearch.conf
%%ETCDIR%%/python.d/example.conf
%%ETCDIR%%/python.d/exim.conf
%%ETCDIR%%/python.d/fail2ban.conf
%%ETCDIR%%/python.d/freeradius.conf
%%ETCDIR%%/python.d/gunicorn_log.conf
%%ETCDIR%%/python.d/haproxy.conf
%%ETCDIR%%/python.d/hddtemp.conf
%%ETCDIR%%/python.d/ipfs.conf
%%ETCDIR%%/python.d/isc_dhcpd.conf
%%ETCDIR%%/python.d/mdstat.conf
%%ETCDIR%%/python.d/memcached.conf
%%ETCDIR%%/python.d/mysql.conf
%%ETCDIR%%/python.d/nginx.conf
%%ETCDIR%%/python.d/nginx_log.conf
%%ETCDIR%%/python.d/ovpn_status_log.conf
%%ETCDIR%%/python.d/phpfpm.conf
%%ETCDIR%%/python.d/postfix.conf
%%ETCDIR%%/python.d/postgres.conf
%%ETCDIR%%/python.d/redis.conf
%%ETCDIR%%/python.d/retroshare.conf
%%ETCDIR%%/python.d/sensors.conf
%%ETCDIR%%/python.d/squid.conf
%%ETCDIR%%/python.d/tomcat.conf
%%ETCDIR%%/python.d/varnish.conf
@mode
@owner
@group
libexec/netdata/charts.d/README.md
libexec/netdata/charts.d/ap.chart.sh
libexec/netdata/charts.d/apache.chart.sh
libexec/netdata/charts.d/apcupsd.chart.sh
libexec/netdata/charts.d/cpu_apps.chart.sh
libexec/netdata/charts.d/cpufreq.chart.sh
libexec/netdata/charts.d/example.chart.sh
libexec/netdata/charts.d/exim.chart.sh
libexec/netdata/charts.d/hddtemp.chart.sh
libexec/netdata/charts.d/load_average.chart.sh
libexec/netdata/charts.d/mem_apps.chart.sh
libexec/netdata/charts.d/mysql.chart.sh
libexec/netdata/charts.d/nginx.chart.sh
libexec/netdata/charts.d/nut.chart.sh
libexec/netdata/charts.d/opensips.chart.sh
libexec/netdata/charts.d/phpfpm.chart.sh
libexec/netdata/charts.d/postfix.chart.sh
libexec/netdata/charts.d/sensors.chart.sh
libexec/netdata/charts.d/squid.chart.sh
libexec/netdata/charts.d/tomcat.chart.sh
libexec/netdata/node.d/README.md
libexec/netdata/node.d/named.node.js
libexec/netdata/node.d/node_modules/asn1.js
libexec/netdata/node.d/node_modules/ber/errors.js
libexec/netdata/node.d/node_modules/ber/index.js
libexec/netdata/node.d/node_modules/ber/reader.js
libexec/netdata/node.d/node_modules/ber/types.js
libexec/netdata/node.d/node_modules/ber/writer.js
libexec/netdata/node.d/node_modules/extend.js
libexec/netdata/node.d/node_modules/net-snmp.js
libexec/netdata/node.d/node_modules/netdata.js
libexec/netdata/node.d/node_modules/pixl-xml.js
libexec/netdata/node.d/sma_webbox.node.js
libexec/netdata/node.d/snmp.node.js
libexec/netdata/plugins.d/README.md
libexec/netdata/plugins.d/alarm-email.sh
libexec/netdata/plugins.d/alarm-notify.sh
libexec/netdata/plugins.d/alarm-test.sh
libexec/netdata/plugins.d/apps.plugin
libexec/netdata/plugins.d/cgroup-name.sh
libexec/netdata/plugins.d/charts.d.dryrun-helper.sh
libexec/netdata/plugins.d/charts.d.plugin
libexec/netdata/plugins.d/fping.plugin
libexec/netdata/plugins.d/loopsleepms.sh.inc
libexec/netdata/plugins.d/node.d.plugin
libexec/netdata/plugins.d/python.d.plugin
libexec/netdata/plugins.d/tc-qos-helper.sh
libexec/netdata/python.d/README.md
libexec/netdata/python.d/apache.chart.py
libexec/netdata/python.d/apache_cache.chart.py
libexec/netdata/python.d/bind_rndc.chart.py
libexec/netdata/python.d/cpufreq.chart.py
libexec/netdata/python.d/cpuidle.chart.py
libexec/netdata/python.d/dovecot.chart.py
libexec/netdata/python.d/elasticsearch.chart.py
libexec/netdata/python.d/example.chart.py
libexec/netdata/python.d/exim.chart.py
libexec/netdata/python.d/fail2ban.chart.py
libexec/netdata/python.d/freeradius.chart.py
libexec/netdata/python.d/gunicorn_log.chart.py
libexec/netdata/python.d/haproxy.chart.py
libexec/netdata/python.d/hddtemp.chart.py
libexec/netdata/python.d/ipfs.chart.py
libexec/netdata/python.d/isc_dhcpd.chart.py
libexec/netdata/python.d/mdstat.chart.py
libexec/netdata/python.d/memcached.chart.py
libexec/netdata/python.d/mysql.chart.py
libexec/netdata/python.d/nginx.chart.py
libexec/netdata/python.d/nginx_log.chart.py
libexec/netdata/python.d/ovpn_status_log.chart.py
libexec/netdata/python.d/phpfpm.chart.py
libexec/netdata/python.d/postfix.chart.py
libexec/netdata/python.d/postgres.chart.py
libexec/netdata/python.d/python-modules-installer.sh
libexec/netdata/python.d/python_modules/__init__.py
libexec/netdata/python.d/python_modules/base.py
libexec/netdata/python.d/python_modules/lm_sensors.py
libexec/netdata/python.d/python_modules/msg.py
libexec/netdata/python.d/python_modules/pyyaml2/__init__.py
libexec/netdata/python.d/python_modules/pyyaml2/composer.py
libexec/netdata/python.d/python_modules/pyyaml2/constructor.py
libexec/netdata/python.d/python_modules/pyyaml2/cyaml.py
libexec/netdata/python.d/python_modules/pyyaml2/dumper.py
libexec/netdata/python.d/python_modules/pyyaml2/emitter.py
libexec/netdata/python.d/python_modules/pyyaml2/error.py
libexec/netdata/python.d/python_modules/pyyaml2/events.py
libexec/netdata/python.d/python_modules/pyyaml2/loader.py
libexec/netdata/python.d/python_modules/pyyaml2/nodes.py
libexec/netdata/python.d/python_modules/pyyaml2/parser.py
libexec/netdata/python.d/python_modules/pyyaml2/reader.py
libexec/netdata/python.d/python_modules/pyyaml2/representer.py
libexec/netdata/python.d/python_modules/pyyaml2/resolver.py
libexec/netdata/python.d/python_modules/pyyaml2/scanner.py
libexec/netdata/python.d/python_modules/pyyaml2/serializer.py
libexec/netdata/python.d/python_modules/pyyaml2/tokens.py
libexec/netdata/python.d/python_modules/pyyaml3/__init__.py
libexec/netdata/python.d/python_modules/pyyaml3/composer.py
libexec/netdata/python.d/python_modules/pyyaml3/constructor.py
libexec/netdata/python.d/python_modules/pyyaml3/cyaml.py
libexec/netdata/python.d/python_modules/pyyaml3/dumper.py
libexec/netdata/python.d/python_modules/pyyaml3/emitter.py
libexec/netdata/python.d/python_modules/pyyaml3/error.py
libexec/netdata/python.d/python_modules/pyyaml3/events.py
libexec/netdata/python.d/python_modules/pyyaml3/loader.py
libexec/netdata/python.d/python_modules/pyyaml3/nodes.py
libexec/netdata/python.d/python_modules/pyyaml3/parser.py
libexec/netdata/python.d/python_modules/pyyaml3/reader.py
libexec/netdata/python.d/python_modules/pyyaml3/representer.py
libexec/netdata/python.d/python_modules/pyyaml3/resolver.py
libexec/netdata/python.d/python_modules/pyyaml3/scanner.py
libexec/netdata/python.d/python_modules/pyyaml3/serializer.py
libexec/netdata/python.d/python_modules/pyyaml3/tokens.py
libexec/netdata/python.d/redis.chart.py
libexec/netdata/python.d/retroshare.chart.py
libexec/netdata/python.d/sensors.chart.py
libexec/netdata/python.d/squid.chart.py
libexec/netdata/python.d/tomcat.chart.py
libexec/netdata/python.d/varnish.chart.py
sbin/netdata
@mode 4640
@owner netdata
@group netdata
%%DATADIR%%/web/.well-known/dnt/cookies
%%DATADIR%%/web/css/bootstrap-3.3.7.css
%%DATADIR%%/web/css/bootstrap-slate-flat-3.3.7.css
%%DATADIR%%/web/css/bootstrap-theme-3.3.7.min.css
%%DATADIR%%/web/css/bootstrap-toggle-2.2.2.min.css
%%DATADIR%%/web/css/c3-0.4.11.min.css
%%DATADIR%%/web/css/font-awesome.min.css
%%DATADIR%%/web/css/morris-0.5.1.css
%%DATADIR%%/web/dashboard.css
%%DATADIR%%/web/dashboard.html
%%DATADIR%%/web/dashboard.js
%%DATADIR%%/web/dashboard.slate.css
%%DATADIR%%/web/dashboard_info.js
%%DATADIR%%/web/demo.html
%%DATADIR%%/web/demo2.html
%%DATADIR%%/web/demosites.html
%%DATADIR%%/web/demosites2.html
%%DATADIR%%/web/favicon.ico
%%DATADIR%%/web/fonts/FontAwesome.otf
%%DATADIR%%/web/fonts/fontawesome-webfont.eot
%%DATADIR%%/web/fonts/fontawesome-webfont.svg
%%DATADIR%%/web/fonts/fontawesome-webfont.ttf
%%DATADIR%%/web/fonts/fontawesome-webfont.woff
%%DATADIR%%/web/fonts/fontawesome-webfont.woff2
%%DATADIR%%/web/fonts/glyphicons-halflings-regular.eot
%%DATADIR%%/web/fonts/glyphicons-halflings-regular.svg
%%DATADIR%%/web/fonts/glyphicons-halflings-regular.ttf
%%DATADIR%%/web/fonts/glyphicons-halflings-regular.woff
%%DATADIR%%/web/fonts/glyphicons-halflings-regular.woff2
%%DATADIR%%/web/goto-host-from-alarm.html
%%DATADIR%%/web/images/alert-128-orange.png
%%DATADIR%%/web/images/alert-128-red.png
%%DATADIR%%/web/images/alert-multi-size-orange.ico
%%DATADIR%%/web/images/alert-multi-size-red.ico
%%DATADIR%%/web/images/animated.gif
%%DATADIR%%/web/images/check-mark-2-128-green.png
%%DATADIR%%/web/images/check-mark-2-multi-size-green.ico
%%DATADIR%%/web/images/post.png
%%DATADIR%%/web/images/seo-performance-114.png
%%DATADIR%%/web/images/seo-performance-128.png
%%DATADIR%%/web/images/seo-performance-16.png
%%DATADIR%%/web/images/seo-performance-24.png
%%DATADIR%%/web/images/seo-performance-256.png
%%DATADIR%%/web/images/seo-performance-32.png
%%DATADIR%%/web/images/seo-performance-48.png
%%DATADIR%%/web/images/seo-performance-512.png
%%DATADIR%%/web/images/seo-performance-64.png
%%DATADIR%%/web/images/seo-performance-72.png
%%DATADIR%%/web/images/seo-performance-multi-size.icns
%%DATADIR%%/web/images/seo-performance-multi-size.ico
%%DATADIR%%/web/index.html
%%DATADIR%%/web/lib/bootstrap-3.3.7.min.js
%%DATADIR%%/web/lib/bootstrap-table-1.11.0.min.js
%%DATADIR%%/web/lib/bootstrap-table-export-1.11.0.min.js
%%DATADIR%%/web/lib/bootstrap-toggle-2.2.2.min.js
%%DATADIR%%/web/lib/c3-0.4.11.min.js
%%DATADIR%%/web/lib/d3-3.5.17.min.js
%%DATADIR%%/web/lib/dygraph-combined-dd74404.js
%%DATADIR%%/web/lib/dygraph-smooth-plotter-dd74404.js
%%DATADIR%%/web/lib/gauge-d5260c3.min.js
%%DATADIR%%/web/lib/jquery-2.2.4.min.js
%%DATADIR%%/web/lib/jquery.easypiechart-97b5824.min.js
%%DATADIR%%/web/lib/jquery.peity-3.2.0.min.js
%%DATADIR%%/web/lib/jquery.sparkline-2.1.2.min.js
%%DATADIR%%/web/lib/morris-0.5.1.min.js
%%DATADIR%%/web/lib/perfect-scrollbar-0.6.15.min.js
%%DATADIR%%/web/lib/raphael-2.2.4-min.js
%%DATADIR%%/web/lib/tableExport-1.6.0.min.js
%%DATADIR%%/web/netdata-swagger.json
%%DATADIR%%/web/netdata-swagger.yaml
%%DATADIR%%/web/old/datasource.html
%%DATADIR%%/web/old/index.html
%%DATADIR%%/web/old/index.js
%%DATADIR%%/web/old/netdata.js
%%DATADIR%%/web/old/theme.css
%%DATADIR%%/web/registry.html
%%DATADIR%%/web/robots.txt
%%DATADIR%%/web/sitemap.xml
%%DATADIR%%/web/tv.html
%%DATADIR%%/web/version.txt
%%NETDATA_CACHE%%/.keep
%%NETDATA_PERST%%/.keep
%%NETDATA_PERST%%/registry/.keep
%%NETDATA_LOG%%/.keep
@mode
@owner
@group
@sample(netdata,netdata,0640) %%ETCDIR%%/netdata.conf.sample
@dir(netdata,netdata,0750) %%ETCDIR%%
@dir(netdata,netdata,0750) %%DATADIR%%
@dir(netdata,netdata,0750) %%DATADIR%%/web
@dir(netdata,netdata,0750) %%NETDATA_CACHE%%
@dir(netdata,netdata,0750) %%NETDATA_PERST%%
@dir(netdata,netdata,0750) %%NETDATA_PERST%%/registry
@dir(netdata,netdata,0750) %%NETDATA_LOG%%