Add rmap, a neat program that generates an image of the Earth at a specific

location in the world (based on longitude and latitude).

PR:		17676
Submitted by:	Trevor Johnson <trevor@jpj.net>
This commit is contained in:
Will Andrews 2000-07-02 07:22:55 +00:00
parent 95a2b0036d
commit 48f4fbc5f8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=30058
7 changed files with 54 additions and 0 deletions

View File

@ -5,6 +5,7 @@
SUBDIR += ephem
SUBDIR += luna
SUBDIR += pyweather
SUBDIR += rmap
SUBDIR += saoimage
SUBDIR += sattrack
SUBDIR += setiathome

25
astro/rmap/Makefile Normal file
View File

@ -0,0 +1,25 @@
# New ports collection makefile for: rmap
# Date created: 29 Mar 2000
# Whom: trevor@jpj.net
#
# $FreeBSD$
#
PORTNAME= rmap
PORTVERSION= 1.2
CATEGORIES= astro
MASTER_SITES= http://www.reza.net/rmap/
MAINTAINER= trevor@jpj.net
LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
MAN1= rmap.1
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I ${LOCALBASE}/include/gd/" \
LIBS="-L${LOCALBASE}/lib -lgnugetopt"
.include <bsd.port.mk>

1
astro/rmap/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (rmap-1.2.tar.gz) = 5406a76b66db65a5fc6073cf4bb62eeb

11
astro/rmap/files/patch-aa Normal file
View File

@ -0,0 +1,11 @@
--- main.c.orig Tue Mar 28 17:01:17 2000
+++ main.c Thu Mar 30 02:43:08 2000
@@ -154,7 +154,7 @@
case 'h':
printf("Usage: rmap [--zoom=VALUE] [--xrot=VALUE] [--yrot=VALUE] [--zrot=VALUE]\n");
printf(" [--datafile=FILENAME] [--continent=LIST] [--category=LIST]\n");
- printf(" [--outfile=FILENAME] [--height=PIXLES] [--width=PIXLES]\n");
+ printf(" [--outfile=FILENAME] [--height=PIXELS] [--width=PIXELS]\n");
printf(" [--colorfile=FILENAME] [--nogridlines] [--cities] [-h] [-v]\n");
printf("\n");
printf("\t--zoom=<value> Zoom Value, 1=whole earth\n");

1
astro/rmap/pkg-comment Normal file
View File

@ -0,0 +1 @@
Generates images of the Earth centered at a particular location

11
astro/rmap/pkg-descr Normal file
View File

@ -0,0 +1,11 @@
This program generates, but does not display, image files containing
raster maps of the Earth. It includes public-domain, vector
data from which they are drawn, describing the continents, bodies
of water, boundaries of countries and U.S. states, and a few cities.
Command-line options allow centering the maps at a particular
latitude and longitude and zooming in.
WWW: http://www.reza.net/rmap/
Trevor Johnson
trevor@jpj.net

4
astro/rmap/pkg-plist Normal file
View File

@ -0,0 +1,4 @@
bin/rmap
share/rmap/rmap.colors
share/rmap/earth.rez
@dirrm share/rmap