Do not install useless .la file.

PR:		44484
Submitted by:	Ports Fury
This commit is contained in:
Christian Weisgerber 2002-11-08 22:01:31 +00:00
parent bd9888119d
commit 48bc240b41
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=69755
6 changed files with 100 additions and 10 deletions

View File

@ -8,6 +8,7 @@
PORTNAME= dbh
PORTVERSION= 1.0.11
PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://dbh.sourceforge.net/archive/
@ -20,6 +21,7 @@ MAINTAINER= ports@FreeBSD.org
PORTCOMMENT= Disk Based Hashtables
USE_LIBTOOL= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
.include <bsd.port.mk>

View File

@ -1,6 +1,50 @@
--- configure.orig Fri Aug 9 23:22:33 2002
+++ configure Fri Aug 9 23:22:38 2002
@@ -10854,7 +10854,7 @@
--- configure.orig Wed Aug 14 06:39:38 2002
+++ configure Sat Oct 26 05:29:34 2002
@@ -1400,7 +1400,7 @@
# an executable is not found, even if stderr is redirected.
# Redirect stdin to placate older versions of autoconf. Sigh.
if (aclocal --version) < /dev/null > /dev/null 2>&1; then
- ACLOCAL=aclocal
+ ACLOCAL=true
echo "$as_me:1404: result: found" >&5
echo "${ECHO_T}found" >&6
else
@@ -1415,7 +1415,7 @@
# an executable is not found, even if stderr is redirected.
# Redirect stdin to placate older versions of autoconf. Sigh.
if (autoconf --version) < /dev/null > /dev/null 2>&1; then
- AUTOCONF=autoconf
+ AUTOCONF=true
echo "$as_me:1419: result: found" >&5
echo "${ECHO_T}found" >&6
else
@@ -1430,7 +1430,7 @@
# an executable is not found, even if stderr is redirected.
# Redirect stdin to placate older versions of autoconf. Sigh.
if (automake --version) < /dev/null > /dev/null 2>&1; then
- AUTOMAKE=automake
+ AUTOMAKE=true
echo "$as_me:1434: result: found" >&5
echo "${ECHO_T}found" >&6
else
@@ -1445,7 +1445,7 @@
# an executable is not found, even if stderr is redirected.
# Redirect stdin to placate older versions of autoconf. Sigh.
if (autoheader --version) < /dev/null > /dev/null 2>&1; then
- AUTOHEADER=autoheader
+ AUTOHEADER=true
echo "$as_me:1449: result: found" >&5
echo "${ECHO_T}found" >&6
else
@@ -6802,6 +6802,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -10854,7 +10855,7 @@
"NONE")
;;
*)

View File

@ -1,8 +1,7 @@
@comment $FreeBSD$
include/dbh.h
include/dbh_config.h
include/dbh_functions.h
lib/libdbh-1.0.so
lib/libdbh-1.0.so.1
lib/libdbh.a
lib/libdbh.la
lib/libdbh.so

View File

@ -8,6 +8,7 @@
PORTNAME= dbh
PORTVERSION= 1.0.11
PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://dbh.sourceforge.net/archive/
@ -20,6 +21,7 @@ MAINTAINER= ports@FreeBSD.org
PORTCOMMENT= Disk Based Hashtables
USE_LIBTOOL= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
.include <bsd.port.mk>

View File

@ -1,6 +1,50 @@
--- configure.orig Fri Aug 9 23:22:33 2002
+++ configure Fri Aug 9 23:22:38 2002
@@ -10854,7 +10854,7 @@
--- configure.orig Wed Aug 14 06:39:38 2002
+++ configure Sat Oct 26 05:29:34 2002
@@ -1400,7 +1400,7 @@
# an executable is not found, even if stderr is redirected.
# Redirect stdin to placate older versions of autoconf. Sigh.
if (aclocal --version) < /dev/null > /dev/null 2>&1; then
- ACLOCAL=aclocal
+ ACLOCAL=true
echo "$as_me:1404: result: found" >&5
echo "${ECHO_T}found" >&6
else
@@ -1415,7 +1415,7 @@
# an executable is not found, even if stderr is redirected.
# Redirect stdin to placate older versions of autoconf. Sigh.
if (autoconf --version) < /dev/null > /dev/null 2>&1; then
- AUTOCONF=autoconf
+ AUTOCONF=true
echo "$as_me:1419: result: found" >&5
echo "${ECHO_T}found" >&6
else
@@ -1430,7 +1430,7 @@
# an executable is not found, even if stderr is redirected.
# Redirect stdin to placate older versions of autoconf. Sigh.
if (automake --version) < /dev/null > /dev/null 2>&1; then
- AUTOMAKE=automake
+ AUTOMAKE=true
echo "$as_me:1434: result: found" >&5
echo "${ECHO_T}found" >&6
else
@@ -1445,7 +1445,7 @@
# an executable is not found, even if stderr is redirected.
# Redirect stdin to placate older versions of autoconf. Sigh.
if (autoheader --version) < /dev/null > /dev/null 2>&1; then
- AUTOHEADER=autoheader
+ AUTOHEADER=true
echo "$as_me:1449: result: found" >&5
echo "${ECHO_T}found" >&6
else
@@ -6802,6 +6802,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -10854,7 +10855,7 @@
"NONE")
;;
*)

View File

@ -1,8 +1,7 @@
@comment $FreeBSD$
include/dbh.h
include/dbh_config.h
include/dbh_functions.h
lib/libdbh-1.0.so
lib/libdbh-1.0.so.1
lib/libdbh.a
lib/libdbh.la
lib/libdbh.so