Support CC/CFLAGS/LOCALBASE/X11BASE properly

Change location of data files from lib/ to share/

PR:		21613
Submitted by:	Ports Fury
This commit is contained in:
Ade Lovett 2000-10-13 20:25:47 +00:00
parent 7d9d46445f
commit 489e7d8a7d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=33789
8 changed files with 179 additions and 132 deletions

View File

@ -5,51 +5,38 @@
# $FreeBSD$
#
PORTNAME= xracer
PORTVERSION= 0.94
CATEGORIES= games
MASTER_SITES= http://xracer.annexia.org/
DISTFILES= xracer-0.94.tar.gz xracer-data.tar.gz
PORTNAME= xracer
PORTVERSION= 0.94
CATEGORIES= games
MASTER_SITES= http://xracer.annexia.org/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} xracer-data.tar.gz
MAINTAINER= troll@digitalspark.net
MAINTAINER= troll@digitalspark.net
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
USE_XLIB= yes
USE_MESA= yes
MAKEFILE= Makefile
WRKSRC= ${WRKDIR}/xracer-0.94
USE_GMAKE= YES
HAS_CONFIGURE= YES
USE_XLIB= yes
USE_MESA= yes
USE_GMAKE= yes
USE_AUTOMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --disable-esd
post-install:
@ ${ECHO} "===> Installing Tracks and Sound"
@ ${CP} -R ${WRKSRC}/../xracer-data \
${PREFIX}/lib/xracer
@ ${CHMOD} -R 744 ${PREFIX}/lib/xracer
@ ${CHMOD} -R a+X ${PREFIX}/lib/xracer
@ ${ECHO} "===> Installing Documentation"
@ ${MKDIR} ${PREFIX}/share/doc/xracer
@${INSTALL_DATA} ${WRKSRC}/README \
${PREFIX}/share/doc/xracer
@${INSTALL_DATA} ${WRKSRC}/AUTHORS \
${PREFIX}/share/doc/xracer
@${INSTALL_DATA} ${WRKSRC}/COPYING \
${PREFIX}/share/doc/xracer
@${INSTALL_DATA} ${WRKSRC}/NEWS \
${PREFIX}/share/doc/xracer
@${INSTALL_DATA} ${WRKSRC}/README.html \
${PREFIX}/share/doc/xracer
@${INSTALL_DATA} ${WRKSRC}/ChangeLog \
${PREFIX}/share/doc/xracer
@ ${ECHO} "===> Stripping Binaries"
@ strip ${PREFIX}/bin/xracer
@ strip ${PREFIX}/bin/mktrackmodel
@ strip ${PREFIX}/bin/mktrack
@ strip ${PREFIX}/bin/perlin
@ strip ${PREFIX}/bin/test-poly-opts
@${ECHO} "===> Installing Tracks and Sound"
@${MKDIR} ${PREFIX}/share/xracer
${TAR} -C ${WRKDIR}/xracer-data -cf - . | \
${TAR} -C ${PREFIX}/share/xracer --unlink -xf -
@${CHMOD} -R 744 ${PREFIX}/share/xracer
@${CHMOD} -R a+X ${PREFIX}/share/xracer
.if !defined(NOPORTDOCS)
@${ECHO} "===> Installing Documentation"
@${MKDIR} ${PREFIX}/share/doc/xracer
.for file in AUTHORS ChangeLog NEWS README README.html
${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/xracer
.endfor
.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -0,0 +1,11 @@
--- aclocal.m4.orig Mon Jun 21 05:48:38 1999
+++ aclocal.m4 Thu Aug 10 01:41:06 2000
@@ -43,7 +43,7 @@
dnl AM_INIT_AUTOMAKE(package,version, [no-define])
AC_DEFUN(AM_INIT_AUTOMAKE,
-[AC_REQUIRE([AM_PROG_INSTALL])
+[AC_REQUIRE([AC_PROG_INSTALL])
PACKAGE=[$1]
AC_SUBST(PACKAGE)
VERSION=[$2]

View File

@ -0,0 +1,12 @@
--- src/Makefile.am.orig Mon Aug 9 00:37:36 1999
+++ src/Makefile.am Thu Aug 10 01:32:14 2000
@@ -15,8 +15,7 @@
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
#TRACK = track-general
-CFLAGS = -Wall -O3 @XRACER_EXTRA_CFLAGS@ \
- -I/usr/X11R6/include -I/usr/local/include
+CFLAGS = @CFLAGS@ @XRACER_EXTRA_CFLAGS@
bin_PROGRAMS = xracer

View File

@ -0,0 +1,11 @@
--- test/Makefile.am.orig Sun Jul 11 21:36:17 1999
+++ test/Makefile.am Thu Aug 10 02:00:47 2000
@@ -14,7 +14,7 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-CFLAGS = -Wall -O3 -I/usr/X11R6/include -I/usr/local/include -I../src
+CFLAGS = @CFLAGS@ -I$(top_srcdir)/src
bin_PROGRAMS = test-poly-opts

View File

@ -0,0 +1,11 @@
--- tools/Makefile.am.orig Wed Aug 25 06:50:22 1999
+++ tools/Makefile.am Thu Aug 10 01:59:08 2000
@@ -15,7 +15,7 @@
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
#TRACK = track-general
-CFLAGS = -Wall -O -I/usr/X11R6/include -I/usr/local/include -I$(top_srcdir)/src
+CFLAGS = @CFLAGS@ -I$(top_srcdir)/src
bin_PROGRAMS = mktrackmodel mktrack perlin

View File

@ -0,0 +1,16 @@
--- src/sound/generic.c.orig Sun Sep 12 22:16:25 1999
+++ src/sound/generic.c Thu Aug 10 03:18:34 2000
@@ -37,11 +37,11 @@
int
os_sound_enable ()
{
- return fd;
+ return -1;
}
int
os_sound_disable ()
{
- return fd;
+ return -1;
}

View File

@ -1,17 +1,17 @@
- --------------------------------------------------------------------- -
- XRACER PORT NOTES ported by trolld -
- --------------------------------------------------------------------- -
- The xracer data files have been installed to: /usr/local/lib/xracer -
- You'll NEED to set the enviroment variable $XRACER_HOME to this dir -
- otherwise xracer will not work. -
- -
- The xracer documentation has been installed in: -
- /usr/local/share/doc/xracer/ -
- -
- That's it, after setting the enviroment, type xracer to run! -
- Enjoy! -
- - trolld -
- -
- --------------------------------------------------------------------- -
- xracer website: http://xracer.annexia.org/ -
- --------------------------------------------------------------------- -
- ----------------------------------------------------------------------- -
- XRACER PORT NOTES ported by trolld -
- ----------------------------------------------------------------------- -
- The xracer data files have been installed to: /usr/local/share/xracer -
- You'll NEED to set the enviroment variable $XRACER_HOME to this dir -
- otherwise xracer will not work. -
- -
- The xracer documentation has been installed in: -
- /usr/local/share/doc/xracer/ -
- -
- That's it, after setting the enviroment, type xracer to run! -
- Enjoy! -
- - trolld -
- -
- ----------------------------------------------------------------------- -
- xracer website: http://xracer.annexia.org/ -
- ----------------------------------------------------------------------- -

View File

@ -1,81 +1,80 @@
bin/xracer
bin/mktrackmodel
bin/mktrack
bin/mktrackmodel
bin/perlin
bin/test-poly-opts
share/doc/xracer/README
bin/xracer
share/doc/xracer/AUTHORS
share/doc/xracer/COPYING
share/doc/xracer/NEWS
share/doc/xracer/README.html
share/doc/xracer/ChangeLog
share/doc/xracer/NEWS
share/doc/xracer/README
share/doc/xracer/README.html
share/xracer/images/andre-logo.jpg
share/xracer/images/beestripes1-large.jpg
share/xracer/images/beestripes1.jpg
share/xracer/images/clouds1.jpg
share/xracer/images/clouds2-large.jpg
share/xracer/images/clouds2.jpg
share/xracer/images/clouds3.jpg
share/xracer/images/clouds4.jpg
share/xracer/images/clouds5.jpg
share/xracer/images/craft1-back-side.jpg
share/xracer/images/craft1-inner-side.jpg
share/xracer/images/craft1-side.jpg
share/xracer/images/craft1-under.jpg
share/xracer/images/craft1-windscreen.jpg
share/xracer/images/crillee14.jpg
share/xracer/images/crillee24.jpg
share/xracer/images/crillee36.jpg
share/xracer/images/crillee48.jpg
share/xracer/images/menus-bg.jpg
share/xracer/images/mountains4-alpha.jpg
share/xracer/images/mountains4.jpg
share/xracer/images/powerup-autopilot-alpha.jpg
share/xracer/images/powerup-autopilot.jpg
share/xracer/images/powerup-energy-alpha.jpg
share/xracer/images/powerup-energy.jpg
share/xracer/images/powerup-faster-alpha.jpg
share/xracer/images/powerup-faster.jpg
share/xracer/images/powerup-shield-alpha.jpg
share/xracer/images/powerup-shield.jpg
share/xracer/images/skyscraper1.jpg
share/xracer/images/snow1.jpg
share/xracer/images/snow2.jpg
share/xracer/images/snowtex1.jpg
share/xracer/images/snowtex2.jpg
share/xracer/images/snowtex3.jpg
share/xracer/images/track1-large.jpg
share/xracer/images/track1.jpg
share/xracer/images/track2.jpg
share/xracer/images/track3.jpg
share/xracer/images/track5+left-fast+right-fast.jpg
share/xracer/images/track5+left-fast+right-faster.jpg
share/xracer/images/track5+left-fast+right-powerup.jpg
share/xracer/images/track5+left-fast.jpg
share/xracer/images/track5+left-faster+right-fast.jpg
share/xracer/images/track5+left-faster+right-faster.jpg
share/xracer/images/track5+left-faster+right-powerup.jpg
share/xracer/images/track5+left-faster.jpg
share/xracer/images/track5+left-powerup+right-fast.jpg
share/xracer/images/track5+left-powerup+right-faster.jpg
share/xracer/images/track5+left-powerup+right-powerup.jpg
share/xracer/images/track5+left-powerup.jpg
share/xracer/images/track5+right-fast.jpg
share/xracer/images/track5+right-faster.jpg
share/xracer/images/track5+right-powerup.jpg
share/xracer/images/track5.jpg
share/xracer/images/xracer-logo-3.jpg
share/xracer/objects/start-lamp/start-lamp-green-texture.jpg
share/xracer/objects/start-lamp/start-lamp-orange-texture.jpg
share/xracer/objects/start-lamp/start-lamp-red-texture.jpg
share/xracer/sounds/faster.wav
share/xracer/sounds/powerup.wav
share/xracer/sounds/wind.wav
share/xracer/tracks/demo.trk.gz
@dirrm share/xracer/tracks
@dirrm share/xracer/sounds
@dirrm share/xracer/objects/start-lamp
@dirrm share/xracer/objects
@dirrm share/xracer/images
@dirrm share/xracer
@dirrm share/doc/xracer
lib/xracer/images/beestripes1.jpg
lib/xracer/images/track1.jpg
lib/xracer/images/track1-large.jpg
lib/xracer/images/clouds1.jpg
lib/xracer/images/track2.jpg
lib/xracer/images/track3.jpg
lib/xracer/images/beestripes1-large.jpg
lib/xracer/images/clouds2.jpg
lib/xracer/images/powerup-energy-alpha.jpg
lib/xracer/images/powerup-shield-alpha.jpg
lib/xracer/images/track5.jpg
lib/xracer/images/skyscraper1.jpg
lib/xracer/images/snowtex1.jpg
lib/xracer/images/track5+left-powerup+right-fast.jpg
lib/xracer/images/track5+right-fast.jpg
lib/xracer/images/track5+left-fast.jpg
lib/xracer/images/track5+left-powerup.jpg
lib/xracer/images/snow1.jpg
lib/xracer/images/track5+right-powerup.jpg
lib/xracer/images/track5+left-fast+right-powerup.jpg
lib/xracer/images/track5+left-faster.jpg
lib/xracer/images/track5+right-faster.jpg
lib/xracer/images/track5+left-fast+right-fast.jpg
lib/xracer/images/track5+left-faster+right-faster.jpg
lib/xracer/images/track5+left-fast+right-faster.jpg
lib/xracer/images/track5+left-faster+right-fast.jpg
lib/xracer/images/track5+left-powerup+right-faster.jpg
lib/xracer/images/track5+left-faster+right-powerup.jpg
lib/xracer/images/track5+left-powerup+right-powerup.jpg
lib/xracer/images/clouds3.jpg
lib/xracer/images/snowtex2.jpg
lib/xracer/images/clouds4.jpg
lib/xracer/images/craft1-side.jpg
lib/xracer/images/clouds2-large.jpg
lib/xracer/images/clouds5.jpg
lib/xracer/images/craft1-windscreen.jpg
lib/xracer/images/powerup-faster-alpha.jpg
lib/xracer/images/powerup-autopilot.jpg
lib/xracer/images/craft1-inner-side.jpg
lib/xracer/images/snowtex3.jpg
lib/xracer/images/craft1-back-side.jpg
lib/xracer/images/craft1-under.jpg
lib/xracer/images/crillee48.jpg
lib/xracer/images/xracer-logo-3.jpg
lib/xracer/images/powerup-autopilot-alpha.jpg
lib/xracer/images/snow2.jpg
lib/xracer/images/andre-logo.jpg
lib/xracer/images/powerup-energy.jpg
lib/xracer/images/powerup-shield.jpg
lib/xracer/images/powerup-faster.jpg
lib/xracer/images/menus-bg.jpg
lib/xracer/images/crillee36.jpg
lib/xracer/images/crillee24.jpg
lib/xracer/images/crillee14.jpg
lib/xracer/images/mountains4-alpha.jpg
lib/xracer/images/mountains4.jpg
@dirrm lib/xracer/images
lib/xracer/tracks/demo.trk.gz
@dirrm lib/xracer/tracks
lib/xracer/objects/start-lamp/start-lamp-green-texture.jpg
lib/xracer/objects/start-lamp/start-lamp-orange-texture.jpg
lib/xracer/objects/start-lamp/start-lamp-red-texture.jpg
@dirrm lib/xracer/objects/start-lamp
@dirrm lib/xracer/objects
lib/xracer/sounds/powerup.wav
lib/xracer/sounds/faster.wav
lib/xracer/sounds/wind.wav
@dirrm lib/xracer/sounds
@dirrm lib/xracer