A Qt-based version of the blackjack game.

PR:           5822
Submitted by: Peter Mutsaers <plm@xs4all.nl
This commit is contained in:
Steve Price 1998-02-23 19:55:07 +00:00
parent 2eb3b5ca74
commit 4894611069
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=9898
6 changed files with 75 additions and 0 deletions

21
games/blackjack/Makefile Normal file
View File

@ -0,0 +1,21 @@
# New ports collection makefile for: acm
# Version required: 1.0
# Date created: 23 February 1998
# Whom: Peter Mutsaers
#
# $Id$
#
DISTNAME= blackjack-1.0
CATEGORIES= games x11
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= games/strategy
MAINTAINER= plm@xs4all.nl
BUILD_DEPENDS= moc:${PORTSDIR}/x11/qt
LIB_DEPENDS= qt\\.1\\.3[0-9]:${PORTSDIR}/x11/qt
MAN1= blackjack.1
.include <bsd.port.mk>

1
games/blackjack/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (blackjack-1.0.tar.gz) = 05c9f6fec4d59ffa524c1f440efc1f44

View File

@ -0,0 +1,29 @@
--- Makefile.orig Fri Jan 24 09:16:39 1997
+++ Makefile Mon Feb 23 12:35:50 1998
@@ -2,8 +2,8 @@
CC=gcc
CXX=g++
CFLAGS=
-INCLUDES=-I$(QTDIR)/include
-LDFLAGS=-L$(QTDIR)/lib -lqt
+INCLUDES=-I/usr/X11R6/include/X11/qt
+LDFLAGS=-L/usr/X11R6/lib -lqt
VERSION=1.0
# For systems that don't have install, use this
@@ -24,12 +24,14 @@
user_input.o dollar_scroll_bar.o bet_option.o table_option.o \
insurance_window.o $(METAOBJS)
-MOC=$(QTDIR)/bin/moc
+MOC=/usr/X11R6/bin/moc
.SUFFIXES: .cpp
.cpp.o:
$(CXX) -c $(CFLAGS) $(INCLUDES) $<
+
+all: blackjack
blackjack: main.o $(OBJS)
$(CXX) -o $@ $(LDFLAGS) main.o $(OBJS)

View File

@ -0,0 +1 @@
One of the better implementations of blackjack, based on QT.

21
games/blackjack/pkg-descr Normal file
View File

@ -0,0 +1,21 @@
This is an X windows based game of the casino game blackjack.
The program is currently written to use the Qt toolkit from Troll Tech.
For more information on Qt see "http://www.troll.no/".
I have always enjoyed the game of blackjack. When I first played in
a casino I lost all the money I had brought. After reading some books
on blackjack and the FAQ for rec.gambling.blackjack, I now know that there
is a basic strategy to follow. The strategy is based on the odds of each
hand and the dealers up card. I wrote this program so I could practice
the basic strategy of blackjack. The basic strategy is in the program
and a help level can be set to help the user learn to play by these rules.
My blackjack game has improved greatly.
I first wrote this program in tcl/tk. It was OK, but I have trouble
remembering all the syntax and parsing rules. The tcl/tk version was also
noticably slow on my 386 running Linux. Qt has been very good as a C++
GUI library and is not slow at all on my 386.
Tom Daley
tdaley@vsys.com

View File

@ -0,0 +1,2 @@
bin/blackjack
man/man1/blackjack.1.gz