Bring transfig up to 3.2, so I can bring xfig up to date also.

Submitted by:	Brian N. Handy <handy@sag.space.lockheed.com>
This commit is contained in:
Chuck Robey 1997-08-28 04:21:32 +00:00
parent 4f40641fc2
commit 487ef124a6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=7710
3 changed files with 35 additions and 34 deletions

View File

@ -1,13 +1,13 @@
# New ports collection makefile for: transfig
# Version required: 3.1.2
# Version required: 3.2
# Date created: 9 August 1996
# Whom: chuckr@freebsd.org
#
# $Id: Makefile,v 1.12 1996/11/18 09:54:46 asami Exp $
# $Id: Makefile,v 1.13 1996/11/19 04:18:49 asami Exp $
#
DISTNAME= transfig.3.1.2
PKGNAME= transfig-3.1.2
DISTNAME= transfig.3.2
PKGNAME= transfig-3.2
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= applications/drawing_tools/transfig
@ -17,7 +17,8 @@ MAINTAINER= chuckr@freebsd.org
LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm \
jpeg\\.7\\.:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript5
USE_IMAKE= yes
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (transfig.3.1.2.tar.gz) = 979ad0cdfbebae2994cca11a9042396d
MD5 (transfig.3.2.tar.gz) = d5ded82f303c75a92bbf4bec568e7853

View File

@ -1,44 +1,44 @@
--- fig2dev/Imakefile.orig Thu Aug 17 20:13:51 1995
+++ fig2dev/Imakefile Fri Aug 9 21:46:00 1996
@@ -32,10 +32,10 @@
XCOMM the XPM (color pixmap) package and you would like to allow XPM files.
XCOMM You need version 3.4c of the XPM package.
--- fig2dev/Imakefile.orig Mon Aug 25 20:51:04 1997
+++ fig2dev/Imakefile Mon Aug 25 20:54:14 1997
@@ -37,7 +37,7 @@
XCOMM inline functions. With the "INLINE" keyword, you should notice that
XCOMM the display will be a bit faster in complex figures
-XCOMM XPMDEFINES = -DUSE_XPM
-XCOMM XPMLIBDIR = -L/usr/local/X11/lib
-XCOMM XPMINCDIR = -I/usr/local/X11/include/xpm
-XCOMM XPMLIB = $(XPMLIBDIR) -lXpm -lX11
+XPMDEFINES = -DUSE_XPM
+XPMLIBDIR = -L/usr/X11R6/lib
+XPMINCDIR = -I/usr/X11R6/include/X11
+XPMLIB = $(XPMLIBDIR) -lXpm -lX11
-XCOMM USEINLINE = -DUSE_INLINE
+USEINLINE = -DUSE_INLINE
XCOMM Uncomment the XPM variables here if you have the XPM (color pixmap)
XCOMM package and you would like to allow XPM files.
@@ -100,8 +100,8 @@
XCOMM Hint: Users of LaTeX2e will probably want to include both of these
XCOMM options; users of LaTeX 2.09 will probably want to include neither.
-XCOMM DDNFSS = -DNFSS
-XCOMM DDEPSF = -DEPSF
+DDNFSS = -DNFSS
+DDEPSF = -DEPSF
XCOMM For Linux machines or any machines that have a separate library for
XCOMM the database management routines, uncomment the following line
@@ -67,7 +67,7 @@
XCOMM set JPEGLIBDIR after the #else to the directory where you have the source
XCOMM for jpeg.
-XCOMM #define USEINSTALLEDJPEG
+#define USEINSTALLEDJPEG
#define IHaveSubdirs
#define PassCDebugFlags 'CDEBUGFLAGS=$(CDEBUGFLAGS)'
@@ -78,7 +78,7 @@
@@ -138,7 +138,7 @@
#ifdef USEINSTALLEDJPEG
JPEGLIBDIR = /usr/local/lib
-JPEGINCDIR = /usr/include/X11
+JPEGINCDIR = /usr/local/include
JPEGLIB = -L$(JPEGLIBDIR) -ljpeg
#else
JPEGLIBDIR = ../../jpeg
XCOMM You shouldn't need to change JPEGINCDIR here.
@@ -95,7 +95,7 @@
EXTRA_INCLUDES = $(XPMINCDIR)
@@ -175,10 +175,10 @@
INCLUDES = -I.. -I$(JPEGINCDIR)
LOCAL_LIBRARIES = $(LIBTRANSFIG) -L$(JPEGLIBDIR) -ljpeg
LOCAL_LIBRARIES = $(LIBTRANSFIG) $(JPEGLIB)
-#if defined(NetBSDArchitecture)
+#if defined(NetBSDArchitecture)
SYS_LIBRARIES = $(XPMLIB) $(DBMLIB) -lm -lcompat
#else
-SYS_LIBRARIES = $(XPMLIB) $(DBMLIB) -lm
+SYS_LIBRARIES = $(XPMLIB) $(DBMLIB) -lm -lcompat
#endif
DEPLIBS = $(LIBTRANSFIG)
SRCS = fig2dev.c psfonts.c iso2tex.c arrow.c bound.c\