Update to 0.8.0.

This commit is contained in:
Pierre Beyssac 2005-12-17 22:42:05 +00:00
parent c79a7b5753
commit 4857cdc881
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=151454
12 changed files with 198 additions and 111 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= kino
PORTVERSION= 0.7.6
PORTREVISION= 1
PORTVERSION= 0.8.0
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -21,6 +20,7 @@ LIB_DEPENDS= dv.4:${PORTSDIR}/multimedia/libdv \
OPTIONS= QUICKTIME "With Quicktime support" off
USE_AUTOTOOLS= autoconf:259
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix libgnomeui libxml2
@ -34,6 +34,10 @@ MAN1= kino.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500039
USE_GCC= 3.4
.endif
.if defined(WITH_QUICKTIME)
LIB_DEPENDS+= quicktime.0:${PORTSDIR}/multimedia/libquicktime
CONFIGURE_ARGS+= --with-quicktime

View File

@ -1,2 +1,3 @@
MD5 (kino-0.7.6.tar.gz) = c1fa929096f5a754455f5a3dd33dd203
SIZE (kino-0.7.6.tar.gz) = 1089097
MD5 (kino-0.8.0.tar.gz) = ec945365580d5e21431c76c07d0576bf
SHA256 (kino-0.8.0.tar.gz) = 3f06abb3dc863689cd44a560d42c203ba882a17f8cdc845e861b854f852a3b0b
SIZE (kino-0.8.0.tar.gz) = 1498967

View File

@ -1,11 +1,11 @@
--- Makefile.in.orig Fri Aug 6 01:40:29 2004
+++ Makefile.in Thu Aug 12 20:27:02 2004
@@ -188,7 +188,7 @@
--- Makefile.in.orig Mon Nov 28 21:15:11 2005
+++ Makefile.in Mon Nov 28 21:16:37 2005
@@ -249,7 +249,7 @@
sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
-SUBDIRS = po src help scripts linux-hotplug pixmaps
+SUBDIRS = po src help scripts pixmaps
MAINTAINERCLEANFILES = Makefile.in aclocal.m4 configure config.h.in
#ACLOCAL_AMFLAGS = -I m4
EXTRA_DIST = config.rpath \
MAINTAINERCLEANFILES = Makefile.in aclocal.m4 configure config.h.in \
intltool-extract.in intltool-merge.in intltool-update.in

View File

@ -1,91 +0,0 @@
--- configure.orig Thu Jul 14 00:44:15 2005
+++ configure Thu Jul 14 00:57:23 2005
@@ -5448,7 +5448,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-ldv $LIBS"
+LIBS="-ldv ${PTHREAD_LIBS} $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -5816,7 +5816,7 @@
else
{ { echo "$as_me:$LINENO: error: Unable to link with libraw1394. Check that you have libraw1394 installed" >&5
echo "$as_me: error: Unable to link with libraw1394. Check that you have libraw1394 installed" >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
@@ -5826,7 +5826,7 @@
else
{ { echo "$as_me:$LINENO: error: raw1394.h not found install libraw1394-devel" >&5
echo "$as_me: error: raw1394.h not found install libraw1394-devel" >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
@@ -5976,7 +5976,7 @@
else
{ { echo "$as_me:$LINENO: error: avc1394.h not found, install libavc1394-devel" >&5
echo "$as_me: error: avc1394.h not found, install libavc1394-devel" >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
@@ -6056,7 +6056,7 @@
else
{ { echo "$as_me:$LINENO: error: Unable to link with libavc1394. Check that you have libavc1394 installed and that the version is 0.4.1 or newer" >&5
echo "$as_me: error: Unable to link with libavc1394. Check that you have libavc1394 installed and that the version is 0.4.1 or newer" >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
@@ -6203,7 +6203,7 @@
else
{ { echo "$as_me:$LINENO: error: rom1394.h not found, install libavc1394-devel" >&5
echo "$as_me: error: rom1394.h not found, install libavc1394-devel" >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
@@ -6283,7 +6283,7 @@
else
{ { echo "$as_me:$LINENO: error: Unable to link with librom1394. Check that your have librom1394 installed (usually part of libavc1394) and that the version is 0.4.1 or newer" >&5
echo "$as_me: error: Unable to link with librom1394. Check that your have librom1394 installed (usually part of libavc1394) and that the version is 0.4.1 or newer" >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
@@ -6363,7 +6363,7 @@
{ { echo "$as_me:$LINENO: error: You need the pthread library to compile kino" >&5
echo "$as_me: error: You need the pthread library to compile kino" >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
@@ -10297,11 +10297,11 @@
echo "$as_me:$LINENO: result: not using file chooser dialogs" >&5
echo "${ECHO_T}not using file chooser dialogs" >&6
else
- GTK24_CFLAGS=$pkg_cv_GTK24_CFLAGS
- GTK24_LIBS=$pkg_cv_GTK24_LIBS
- cat >>confdefs.h <<\_ACEOF
-#define HAVE_GTK24 1
-_ACEOF
+# GTK24_CFLAGS=$pkg_cv_GTK24_CFLAGS
+# GTK24_LIBS=$pkg_cv_GTK24_LIBS
+# cat >>confdefs.h <<\_ACEOF
+##define HAVE_GTK24 1
+#_ACEOF
fi

View File

@ -1,10 +1,10 @@
--- src/image_create.h Mon Dec 15 05:08:34 2003
+++ src/image_create.h Sat Apr 10 12:16:27 2004
--- src/image_create.h.orig Thu Jul 28 16:36:23 2005
+++ src/image_create.h Mon Nov 28 21:27:51 2005
@@ -27,7 +27,6 @@
// C Includes
-#include <stdint.h>
#include <gnome.h>
#include <gtk/gtk.h>
/** Public interface for all image create classes.

View File

@ -1,11 +1,10 @@
--- src/kino_common.h Mon Dec 15 04:23:12 2003
+++ src/kino_common.h Sat Apr 10 12:15:02 2004
@@ -24,7 +24,7 @@
--- src/kino_common.h.orig Fri Nov 11 06:42:22 2005
+++ src/kino_common.h Mon Nov 28 21:28:55 2005
@@ -25,7 +25,6 @@
#include <gdk/gdkkeysyms.h>
#include <limits.h>
#include <stdlib.h>
#include <gnome.h>
-#include <stdint.h>
+//#include <stdint.h>
#include "playlist.h"
#include "frame.h"
#include "preferences.h"

View File

@ -0,0 +1,53 @@
--- configure.in.orig Mon Nov 21 00:01:31 2005
+++ configure.in Mon Nov 28 21:39:59 2005
@@ -40,29 +40,29 @@
AC_SUBST(LIBDV_CFLAGS)
AC_SUBST(LIBDV_LIBS)
-PKG_CHECK_MODULES(LIBRAW1394, libraw1394 >= 1.0.0, AC_DEFINE(HAVE_LIBRAW1394, 1, [libraw1394 present]))
-AC_SUBST(LIBRAW1394_CFLAGS)
-AC_SUBST(LIBRAW1394_LIBS)
+#PKG_CHECK_MODULES(LIBRAW1394, libraw1394 >= 1.0.0, AC_DEFINE(HAVE_LIBRAW1394, 1, [libraw1394 present]))
+#AC_SUBST(LIBRAW1394_CFLAGS)
+#AC_SUBST(LIBRAW1394_LIBS)
-AC_CHECK_HEADER([libavc1394/avc1394.h], ,
- [AC_MSG_ERROR([avc1394.h not found, install libavc1394-devel])
-])
-AC_CHECK_LIB(avc1394, avc1394_vcr_record, ,
- [AC_MSG_ERROR([Unable to link with libavc1394. Check that you have libavc1394 installed and that the version is 0.4.1 or newer])],
- [$LIBRAW1394_CFLAGS $LIBRAW1394_LIBS])
-AC_CHECK_HEADER([libavc1394/rom1394.h], ,
- [AC_MSG_ERROR([rom1394.h not found, install libavc1394-devel])
-])
-AC_CHECK_LIB(rom1394, rom1394_get_node_type, ,
- [AC_MSG_ERROR([Unable to link with librom1394. Check that your have librom1394 installed (usually part of libavc1394) and that the version is 0.4.1 or newer])],
- [$LIBRAW1394_CFLAGS $LIBRAW1394_LIBS -lm])
+#AC_CHECK_HEADER([libavc1394/avc1394.h], ,
+# [AC_MSG_ERROR([avc1394.h not found, install libavc1394-devel])
+#])
+#AC_CHECK_LIB(avc1394, avc1394_vcr_record, ,
+# [AC_MSG_ERROR([Unable to link with libavc1394. Check that you have libavc1394 installed and that the version is 0.4.1 or newer])],
+# [$LIBRAW1394_CFLAGS $LIBRAW1394_LIBS])
+#AC_CHECK_HEADER([libavc1394/rom1394.h], ,
+# [AC_MSG_ERROR([rom1394.h not found, install libavc1394-devel])
+#])
+#AC_CHECK_LIB(rom1394, rom1394_get_node_type, ,
+# [AC_MSG_ERROR([Unable to link with librom1394. Check that your have librom1394 installed (usually part of libavc1394) and that the version is 0.4.1 or newer])],
+# [$LIBRAW1394_CFLAGS $LIBRAW1394_LIBS -lm])
-AC_CHECK_LIB(pthread, pthread_create, ,
- [AC_MSG_ERROR([You need the pthread library to compile kino])],
- [$LIBRAW1394_CFLAGS $LIBRAW1394_LIBS -lm])
-AC_CHECK_LIB(dl, dlopen, ,
- [AC_MSG_ERROR([You need libdl to compile kino])],
- [$LIBRAW1394_CFLAGS $LIBRAW1394_LIBS -lm])
+#AC_CHECK_LIB(pthread, pthread_create, ,
+# [AC_MSG_ERROR([You need the pthread library to compile kino])],
+# [$LIBRAW1394_CFLAGS $LIBRAW1394_LIBS -lm])
+#AC_CHECK_LIB(dl, dlopen, ,
+# [AC_MSG_ERROR([You need libdl to compile kino])],
+# [$LIBRAW1394_CFLAGS $LIBRAW1394_LIBS -lm])
# ######################################################################
# checks for optional ALSA packages

View File

@ -0,0 +1,29 @@
--- src/Makefile.in.bak Fri Nov 25 20:27:49 2005
+++ src/Makefile.in Mon Nov 28 21:44:34 2005
@@ -200,8 +200,6 @@
LIBOBJS = @LIBOBJS@
LIBQUICKTIME_CFLAGS = @LIBQUICKTIME_CFLAGS@
LIBQUICKTIME_LIBS = @LIBQUICKTIME_LIBS@
-LIBRAW1394_CFLAGS = @LIBRAW1394_CFLAGS@
-LIBRAW1394_LIBS = @LIBRAW1394_LIBS@
LIBS = @LIBS@
LIBTOOL = @LIBTOOL@
LIBXML2_CFLAGS = @LIBXML2_CFLAGS@
@@ -348,8 +346,6 @@
EXTRA_kino_SOURCES = cmd_ref.c
kino_LDADD = \
$(LIBDV_LIBS) \
- $(LIBRAW1394_LIBS) \
- $(LIBAVC1394_LIBS) \
$(LIBQUICKTIME_LIBS) \
$(ALSA_LIBS) \
$(LIBXML2_LIBS) \
@@ -361,8 +357,6 @@
kino_LDFLAGS = -export-dynamic
INCLUDES = -Wall \
$(LIBDV_CFLAGS) \
- $(LIBRAW1394_CFLAGS) \
- $(LIBAVC1394_CFLAGS) \
$(LIBQUICKTIME_CFLAGS) \
$(ALSA_CFLAGS) \
$(LIBXML2_CFLAGS) \

View File

@ -0,0 +1,11 @@
--- src/dvtitler/textblock.cc.orig Tue Oct 4 09:15:44 2005
+++ src/dvtitler/textblock.cc Sat Dec 17 23:25:26 2005
@@ -22,7 +22,7 @@
#endif
#include "textblock.h"
-#include <stdint.h>
+#include <sys/types.h>
struct DVColor
{

View File

@ -0,0 +1,10 @@
--- src/jogshuttle.h.orig Mon Oct 3 01:40:59 2005
+++ src/jogshuttle.h Sat Dec 17 23:22:45 2005
@@ -26,6 +26,7 @@
#endif
#include <gtk/gtk.h>
+#include <sys/time.h>
#include "mediactrl.h"
/**

View File

@ -0,0 +1,17 @@
--- src/timfx/kino_plugin_types.h.orig Mon Oct 3 05:13:13 2005
+++ src/timfx/kino_plugin_types.h Sat Dec 17 22:00:05 2005
@@ -2,13 +2,13 @@
#define KINO_PLUGIN_TYPES_H
#include "kino_plugin_utility.h"
+#include <sys/types.h>
#include <algorithm>
#include <cmath>
#include <functional>
#include <iostream>
#include <string>
-#include <stdint.h>
namespace kino
{

View File

@ -7,9 +7,18 @@ include/kino/image_filters.h
include/kino/image_transitions.h
include/kino/kino_extra.h
include/kino/playlist.h
lib/kino-gtk2/libdvtitler.a
lib/kino-gtk2/libdvtitler.la
lib/kino-gtk2/libdvtitler.so
lib/kino-gtk2/libdvtitler.so.0
lib/kino-gtk2/libtimfx.a
lib/kino-gtk2/libtimfx.la
lib/kino-gtk2/libtimfx.so
lib/kino-gtk2/libtimfx.so.0
share/gnome/applications/Kino.desktop
share/gnome/kino/about.jpeg
share/gnome/kino/capture.png
share/gnome/kino/dvtitler.glade
share/gnome/kino/edit.png
share/gnome/kino/export.png
share/gnome/kino/fx.png
@ -24,8 +33,11 @@ share/gnome/kino/link.xpm
share/gnome/kino/link_off.xpm
share/gnome/kino/magick.glade
share/gnome/kino/publish_project.png
share/gnome/kino/publish_project_16.png
share/gnome/kino/publish_still.png
share/gnome/kino/publish_still_16.png
share/gnome/kino/saveframe.png
share/gnome/kino/saveframe_16.png
share/gnome/kino/split.xpm
share/gnome/kino/stock_media-begin-16.png
share/gnome/kino/stock_media-end-16.png
@ -41,6 +53,7 @@ share/gnome/kino/stock_media-repeat-alt.png
share/gnome/kino/stock_media-rew-16.png
share/gnome/kino/stock_media-stop-16.png
share/gnome/kino/timeline.png
share/gnome/kino/timfx.glade
share/gnome/kino/trim.png
share/gnome/kino/trim_in.xpm
share/gnome/kino/trim_out.xpm
@ -66,13 +79,51 @@ share/gnome/kino/scripts/exports/ffmpeg_divx_dual.sh
share/gnome/kino/scripts/exports/ffmpeg_dvd.sh
share/gnome/kino/scripts/exports/ffmpeg_dvd_dual.sh
share/gnome/kino/scripts/exports/ffmpeg_flv.sh
share/gnome/kino/scripts/exports/ffmpeg_h264.sh
share/gnome/kino/scripts/exports/ffmpeg_h264_dual.sh
share/gnome/kino/scripts/exports/ffmpeg_mp3.sh
share/gnome/kino/scripts/exports/ffmpeg_mp4.sh
share/gnome/kino/scripts/exports/ffmpeg_mp4_dual.sh
share/gnome/kino/scripts/exports/ffmpeg_vcd.sh
share/gnome/kino/scripts/exports/mencoder.sh
share/gnome/kino/scripts/exports/rawplay.sh
share/gnome/kino/scripts/import/media.sh
share/gnome/kino/scripts/publish/frame.sh
share/gnome/kino/scripts/publish/project.sh
share/gnome/kino/lumas/bar_bottom.png
share/gnome/kino/lumas/bar_left.png
share/gnome/kino/lumas/bar_right.png
share/gnome/kino/lumas/bar_top.png
share/gnome/kino/lumas/barn_bottomleft.png
share/gnome/kino/lumas/barn_horz.png
share/gnome/kino/lumas/barn_topleft.png
share/gnome/kino/lumas/barn_vert.png
share/gnome/kino/lumas/box_bottomcentre.png
share/gnome/kino/lumas/box_bottomleft.png
share/gnome/kino/lumas/box_bottomright.png
share/gnome/kino/lumas/box_leftcentre.png
share/gnome/kino/lumas/box_rightcentre.png
share/gnome/kino/lumas/box_topcentre.png
share/gnome/kino/lumas/box_topleft.png
share/gnome/kino/lumas/box_topright.png
share/gnome/kino/lumas/burst.png
share/gnome/kino/lumas/checkerboard_small.png
share/gnome/kino/lumas/clock.png
share/gnome/kino/lumas/clock_clockwise12.png
share/gnome/kino/lumas/clock_clockwise6.png
share/gnome/kino/lumas/diag_bottomleft.png
share/gnome/kino/lumas/diag_bottomright.png
share/gnome/kino/lumas/diag_topleft.png
share/gnome/kino/lumas/diag_topright.png
share/gnome/kino/lumas/fourbox_in.png
share/gnome/kino/lumas/fourbox_out.png
share/gnome/kino/lumas/horizontal_barn_doors.png
share/gnome/kino/lumas/horizontal_blinds.png
share/gnome/kino/lumas/iris_circle.png
share/gnome/kino/lumas/iris_rectangle.png
share/gnome/kino/lumas/left_to_right.png
share/gnome/kino/lumas/matrix_snake_toplefthorizontal.png
share/gnome/kino/lumas/symmetric_clock.png
share/gnome/pixmaps/kino.png
share/locale/cs/LC_MESSAGES/kino.mo
share/locale/da/LC_MESSAGES/kino.mo
@ -85,8 +136,11 @@ share/locale/nb/LC_MESSAGES/kino.mo
share/locale/eu/LC_MESSAGES/kino.mo
share/mime/packages/kino.xml
@dirrm include/kino
@dirrm lib/kino-gtk2
@dirrm share/gnome/kino/help
@dirrm share/gnome/kino/lumas
@dirrm share/gnome/kino/scripts/exports
@dirrm share/gnome/kino/scripts/import
@dirrm share/gnome/kino/scripts/publish
@dirrm share/gnome/kino/scripts
@dirrm share/gnome/kino