- Update to 4.0.3

PR:		131655
Submitted by:	Joerg Pulz <Joerg.Pulz@frm2.tum.de>
Approved by:	maintainer
This commit is contained in:
Martin Wilke 2009-02-28 19:49:49 +00:00
parent 77cf3f1d2b
commit 484b5acc7f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=229234
9 changed files with 280 additions and 287 deletions

View File

@ -6,153 +6,186 @@
#
PORTNAME= gromacs
PORTVERSION= 3.2.1
PORTREVISION= 4
PORTVERSION= 4.0.3
CATEGORIES= science
MASTER_SITES= ftp://ftp.gromacs.org/pub/gromacs/
MAINTAINER= stephen@math.missouri.edu
COMMENT= Compute molecular dynamics
.ifndef WITHOUT_FFTW
LIB_DEPENDS= fftw:${PORTSDIR}/math/fftw:install
.endif
.ifdef WITH_MPI
BUILD_DEPENDS= ${LOCALBASE}/mpich/bin/mpicc:${PORTSDIR}/net/mpich
RUN_DEPENDS= ${LOCALBASE}/mpich/bin/mpicc:${PORTSDIR}/net/mpich
.endif
USE_GNOME= libxml2
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
CONFIGURE_ARGS= --exec-prefix=${PREFIX}
CONFIGURE_ARGS= --exec-prefix=${PREFIX} --program-suffix="" --enable-shared
PLIST_SUB= BUILD=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.ifndef WITHOUT_FFTW
.ifdef WITH_FLOAT
IGNORE= Cannot currently build with fftw and single precision floating point
.elifdef WITH_MPI
IGNORE= Cannot currently build with fftw and mpi support
.endif
.endif
.ifdef WITHOUT_X
PLIST_SUB+= WITHOUT_X="@comment "
CONFIGURE_ARGS+= --without-x
.else
PLIST_SUB+= WITHOUT_X=
CONFIGURE_ARGS+= --with-x
USE_XORG= x11
.endif
.ifndef WITH_FLOAT
CONFIGURE_ARGS+= --disable-float --program-suffix=
PLIST_SUB+= SUFFIX_D=_d SUFFIX_DOUBLE=_double
.else
PLIST_SUB+= SUFFIX_D= SUFFIX_DOUBLE=
.endif
.ifdef WITHOUT_FFTW
CONFIGURE_ARGS+= --without-fftw
.endif
.ifdef WITH_MPI
CONFIGURE_ARGS+= --enable-mpi
CONFIGURE_ENV+= MPICC=${PREFIX}/mpich/bin/mpicc
PLIST_SUB+= WITH_MPI= SUFFIX_MPI=_mpi WITHOUT_MPI="@comment "
.else
PLIST_SUB+= WITH_MPI="@comment " SUFFIX_MPI= WITHOUT_MPI=
.endif
MAN1= anadock.1 \
g_cluster.1 \
g_filter.1 \
g_potential.1 \
g_velacc.1 \
ngmx.1 \
cdist.1 \
g_clustsize.1 \
g_gyrate.1 \
g_rama.1 \
g_wham.1 \
pdb2gmx.1 \
disco.1 \
g_confrms.1 \
g_h2order.1 \
g_rdf.1 \
genbox.1 \
protonate.1 \
do_dssp.1 \
g_covar.1 \
g_hbond.1 \
g_rms.1 \
genconf.1 \
tpbconv.1 \
editconf.1 \
g_density.1 \
g_helix.1 \
g_rmsdist.1 \
genion.1 \
trjcat.1 \
eneconv.1 \
g_dielectric.1 \
g_lie.1 \
g_rmsf.1 \
genpr.1 \
trjconv.1 \
ffscan.1 \
g_dih.1 \
g_mdmat.1 \
g_rotacf.1 \
gmxcheck.1 \
trjorder.1 \
g_anaeig.1 \
g_dipoles.1 \
g_mindist.1 \
g_saltbr.1 \
gmxdump.1 \
wheel.1 \
g_analyze.1 \
g_disre.1 \
g_morph.1 \
g_sas.1 \
grompp.1 \
x2top.1 \
g_angle.1 \
g_dist.1 \
g_msd.1 \
g_sgangle.1 \
highway.1 \
xpm2ps.1 \
g_bond.1 \
g_dyndom.1 \
g_nmeig.1 \
g_sorient.1 \
make_ndx.1 \
xrama.1 \
g_bundle.1 \
g_enemat.1 \
g_nmens.1 \
g_tcaf.1 \
mdrun.1 \
g_chi.1 \
g_energy.1 \
g_order.1 \
g_traj.1 \
mk_angndx.1
OPTIONS= FFTW3 "Use FFT routines from math/fftw3" on \
FFTW2 "Use FFT routines from math/fftw" off \
GSL "Enable extra analysis using math/gsl" on \
FLOAT "Use single instead of double precision" off \
X11 "Build and install X11 programs" on \
MPICH "Enable MPI support using net/mpich" off \
OMPI "Enable MPI support using net/openmpi" off
.include <bsd.port.pre.mk>
pre-fetch:
@${ECHO}
@${ECHO} "OPTIONS:"
@${ECHO}
@${ECHO} "To compile without X11: define WITHOUT_X"
@${ECHO} "To compile using single precision floating point: define WITH_FLOAT"
@${ECHO} "To compile without fftw: define WITHOUT_FFTW"
@${ECHO} "To compile with mpi: define WITH_MPI"
@${ECHO}
.if !defined(WITHOUT_FFTW3) && defined(WITH_FFTW2)
IGNORE= Cannot build with FFTW3 and FFTW2. Run 'make config' again and choose only one of them.
.endif
.if defined(WITH_MPICH) && defined(WITH_OMPI)
IGNORE= Cannot build with MPICH and OpenMPI support. Run 'make config' again and choose only one of them.
.endif
.if !defined(WITHOUT_FFTW3)
CONFIGURE_ARGS+= --with-fft=fftw3
. if defined(WITH_FLOAT)
LIB_DEPENDS+= fftw3f.4:${PORTSDIR}/math/fftw3-float
. else
LIB_DEPENDS+= fftw3.4:${PORTSDIR}/math/fftw3
. endif
.else
. if defined(WITH_FFTW2)
CONFIGURE_ARGS+= --with-fft=fftw2
. if defined(WITH_FLOAT)
LIB_DEPENDS+= sfftw.2:${PORTSDIR}/math/fftw-float
. else
LIB_DEPENDS+= fftw.2:${PORTSDIR}/math/fftw
. endif
. else
CONFIGURE_ARGS+= --with-fft=fftpack
. endif
.endif
.if !defined(WITHOUT_GSL)
CONFIGURE_ARGS+= --with-gsl
LIB_DEPENDS+= gsl.13:${PORTSDIR}/math/gsl
.else
CONFIGURE_ARGS+= --without-gsl
.endif
.if !defined(WITHOUT_X11)
PLIST_SUB+= X11=""
CONFIGURE_ARGS+= --with-x
USE_XORG= x11
.else
PLIST_SUB+= X11="@comment "
CONFIGURE_ARGS+= --without-x
.endif
.if defined(WITH_FLOAT)
PLIST_SUB+= SUFFIX_D="" SUFFIX_DOUBLE=""
.else
CONFIGURE_ARGS+= --disable-float
PLIST_SUB+= SUFFIX_D=_d SUFFIX_DOUBLE=_double
.endif
.if defined(WITH_MPICH) || defined(WITH_OMPI)
CONFIGURE_ARGS+= --enable-mpi
. if defined(WITH_MPICH)
CONFIGURE_ENV+= MPICC=${PREFIX}/mpich/bin/mpicc
BUILD_DEPENDS+= ${PREFIX}/mpich/bin/mpicc:${PORTSDIR}/net/mpich
RUN_DEPENDS+= ${PREFIX}/mpich/bin/mpicc:${PORTSDIR}/net/mpich
. else
CONFIGURE_ENV+= MPICC=${PREFIX}/mpi/openmpi/bin/mpicc
BUILD_DEPENDS+= ${PREFIX}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
RUN_DEPENDS+= ${PREFIX}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
. endif
PLIST_SUB+= SUFFIX_MPI="_mpi" MPI=""
.else
PLIST_SUB+= SUFFIX_MPI="" MPI="@comment "
.endif
MAN1= anadock.1 \
do_dssp.1 \
editconf.1 \
eneconv.1 \
g_anaeig.1 \
g_analyze.1 \
g_angle.1 \
g_bond.1 \
g_bundle.1 \
g_chi.1 \
g_cluster.1 \
g_clustsize.1 \
g_confrms.1 \
g_covar.1 \
g_current.1 \
g_density.1 \
g_densmap.1 \
g_dielectric.1 \
g_dih.1 \
g_dipoles.1 \
g_disre.1 \
g_dist.1 \
g_dyndom.1 \
g_enemat.1 \
g_energy.1 \
g_filter.1 \
g_gyrate.1 \
g_h2order.1 \
g_hbond.1 \
g_helix.1 \
g_helixorient.1 \
g_kinetics.1 \
g_lie.1 \
g_mdmat.1 \
g_mindist.1 \
g_morph.1 \
g_msd.1 \
g_nmeig.1 \
g_nmens.1 \
g_nmtraj.1 \
g_order.1 \
g_polystat.1 \
g_potential.1 \
g_principal.1 \
g_rama.1 \
g_rdf.1 \
g_rms.1 \
g_rmsdist.1 \
g_rmsf.1 \
g_rotacf.1 \
g_saltbr.1 \
g_sas.1 \
g_sdf.1 \
g_sgangle.1 \
g_sham.1 \
g_sorient.1 \
g_spatial.1 \
g_spol.1 \
g_tcaf.1 \
g_traj.1 \
g_vanhove.1 \
g_velacc.1 \
g_wham.1 \
gen_table.1 \
genbox.1 \
genconf.1 \
genion.1 \
genrestr.1 \
gmxcheck.1 \
gmxdump.1 \
grompp.1 \
highway.1 \
make_edi.1 \
make_ndx.1 \
mdrun.1 \
mk_angndx.1 \
ngmx.1 \
pdb2gmx.1 \
protonate.1 \
sigeps.1 \
tpbconv.1 \
trjcat.1 \
trjconv.1 \
trjorder.1 \
wheel.1 \
x2top.1 \
xpm2ps.1 \
xrama.1
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (gromacs-3.2.1.tar.gz) = d298386495f6ee39b3155ce951984485
SHA256 (gromacs-3.2.1.tar.gz) = de85710553202e17a3ac67049d2cf51117939d3d8944a34aa0909aa3771bef53
SIZE (gromacs-3.2.1.tar.gz) = 3302723
MD5 (gromacs-4.0.3.tar.gz) = 2902403671a0f9b0934ddf3ca586b7ec
SHA256 (gromacs-4.0.3.tar.gz) = 6fc33ac9e1e9b208e2e8c73cb9e95940ed86969207fedc02bf30119f2ed58572
SIZE (gromacs-4.0.3.tar.gz) = 8420556

View File

@ -1,15 +0,0 @@
--- src/contrib/Makefile.in.orig Mon Mar 1 20:49:01 2004
+++ src/contrib/Makefile.in Thu Dec 9 19:54:56 2004
@@ -307,10 +307,10 @@
@AMDEP_TRUE@ ./$(DEPDIR)/sigeps.Po
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
+LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
CCLD = $(CC)
-LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
F77COMPILE = $(F77) $(AM_FFLAGS) $(FFLAGS)
LTF77COMPILE = $(LIBTOOL) --mode=compile $(F77) $(AM_FFLAGS) $(FFLAGS)

View File

@ -1,22 +0,0 @@
--- src/gmxlib/Makefile.in.orig Mon Mar 1 20:49:02 2004
+++ src/gmxlib/Makefile.in Thu Dec 9 00:11:00 2004
@@ -292,16 +292,16 @@
@AMDEP_TRUE@ ./$(DEPDIR)/xtcio.Plo ./$(DEPDIR)/xvgr.Plo
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
+LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
CCLD = $(CC)
-LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
F77COMPILE = $(F77) $(AM_FFLAGS) $(FFLAGS)
LTF77COMPILE = $(LIBTOOL) --mode=compile $(F77) $(AM_FFLAGS) $(FFLAGS)
F77LD = $(F77)
CCASCOMPILE = $(CCAS) $(AM_CCASFLAGS) $(CCASFLAGS)
-LTCCASCOMPILE = $(LIBTOOL) --mode=compile $(CCAS) $(AM_CCASFLAGS) \
+LTCCASCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CCAS) $(AM_CCASFLAGS) \
$(CCASFLAGS)
DIST_SOURCES = $(libgmx@LIBSUFFIX@_la_SOURCES) \
$(EXTRA_libgmx@LIBSUFFIX@_la_SOURCES)

View File

@ -1,15 +0,0 @@
--- src/kernel/Makefile.in.orig Mon Mar 1 20:49:03 2004
+++ src/kernel/Makefile.in Thu Dec 9 00:33:06 2004
@@ -367,10 +367,10 @@
@AMDEP_TRUE@ ./$(DEPDIR)/xutils.Po
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
+LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
CCLD = $(CC)
-LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
DIST_SOURCES = $(ffscan_SOURCES) $(gmxcheck_SOURCES) gmxdump.c \
$(grompp_SOURCES) luck.c $(mdrun_SOURCES) $(pdb2gmx_SOURCES) \

View File

@ -1,15 +0,0 @@
--- src/mdlib/Makefile.in.orig Mon Mar 1 20:49:03 2004
+++ src/mdlib/Makefile.in Thu Dec 9 00:22:03 2004
@@ -233,10 +233,10 @@
@AMDEP_TRUE@ ./$(DEPDIR)/vcm.Plo ./$(DEPDIR)/wnblist.Plo
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
+LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
CCLD = $(CC)
-LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
F77COMPILE = $(F77) $(AM_FFLAGS) $(FFLAGS)
LTF77COMPILE = $(LIBTOOL) --mode=compile $(F77) $(AM_FFLAGS) $(FFLAGS)

View File

@ -1,15 +0,0 @@
--- src/ngmx/Makefile.in.orig Mon Mar 1 20:49:04 2004
+++ src/ngmx/Makefile.in Thu Dec 9 19:53:57 2004
@@ -272,10 +272,10 @@
@AMDEP_TRUE@ ./$(DEPDIR)/xrama.Po ./$(DEPDIR)/xutil.Po
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
+LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
CCLD = $(CC)
-LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
DIST_SOURCES = $(dlg_SOURCES) $(gmxlogo_SOURCES) $(highway_SOURCES) \
$(ngmx_SOURCES) $(scrollw_SOURCES) $(showcol_SOURCES) \

View File

@ -1,15 +0,0 @@
--- src/tools/Makefile.in.orig Mon Mar 1 20:49:06 2004
+++ src/tools/Makefile.in Thu Dec 9 19:35:43 2004
@@ -744,10 +744,10 @@
@AMDEP_TRUE@ ./$(DEPDIR)/xpm2ps.Po
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
+LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
CCLD = $(CC)
-LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
DIST_SOURCES = $(libgmxana@LIBSUFFIX@_la_SOURCES) $(anadock_SOURCES) \
average.c $(cdist_SOURCES) $(disco_SOURCES) do_dssp.c \

View File

@ -3,16 +3,13 @@ bin/GMXRC.bash
bin/GMXRC.csh
bin/GMXRC.zsh
bin/anadock
bin/average
bin/cdist
bin/completion.bash
bin/completion.csh
bin/completion.zsh
bin/disco
bin/demux.pl
bin/do_dssp
bin/editconf
bin/eneconv
bin/ffscan
bin/g_anaeig
bin/g_analyze
bin/g_angle
@ -23,7 +20,9 @@ bin/g_cluster
bin/g_clustsize
bin/g_confrms
bin/g_covar
bin/g_current
bin/g_density
bin/g_densmap
bin/g_dielectric
bin/g_dih
bin/g_dipoles
@ -37,6 +36,8 @@ bin/g_gyrate
bin/g_h2order
bin/g_hbond
bin/g_helix
bin/g_helixorient
bin/g_kinetics
bin/g_lie
bin/g_mdmat
bin/g_mindist
@ -44,8 +45,11 @@ bin/g_morph
bin/g_msd
bin/g_nmeig
bin/g_nmens
bin/g_nmtraj
bin/g_order
bin/g_polystat
bin/g_potential
bin/g_principal
bin/g_rama
bin/g_rdf
bin/g_rms
@ -54,77 +58,88 @@ bin/g_rmsf
bin/g_rotacf
bin/g_saltbr
bin/g_sas
bin/g_sdf
bin/g_sgangle
bin/g_sham
bin/g_sorient
bin/g_spatial
bin/g_spol
bin/g_tcaf
bin/g_traj
bin/g_vanhove
bin/g_velacc
bin/g_wham
bin/genbox
bin/genconf
bin/genion
bin/genpr
bin/genrestr
bin/gmxcheck
bin/gmxdump
bin/grompp
%%WITHOUT_X%%bin/highway
%%X11%%bin/highway
bin/luck
bin/make_edi
bin/make_ndx
bin/mdrun
bin/mk_angndx
%%WITHOUT_X%%bin/ngmx
%%X11%%bin/ngmx
bin/pdb2gmx
bin/protonate
bin/sigeps
bin/tpbconv
bin/trjcat
bin/trjconv
bin/trjorder
bin/wheel
bin/x2top
bin/xplor2gmx.pl
bin/xpm2ps
%%WITHOUT_X%%bin/xrama
%%X11%%bin/xrama
include/gromacs/3dview.h
include/gromacs/assert.h
include/gromacs/atomprop.h
include/gromacs/axp_asm.h
include/gromacs/block_tx.h
include/gromacs/bondf.h
include/gromacs/calcgrid.h
include/gromacs/calch.h
include/gromacs/calcmu.h
include/gromacs/callf77.h
include/gromacs/checkpoint.h
include/gromacs/confio.h
include/gromacs/constr.h
include/gromacs/copyrite.h
include/gromacs/detectcpu.h
include/gromacs/coulomb.h
include/gromacs/dihre.h
include/gromacs/disre.h
include/gromacs/do_fit.h
include/gromacs/do_md.h
include/gromacs/dummies.h
include/gromacs/domdec.h
include/gromacs/domdec_network.h
include/gromacs/ebin.h
include/gromacs/edsam.h
include/gromacs/enxio.h
include/gromacs/ewald.h
include/gromacs/ewald_util.h
include/gromacs/fatal.h
include/gromacs/ffscanf.h
include/gromacs/fftgrid.h
include/gromacs/fftw_wrapper.h
include/gromacs/filenm.h
include/gromacs/force.h
include/gromacs/futil.h
include/gromacs/gbutil.h
include/gromacs/gmx_ana.h
include/gromacs/gmx_arpack.h
include/gromacs/gmx_blas.h
include/gromacs/gmx_cyclecounter.h
include/gromacs/gmx_fatal.h
include/gromacs/gmx_fft.h
include/gromacs/gmx_lapack.h
include/gromacs/gmx_parallel_3dfft.h
include/gromacs/gmx_random.h
include/gromacs/gmx_system_xdr.h
include/gromacs/gmx_thread.h
include/gromacs/gmx_wallcycle.h
include/gromacs/gmxcomplex.h
include/gromacs/gmxfio.h
include/gromacs/gpp_atomtype.h
include/gromacs/gpp_nextnb.h
include/gromacs/grompp.h
include/gromacs/gstat.h
include/gromacs/index.h
include/gromacs/init.h
include/gromacs/invblock.h
include/gromacs/macros.h
include/gromacs/magic.h
@ -134,28 +149,31 @@ include/gromacs/matio.h
include/gromacs/mdatoms.h
include/gromacs/mdebin.h
include/gromacs/mdrun.h
include/gromacs/metacode.h
include/gromacs/mpelogging.h
include/gromacs/mshift.h
include/gromacs/mtop_util.h
include/gromacs/mtxio.h
include/gromacs/mvdata.h
include/gromacs/names.h
include/gromacs/network.h
include/gromacs/nr.h
include/gromacs/nonbonded.h
include/gromacs/nrama.h
include/gromacs/nrjac.h
include/gromacs/nrnb.h
include/gromacs/ns.h
include/gromacs/nsb.h
include/gromacs/nsgrid.h
include/gromacs/orires.h
include/gromacs/partdec.h
include/gromacs/pbc.h
include/gromacs/pdbio.h
include/gromacs/pdebug.h
include/gromacs/perf_est.h
include/gromacs/physics.h
include/gromacs/pme.h
include/gromacs/ppc_altivec.h
include/gromacs/pppm.h
include/gromacs/princ.h
include/gromacs/pull.h
include/gromacs/qmmm.h
include/gromacs/random.h
include/gromacs/rbin.h
include/gromacs/rdgroup.h
@ -163,12 +181,13 @@ include/gromacs/readcomp.h
include/gromacs/readinp.h
include/gromacs/reorder.h
include/gromacs/rmpbc.h
include/gromacs/sheader.h
include/gromacs/shellfc.h
include/gromacs/shift.h
include/gromacs/shift_util.h
include/gromacs/smalloc.h
include/gromacs/sortwater.h
include/gromacs/sparsematrix.h
include/gromacs/split.h
include/gromacs/splitter.h
include/gromacs/statusio.h
include/gromacs/statutil.h
include/gromacs/strdb.h
@ -178,6 +197,7 @@ include/gromacs/symtab.h
include/gromacs/sysstuff.h
include/gromacs/tags.h
include/gromacs/tgroup.h
include/gromacs/topsort.h
include/gromacs/tpxio.h
include/gromacs/transfer.h
include/gromacs/trnio.h
@ -186,7 +206,7 @@ include/gromacs/typedefs.h
include/gromacs/types/atoms.h
include/gromacs/types/block.h
include/gromacs/types/commrec.h
include/gromacs/types/edsams.h
include/gromacs/types/constr.h
include/gromacs/types/energy.h
include/gromacs/types/enums.h
include/gromacs/types/fcdata.h
@ -203,9 +223,11 @@ include/gromacs/types/mdatom.h
include/gromacs/types/nblist.h
include/gromacs/types/nbslist.h
include/gromacs/types/nrnb.h
include/gromacs/types/nsborder.h
include/gromacs/types/ns.h
include/gromacs/types/nsgrid.h
include/gromacs/types/parm.h
include/gromacs/types/pbc.h
include/gromacs/types/qmmmrec.h
include/gromacs/types/shellfc.h
include/gromacs/types/simple.h
include/gromacs/types/state.h
include/gromacs/types/symtab.h
@ -216,34 +238,27 @@ include/gromacs/utils.h
include/gromacs/vcm.h
include/gromacs/vec.h
include/gromacs/viewit.h
include/gromacs/vsite.h
include/gromacs/wgms.h
include/gromacs/wman.h
include/gromacs/writeps.h
include/gromacs/x86_3dnow.h
include/gromacs/x86_sse.h
include/gromacs/x86_sse2.h
include/gromacs/xdrf.h
include/gromacs/xtcio.h
include/gromacs/xvgr.h
lib/libgmx%%SUFFIX_MPI%%%%SUFFIX_D%%.a
lib/libgmx%%SUFFIX_MPI%%%%SUFFIX_D%%.la
lib/libgmx%%SUFFIX_MPI%%%%SUFFIX_D%%.so
lib/libgmx%%SUFFIX_MPI%%%%SUFFIX_D%%.so.3
lib/libgmxana%%SUFFIX_D%%.a
lib/libgmxana%%SUFFIX_D%%.la
lib/libgmxana%%SUFFIX_D%%.so
%%WITHOUT_MPI%%lib/libgmxana%%SUFFIX_D%%.a
%%WITHOUT_MPI%%lib/libgmxana%%SUFFIX_D%%.la
%%WITHOUT_MPI%%lib/libgmxana%%SUFFIX_D%%.so
%%WITHOUT_MPI%%lib/libgmxana%%SUFFIX_D%%.so.3
%%WITH_MPI%%lib/libgmxana%%SUFFIX_MPI%%%%SUFFIX_D%%.a
%%WITH_MPI%%lib/libgmxana%%SUFFIX_MPI%%%%SUFFIX_D%%.la
%%WITH_MPI%%lib/libgmxana%%SUFFIX_MPI%%%%SUFFIX_D%%.so
%%WITH_MPI%%lib/libgmxana%%SUFFIX_MPI%%%%SUFFIX_D%%.so.3
lib/libgmx%%SUFFIX_MPI%%%%SUFFIX_D%%.so.5
%%MPI%%lib/libgmxana%%SUFFIX_D%%.a
%%MPI%%lib/libgmxana%%SUFFIX_D%%.so
lib/libgmxana%%SUFFIX_MPI%%%%SUFFIX_D%%.a
lib/libgmxana%%SUFFIX_MPI%%%%SUFFIX_D%%.la
lib/libgmxana%%SUFFIX_MPI%%%%SUFFIX_D%%.so
lib/libgmxana%%SUFFIX_MPI%%%%SUFFIX_D%%.so.5
lib/libmd%%SUFFIX_MPI%%%%SUFFIX_D%%.a
lib/libmd%%SUFFIX_MPI%%%%SUFFIX_D%%.la
lib/libmd%%SUFFIX_MPI%%%%SUFFIX_D%%.so
lib/libmd%%SUFFIX_MPI%%%%SUFFIX_D%%.so.3
lib/libmd%%SUFFIX_MPI%%%%SUFFIX_D%%.so.5
%%DATADIR%%/html/gmxfaq.html
%%DATADIR%%/html/images/1ctf-0.2.jpg
%%DATADIR%%/html/images/1ctf-0.5.jpg
@ -280,6 +295,7 @@ lib/libmd%%SUFFIX_MPI%%%%SUFFIX_D%%.so.3
%%DATADIR%%/html/images/topologies.gif
%%DATADIR%%/html/images/xvgr.gif
%%DATADIR%%/html/online.html
%%DATADIR%%/html/online/cpt.html
%%DATADIR%%/html/online/dat.html
%%DATADIR%%/html/online/dlg.html
%%DATADIR%%/html/online/do_dssp.html
@ -304,6 +320,7 @@ lib/libmd%%SUFFIX_MPI%%%%SUFFIX_D%%.so.3
%%DATADIR%%/html/online/g_confrms.html
%%DATADIR%%/html/online/g_covar.html
%%DATADIR%%/html/online/g_density.html
%%DATADIR%%/html/online/g_densmap.html
%%DATADIR%%/html/online/g_dielectric.html
%%DATADIR%%/html/online/g_dih.html
%%DATADIR%%/html/online/g_dipoles.html
@ -334,6 +351,7 @@ lib/libmd%%SUFFIX_MPI%%%%SUFFIX_D%%.so.3
%%DATADIR%%/html/online/g_saltbr.html
%%DATADIR%%/html/online/g_sas.html
%%DATADIR%%/html/online/g_sgangle.html
%%DATADIR%%/html/online/g_sham.html
%%DATADIR%%/html/online/g_sorient.html
%%DATADIR%%/html/online/g_tcaf.html
%%DATADIR%%/html/online/g_traj.html
@ -355,6 +373,7 @@ lib/libmd%%SUFFIX_MPI%%%%SUFFIX_D%%.so.3
%%DATADIR%%/html/online/itp.html
%%DATADIR%%/html/online/log.html
%%DATADIR%%/html/online/m2p.html
%%DATADIR%%/html/online/make_edi.html
%%DATADIR%%/html/online/make_ndx.html
%%DATADIR%%/html/online/map.html
%%DATADIR%%/html/online/mdp.html
@ -419,7 +438,10 @@ lib/libmd%%SUFFIX_MPI%%%%SUFFIX_D%%.so.3
%%DATADIR%%/top/dmso.gro
%%DATADIR%%/top/dmso.itp
%%DATADIR%%/top/edissoc.dat
%%DATADIR%%/top/electroneg.dat
%%DATADIR%%/top/elements.dat
%%DATADIR%%/top/export.dlg
%%DATADIR%%/top/f3c.itp
%%DATADIR%%/top/fa.itp
%%DATADIR%%/top/ffG43a1-c.tdb
%%DATADIR%%/top/ffG43a1-n.tdb
@ -439,23 +461,57 @@ lib/libmd%%SUFFIX_MPI%%%%SUFFIX_D%%.so.3
%%DATADIR%%/top/ffG43a2.rtp
%%DATADIR%%/top/ffG43a2bon.itp
%%DATADIR%%/top/ffG43a2nb.itp
%%DATADIR%%/top/ffG43b1-c.tdb
%%DATADIR%%/top/ffG43b1-n.tdb
%%DATADIR%%/top/ffG43b1.atp
%%DATADIR%%/top/ffG43b1.ddb
%%DATADIR%%/top/ffG43b1.hdb
%%DATADIR%%/top/ffG43b1.itp
%%DATADIR%%/top/ffG43b1.rtp
%%DATADIR%%/top/ffG43b1bon.itp
%%DATADIR%%/top/ffG43b1nb.itp
%%DATADIR%%/top/ffG45a3-c.tdb
%%DATADIR%%/top/ffG45a3-n.tdb
%%DATADIR%%/top/ffG45a3.atp
%%DATADIR%%/top/ffG45a3.ddb
%%DATADIR%%/top/ffG45a3.hdb
%%DATADIR%%/top/ffG45a3.itp
%%DATADIR%%/top/ffG45a3.rtp
%%DATADIR%%/top/ffG45a3bon.itp
%%DATADIR%%/top/ffG45a3nb.itp
%%DATADIR%%/top/ffG53a5-c.tdb
%%DATADIR%%/top/ffG53a5-n.tdb
%%DATADIR%%/top/ffG53a5.atp
%%DATADIR%%/top/ffG53a5.ddb
%%DATADIR%%/top/ffG53a5.hdb
%%DATADIR%%/top/ffG53a5.itp
%%DATADIR%%/top/ffG53a5.n2t
%%DATADIR%%/top/ffG53a5.rtp
%%DATADIR%%/top/ffG53a5bon.itp
%%DATADIR%%/top/ffG53a5nb.itp
%%DATADIR%%/top/ffG53a6-c.tdb
%%DATADIR%%/top/ffG53a6-n.tdb
%%DATADIR%%/top/ffG53a6.atp
%%DATADIR%%/top/ffG53a6.ddb
%%DATADIR%%/top/ffG53a6.hdb
%%DATADIR%%/top/ffG53a6.itp
%%DATADIR%%/top/ffG53a6.rtp
%%DATADIR%%/top/ffG53a6bon.itp
%%DATADIR%%/top/ffG53a6nb.itp
%%DATADIR%%/top/ff_dum.itp
%%DATADIR%%/top/ffencads-c.tdb
%%DATADIR%%/top/ffencads-n.tdb
%%DATADIR%%/top/ffencads.atp
%%DATADIR%%/top/ffencads.hdb
%%DATADIR%%/top/ffencads.itp
%%DATADIR%%/top/ffencads.rtp
%%DATADIR%%/top/ffencadsbon.itp
%%DATADIR%%/top/ffencadsnb.itp
%%DATADIR%%/top/ffencadv-c.tdb
%%DATADIR%%/top/ffencadv-n.tdb
%%DATADIR%%/top/ffencadv.atp
%%DATADIR%%/top/ffencadv.hdb
%%DATADIR%%/top/ffencadv.itp
%%DATADIR%%/top/ffencadv.rtp
%%DATADIR%%/top/ffencadvbon.itp
%%DATADIR%%/top/ffencadvnb.itp
%%DATADIR%%/top/ffgmx-c.tdb
%%DATADIR%%/top/ffgmx-n.tdb
%%DATADIR%%/top/ffgmx.atp
%%DATADIR%%/top/ffgmx.ddb
%%DATADIR%%/top/ffgmx.hdb
%%DATADIR%%/top/ffgmx.itp
%%DATADIR%%/top/ffgmx.n2t
%%DATADIR%%/top/ffgmx.rtp
%%DATADIR%%/top/ffgmx2-c.tdb
%%DATADIR%%/top/ffgmx2-n.tdb
@ -474,6 +530,7 @@ lib/libmd%%SUFFIX_MPI%%%%SUFFIX_D%%.so.3
%%DATADIR%%/top/ffoplsaa.ddb
%%DATADIR%%/top/ffoplsaa.hdb
%%DATADIR%%/top/ffoplsaa.itp
%%DATADIR%%/top/ffoplsaa.n2t
%%DATADIR%%/top/ffoplsaa.rtp
%%DATADIR%%/top/ffoplsaabon.itp
%%DATADIR%%/top/ffoplsaanb.itp
@ -486,6 +543,7 @@ lib/libmd%%SUFFIX_MPI%%%%SUFFIX_D%%.so.3
%%DATADIR%%/top/h2p8o25.itp
%%DATADIR%%/top/h2po4.itp
%%DATADIR%%/top/ha-shift.dat
%%DATADIR%%/top/highway.dat
%%DATADIR%%/top/ions.itp
%%DATADIR%%/top/links.dat
%%DATADIR%%/top/methanol.itp
@ -515,7 +573,6 @@ lib/libmd%%SUFFIX_MPI%%%%SUFFIX_D%%.so.3
%%DATADIR%%/top/urea.itp
%%DATADIR%%/top/vdwradii.dat
%%DATADIR%%/top/xlateat.dat
%%DATADIR%%/tutor/cleanit
%%DATADIR%%/tutor/gmxdemo/cpeptide.pdb
%%DATADIR%%/tutor/gmxdemo/demo
%%DATADIR%%/tutor/methanol/conf.gro