- Fix build with clang

- Support PLIST_FILES

PR:		179226
Submitted by:	ports fury
This commit is contained in:
Martin Wilke 2013-06-04 10:04:47 +00:00
parent 92f330d019
commit 47b14d783b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=319849
34 changed files with 358 additions and 26 deletions

View File

@ -13,9 +13,19 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Petri-Net Simulator for Xwindows
NO_WRKSUBDIR= yes
USE_XORG= x11 xaw
MAKEFILE= makefile
ALL_TARGET= pns
MAKE_JOBS_SAFE= yes
PORTDOCS= *
PLIST_FILES= bin/xpns \
libexec/xpns/pns \
%%DATADIR%%/pns.hlp \
%%DATADIR%%/pns.shell
PLIST_DIRS= %%DATADIR%% \
libexec/xpns
.include <bsd.port.options.mk>
@ -23,15 +33,14 @@ post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/xpns
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/xpns ${PREFIX}/bin/xpns
${MKDIR} ${PREFIX}/libexec/xpns
${INSTALL_PROGRAM} ${WRKSRC}/pns ${PREFIX}/libexec/xpns
${MKDIR} ${PREFIX}/share/xpns
${INSTALL_DATA} ${WRKSRC}/pns.hlp ${PREFIX}/share/xpns
${INSTALL_DATA} ${WRKSRC}/pns.shell ${PREFIX}/share/xpns
(cd ${WRKSRC} && ${INSTALL_SCRIPT} xpns ${PREFIX}/bin)
@${MKDIR} ${PREFIX}/libexec/xpns
(cd ${WRKSRC} && ${INSTALL_PROGRAM} pns ${PREFIX}/libexec/xpns)
@${MKDIR} ${DATADIR}
(cd ${WRKSRC} && ${INSTALL_DATA} pns.hlp pns.shell ${DATADIR})
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${PREFIX}/share/doc/xpns
${INSTALL_DATA} ${WRKSRC}/*.net ${PREFIX}/share/doc/xpns
@${MKDIR} ${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} *.net ${DOCSDIR})
.endif
.include <bsd.port.mk>

View File

@ -1,12 +1,13 @@
--- xpns.orig Tue Apr 8 11:27:14 1997
+++ xpns Tue Apr 8 11:29:05 1997
@@ -1,6 +1,7 @@
@@ -1,6 +1,8 @@
-#!/bin/tcsh
-setenv XAPPLRESDIR $PWD/
-pns
+#!/bin/csh
+setenv XAPPLRESDIR %%PREFIX%%/share/xpns/
+#!/bin/sh
+# Note pns will dump core if environment is not correct
+XAPPLRESDIR=%%PREFIX%%/share/xpns/
+export XAPPLRESDIR
+%%PREFIX%%/libexec/xpns/pns

View File

@ -0,0 +1,10 @@
--- celldel.c.orig
+++ celldel.c
@@ -17,6 +17,7 @@
#include "cellrefr.h"
#include <stdio.h>
+#include <stdlib.h>
#define CellOListToRList( v) do { \

View File

@ -0,0 +1,10 @@
--- cellein.c.orig
+++ cellein.c
@@ -14,6 +14,7 @@
#include "celltype.h"
#include <stdio.h>
+#include <stdlib.h>
/*************************************************************************

View File

@ -0,0 +1,10 @@
--- cellget.c.orig
+++ cellget.c
@@ -16,6 +16,7 @@
#include <stdio.h>
+#include <stdlib.h>
static OBJECT *pSte, *pTra, *pK;

View File

@ -0,0 +1,10 @@
--- cellkaio.c.orig
+++ cellkaio.c
@@ -21,6 +21,7 @@
#include <stdio.h>
+#include <stdlib.h>

View File

@ -0,0 +1,10 @@
--- cellkalook.c.orig
+++ cellkalook.c
@@ -16,6 +16,7 @@
#include <stdio.h>
+#include <stdlib.h>

View File

@ -0,0 +1,11 @@
--- cellmisc.c.orig
+++ cellmisc.c
@@ -14,6 +14,8 @@
#include "cell.h"
#include "misc.h"
+#include <stdlib.h>
+

View File

@ -0,0 +1,11 @@
--- cellorg.c.orig
+++ cellorg.c
@@ -16,6 +16,8 @@
#include "tra.h"
#include "ka.h"
+#include <stdlib.h>
+

View File

@ -0,0 +1,10 @@
--- cellrefr.c.orig
+++ cellrefr.c
@@ -15,6 +15,7 @@
#include <stdio.h>
+#include <stdlib.h>
/*************************************************************************

View File

@ -0,0 +1,11 @@
--- diwinpop.c.orig
+++ diwinpop.c
@@ -27,6 +27,8 @@
#include "hawin.h"
#include "haka.H"
+#include <unistd.h>
+
/*************************************************************************
** FUNKTION: DiWinPopdown
** ZWECK: schliesst und zerstoert Widget

View File

@ -0,0 +1,10 @@
--- filekaio.c.orig
+++ filekaio.c
@@ -19,6 +19,7 @@
#include <string.h>
#include <stdio.h>
+#include <stdlib.h>

View File

@ -0,0 +1,10 @@
--- filesteio.c.orig
+++ filesteio.c
@@ -18,6 +18,7 @@
#include <string.h>
#include <stdio.h>
+#include <stdlib.h>

View File

@ -0,0 +1,10 @@
--- filetraio.c.orig
+++ filetraio.c
@@ -17,6 +17,7 @@
#include <string.h>
#include <stdio.h>
+#include <stdlib.h>

View File

@ -0,0 +1,11 @@
--- habreakmisc.c.orig
+++ habreakmisc.c
@@ -52,7 +52,7 @@ void HaBreakInit()
** RETURN:
** ANMERK:
*************************************************************************/
-static HaBreakMark( MarkOn)
+static void HaBreakMark( MarkOn)
BOOLEAN MarkOn;
{
OBJECT *e;

View File

@ -0,0 +1,11 @@
--- hadatmisc.c.orig
+++ hadatmisc.c
@@ -14,6 +14,8 @@
#include "hawin.h"
#include "diwin.h"
+#include <stdlib.h>
+
/*************************************************************************

View File

@ -0,0 +1,10 @@
--- hadelmisc.c.orig
+++ hadelmisc.c
@@ -22,6 +22,7 @@
#include "cellget.h"
#include <stdio.h>
+#include <stdlib.h>
/*************************************************************************

View File

@ -0,0 +1,11 @@
--- hakadelta.c.orig
+++ hakadelta.c
@@ -17,6 +17,8 @@
#include "colors"
#include "cellname.h"
+#include <stdio.h>
+
#define DeDrawX( t, p, gc) XDrawImageString( MyDisplay, HaGraphPixmap, \

View File

@ -0,0 +1,11 @@
--- hakamisc.c.orig
+++ hakamisc.c
@@ -19,6 +19,8 @@
#include "hagraph.h"
#include "colors"
+#include <stdlib.h>
+
/*************************************************************************
** FUNKTION: HaKaInit
*************************************************************************/

View File

@ -0,0 +1,11 @@
--- hakasete.c.orig
+++ hakasete.c
@@ -18,6 +18,8 @@
#include "celltype.h"
#include "katype.h"
+#include <stdlib.h>
+

View File

@ -0,0 +1,11 @@
--- halook.c.orig
+++ halook.c
@@ -18,7 +18,7 @@
#include "stewin.h"
#include <stdio.h>
-
+#include <stdlib.h>

View File

@ -0,0 +1,10 @@
--- harefreshx.c.orig
+++ harefreshx.c
@@ -25,6 +25,7 @@
#include "hastename.h"
#include <stdio.h>
+#include <stdlib.h>
#ifdef HALLO

View File

@ -0,0 +1,11 @@
--- hastemarke.c.orig
+++ hastemarke.c
@@ -17,6 +17,8 @@
#include "hagraph.h"
#include "misc.h"
+#include <stdlib.h>
+
#define yDISP 5

View File

@ -0,0 +1,10 @@
--- hi.c.orig
+++ hi.c
@@ -22,6 +22,7 @@
#include <X11/Xaw/Viewport.h>
#include <X11/Xaw/Paned.h>
#include <stdio.h>
+#include <stdlib.h>
Widget HiCom;
Widget HiShell;

View File

@ -0,0 +1,11 @@
--- kaio.c.orig
+++ kaio.c
@@ -17,6 +17,8 @@
#include "ste.h"
#include "tra.h"
+#include <stdlib.h>
+
/*************************************************************************

View File

@ -0,0 +1,10 @@
--- kawinpop.c.orig
+++ kawinpop.c
@@ -12,6 +12,7 @@
*************************************************************************/
#include "kawin.H"
#include <stdio.h>
+#include <stdlib.h>

View File

@ -0,0 +1,11 @@
--- pns.c.orig
+++ pns.c
@@ -39,7 +39,7 @@
extern Widget HaKonBox;
extern Widget HaKonMenuLabel;
-main( argc, argv)
+int main( argc, argv)
int argc;
char **argv;
{

View File

@ -0,0 +1,11 @@
--- scandir.c.orig
+++ scandir.c
@@ -12,6 +12,8 @@
**
*************************************************************************/
#include <stdio.h>
+#include <ctype.h>
+#include <stdlib.h>
#include "dir.H"
#include "misc.h"

View File

@ -0,0 +1,11 @@
--- setpath.c.orig
+++ setpath.c
@@ -15,6 +15,8 @@
#include "dir.H"
#include "misc.h"
+#include <string.h>
+
BOOLEAN SetPath( DirInh, Pfad)
DIRECTORY *DirInh;

View File

@ -0,0 +1,11 @@
--- simbreak.c.orig
+++ simbreak.c
@@ -15,6 +15,8 @@
#include "celltype.h"
#include "misc.h"
+#include <stdlib.h>
+
/*************************************************************************
** FUNKTION: SimBreakInit

View File

@ -0,0 +1,22 @@
--- simget.c.orig
+++ simget.c
@@ -19,8 +19,9 @@
#include <stdio.h>
-
-#define RAND_MAX ((1<<31)-1)
+#ifndef RAND_MAX
+#define RAND_MAX ((1UL<<31)-1)
+#endif
/*************************************************************************
@@ -32,6 +33,7 @@ void SimGetInit()
unsigned int e;
srand( 17);
+ srandom( 17);
}

View File

@ -0,0 +1,10 @@
--- steio.c.orig
+++ steio.c
@@ -15,6 +15,7 @@
#include "celltype.h"
#include "netsize.h"
#include <stdio.h>
+#include <stdlib.h>
#define DEFAULT_STEN_X_DISP -HA_STE_RAD

View File

@ -0,0 +1,10 @@
--- traio.c.orig
+++ traio.c
@@ -15,6 +15,7 @@
#include "celltype.h"
#include "netsize.h"
#include <stdio.h>
+#include <stdlib.h>
#define DEFAULT_TRAN_X_DISP -HA_STE_RAD

View File

@ -1,15 +0,0 @@
bin/xpns
libexec/xpns/pns
share/xpns/pns.hlp
share/xpns/pns.shell
%%PORTDOCS%%share/doc/xpns/a.net
%%PORTDOCS%%share/doc/xpns/a1.net
%%PORTDOCS%%share/doc/xpns/add.net
%%PORTDOCS%%share/doc/xpns/mult.net
%%PORTDOCS%%share/doc/xpns/phil.net
%%PORTDOCS%%share/doc/xpns/rw.net
%%PORTDOCS%%share/doc/xpns/sub.net
%%PORTDOCS%%share/doc/xpns/sub2.net
@dirrm share/xpns
%%PORTDOCS%%@dirrm share/doc/xpns
@dirrm libexec/xpns