Update to 2.14.2.

This commit is contained in:
Jeremy Messenger 2007-12-11 23:09:50 +00:00
parent 7a9eeddf52
commit 476e65ebd2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=203074
4 changed files with 5 additions and 40 deletions

View File

@ -3,11 +3,11 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
# $MCom: ports/devel/glibmm/Makefile,v 1.48 2007/10/06 21:15:01 mezz Exp $
# $MCom: ports-stable/devel/glibmm/Makefile,v 1.3 2007/12/02 00:19:26 mezz Exp $
#
PORTNAME= glibmm
PORTVERSION= 2.14.1
PORTVERSION= 2.14.2
PORTREVISION?= 0
PORTEPOCH= 1
CATEGORIES= devel

View File

@ -1,3 +1,3 @@
MD5 (gnome2/glibmm-2.14.1.tar.bz2) = b75877e454afa956a1e86a89ab1fa9b0
SHA256 (gnome2/glibmm-2.14.1.tar.bz2) = 963b47b530a0cead2148295d8929b957db53578ca80dee362d1dbd675ea1b2d5
SIZE (gnome2/glibmm-2.14.1.tar.bz2) = 9273164
MD5 (gnome2/glibmm-2.14.2.tar.bz2) = 58b4fdc97738795a19b1f5ad37f186b4
SHA256 (gnome2/glibmm-2.14.2.tar.bz2) = 7602068e8ea8e705c3970b5f2f524c7335db4ee0ca630a424690bc4951544851
SIZE (gnome2/glibmm-2.14.2.tar.bz2) = 9268918

View File

@ -1,17 +0,0 @@
--- glib/glibmm/date.cc.orig Sun May 6 00:19:51 2007
+++ glib/glibmm/date.cc Sun May 6 00:21:36 2007
@@ -72,12 +72,14 @@ void Date::set_parse(const Glib::ustring
}
#ifndef GLIBMM_DISABLE_DEPRECATED
+#if GLIB_SIZEOF_LONG != 4 && !defined(__alpha__)
void Date::set_time(GTime time)
{
//This method, and the C function that it wraps, are deprecated.
g_date_set_time(&gobject_, time);
}
+#endif
#endif // GLIBMM_DISABLE_DEPRECATED

View File

@ -1,18 +0,0 @@
--- glib/glibmm/date.h.orig Sun May 6 00:22:03 2007
+++ glib/glibmm/date.h Sun May 6 00:22:31 2007
@@ -120,6 +120,7 @@ enum DMY
void set_parse (const Glib::ustring& str);
#ifndef GLIBMM_DISABLE_DEPRECATED
+#if GLIB_SIZEOF_LONG != 4 && !defined(__alpha__)
/** Sets the value of a date from a GTime (time_t) value.
*
@@ -128,6 +129,7 @@ enum DMY
* @deprecated Please use set_time(time_t) or set_time(const GTimeVal&).
*/
void set_time(GTime time);
+#endif
#endif // GLIBMM_DISABLE_DEPRECATED