MFH: r526357 devel/py-Faker: Add missing dependencies

None of the packages upstream specified dependencies were declared in the
port. This change adds those missing dependencies.

The issue was identified while QA'ing www/py-freenit via bug 242817

File "/usr/local/lib/python3.7/site-packages/faker/providers/internet/__init__.py", line 4, in <module>
    from text_unidecode import unidecode
ModuleNotFoundError: No module named 'text_unidecode'

While I'm here, level up ports (and Python ports) compliance and add test
target.

Approved by:	portmgr (blanket(s): missing dependencies, ports (Python) compliance)

Approved by:	ports-secteam (blanket(s): missing dependencies, ports (Python) compliance)
This commit is contained in:
Kubilay Kocak 2020-02-17 10:46:22 +00:00
parent 4e3fe60565
commit 475716846e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q1/; revision=526360
3 changed files with 30 additions and 3 deletions

View File

@ -3,17 +3,30 @@
PORTNAME= Faker
PORTVERSION= 0.8.15
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= alfred@FreeBSD.org
COMMENT= Generate fake data using python
COMMENT= Python package that generates fake data for you
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=2.4:devel/py-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.10:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}text-unidecode>=1.2:converters/py-text-unidecode@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
USES= python
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes
do-test:
${RM} ${WRKSRC}/tests/providers/test_address.py # Needs ukpostcodeparser.parser port
${RM} ${WRKSRC}/tests/providers/test_internet.py # Needs email_validator port
cd ${WRKSRC} && ${PYTHON_CMD} -m unittest discover -v
.include <bsd.port.mk>

View File

@ -0,0 +1,14 @@
# == (pinned) dependencies are extremely brittle
# for FreeBSD ports. Get upstream to fix (>=) these
--- setup.py.orig 2020-02-17 09:58:01 UTC
+++ setup.py
@@ -63,7 +63,7 @@ setup(
install_requires=[
"python-dateutil>=2.4",
"six>=1.10",
- "text-unidecode==1.2",
+ "text-unidecode>=1.2",
],
tests_require=[
"email_validator>=1.0.0,<1.1.0",

View File

@ -6,4 +6,4 @@ data taken from a production service, Faker is for you.
Faker is heavily inspired by PHP's [Faker][php-faker], Perl's
[Data::Faker][perl-faker], and by ruby's [Faker][ruby-faker].
WWW: https://pypi.org/project/Faker/
WWW: https://github.com/joke2k/faker