- Add python22 as an alternative version.

- Correct pydoc search path to lang/python-doc-html port's [1]

PR:		43036 [1]
Submitted by:	Emil Sit <sit@amsterdam.lcs.mit.edu> [1]
This commit is contained in:
Hye-Shik Chang 2003-07-31 19:38:54 +00:00
parent d6fb067853
commit 4749ae321d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=86070
4 changed files with 26 additions and 13 deletions

View File

@ -177,6 +177,7 @@
SUBDIR += python15
SUBDIR += python20
SUBDIR += python21
SUBDIR += python22
SUBDIR += qscheme
SUBDIR += ratfor
SUBDIR += rexx-imc

View File

@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.2.3
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@ -21,12 +21,13 @@ WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
INSTALL_TARGET= install
MAN1= python.1
INSTALL_TARGET= altinstall
MAN1= ${PYTHON_VERSION}.1
USE_PYTHON= yes
PYTHON_VERSION= python2.2
PYTHON_NO_DEPENDS= yes
USE_REINPLACE= yes
#
# If you don't want to use Python's thread module, you need to set
@ -81,6 +82,11 @@ PLATFORMS=plat-freebsd2 plat-freebsd4 plat-freebsd5
PLATFORMS=plat-freebsd3 plat-freebsd4 plat-freebsd5
.endif
post-patch:
${REINPLACE_CMD} -e \
's,/usr/doc/python-docs-,${PREFIX}/share/doc/python,g' \
${WRKSRC}/Lib/pydoc.py
pre-install:
.for platform in ${PLATFORMS}
${MKDIR} ${PYTHONPREFIX_LIBDIR}/${platform}
@ -96,9 +102,9 @@ post-extract:
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.2 ${PREFIX}/bin/
${INSTALL_DATA} ${WRKSRC}/Misc/python-mode.el \
${PREFIX}/share/emacs/site-lisp
@${MKDIR} ${PYTHONPREFIX_SITELIBDIR}
@${MKDIR} ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/Misc/python.man \
${MANPREFIX}/man/man1/${PYTHON_VERSION}.1
.if !defined(NOPORTDOCS)
@cd ${WRKSRC}; tar -c --exclude='*CVS*' -f - Tools | \
(cd ${PYTHONPREFIX_LIBDIR}; tar xf -)

View File

@ -1,7 +1,7 @@
--- setup.py.orig Fri Mar 2 07:24:14 2001
+++ setup.py Mon Mar 5 15:26:17 2001
@@ -14,7 +14,7 @@
from distutils.command.build_ext import build_ext
--- setup.py.orig Fri May 23 02:36:54 2003
+++ setup.py Fri Aug 1 03:23:45 2003
@@ -12,7 +12,7 @@
from distutils.command.install import install
# This global variable is used to hold the list of modules to be disabled.
-disabled_module_list = []
@ -9,3 +9,12 @@
def find_file(filename, std_dirs, paths):
"""Searches for the directory where a given file is located,
@@ -808,7 +808,7 @@
ext_modules=[Extension('struct', ['structmodule.c'])],
# Scripts to install
- scripts = ['Tools/scripts/pydoc']
+ scripts = []
)
# --install-platlib

View File

@ -1,6 +1,4 @@
bin/pydoc
bin/pydoc2.2
bin/python
bin/%%PYTHON_VERSION%%
include/%%PYTHON_VERSION%%/Python.h
include/%%PYTHON_VERSION%%/abstract.h
@ -2299,7 +2297,6 @@ lib/%%PYTHON_VERSION%%/xmlrpclib.pyo
lib/%%PYTHON_VERSION%%/zipfile.py
lib/%%PYTHON_VERSION%%/zipfile.pyc
lib/%%PYTHON_VERSION%%/zipfile.pyo
share/emacs/site-lisp/python-mode.el
%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/README
%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/classes/Complex.py
%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/classes/Dates.py