Add modlogan, a modular log file analysis program.

Submitted by:	Alexander Leidinger <Alexander@Leidinger.net>
This commit is contained in:
Anton Berezin 2001-09-22 23:26:36 +00:00
parent 2284070020
commit 472deb4dca
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=48096
9 changed files with 237 additions and 0 deletions

View File

@ -86,6 +86,7 @@
SUBDIR += mguesser
SUBDIR += minidom
SUBDIR += mkcatalog
SUBDIR += modlogan
SUBDIR += mswordview
SUBDIR += nfbtrans
SUBDIR += nicetext

View File

@ -0,0 +1,74 @@
# New ports collection makefile for: modlogan
# Date created: 06.Sep.2000
# Whom: Alexander@Leidinger.net
#
# $FreeBSD$
#
PORTNAME= modlogan
PORTVERSION= 0.7.2
CATEGORIES= textproc www
MASTER_SITES= http://www.kneschke.de/projekte/modlogan/download/ \
${MASTER_SITE_SOURCEFORGE}
MAINTAINER= Alexander@Leidinger.net
LIB_DEPENDS= adns.1:${PORTSDIR}/net/adns \
gd.2:${PORTSDIR}/graphics/gd \
intl.1:${PORTSDIR}/devel/gettext \
pcre.0:${PORTSDIR}/devel/pcre \
xml2.5:${PORTSDIR}/textproc/libxml2 \
ltdl.1:${PORTSDIR}/devel/libtool
.if defined(WITH_MYSQL)
# To quote the author:
# It is used by src/processor/telecom/... for a commercial project. The
# project itself is opensource but not documented.
# Therefore no testing if it works is made in the FreeBSD port.
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
.endif
# Please don't remove the comments, as soon as autoconf/libtool get's
# updated in the ports collection the comments may be removed.
# They serve as a reminder.
#USE_AUTOCONF= yes
#USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
#LIBTOOLFLAGS= --disable-ltlibs --release-suffix
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-ltdl-install=no --with-gd=${LOCALBASE}/include
.if defined(WITH_MYSQL)
CONFIGURE_ARGS+=--with-mysql
.endif
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
MAN1= modlogan.1
DOC1= faq.txt glosar manual.txt plugin-options.txt \
using-plugins.txt writing-plugins.txt
post-patch:
@${PERL} -pi -e 's:\@sysconfdir\@:${PREFIX}/etc/modlogan:g' ${WRKSRC}/doc/modlogan.conf-dist
post-configure:
${TOUCH} ${WRKSRC}/libltdl/config.status
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/modlogan
.for i in ${DOC1}
@${INSTALL_DATA} ${WRKSRC}/doc/${i} ${PREFIX}/share/doc/modlogan/${i}
.endfor
.endif
${MKDIR} ${PREFIX}/share/examples/modlogan
.for i in footer.ihtml header.ihtml convert_to_055.pl convert_to_060.pl
@${INSTALL_DATA} ${WRKSRC}/doc/${i} ${PREFIX}/share/examples/modlogan/${i}
.endfor
@# remove .la (can't use USE_LIBTOOL)
-${RM} ${PREFIX}/lib/libmla_*.la
${MV} ${PREFIX}/bin/${MACHINE_ARCH}--freebsd${OSREL}-modlogan ${PREFIX}/bin/modlogan
${MV} ${PREFIX}/man/man1/${MACHINE_ARCH}--freebsd${OSREL}-modlogan.1 ${PREFIX}/man/man1/modlogan.1
.for i in css conf def.conf
[ -f ${PREFIX}/etc/modlogan/modlogan.${i} ] || ${INSTALL_DATA} ${PREFIX}/etc/modlogan/modlogan.${i}-dist ${PREFIX}/etc/modlogan/modlogan.${i}
.endfor
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (modlogan-0.7.2.tar.gz) = 6e40dac4df582439f40e4431b2848338

View File

@ -0,0 +1,12 @@
--- aclocal.m4_bak Tue Dec 26 12:57:08 2000
+++ aclocal.m4 Tue Dec 26 12:57:22 2000
@@ -672,6 +672,9 @@
INSTOBJEXT=.mo
fi
fi
+ if test "$gt_cv_func_gettext_libintl" = "yes"; then
+ INTLLIBS='-lintl'
+ fi
])
if test "$CATOBJEXT" = "NONE"; then

View File

@ -0,0 +1,40 @@
--- configure.orig Wed Sep 5 16:56:33 2001
+++ configure Thu Sep 6 14:00:42 2001
@@ -260,7 +260,6 @@
: ${ac_max_here_lines=38}
ac_unique_file="src/main.c"
-ac_subdirs_all="$ac_subdirs_all libltdl"
# Factoring default headers for most tests.
ac_includes_default="\
#include <stdio.h>
@@ -7610,6 +7609,9 @@
# PORTME does your system automatically load deplibs for dlopen()?
libltdl_cv_sys_dlopen_deplibs=unknown
case "$host_os" in
+ freebsd*)
+ libltdl_cv_sys_dlopen_deplibs=yes
+ ;;
linux*)
libltdl_cv_sys_dlopen_deplibs=yes
;;
@@ -11850,7 +11852,7 @@
CFLAGS="${ac_save_CFLAGS}" # don't use CFLAGS from libtool
-subdirs="$subdirs libltdl"
+subdirs="$subdirs"
echo "$as_me:11855: checking for dmalloc.h" >&5
echo $ECHO_N "checking for dmalloc.h... $ECHO_C" >&6
@@ -14476,7 +14478,9 @@
if test "$gt_cv_func_gettext_libintl" = "yes"; then
INTLLIBS='-lintl'
fi
-
+ if test "$gt_cv_func_gettext_libintl" = "yes"; then
+ INTLLIBS='-lintl'
+ fi
fi
if test "$CATOBJEXT" = "NONE"; then

View File

@ -0,0 +1,11 @@
--- libltdl/Makefile.in.orig Sat Sep 15 19:24:49 2001
+++ libltdl/Makefile.in Sun Sep 16 11:27:00 2001
@@ -83,7 +83,7 @@
AUTOMAKE_OPTIONS = no-dependencies foreign
-mkinstalldirs = $(SHELL) $(top_srcdir)/../mkinstalldirs
+mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
@INSTALL_LTDL_TRUE@include_HEADERS = ltdl.h
@INSTALL_LTDL_TRUE@lib_LTLIBRARIES = libltdl.la

View File

@ -0,0 +1 @@
A modular log file analysis program

View File

@ -0,0 +1,11 @@
Modlogan is for all those who want a log-analyzer that is easy
to extend and very flexible. Just write a new output plugin and
create your very special report-design. You don't have to
reinvent to whole wheel to change the colour of the tire.
Imagine a SQL-output-plugin that writes the calculated data
into your database. Or a Memo generator that posts the
monthly stats to your department mailing list for further
investigation.
WWW: http://www.kneschke.de/projekte/modlogan/

View File

@ -0,0 +1,86 @@
bin/modlogan
etc/modlogan/group.extension.conf
etc/modlogan/group.host.conf
etc/modlogan/group.os.conf
etc/modlogan/group.ua.conf
etc/modlogan/match.os.conf
etc/modlogan/match.searchengines.conf
etc/modlogan/match.ua.conf
@unexec if cmp -s %D/etc/modlogan/modlogan.conf %D/etc/modlogan/modlogan.conf-dist; then rm -f %D/etc/modlogan/modlogan.conf; fi
etc/modlogan/modlogan.conf-dist
@unexec if cmp -s %D/etc/modlogan/modlogan.css %D/etc/modlogan/modlogan.css-dist; then rm -f %D/etc/modlogan/modlogan.css; fi
etc/modlogan/modlogan.css-dist
@unexec if cmp -s %D/etc/modlogan/modlogan.def.conf %D/etc/modlogan/modlogan.def.conf-dist; then rm -f %D/etc/modlogan/modlogan.def.conf; fi
etc/modlogan/modlogan.def.conf-dist
@dirrm etc/modlogan
lib/libmla_input_bsdftpd.so
lib/libmla_input_clf.so
lib/libmla_input_elmeg.so
lib/libmla_input_flow.so
lib/libmla_input_flowraw.so
lib/libmla_input_hicom116.so
lib/libmla_input_ipchains.so
lib/libmla_input_isdnlog.so
lib/libmla_input_msiis.so
lib/libmla_input_msmedia.so
lib/libmla_input_netscape.so
lib/libmla_input_null.so
lib/libmla_input_pureftpd.so
lib/libmla_input_qmail.so
lib/libmla_input_qtss.so
lib/libmla_input_realserver.so
lib/libmla_input_sendmail.so
lib/libmla_input_shoutcast.so
lib/libmla_input_squid.so
lib/libmla_input_viruswall.so
lib/libmla_input_wuftpd.so
lib/libmla_mdata_brokenlink.so
lib/libmla_mdata_count.so
lib/libmla_mdata_match.so
lib/libmla_mdata_netmask.so
lib/libmla_mdata_query.so
lib/libmla_mdata_record.so
lib/libmla_mdata_split.so
lib/libmla_mdata_state.so
lib/libmla_mdata_sublist.so
lib/libmla_mdata_traffic.so
lib/libmla_mdata_visit.so
lib/libmla_mdata_visited.so
lib/libmla_mdata_webhist.so
lib/libmla_output_csv.so
lib/libmla_output_modlogan.so
lib/libmla_output_null.so
lib/libmla_output_template.so
lib/libmla_output_text.so
lib/libmla_output_tkcontrol.so
lib/libmla_output_webalizer.so
lib/libmla_processor_accounting.so
lib/libmla_processor_firewall.so
lib/libmla_processor_mail.so
lib/libmla_processor_null.so
lib/libmla_processor_telecom.so
lib/libmla_processor_web.so
%%PORTDOCS%%share/doc/modlogan/faq.txt
%%PORTDOCS%%share/doc/modlogan/glosar
%%PORTDOCS%%share/doc/modlogan/manual.txt
%%PORTDOCS%%share/doc/modlogan/plugin-options.txt
%%PORTDOCS%%share/doc/modlogan/using-plugins.txt
%%PORTDOCS%%share/doc/modlogan/writing-plugins.txt
share/examples/modlogan/convert_to_055.pl
share/examples/modlogan/convert_to_060.pl
share/examples/modlogan/footer.ihtml
share/examples/modlogan/header.ihtml
share/locale/cs/LC_MESSAGES/modlogan.mo
share/locale/de/LC_MESSAGES/modlogan.mo
share/locale/es/LC_MESSAGES/modlogan.mo
share/locale/it/LC_MESSAGES/modlogan.mo
@dirrm share/doc/modlogan
@dirrm share/examples/modlogan
@unexec rmdir %D/share/locale/cs/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/cs 2>/dev/null || true
@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/de 2>/dev/null || true
@unexec rmdir %D/share/locale/es/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/es 2>/dev/null || true
@unexec rmdir %D/share/locale/it/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/it 2>/dev/null || true