Update to 5.1.2
PR: ports/68766 Submitted by: John Merryweather Cooper (maintainer)
This commit is contained in:
parent
efd8e218f2
commit
46e48ea220
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=113276
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= plugger
|
||||
PORTVERSION= 5.0
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 5.1.2
|
||||
CATEGORIES= www audio graphics multimedia
|
||||
MASTER_SITES= http://fredrik.hubbe.net/plugger/
|
||||
|
||||
@ -16,26 +15,14 @@ COMMENT= A multimedia front-end plugin for Mozilla or Opera
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_REINPLACE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
MAN7= plugger.7
|
||||
ALL_TARGET= freebsd-elf
|
||||
PKGDEINSTALL= ${PKGINSTALL}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/usr/local/|${PREFIX}/|g' \
|
||||
${WRKSRC}/plugger.c
|
||||
@${REINPLACE_CMD} -e 's|CC=gcc|CC=${CC}|g' \
|
||||
-e 's|LD=gcc|LD=${CC}|g' ${WRKSRC}/Makefile
|
||||
@${REINPLACE_CMD} -e 's|/usr/X11R6/|${X11BASE}|g' \
|
||||
${WRKSRC}/Makefile
|
||||
@${REINPLACE_CMD} -e 's|oowriter|openoffice-1.1-swriter|g' \
|
||||
-e 's|oocalc|openoffice-1.1-scalc|g' \
|
||||
-e 's|ooimpress|openoffice-1.1-simpress|g' \
|
||||
-e 's|oodraw|openoffice-1.1-sdraw|g' \
|
||||
-e 's|oomath|openoffice-1.1-smath|g' \
|
||||
${WRKSRC}/pluggerrc
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|/usr/X11R6/lib/xscreensaver|${X11BASE}/bin/xscreensaver-hacks|g' \
|
||||
${WRKSRC}/pluggerrc
|
||||
@ -45,13 +32,13 @@ pre-install:
|
||||
${PKGINSTALL} ${PKGNAME} PRE-INSTALL
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/plugger-${PORTVERSION} \
|
||||
${PREFIX}/bin
|
||||
@${MKDIR} ${PREFIX}/lib/browser_plugins
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/plugger-${PORTVERSION} \
|
||||
${PREFIX}/bin
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/plugger-controller \
|
||||
${PREFIX}/bin
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/plugger-oohelper \
|
||||
${PREFIX}/bin
|
||||
@${MKDIR} ${PREFIX}/lib/browser_plugins
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/plugger.so \
|
||||
${PREFIX}/lib/browser_plugins/npplugger.so
|
||||
@if [ -f ${PREFIX}/etc/pluggerrc-${PORTVERSION} ]; then \
|
||||
@ -63,32 +50,29 @@ do-install:
|
||||
@${INSTALL_MAN} ${WRKSRC}/plugger.7 ${MANPREFIX}/man/man7
|
||||
|
||||
local-install:
|
||||
@${MKDIR} ${HOME}/.plugger
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/plugger-${PORTVERSION} \
|
||||
${HOME}/.plugger
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/plugger-controller \
|
||||
${HOME}/.plugger
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/plugger-oohelper \
|
||||
${HOME}/.plugger
|
||||
@if [ -f ${HOME}/.plugger/pluggerrc-${PORTVERSION} ]; then \
|
||||
${MV} ${HOME}/.plugger/pluggerrc-${PORTVERSION} \
|
||||
${HOME}/.plugger/pluggerrc-${PORTVERSION}.old; \
|
||||
fi
|
||||
@${INSTALL_DATA} ${WRKSRC}/pluggerrc \
|
||||
${HOME}/.plugger/pluggerrc-${PORTVERSION}
|
||||
|
||||
local-mozilla-install: local-install
|
||||
@${MKDIR} ${HOME}/.mozilla/plugins
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/plugger.so \
|
||||
${HOME}/.mozilla/plugins/npplugger.so
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/plugger-${PORTVERSION} \
|
||||
${HOME}/.mozilla
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/plugger-controller \
|
||||
${HOME}/.mozilla
|
||||
@if [ -f ${HOME}/.mozilla/pluggerrc-${PORTVERSION} ]; then \
|
||||
${MV} ${HOME}/.mozilla/pluggerrc-${PORTVERSION} \
|
||||
${HOME}/.mozilla/pluggerrc-${PORTVERSION}.old; \
|
||||
fi
|
||||
@${INSTALL_DATA} ${WRKSRC}/pluggerrc \
|
||||
${HOME}/.mozilla/pluggerrc-${PORTVERSION}
|
||||
|
||||
local-opera-install:
|
||||
local-opera-install: local-install
|
||||
@${MKDIR} ${HOME}/.opera/plugins
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/plugger.so \
|
||||
${HOME}/.opera/plugins/npplugger.so
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/plugger-${PORTVERSION} \
|
||||
${HOME}/.opera
|
||||
@if [ -f ${HOME}/.opera/pluggerrc-${PORTVERSION} ]; then \
|
||||
${MV} ${HOME}/.opera/pluggerrc-${PORTVERSION} \
|
||||
${HOME}/.opera/pluggerrc-${PORTVERSION}.old; \
|
||||
fi
|
||||
@${INSTALL_DATA} ${WRKSRC}/pluggerrc \
|
||||
${HOME}/.opera/pluggerrc-${PORTVERSION}
|
||||
|
||||
post-install:
|
||||
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (plugger-5.0.tar.gz) = c2b263c7c34f759fb8b2e29b243b5ca1
|
||||
SIZE (plugger-5.0.tar.gz) = 55005
|
||||
MD5 (plugger-5.1.2.tar.gz) = d3b93e7c8179e232fb796357b4b23099
|
||||
SIZE (plugger-5.1.2.tar.gz) = 75875
|
||||
|
29
www/plugger/files/patch-Makefile.in
Normal file
29
www/plugger/files/patch-Makefile.in
Normal file
@ -0,0 +1,29 @@
|
||||
--- Makefile.in.orig Wed Jul 7 03:13:00 2004
|
||||
+++ Makefile.in Wed Jul 7 03:21:47 2004
|
||||
@@ -30,7 +30,7 @@
|
||||
CC=@CC@
|
||||
LD=@LD@
|
||||
BINFORMAT=bin
|
||||
-OPT_FLAGS=-O2
|
||||
+OPT_FLAGS=@CFLAGS@
|
||||
|
||||
@SET_MAKE@
|
||||
|
||||
@@ -66,7 +66,7 @@
|
||||
DEBUG= # -DDEBUG # -DPLUGIN_TRACE
|
||||
DEFINES=$(STREAM) -DVERSION=\"$(VERSION)\" $(DEBUG)
|
||||
COMMON_CFLAGS=$(OPT_FLAGS) -I$(SDK)/include -I@x_includes@ -DXP_UNIX $(DEFINES)
|
||||
-COMMON_LDFLAGS=
|
||||
+COMMON_LDFLAGS=@LDFLAGS@
|
||||
NORM_CFLAGS=
|
||||
NORM_LDFLAGS=
|
||||
XCFLAGS=@XCFLAGS@ @X_CFLAGS@
|
||||
@@ -79,7 +79,7 @@
|
||||
LDFLAGS=$(COMMON_LDFLAGS) $(NORM_LDFLAGS)
|
||||
SHARED_CFLAGS=$(COMMON_CFLAGS) $(XCFLAGS)
|
||||
|
||||
-## Targes
|
||||
+## Targets
|
||||
all: plugger.so plugger-$(VERSION) plugger-controller
|
||||
|
||||
|
15
www/plugger/files/patch-configure
Normal file
15
www/plugger/files/patch-configure
Normal file
@ -0,0 +1,15 @@
|
||||
--- configure.orig Wed Jul 7 02:41:28 2004
|
||||
+++ configure Wed Jul 7 02:49:41 2004
|
||||
@@ -1819,10 +1819,10 @@
|
||||
XLDFLAGS='-expect_unresolved "*" -shared -msym -O3'
|
||||
;;
|
||||
|
||||
- FreeBSD)
|
||||
+ FreeBSD*)
|
||||
case "`file /bin/ls`" in
|
||||
*ELF*)
|
||||
- XCFLAGS=-fpic
|
||||
+ XCFLAGS=-fPIC
|
||||
XLDFLAGS=-shared
|
||||
;;
|
||||
*)
|
@ -1,11 +0,0 @@
|
||||
--- plugger-controller.c.old Wed Feb 11 16:22:04 2004
|
||||
+++ plugger-controller.c Wed Feb 11 16:23:47 2004
|
||||
@@ -136,7 +136,7 @@
|
||||
if(!pid)
|
||||
{
|
||||
char *cmd[4];
|
||||
- setpgrp();
|
||||
+ setpgrp(0, 0);
|
||||
cmd[0]="/bin/sh";
|
||||
cmd[1]="-c";
|
||||
cmd[2]=argv[1];
|
@ -1,11 +0,0 @@
|
||||
--- plugger-helper.c.old Wed Feb 11 16:19:27 2004
|
||||
+++ plugger-helper.c Wed Feb 11 16:20:30 2004
|
||||
@@ -76,7 +76,7 @@
|
||||
|
||||
static void very_low_run(char **argv)
|
||||
{
|
||||
- setpgrp();
|
||||
+ setpgrp(0, 0);
|
||||
#ifdef H_NOISY
|
||||
if(flags & H_NOISY)
|
||||
{
|
@ -1,11 +0,0 @@
|
||||
--- plugger.c.old Wed Feb 11 16:15:56 2004
|
||||
+++ plugger.c Wed Feb 11 16:17:04 2004
|
||||
@@ -189,7 +189,7 @@
|
||||
int signum;
|
||||
alarm(0);
|
||||
if(!(THIS->flags & H_DAEMON))
|
||||
- setpgrp();
|
||||
+ setpgrp(0, 0);
|
||||
|
||||
for(signum=0;signum<NSIG;signum++) signal(signum, SIG_DFL);
|
||||
|
@ -5,7 +5,7 @@
|
||||
PKGNAME=$1
|
||||
ACTION=$2
|
||||
|
||||
FILES_DELETE="pluggerrc-5.0.old"
|
||||
FILES_DELETE="pluggerrc-5.1.2.old"
|
||||
|
||||
ETCDIR=${PKG_PREFIX}/etc
|
||||
|
||||
@ -16,8 +16,8 @@ ECHO=/bin/echo
|
||||
case "$ACTION" in
|
||||
|
||||
POST-INSTALL)
|
||||
if [ ! -f ${ETCDIR}/pluggerrc-5.0 ]; then
|
||||
${CP} ${ETCDIR}/pluggerrc-5.0.sample ${ETCDIR}/pluggerrc-5.0
|
||||
if [ ! -f ${ETCDIR}/pluggerrc-5.1.2 ]; then
|
||||
${CP} ${ETCDIR}/pluggerrc-5.1.2.sample ${ETCDIR}/pluggerrc-5.1.2
|
||||
fi
|
||||
;;
|
||||
|
||||
@ -32,18 +32,21 @@ DEINSTALL)
|
||||
|
||||
PRE-INSTALL)
|
||||
${ECHO}
|
||||
${ECHO} "Run ''make local-install'' as user to locally"
|
||||
${ECHO} "Run ''make local-mozilla-install'' as user to locally"
|
||||
${ECHO} "install plugger for Mozilla"
|
||||
${ECHO}
|
||||
${ECHO} "Run ''make local-opera-install'' as user to locally"
|
||||
${ECHO} "install plugger for Opera"
|
||||
${ECHO}
|
||||
${ECHO} "NOTE: For plugger-oohelper to work, [o|s]office must be"
|
||||
${ECHO} "in the PATH."
|
||||
${ECHO}
|
||||
;;
|
||||
|
||||
POST-DEINSTALL)
|
||||
${ECHO}
|
||||
${ECHO} "If you are permanently removing this port,"
|
||||
${ECHO} "you should do a ''rm -f ${ETCDIR}/pluggerrc-5.0''"
|
||||
${ECHO} "you should do a ''rm -f ${ETCDIR}/pluggerrc-5.1.2''"
|
||||
${ECHO} "to remove it."
|
||||
${ECHO}
|
||||
;;
|
||||
|
@ -1,5 +1,6 @@
|
||||
bin/plugger-5.0
|
||||
bin/plugger-5.1.2
|
||||
bin/plugger-controller
|
||||
etc/pluggerrc-5.0.sample
|
||||
bin/plugger-oohelper
|
||||
etc/pluggerrc-5.1.2.sample
|
||||
lib/browser_plugins/npplugger.so
|
||||
@dirrm lib/browser_plugins
|
||||
@unexec rmdir %D/lib/browser_plugins 2>/dev/null || true
|
||||
|
Loading…
Reference in New Issue
Block a user