- add stage support

This commit is contained in:
Olli Hauer 2014-06-01 09:34:52 +00:00
parent de58a02313
commit 46e1755ca1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=356069
3 changed files with 26 additions and 7 deletions

View File

@ -21,12 +21,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+=--datadir=${DATADIR}
MAN1= dbench.1
MLINKS= dbench.1 tbench.1 dbench.1 tbench_srv.1
NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's,$$(mandir),$$(mandir)/man1,' \
${WRKSRC}/Makefile.in
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
.include <bsd.port.mk>

View File

@ -0,0 +1,21 @@
--- ./Makefile.in.orig 2014-06-01 10:35:20.000000000 +0200
+++ ./Makefile.in 2014-06-01 10:36:46.000000000 +0200
@@ -32,12 +32,12 @@
# Careful here: don't install client.txt over itself.
install: all
- ${INSTALLCMD} -d $(bindir) $(datadir) $(mandir)
- ${INSTALLCMD} dbench tbench tbench_srv $(bindir)
- ${INSTALLCMD} client.txt $(datadir)
- ${INSTALLCMD} -m644 dbench.1 $(mandir)
- ln -sf dbench.1 $(mandir)/tbench.1
- ln -sf dbench.1 $(mandir)/tbench_srv.1
+ ${INSTALLCMD} -d $(DESTDIR)$(bindir) $(DESTDIR)$(datadir) $(DESTDIR)$(mandir)/man1
+ ${INSTALLCMD} dbench tbench tbench_srv $(DESTDIR)$(bindir)
+ ${INSTALLCMD} client.txt $(DESTDIR)$(datadir)
+ ${INSTALLCMD} -m644 dbench.1 $(DESTDIR)$(mandir)/man1
+ ln -sf dbench.1 $(DESTDIR)$(mandir)/man1/tbench.1
+ ln -sf dbench.1 $(DESTDIR)$(mandir)/man1/tbench_srv.1
clean:
rm -f *.o *~ dbench tbench tbench_srv

View File

@ -1,5 +1,8 @@
bin/dbench
bin/tbench
bin/tbench_srv
man/man1/dbench.1.gz
man/man1/tbench.1.gz
man/man1/tbench_srv.1.gz
%%DATADIR%%/client.txt
@dirrm %%DATADIR%%