x11/login.app : update and take maintainership

This updates x11/login.app from 2.0.0.a7_1 to 2.1.1 and
	transmits maintainership from ports@freebsd.org to me.

PR:		ports/76010
Submitted by:   Tobias Roth <ports@fsck.ch>
This commit is contained in:
Edwin Groothuis 2005-01-10 10:51:29 +00:00
parent 95ba0766ed
commit 46d68af243
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=126039
27 changed files with 180 additions and 248 deletions

View File

@ -6,39 +6,59 @@
#
PORTNAME= login.app
PORTVERSION= 2.0.0.a7
PORTREVISION= 1
PORTVERSION= 2.1.1
CATEGORIES= x11 windowmaker
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://wm.current.nu/files/Login.app/ \
http://wm.current.nu/files/Login.app/Themes/
MASTER_SITE_SUBDIR= sobomax
DISTFILES= Login.app-${PORTVERSION:S/.a/-Alpha-/}${EXTRACT_SUFX} \
Drone${EXTRACT_SUFX}
MASTER_SITES= http://largo.windowmaker.org/files/Login.app/ \
http://depot.fsck.ch/mirror/distfiles/
DISTNAME= Login.app-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Nice looking login interface to your favorite X-Server
MAINTAINER= ports@fsck.ch
COMMENT= Graphical login interface for X that is themable
LIB_DEPENDS= wraster.4:${PORTSDIR}/x11-wm/windowmaker \
PropList.2:${PORTSDIR}/devel/libPropList
WRKSRC= ${WRKDIR}/Login.app-${PORTVERSION:S/.a/-Alpha-/}
USE_PERL5_BUILD=yes
USE_X_PREFIX= yes
USE_XPM= yes
MAKE_ENV= MKDIR="${MKDIR}"
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
USE_GMAKE= yes
USE_REINPLACE= yes
ALL_TARGET= Login
MAN1= Login.app.1x
pre-configure:
@${REINPLACE_CMD} -e \
's|GNUstep/Applications|GNUstep/Apps|' \
${WRKSRC}/Makefile.am \
${WRKSRC}/Makefile.in \
${WRKSRC}/Scripts/Makefile.am \
${WRKSRC}/Scripts/Makefile.in \
${WRKSRC}/Themes/Linux/Makefile.am \
${WRKSRC}/Themes/Linux/Makefile.in \
${WRKSRC}/Themes/GNUstep/Makefile.am \
${WRKSRC}/Themes/GNUstep/Makefile.in \
${WRKSRC}/Themes/Drone/Makefile.in \
${WRKSRC}/Themes/Drone/Makefile.am \
${WRKSRC}/src/Makefile.in \
${WRKSRC}/src/Makefile.am
post-configure:
@cd ${WRKSRC} && ${PERL} -pi -e 's|%%X11BASE%%|${X11BASE}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g' preferences.h Scripts/Login.user \
Scripts/Login.root Scripts/Logout.root Scripts/Startup \
Preferences config.h
@${REINPLACE_CMD} -e \
's|%%X11BASE%%|${X11BASE}|; \
s|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/Scripts/Login.user \
${WRKSRC}/Scripts/Login.root \
${WRKSRC}/Scripts/Logout.root \
${WRKSRC}/Scripts/Startup \
${WRKSRC}/Preferences \
${WRKSRC}/src/config.h \
${WRKSRC}/src/preferences.h
post-install:
@(cd ${WRKDIR} && ${TAR} --exclude "*.orig" -c -f - Drone) \
| (cd ${PREFIX}/GNUstep/Apps/Login.app/Themes && ${TAR} --unlink -x -f -)
@${SED} 's|%%X11BASE%%|${PREFIX}|' \
${FILESDIR}/loginapp.sh > ${PREFIX}/etc/rc.d/loginapp.sh
@${CHMOD} ${BINMODE} ${PREFIX}/etc/rc.d/loginapp.sh
.include <bsd.port.mk>

View File

@ -1,4 +1,4 @@
MD5 (Login.app-2.0.0-Alpha-7.tar.gz) = 97101446a0fe23e7b528160290126b9e
SIZE (Login.app-2.0.0-Alpha-7.tar.gz) = 287088
MD5 (Login.app-2.1.1.tar.gz) = 4d85cbdc505a94f7fbfe37bd0a709e75
SIZE (Login.app-2.1.1.tar.gz) = 421070
MD5 (Drone.tar.gz) = 5dd4a22bd23ffe8d66a3a86fb70e502b
SIZE (Drone.tar.gz) = 51765

View File

@ -0,0 +1,24 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: login_app
# REQUIRE: LOGIN
# Add the following line to /etc/rc.conf to enable login.app:
#
# login_app_enable="YES"
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
login_app_enable=${login_app_enable-"NO"}
. /etc/rc.subr
name="login_app"
rcvar=`set_rcvar`
command="%%X11BASE%%/GNUstep/Apps/Login.app/Login"
load_rc_config $name
run_rc_command "$1"

View File

@ -0,0 +1,11 @@
--- Preferences.orig Sat Jan 8 18:18:14 2005
+++ Preferences Sat Jan 8 18:19:05 2005
@@ -5,7 +5,7 @@
ConfirmRestartMessage = "Do you really want to restart the computer (y/n)?";
ConfirmPowerOffMessage = "Do you really want to turn off the computer (y/n)?";
- XServer = "/usr/X11R6/bin/X -nolisten tcp";
+ XServer = "%%X11BASE%%/bin/X -nolisten tcp";
Theme = "Drone";
DisableWelcomeMessage = Yes;

View File

@ -0,0 +1,21 @@
--- Scripts/Login.root.orig Sat Jan 8 20:48:19 2005
+++ Scripts/Login.root Sat Jan 8 20:47:48 2005
@@ -1,15 +1,15 @@
#!/bin/sh
-PATH="/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin"
+PATH="/sbin:/usr/sbin:/bin:/usr/bin:%%LOCALBASE%%/bin:%%X11BASE%%/bin"
#
# Make user the owner of /dev/console.
#
-#chown $USER /dev/console
+#/usr/sbin/chown $USER /dev/console
#
# Add user to utmp/wtmp.
#
-sessreg -a -w /var/log/wtmp -u /var/run/utmp -l "$DISPLAY" $USER
+%%X11BASE%%/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -l "$DISPLAY" $USER
# End of file

View File

@ -1,5 +1,5 @@
--- Scripts/Login.user.orig Sat Nov 11 09:24:21 2000
+++ Scripts/Login.user Thu Dec 14 10:43:08 2000
--- Scripts/Login.user.orig Sat Jan 8 18:41:35 2005
+++ Scripts/Login.user Sat Jan 8 18:45:07 2005
@@ -1,32 +1,32 @@
#!/bin/sh

View File

@ -1,5 +1,5 @@
--- Scripts/Logout.root.orig Sat Nov 11 10:49:57 2000
+++ Scripts/Logout.root Thu Dec 14 10:38:58 2000
--- Scripts/Logout.root.orig Sat Jan 8 20:48:25 2005
+++ Scripts/Logout.root Sat Jan 8 20:47:48 2005
@@ -1,23 +1,23 @@
#!/bin/sh
@ -17,15 +17,15 @@
#
# Remove user from utmp/wtmp.
#
-sessreg -d $USER
+%%X11BASE%%/bin/sessreg -d $USER
-sessreg -d -w /var/log/wtmp -u /var/run/utmp -l "$DISPLAY" $USER
+%%X11BASE%%/bin/sessreg -d -w /var/log/wtmp -u /var/run/utmp -l "$DISPLAY" $USER
#
# Make root the owner of /dev/console.
#
-chmod 622 /dev/console
-chown root /dev/console
+/bin/chmod 622 /dev/console
+/usr/sbin/chown root /dev/console
-#chmod 622 /dev/console
-#chown root /dev/console
+#/bin/chmod 622 /dev/console
+#/usr/sbin/chown root /dev/console
# End of file

View File

@ -0,0 +1,10 @@
--- Scripts/PowerOff.orig Sat Jan 8 18:39:45 2005
+++ Scripts/PowerOff Sat Jan 8 18:39:51 2005
@@ -3,6 +3,6 @@
#
# Take the system down for halt.
#
-/sbin/shutdown -h now
+/sbin/shutdown -p now
# End of file

View File

@ -0,0 +1,15 @@
--- Scripts/Startup.orig Sat Jan 8 18:46:15 2005
+++ Scripts/Startup Sat Jan 8 18:47:45 2005
@@ -1,10 +1,10 @@
#!/bin/sh
-PATH="/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin"
+PATH="/bin:/usr/bin:%%LOCALBASE%%/bin:%%X11BASE%%/bin"
#
# Set cursor for the root window.
#
-xsetroot -solid "#000000" -cursor_name left_ptr
+%%X11BASE%%/bin/xsetroot -solid "#000000" -cursor_name left_ptr
# End of file

View File

@ -0,0 +1,22 @@
--- Scripts/Suspend.orig Sat Jan 8 18:57:32 2005
+++ Scripts/Suspend Sat Jan 8 20:45:56 2005
@@ -4,8 +4,17 @@
# Suspend the system, can be handy if you are
# using a laptop computer.
#
-if [ apm_available -a -x /usr/bin/apm ]; then
- /usr/bin/apm --suspend
+
+apm_out=` /usr/sbin/apm -s 2> /dev/null `
+sysctl_out=` /sbin/sysctl hw.acpi.suspend_state 2> /dev/null `
+suspend_state=` expr "//$sysctl_out" : '.*hw.acpi.suspend_state:.*\(S.*\)' `
+
+if [ -n "$suspend_state" ] ; then
+ /usr/sbin/acpiconf -s $suspend_state
+elif [ -e "/dev/apm" -a -n "$apm_out" ] ; then
+ if [ $apm_out -eq 1 ] ; then
+ /usr/sbin/apm -z
+ fi
fi
# End of file

View File

@ -1,49 +0,0 @@
--- Makefile.orig Sun Nov 12 06:54:45 2000
+++ Makefile Thu Dec 14 10:50:15 2000
@@ -3,7 +3,7 @@
#
# Directory where Login.app will be installed
-INSTALL_DIR = /usr/local/GNUstep/Apps/Login.app
+INSTALL_DIR = ${PREFIX}/GNUstep/Apps/Login.app
# Use shadow passwords, comment out to disable
SHADOW = -DSHADOW_PASSWD
@@ -13,8 +13,10 @@
INSTALL = /usr/bin/install -c
CC = cc
-CFLAGS += -Wall -pedantic -D_GNU_SOURCE `get-wraster-flags --cflags` $(SHADOW)
-LDFLAGS += `get-wraster-flags --ldflags` `get-wraster-flags --libs` -lXmu -lPropList -lcrypt
+WRASTER_CFLAGS != ${X11BASE}/bin/get-wraster-flags --cflags
+WRASTER_LDFLAGS != ${X11BASE}/bin/get-wraster-flags --ldflags --libs
+CFLAGS += -Wall -pedantic -D_GNU_SOURCE $(WRASTER_CFLAGS) $(SHADOW)
+LDFLAGS += $(WRASTER_LDFLAGS) -lXmu -lPropList -lcrypt
TARGET = Login
@@ -61,16 +63,14 @@
rm -rf $(TARGET) $(OBJS) core `find -name \*~`
install: $(TARGET)
- $(INSTALL) -d $(INSTALL_DIR)
- $(INSTALL) -d $(INSTALL_DIR)/Scripts
- $(INSTALL) -d $(INSTALL_DIR)/Themes
- $(INSTALL) -d $(INSTALL_DIR)/Themes/Linux
- $(INSTALL) -d $(INSTALL_DIR)/Themes/GNUstep
- $(INSTALL) -s $(TARGET) $(INSTALL_DIR)
- $(INSTALL) -m 644 Preferences $(INSTALL_DIR)/Preferences
- $(INSTALL) $(SCRIPTS) $(INSTALL_DIR)/Scripts/
- $(INSTALL) -m 644 $(THEME_LINUX) $(INSTALL_DIR)/Themes/Linux/
- $(INSTALL) -m 644 $(THEME_GNUSTEP) $(INSTALL_DIR)/Themes/GNUstep/
+ $(MKDIR) $(INSTALL_DIR)/Scripts
+ $(MKDIR) $(INSTALL_DIR)/Themes/Linux
+ $(MKDIR) $(INSTALL_DIR)/Themes/GNUstep
+ $(BSD_INSTALL_PROGRAM) $(TARGET) $(INSTALL_DIR)
+ $(BSD_INSTALL_DATA) Preferences $(INSTALL_DIR)/Preferences
+ $(BSD_INSTALL_SCRIPT) $(SCRIPTS) $(INSTALL_DIR)/Scripts/
+ $(BSD_INSTALL_DATA) $(THEME_LINUX) $(INSTALL_DIR)/Themes/Linux/
+ $(BSD_INSTALL_DATA) $(THEME_GNUSTEP) $(INSTALL_DIR)/Themes/GNUstep/
uninstall:
rm -rf $(INSTALL_DIR)

View File

@ -1,18 +0,0 @@
--- Preferences.orig Sat Nov 11 11:07:58 2000
+++ Preferences Thu Dec 14 00:49:48 2000
@@ -1,12 +1,12 @@
{
- WelcomeMessage = "Welcome to LINUX";
+ WelcomeMessage = "Welcome to FreeBSD";
RestartMessage = "System is rebooting...";
PowerOffMessage = "System is shutting down...";
ConfirmRestartMessage = "Do you really want to restart the computer (y/n)?";
ConfirmPowerOffMessage = "Do you really want to turn off the computer (y/n)?";
- XServer = "/usr/X11R6/bin/X -nolisten tcp";
- Theme = "Linux";
+ XServer = "%%X11BASE%%/bin/X -nolisten tcp";
+ Theme = "Drone";
DisableWelcomeMessage = Yes;
DisableUserShutdown = No;

View File

@ -1,21 +0,0 @@
--- Scripts/Login.root.orig Sat Nov 11 10:49:02 2000
+++ Scripts/Login.root Thu Dec 14 10:38:58 2000
@@ -1,15 +1,15 @@
#!/bin/sh
-PATH="/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin"
+PATH="/sbin:/usr/sbin:/bin:/usr/bin:%%LOCALBASE%%/bin:%%X11BASE%%/bin"
#
# Make user the owner of /dev/console.
#
-chown $USER /dev/console
+/usr/sbin/chown $USER /dev/console
#
# Add user to utmp/wtmp.
#
-sessreg -a $USER
+%%X11BASE%%/bin/sessreg -a $USER
# End of file

View File

@ -1,11 +0,0 @@
--- preferences.h 2000/12/13 20:54:07 1.1
+++ preferences.h 2000/12/13 20:54:43
@@ -39,7 +39,7 @@
#define DEFAULT_WELCOMEMESSAGE "Welcome to LINUX"
#define DEFAULT_POWEROFFMESSAGE "System is shutting down..."
#define DEFAULT_RESTARTMESSAGE "System is rebooting..."
-#define DEFAULT_XSERVER "/usr/X11R6/bin/X"
+#define DEFAULT_XSERVER "%%X11BASE%%/bin/X"
#define DEFAULT_THEME "Linux"
#define DEFAULT_DISABLEWELCOMEMESSAGE NO
#define DEFAULT_DISABLEUSERSHUTDOWN NO

View File

@ -1,10 +0,0 @@
--- Scripts/Startup.orig Sat Nov 11 09:24:57 2000
+++ Scripts/Startup Thu Dec 14 10:38:58 2000
@@ -1,6 +1,6 @@
#!/bin/sh
-PATH="/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin"
+PATH="/bin:/usr/bin:%%LOCALBASE%%/bin:%%X11BASE%%/bin"
#
# Set cursor for the root window.

View File

@ -1,17 +0,0 @@
--- Themes/Linux/Settings 2000/12/13 21:12:32 1.1
+++ Themes/Linux/Settings 2000/12/13 21:12:53
@@ -15,12 +15,12 @@
MessagePosition = "231, 130";
MessageJustification = Center;
- MessageFont = "-*-utopia-regular-*-*-*-18-*-*-*-*-*-*-*";
+ MessageFont = "-*-utopia-regular-*-*-*-19-*-*-*-*-*-*-*";
MessageColor = "grey20";
HostnamePosition = "450, 80";
HostnameJustification = Right;
- HostnameFont = "-*-utopia-regular-*-*-*-18-*-*-*-*-*-*-*";
+ HostnameFont = "-*-utopia-regular-*-*-*-19-*-*-*-*-*-*-*";
HostnameColor = "grey30";
InputFont = "-*-helvetica-medium-r-*-*-18-*-*-*-*-*-*-*";

View File

@ -1,10 +0,0 @@
--- Scripts/PowerOff.orig Tue Jul 4 01:03:30 2000
+++ Scripts/PowerOff Thu Dec 14 00:28:50 2000
@@ -3,6 +3,6 @@
#
# Take the system down for halt.
#
-#/sbin/shutdown -h now
+/sbin/shutdown -p now
# End of file

View File

@ -1,10 +0,0 @@
--- Scripts/Restart 2000/12/13 22:24:55 1.1
+++ Scripts/Restart 2000/12/13 22:25:01
@@ -3,6 +3,6 @@
#
# Take the system down for reboot.
#
-#/sbin/shutdown -r now
+/sbin/shutdown -r now
# End of file

View File

@ -1,17 +0,0 @@
--- Themes/GNUstep/Settings 2000/12/13 22:45:18 1.1
+++ Themes/GNUstep/Settings 2000/12/13 22:45:39
@@ -15,12 +15,12 @@
MessagePosition = "231, 130";
MessageJustification = Center;
- MessageFont = "-*-utopia-regular-*-*-*-18-*-*-*-*-*-*-*";
+ MessageFont = "-*-utopia-regular-*-*-*-19-*-*-*-*-*-*-*";
MessageColor = "grey20";
HostnamePosition = "450, 80";
HostnameJustification = Right;
- HostnameFont = "-*-utopia-regular-*-*-*-18-*-*-*-*-*-*-*";
+ HostnameFont = "-*-utopia-regular-*-*-*-19-*-*-*-*-*-*-*";
HostnameColor = "grey30";
InputFont = "-*-helvetica-medium-r-*-*-18-*-*-*-*-*-*-*";

View File

@ -1,17 +0,0 @@
--- ../Drone/Settings 2000/12/14 09:12:17 1.1
+++ ../Drone/Settings 2000/12/14 09:12:54
@@ -15,12 +15,12 @@
MessagePosition = "205, 280";
MessageJustification = Center;
- MessageFont = "-*-utopia-regular-*-*-*-18-*-*-*-*-*-*-*";
+ MessageFont = "-*-utopia-regular-*-*-*-19-*-*-*-*-*-*-*";
MessageColor = "grey20";
HostnamePosition = "203, 249";
HostnameJustification = center;
- HostnameFont = "-*-utopia-regular-*-*-*-18-*-*-*-*-*-*-*";
+ HostnameFont = "-*-utopia-regular-*-*-*-19-*-*-*-*-*-*-*";
HostnameColor = "grey30";
InputFont = "-*-helvetica-medium-r-*-*-18-*-*-*-*-*-*-*";

View File

@ -1,11 +0,0 @@
--- graphics.c.orig Sun Oct 31 11:44:10 2004
+++ graphics.c Sun Oct 31 11:44:54 2004
@@ -73,7 +73,7 @@
img = RCloneImage(bottom);
RCombineImages(img, top);
setWindowImage(win, img);
- RDestroyImage(img);
+ RReleaseImage(img);
}
void drawText(Window win, XFontStruct* font, int justification, int x, int y,

View File

@ -1,11 +0,0 @@
--- panel.c.orig Sun Oct 31 11:44:16 2004
+++ panel.c Sun Oct 31 11:44:41 2004
@@ -297,7 +297,7 @@
image = RCreateImageFromDrawable(ctx, panel, 0);
RConvertImage(ctx, image, &shrinkPixmap);
- RDestroyImage(image);
+ RReleaseImage(image);
XSetWindowBackgroundPixmap(dpy, panel, shrinkPixmap);
XUnmapSubwindows(dpy, panel);

View File

@ -1,5 +1,5 @@
--- config.h 2000/12/13 21:04:54 1.1
+++ config.h 2000/12/13 21:05:08
--- src/config.h.orig Sat Jan 8 18:29:31 2005
+++ src/config.h Sat Jan 8 18:29:45 2005
@@ -23,7 +23,7 @@
#define CONFIG_H

View File

@ -0,0 +1,11 @@
--- src/preferences.h.orig Sun Oct 24 04:15:32 2004
+++ src/preferences.h Sat Jan 8 18:26:20 2005
@@ -47,7 +47,7 @@
#endif
#define DEFAULT_POWEROFFMESSAGE "System is shutting down..."
#define DEFAULT_RESTARTMESSAGE "System is rebooting..."
-#define DEFAULT_XSERVER "/usr/X11R6/bin/X"
+#define DEFAULT_XSERVER "%%X11BASE%%/bin/X"
#define DEFAULT_THEME "Drone"
#define DEFAULT_DISABLEWELCOMEMESSAGE True
#define DEFAULT_DISABLEUSERSHUTDOWN False

View File

@ -1,5 +1,5 @@
--- switchuser.c 2000/12/13 19:53:23 1.1
+++ switchuser.c 2000/12/13 20:23:40
--- src/switchuser.c.orig Sun Oct 24 04:15:32 2004
+++ src/switchuser.c Sat Jan 8 18:37:49 2005
@@ -77,7 +77,7 @@
char* correct;
struct passwd *pw;

View File

@ -10,4 +10,4 @@ Also, it does have some nice features to halt, reboot and suspend you system.
It will serve the needs of most users that just want a nice looking login
interface on their FreeBSD workstation.
WWW: http://wm.current.nu/Login.app/
WWW: http://largo.windowmaker.org/Login.app/

View File

@ -1,3 +1,4 @@
etc/rc.d/loginapp.sh
GNUstep/Apps/Login.app/Login
GNUstep/Apps/Login.app/Preferences
GNUstep/Apps/Login.app/Scripts/Login.root
@ -7,17 +8,16 @@ GNUstep/Apps/Login.app/Scripts/PowerOff
GNUstep/Apps/Login.app/Scripts/Restart
GNUstep/Apps/Login.app/Scripts/Startup
GNUstep/Apps/Login.app/Scripts/Suspend
GNUstep/Apps/Login.app/Themes/Drone/README
GNUstep/Apps/Login.app/Themes/Drone/Settings
GNUstep/Apps/Login.app/Themes/Drone/fieldlabels1.png
GNUstep/Apps/Login.app/Themes/Drone/fieldlabels.png
GNUstep/Apps/Login.app/Themes/Drone/inputfield1.png
GNUstep/Apps/Login.app/Themes/Drone/inputfield2.png
GNUstep/Apps/Login.app/Themes/Drone/inputfield3.png
GNUstep/Apps/Login.app/Themes/Drone/panel3.png
GNUstep/Apps/Login.app/Themes/Drone/powerbuttondown2.png
GNUstep/Apps/Login.app/Themes/Drone/powerbuttonup2.png
GNUstep/Apps/Login.app/Themes/Drone/restartbuttondown2.png
GNUstep/Apps/Login.app/Themes/Drone/restartbuttonup2.png
GNUstep/Apps/Login.app/Themes/Drone/stop1.png
GNUstep/Apps/Login.app/Themes/Drone/panel.png
GNUstep/Apps/Login.app/Themes/Drone/powerbuttondown.png
GNUstep/Apps/Login.app/Themes/Drone/powerbuttonup.png
GNUstep/Apps/Login.app/Themes/Drone/restartbuttondown.png
GNUstep/Apps/Login.app/Themes/Drone/restartbuttonup.png
GNUstep/Apps/Login.app/Themes/Drone/stop.png
GNUstep/Apps/Login.app/Themes/GNUstep/Settings
GNUstep/Apps/Login.app/Themes/GNUstep/fieldlabels.tiff
GNUstep/Apps/Login.app/Themes/GNUstep/inputfield.tiff