net/open-isns: Update to 0.101

ChangeLog: https://github.com/open-iscsi/open-isns/blob/master/ChangeLog

PR:	253343
Submitted by:	pavelivolkov@gmail.com (maintainer)
This commit is contained in:
Fernando Apesteguía 2021-02-09 06:56:15 +00:00
parent dfe08d1dc1
commit 46abde0a25
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=564768
5 changed files with 47 additions and 60 deletions

View File

@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= open-isns
PORTVERSION= 0.99
DISTVERSIONPREFIX= v
DISTVERSION= 0.101
CATEGORIES= net
MAINTAINER= pavelivolkov@gmail.com
@ -10,61 +10,80 @@ COMMENT= Internet Storage Name Service (iSNS)
LICENSE= LGPL21
USES= autoreconf gmake pathfix
USE_LDCONFIG= yes
USES= autoreconf gmake pathfix python:3.6+,test shebangfix
USE_GITHUB= yes
GH_ACCOUNT= open-iscsi
GH_TAGNAME= cfdbcff
USE_LDCONFIG= yes
USE_RC_SUBR= isnsd
SHEBANG_FILES= isnssetup ${TEST_WRKSRC}/*.py ${TEST_WRKSRC}/*.pl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
INSTALL_TARGET= install install_lib
USE_RC_SUBR= isnsd
DATABASE_PLACE?= /var/db/isns
TEST_ARGS= LD_LIBRARY_PATH=${WRKSRC}
TEST_WRKSRC= ${WRKSRC}/tests
OPTIONS_SUB= yes
OPTIONS_DEFINE= DEV SECURITY SLP
OPTIONS_DEFAULT= SECURITY
OPTIONS_SUB= yes
DEV_DESC= Install Headers & Static lib
SECURITY_DESC= Enable iSNS authentication
SLP_DESC= Enable SLP for server discovery
DEV_CONFIGURE_ENABLE= static
DEV_VARS= INSTALL_TARGET+=install_hdrs
SECURITY_DESC= Enable iSNS authentication
SECURITY_CONFIGURE_WITH= security
SECURITY_USES= ssl
SECURITY_CONFIGURE_WITH= security
SECURITY_TEST_TARGET= tests
SECURITY_TEST_TARGET_OFF= tests-no-security
SLP_DESC= Enable SLP for server discovery
SLP_CONFIGURE_WITH= slp
SLP_LIB_DEPENDS= libslp.so:net/openslp
SLP_CONFIGURE_WITH= slp
SLP_CPPFLAGS= -I${PREFIX}/include
SLP_LDFLAGS= -L${PREFIX}/lib
_DATABASE_PLACE?= ${DESTDIR}/var/db/isns
.include <bsd.port.options.mk>
post-patch:
#
# Move paths to configurations according to the variable ${PREFIX} and ${_DATABASE_PLACE}.
${REINPLACE_CMD} -E \
-e "s|^([[:blank:]]*#define ISNS_ETCDIR[[:blank:]]+\")(.*)$$|\1${PREFIX}\2|" \
-e "s|^([[:blank:]]*#define ISCSI_DEFAULT_INITIATORNAME[[:blank:]]+\")(.*)$$|\1${PREFIX}\2|" \
-e "s|(/etc/)|${PREFIX}\1|g" \
-e "s|^(.*Database[[:blank:]]*=[[:blank:]]*)(.*)$$|\1${_DATABASE_PLACE}|" \
${WRKSRC}/etc/isnsadm.conf \
${WRKSRC}/etc/isnsd.conf \
${WRKSRC}/etc/isnsdd.conf \
${WRKSRC}/isnssetup \
${WRKSRC}/include/libisns/paths.h.in
#
# Move paths to configurations according to the variables ${PREFIX} and ${_DATABASE_PLACE}, remove the dependencies on the systemd.
${REINPLACE_CMD} -E \
-e "1,10s|^(vardir[[:blank:]]*=[[:blank:]]*)(.*)$$|\1${DATABASE_PLACE}|" \
-e "1,12s|(/etc)|${PREFIX}\1|" \
-e "1,12s|^(vardir[[:blank:]]*=[[:blank:]]*)(.*)$$|\1${_DATABASE_PLACE}|" \
-e "s|^(.*)[[:blank:]]+\\$$\(SYSTEMDDIR\)$$|\1|" \
-e "/isnsd\.(service|socket)/d" \
${WRKSRC}/Makefile.in
.for FILE in isnsadm.conf isnsd.conf isnsdd.conf
#
# Move paths to configurations according to the variable ${PREFIX}, remove bashism.
${REINPLACE_CMD} -E \
-e "s|^(.*AuthKeyFile[[:blank:]]*=[[:blank:]]*)(.*)$$|\1${PREFIX}\2|" \
-e "s|^(.*ServerKeyFile[[:blank:]]*=[[:blank:]]*)(.*)$$|\1${PREFIX}\2|" \
-e "s|^(.*Database[[:blank:]]*=[[:blank:]]*)(.*)$$|\1${DATABASE_PLACE}|" \
${WRKSRC}/etc/${FILE}
.endfor
-e "1,3s|ba(sh)|\1|" \
-e "1,27s|(/etc/)|${PREFIX}\1|g" \
-e "s|^[[:blank:]]*function[[:blank:]]+([^[:blank:]]+)(.*)$$|\1()\2|" \
${WRKSRC}/tests/genkey
post-patch-SLP-off:
${REINPLACE_CMD} -E \
${REINPLACE_CMD} -E -i.bak-SLP \
-e "s|^(.*SLPRegister[[:blank:]]*=[[:blank:]]*)(.*)$$|\10|" \
${WRKSRC}/etc/isnsd.conf
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/isnssetup ${STAGEDIR}${PREFIX}/sbin
${FIND} ${STAGEDIR}${PREFIX}/etc/isns -type f -a -name '*.conf' -exec ${MV} '{}' '{}.sample' ';'
.for FILE in sbin/isnsadm sbin/isnsd sbin/isnsdd lib/libisns.so.0
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${FILE}
.endfor

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1540627511
SHA256 (open-iscsi-open-isns-v0.99-cfdbcff_GH0.tar.gz) = cbfccc69b468cce39ad7cda4800baeca18de91aa363042cc72938f0756b7f218
SIZE (open-iscsi-open-isns-v0.99-cfdbcff_GH0.tar.gz) = 282862
TIMESTAMP = 1612586523
SHA256 (open-iscsi-open-isns-v0.101_GH0.tar.gz) = f672ec86b6c9e984843a7a28d76f07e26393499c486f86034b8b18caa8deb556
SIZE (open-iscsi-open-isns-v0.101_GH0.tar.gz) = 301912

View File

@ -1,34 +0,0 @@
--- Makefile.in.orig 2018-10-27 08:58:20 UTC
+++ Makefile.in
@@ -4,7 +4,7 @@ exec_prefix = @exec_prefix@
sbindir = @sbindir@
mandir = @mandir@
libdir = @libdir@
-etcdir = /etc
+etcdir = $(prefix)/etc
vardir = /var/lib/isns
systemddir = $(prefix)/lib/systemd/system
datarootdir = @datarootdir@
@@ -109,18 +109,16 @@ all: $(LIB) $(SOLIB) isnsd isnsadm isnsd
install:
@echo "*** Installing Open-iSNS ***"
- $(INSTALL) -m 755 -d $(CFGDIR) $(MANDIR)/man8 $(MANDIR)/man5 $(SBINDIR) $(SYSTEMDDIR)
+ $(INSTALL) -m 755 -d $(CFGDIR) $(MANDIR)/man8 $(MANDIR)/man5 $(SBINDIR)
$(INSTALL) -m 700 -d $(VARDIR)
$(INSTALL) -m 555 isnsd isnsadm isnsdd $(SBINDIR)
- $(INSTALL) -m 644 $(srcdir)/etc/isnsd.conf $(CFGDIR)
- $(INSTALL) -m 644 $(srcdir)/etc/isnsdd.conf $(CFGDIR)
- $(INSTALL) -m 644 $(srcdir)/etc/isnsadm.conf $(CFGDIR)
+ $(INSTALL) -m 644 $(srcdir)/etc/isnsd.conf $(CFGDIR)/isnsd.conf.sample
+ $(INSTALL) -m 644 $(srcdir)/etc/isnsdd.conf $(CFGDIR)/isnsdd.conf.sample
+ $(INSTALL) -m 644 $(srcdir)/etc/isnsadm.conf $(CFGDIR)/isnsadm.conf.sample
$(INSTALL) -m 644 $(srcdir)/doc/isnsd.8 $(MANDIR)/man8
$(INSTALL) -m 644 $(srcdir)/doc/isnsdd.8 $(MANDIR)/man8
$(INSTALL) -m 644 $(srcdir)/doc/isnsadm.8 $(MANDIR)/man8
$(INSTALL) -m 644 $(srcdir)/doc/isns_config.5 $(MANDIR)/man5
- $(INSTALL) -m 644 $(srcdir)/isnsd.service $(SYSTEMDDIR)
- $(INSTALL) -m 644 $(srcdir)/isnsd.socket $(SYSTEMDDIR)
install_hdrs:
@echo '*** Installing Open-iSNS header files ***'

View File

@ -1,6 +1,6 @@
--- attrs.c.orig 2018-10-28 09:10:34 UTC
--- attrs.c.orig 2021-02-06 13:40:34 UTC
+++ attrs.c
@@ -777,7 +777,7 @@ isns_attr_decode(buf_t *bp, isns_attr_t
@@ -777,7 +777,7 @@ isns_attr_decode(buf_t *bp, isns_attr_t **result)
{
isns_attr_t *attr = NULL;
isns_value_t *value;

View File

@ -17,7 +17,9 @@ man/man5/isns_config.5.gz
man/man8/isnsadm.8.gz
man/man8/isnsd.8.gz
man/man8/isnsdd.8.gz
man/man8/isnssetup.8.gz
sbin/isnsadm
sbin/isnsd
sbin/isnsdd
sbin/isnssetup
@dir /var/db/isns