- Update to 1.1

- Remove patch committed upstream
- Remove unneeded CXXFLAGS; builds fine on 10.x without them
This commit is contained in:
Jason E. Hale 2014-02-21 05:40:03 +00:00
parent 33ebebdc24
commit 4687827e7a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=345318
4 changed files with 5 additions and 22 deletions

View File

@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= chromaprint
PORTVERSION= 1.0
PORTREVISION= 1
PORTVERSION= 1.1
CATEGORIES= audio
MASTER_SITES= http://bitbucket.org/acoustid/${PORTNAME}/downloads/
@ -23,10 +22,4 @@ post-patch:
${REINPLACE_CMD} -e '/pkgconfig/s|$${LIB_INSTALL_DIR}|libdata|' \
${WRKSRC}/CMakeLists.txt
.include <bsd.port.pre.mk>
.if (${CXX:T} == "clang++" && ${OSVERSION} > 902000) || ${OSVERSION} > 1000054
CXXFLAGS+= -stdlib=libc++ -std=c++11
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (chromaprint-1.0.tar.gz) = af4f780e587ebd7e61a8d175db3bbd63ee644a960bd75e52407a28fd83089f1e
SIZE (chromaprint-1.0.tar.gz) = 541381
SHA256 (chromaprint-1.1.tar.gz) = 6b14d7ea4964581b73bd3f8038c8857c01e446421c1ae99cbbf64de26b47cd12
SIZE (chromaprint-1.1.tar.gz) = 542360

View File

@ -1,10 +0,0 @@
--- src/utils.h.orig 2013-09-21 17:20:43.538723086 +0000
+++ src/utils.h 2013-09-21 17:21:02.622721058 +0000
@@ -30,6 +30,7 @@
#include <stdint.h>
#include <limits>
#include <iterator>
+#include <algorithm> // std::fill
#ifndef HAVE_ROUND
static inline double round(double x)

View File

@ -2,5 +2,5 @@ bin/fpcalc
include/chromaprint.h
lib/libchromaprint.so
lib/libchromaprint.so.0
lib/libchromaprint.so.0.2.1
lib/libchromaprint.so.0.2.2
libdata/pkgconfig/libchromaprint.pc