o Update to version 1.1.4

o PREFIX safeness
o hier(7) police: share/ipa/examples -> share/examples/ipa
o better deinstall:
	- remove all pending directories
	- more graceful removal of startup files
o deploy BSD_INSTALL_* var where appropriate

PR:		29024
Submitted by:	maintainer
This commit is contained in:
Mario Sergio Fujikawa Ferreira 2001-07-31 17:42:34 +00:00
parent daa05435e2
commit 46290e0811
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=45673
4 changed files with 61 additions and 13 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= ipa
PORTVERSION= 1.1.3
PORTVERSION= 1.1.4
CATEGORIES= sysutils
MASTER_SITES= http://www.simon.org.ua/ipa/
@ -19,4 +19,8 @@ MAN5= ipa.5 ipa.conf.5
MAN8= ipa.8 ipastat.8
MANLANG= "" ru_RU.KOI8-R
post-patch:
@${PERL} -pi -ne "s|/usr/local/|${PREFIX}/|" \
${WRKSRC}/Makefile
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (ipa-1.1.3.tar.gz) = 79966745dafd16ce909ade55fb10ffc8
MD5 (ipa-1.1.4.tar.gz) = 996c0d9459c64695971bd6c5b427182d

View File

@ -1,5 +1,5 @@
--- Makefile.orig Sun Jun 24 19:18:49 2001
+++ Makefile Mon Jun 25 23:08:29 2001
--- Makefile.orig Mon Jul 16 15:15:34 2001
+++ Makefile Tue Jul 31 14:36:48 2001
@@ -38,7 +38,7 @@
# -O3 - optimize (it seems that -O3 also help to find out some errors);
# -g - produce debugging information.
@ -9,12 +9,55 @@
#
# DSTBINDIR - where to install binaries
@@ -204,7 +204,7 @@
@@ -63,7 +63,7 @@
#
# DSTSHAREDIR - where to install examples, etc.
#
-DSTSHAREDIR= /usr/local/share/ipa
+DSTSHAREDIR= /usr/local/share/examples/ipa
#
# IP6FW (FreeBSD only)
@@ -204,25 +204,25 @@
@${ECHO}
.else
@${ECHO} ">> Installing binaries, manual pages and miscellaneous files"
- ${INSTALL} -c -g wheel -o root -m 0555 ipa ipastat ${DSTBINDIR}
+ ${INSTALL} -c -s -g wheel -o root -m 0555 ipa ipastat ${DSTBINDIR}
+ ${BSD_INSTALL_PROGRAM} ipa ipastat ${DSTBINDIR}
${CHMOD} u+s ${DSTBINDIR}/ipastat
${INSTALL} -c -g wheel -o root -m 0444 man/ipa.5 man/ipa.conf.5 ${DSTMANDIR}/man5
${INSTALL} -c -g wheel -o root -m 0444 man/ipa.8 man/ipastat.8 ${DSTMANDIR}/man8
- ${INSTALL} -c -g wheel -o root -m 0444 man/ipa.5 man/ipa.conf.5 ${DSTMANDIR}/man5
- ${INSTALL} -c -g wheel -o root -m 0444 man/ipa.8 man/ipastat.8 ${DSTMANDIR}/man8
.if !exists(${DSTMANDIR}/ru_SU.KOI8-R/man5)
${INSTALL} -d -m 0555 ${DSTMANDIR}/ru_SU.KOI8-R/man5
.endif
.if !exists(${DSTMANDIR}/ru_SU.KOI8-R/man8)
${INSTALL} -d -m 0555 ${DSTMANDIR}/ru_SU.KOI8-R/man8
.endif
+ ${BSD_INSTALL_MAN} man/ipa.5 man/ipa.conf.5 ${DSTMANDIR}/man5
+ ${BSD_INSTALL_MAN} man/ipa.8 man/ipastat.8 ${DSTMANDIR}/man8
.if !exists(${DSTMANDIR}/ru_RU.KOI8-R)
${LN} -s ${DSTMANDIR}/ru_SU.KOI8-R ${DSTMANDIR}/ru_RU.KOI8-R
.endif
- ${INSTALL} -c -g wheel -o root -m 0444 man/ru_RU.KOI8-R/ipa.5 man/ru_RU.KOI8-R/ipa.conf.5 ${DSTMANDIR}/ru_RU.KOI8-R/man5
- ${INSTALL} -c -g wheel -o root -m 0444 man/ru_RU.KOI8-R/ipa.8 man/ru_RU.KOI8-R/ipastat.8 ${DSTMANDIR}/ru_RU.KOI8-R/man8
- ${INSTALL} -d -m 0555 ${DSTSHAREDIR}/examples
- ${INSTALL} -c -g wheel -o root -m 0444 examples/* ${DSTSHAREDIR}/examples
+ ${BSD_INSTALL_MAN} man/ru_RU.KOI8-R/ipa.5 man/ru_RU.KOI8-R/ipa.conf.5 ${DSTMANDIR}/ru_RU.KOI8-R/man5
+ ${BSD_INSTALL_MAN} man/ru_RU.KOI8-R/ipa.8 man/ru_RU.KOI8-R/ipastat.8 ${DSTMANDIR}/ru_RU.KOI8-R/man8
+ ${INSTALL} -d -m 0555 ${DSTSHAREDIR}
+ ${BSD_INSTALL_DATA} examples/* ${DSTSHAREDIR}
.if exists(${DSTRCDIR})
- ${INSTALL} -c -g wheel -o root -m 0500 etc/ipa.sh.sample ${DSTRCDIR}
+ ${BSD_INSTALL_DATA} etc/ipa.sh.sample ${DSTRCDIR}
.else
@${ECHO}
@${ECHO} ">> Can't find directory ${DSTRCDIR}, skip installing of ipa.sh.sample"
@@ -230,7 +230,7 @@
@${ECHO}
.endif
.if exists(${DSTETCDIR})
- ${INSTALL} -c -g wheel -o root -m 0400 etc/ipa.conf.default ${DSTETCDIR}
+ ${BSD_INSTALL_DATA} -c -g wheel -o root -m 0400 etc/ipa.conf.default ${DSTETCDIR}
.else
@${ECHO}
@${ECHO} ">> Can't find directory ${DSTETCDIR}, skip installing of ipa.conf.default"

View File

@ -1,9 +1,10 @@
bin/ipa
bin/ipastat
etc/ipa.conf.default
@unexec if [ -f %D/etc/rc.d/ipa.sh ]; then cmp -s %D/etc/rc.d/ipa.sh.sample %D/etc/rc.d/ipa.sh && rm -f %D/etc/rc.d/ipa.sh || echo "If you are permanently removing this port, you should do a ``rm ${PKG_PREFIX}/etc/rc.d/ipa.sh`` to remove startup files left." | fmt ; fi
etc/rc.d/ipa.sh.sample
share/ipa/examples/README
share/ipa/examples/example-1
share/ipa/examples/example-2
@dirrm share/ipa/examples
@dirrm share/ipa
share/examples/ipa/README
share/examples/ipa/example-1
share/examples/ipa/example-2
@dirrm share/examples/ipa
@unexec rmdir %D/man/ru_SU.KOI8-R/man8 %D/man/ru_SU.KOI8-R/man5 %D/man/ru_SU.KOI8-R && rm %D/man/ru_RU.KOI8-R || true