Upgrade to 2.2pl2. Almost of IPv6 patch was merged but netperf still

barks with -DDO_1644.
This commit is contained in:
Munechika SUMIKAWA 2003-01-21 01:02:54 +00:00
parent dbc9c2a5a4
commit 460580a8a4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=73692
15 changed files with 193 additions and 334 deletions

View File

@ -6,15 +6,14 @@
#
PORTNAME= netperf
PORTVERSION= 2.1.3
PORTREVISION= 1
PORTVERSION= 2.2.2
CATEGORIES= benchmarks ipv6
MASTER_SITES= ftp://ftp.cup.hp.com/dist/networking/benchmarks/netperf/%SUBDIR%/
MASTER_SITE_SUBDIR=. archive
DISTNAME= netperf-2.1pl3
DISTNAME= netperf-2.2pl2
PATCH_SITES= ftp://ftp.kame.net/pub/kame/misc/
PATCHFILES= netperf-21pl3-20010302.diff.gz
PATCHFILES= netperf-22pl2-v6-20030121.diff.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= sumikawa@FreeBSD.org
@ -22,15 +21,12 @@ MAINTAINER= sumikawa@FreeBSD.org
MAKEFILE= makefile
MAN1= netperf.1 netserver.1
SCRIPTS= arr_script snapshot_script tcp_range_script tcp_rr_script \
SCRIPTS= arr_script snapshot_script tcp_range_script tcp_rr_script \
tcp_stream_script udp_rr_script udp_stream_script
.include <bsd.port.pre.mk>
BUILD_DEFS+= USE_INET6
.if ${OSVERSION} >= 400014
CFLAGS+= -DDO_IPV6
.endif
post-patch:
.for i in ${SCRIPTS}

View File

@ -1,2 +1,2 @@
MD5 (netperf-2.1pl3.tar.gz) = 08d41c137414adbb26741cae9d1fd86f
MD5 (netperf-21pl3-20010302.diff.gz) = 36dcd1a3d06456e38f4a69a34d7f22e5
MD5 (netperf-2.2pl2.tar.gz) = f6a5b15667bcd5f2fd7ac36bfbf682fa
MD5 (netperf-22pl2-v6-20030121.diff.gz) = 1a879e7a28ead9f845d7a9271bc89690

View File

@ -1,324 +0,0 @@
*** makefile.orig Thu Jul 25 12:54:42 1996
--- makefile Sat Aug 3 12:24:17 1996
***************
*** 15,22 ****
# for the rest of the world, it is probably better to put the binaries
# in /usr/local/netperf or /opt/netperf
#
! #NETPERF_HOME = /usr/local/netperf
! NETPERF_HOME = /opt/netperf
# The compiler on your system might be somewhere else, and/or have
# a different name.
--- 15,22 ----
# for the rest of the world, it is probably better to put the binaries
# in /usr/local/netperf or /opt/netperf
#
! NETPERF_HOME = ${PREFIX}/netperf
! #NETPERF_HOME = /opt/netperf
# The compiler on your system might be somewhere else, and/or have
# a different name.
***************
*** 83,89 ****
# -U__hpux - Use this when compiling _on_ HP-UX *for* an HP-RT system
LOG_FILE=DEBUG_LOG_FILE="\"/tmp/netperf.debug\""
! CFLAGS = -O -D$(LOG_FILE) -DUSE_LOOPER
# Some platforms, and some options, require additional libraries.
# you can add to the "LIBS =" line to accomplish this. if you find
--- 83,89 ----
# -U__hpux - Use this when compiling _on_ HP-UX *for* an HP-RT system
LOG_FILE=DEBUG_LOG_FILE="\"/tmp/netperf.debug\""
! CFLAGS = %CFLAGS% -D$(LOG_FILE) -DUSE_LOOPER -DHISTOGRAM -DDO_UNIX -DDO_1644
# Some platforms, and some options, require additional libraries.
# you can add to the "LIBS =" line to accomplish this. if you find
***************
*** 181,186 ****
--- 181,187 ----
netserver.o: netserver.c nettest_bsd.h netlib.h makefile
install: netperf netserver
+ mkdir -p $(NETPERF_HOME)
chmod -w *.[ch]
chmod +x $(NETPERF_SCRIPTS)
cp netperf $(NETPERF_HOME)
*** netlib.c.orig Thu Jul 25 12:54:36 1996
--- netlib.c Sat Aug 3 12:42:13 1996
***************
*** 1285,1291 ****
dump_request();
fprintf(where,
! "\nsend_request: about to send %ld bytes from %p\n",
sizeof(netperf_request),
&netperf_request);
fflush(where);
--- 1285,1291 ----
dump_request();
fprintf(where,
! "\nsend_request: about to send %d bytes from %p\n",
sizeof(netperf_request),
&netperf_request);
fflush(where);
***************
*** 2785,2791 ****
/* program, but that doesn't really seem worthwhile - raj 4/95 */
if (debug > 1) {
fprintf(where,
! "Looper child %d is born, pid %d\n",
child_index,
getpid());
fflush(where);
--- 2785,2791 ----
/* program, but that doesn't really seem worthwhile - raj 4/95 */
if (debug > 1) {
fprintf(where,
! "Looper child %d is born, pid %ld\n",
child_index,
getpid());
fflush(where);
*** netlib.h.orig Thu Jul 25 12:54:36 1996
--- netlib.h Sat Aug 3 12:16:21 1996
***************
*** 262,267 ****
--- 262,268 ----
extern int dl_open();
extern char format_cpu_method();
extern unsigned int convert();
+ extern int delta_micro();
/* these are all for the confidence interval stuff */
extern double confidence;
***************
*** 274,279 ****
--- 275,285 ----
#define HAVE_BCOPY
#define HAVE_BZERO
#endif
+
+ #if defined(__FreeBSD__) || defined(__NetBSD__)
+ #define HAVE_BCOPY
+ #define HAVE_BZERO
+ #endif /* __FreeBSD__ || __NetBSD__ */
#ifndef HAVE_BCOPY
#define bcopy(s,d,h) memcpy((d),(s),(h))
*** netserver.c.orig Thu Jul 25 12:54:36 1996
--- netserver.c Sat Aug 3 12:16:21 1996
***************
*** 405,411 ****
fclose(stdin);
fclose(stderr);
/* can I just use setsid on all systems? raj 4/96 */
! #if defined(__NetBSD__) || defined(__bsdi__) || defined(sun) || defined(__FREEBSD__)
setsid();
#else
setpgrp();
--- 405,411 ----
fclose(stdin);
fclose(stderr);
/* can I just use setsid on all systems? raj 4/96 */
! #if defined(__NetBSD__) || defined(__bsdi__) || defined(sun) || defined(__FreeBSD__)
setsid();
#else
setpgrp();
*** netsh.h.orig Thu Jul 25 12:54:36 1996
--- netsh.h Sat Aug 3 12:16:21 1996
***************
*** 28,34 ****
#define REM_SEND_ALIGN 4 /* alignment for remote sends */
/* misc defines for the hell of it */
! #define MAXLONG 4294967295L
#ifndef NETSH
/* stuff to say where this test is going */
--- 28,34 ----
#define REM_SEND_ALIGN 4 /* alignment for remote sends */
/* misc defines for the hell of it */
! #define MAXLONG 4294967295LU
#ifndef NETSH
/* stuff to say where this test is going */
*** nettest_bsd.c.orig Thu Jul 25 12:54:37 1996
--- nettest_bsd.c Sat Aug 3 12:16:22 1996
***************
*** 54,59 ****
--- 54,60 ----
#include <netinet/in.h>
#include <netinet/tcp.h>
#include <netdb.h>
+ #include <sys/param.h>
#else /* WIN32 */
#include <process.h>
#include <windows.h>
***************
*** 64,69 ****
--- 65,75 ----
#include "netlib.h"
#include "netsh.h"
#include "nettest_bsd.h"
+
+ #ifdef BSD
+ #include <sys/time.h>
+ #include <arpa/inet.h>
+ #endif /* BSD */
#ifdef HISTOGRAM
#include "hist.h"
*** nettest_unix.c.orig Thu Jul 25 12:54:39 1996
--- nettest_unix.c Sat Aug 3 12:16:22 1996
***************
*** 45,51 ****
#include <string.h>
#include <time.h>
#include <unistd.h>
! #ifndef __bsdi__
#include <malloc.h>
#endif
--- 45,52 ----
#include <string.h>
#include <time.h>
#include <unistd.h>
! #include <sys/param.h>
! #ifndef BSD
#include <malloc.h>
#endif
*** snapshot_script.orig Thu Jul 25 12:54:35 1996
--- snapshot_script Sat Aug 3 12:16:22 1996
***************
*** 34,40 ****
#
# where is netperf installed, there are a few possible places:
! NETPERF_CMD=${NETPERF_CMD:=/opt/netperf/netperf}
# there should be no more than two parms passed
--- 34,40 ----
#
# where is netperf installed, there are a few possible places:
! NETPERF_CMD=${NETPERF_CMD:=%%PREFIX%%/netperf/netperf}
# there should be no more than two parms passed
*** tcp_range_script.orig Thu Jul 25 12:54:35 1996
--- tcp_range_script Sat Aug 3 12:16:23 1996
***************
*** 43,49 ****
# where is netperf, and are there any "constant" options such as
# the netserver port number
#NETHOME=/usr/etc/net_perf
! NETHOME="."
NETPERF=$NETHOME/netperf $PORT
# How accurate we want the estimate of performance:
--- 43,49 ----
# where is netperf, and are there any "constant" options such as
# the netserver port number
#NETHOME=/usr/etc/net_perf
! NETHOME="%%PREFIX%%/netperf"
NETPERF=$NETHOME/netperf $PORT
# How accurate we want the estimate of performance:
*** tcp_rr_script.orig Thu Jul 25 12:54:35 1996
--- tcp_rr_script Sat Aug 3 12:16:23 1996
***************
*** 23,31 ****
fi
# where the programs are
! #NETHOME=/usr/local/netperf
#NETHOME="/opt/netperf"
! NETHOME=.
# at what port will netserver be waiting? If you decide to run
# netserver at a differnet port than the default of 12865, then set
--- 23,31 ----
fi
# where the programs are
! NETHOME=%%PREFIX%%/netperf
#NETHOME="/opt/netperf"
! #NETHOME=.
# at what port will netserver be waiting? If you decide to run
# netserver at a differnet port than the default of 12865, then set
*** tcp_stream_script.orig Thu Jul 25 12:54:34 1996
--- tcp_stream_script Sat Aug 3 12:16:23 1996
***************
*** 22,30 ****
fi
# where the programs are
! #NETHOME=/usr/local/netperf
#NETHOME="/opt/netperf"
! NETHOME=.
# at what port will netserver be waiting? If you decide to run
# netserver at a differnet port than the default of 12865, then set
--- 22,30 ----
fi
# where the programs are
! NETHOME=%%PREFIX%%/netperf
#NETHOME="/opt/netperf"
! #NETHOME=.
# at what port will netserver be waiting? If you decide to run
# netserver at a differnet port than the default of 12865, then set
*** udp_rr_script.orig Thu Jul 25 12:54:35 1996
--- udp_rr_script Sat Aug 3 12:16:23 1996
***************
*** 20,28 ****
# where the programs are
! #NETHOME=/usr/local/netperf
#NETHOME="/opt/netperf"
! NETHOME="."
# at what port will netserver be waiting? If you decide to run
# netserver at a differnet port than the default of 12865, then set
--- 20,28 ----
# where the programs are
! NETHOME=%%PREFIX%%/netperf
#NETHOME="/opt/netperf"
! #NETHOME="."
# at what port will netserver be waiting? If you decide to run
# netserver at a differnet port than the default of 12865, then set
*** udp_stream_script.orig Thu Jul 25 12:54:34 1996
--- udp_stream_script Sat Aug 3 12:16:23 1996
***************
*** 17,25 ****
# where the programs are
! #NETHOME=/usr/local/netperf
#NETHOME="/opt/netperf"
! NETHOME="."
# at what port will netserver be waiting? If you decide to run
# netserver at a differnet port than the default of 12865, then set
--- 17,25 ----
# where the programs are
! NETHOME=%%PREFIX%%/netperf
#NETHOME="/opt/netperf"
! #NETHOME="."
# at what port will netserver be waiting? If you decide to run
# netserver at a differnet port than the default of 12865, then set

View File

@ -0,0 +1,23 @@
--- makefile 21 Jan 2003 00:28:51 -0000 1.7
+++ makefile 21 Jan 2003 00:44:57 -0000
@@ -15,8 +15,8 @@
# for the rest of the world, it is probably better to put the binaries
# in /usr/local/netperf or /opt/netperf
#
-#NETPERF_HOME = /usr/local/netperf
-NETPERF_HOME = /opt/netperf
+NETPERF_HOME = ${PREFIX}/netperf
+#NETPERF_HOME = /opt/netperf
# The compiler on your system might be somewhere else, and/or have
# a different name.
@@ -91,7 +91,8 @@
#
LOG_FILE=DEBUG_LOG_FILE="\"/tmp/netperf.debug\""
-CFLAGS = -Ae -O -D$(LOG_FILE) -DUSE_PSTAT -DHAVE_SENDFILE -DDO_FIRST_BURST
+CFLAGS = %CFLAGS% -D$(LOG_FILE) -DDO_FIRST_BURST #-DHAVE_SENDFILE
+CFLAGS+= -DHISTOGRAM -DDO_UNIX -DDO_1644 -DO_IPV6
# Some platforms, and some options, require additional libraries.
# you can add to the "LIBS =" line to accomplish this. if you find

View File

@ -0,0 +1,20 @@
--- netlib.c 21 Jan 2003 00:28:51 -0000 1.4
+++ netlib.c 21 Jan 2003 00:45:01 -0000
@@ -1414,7 +1414,7 @@
dump_request();
fprintf(where,
- "\nsend_request: about to send %ld bytes from %p\n",
+ "\nsend_request: about to send %d bytes from %p\n",
sizeof(netperf_request),
&netperf_request);
fflush(where);
@@ -3305,7 +3305,7 @@
/* program, but that doesn't really seem worthwhile - raj 4/95 */
if (debug > 1) {
fprintf(where,
- "Looper child %d is born, pid %d\n",
+ "Looper child %d is born, pid %ld\n",
child_index,
getpid());
fflush(where);

View File

@ -0,0 +1,22 @@
--- netlib.h 21 Jan 2003 00:26:13 -0000 1.1.1.3
+++ netlib.h 21 Jan 2003 00:45:02 -0000
@@ -305,6 +305,7 @@
extern int dl_open();
extern char format_cpu_method();
extern unsigned int convert();
+extern int delta_micro();
/* these are all for the confidence interval stuff */
extern double confidence;
@@ -317,6 +318,11 @@
#define HAVE_BCOPY
#define HAVE_BZERO
#endif
+
+#if defined(__FreeBSD__) || defined(__NetBSD__)
+#define HAVE_BCOPY
+#define HAVE_BZERO
+#endif /* __FreeBSD__ || __NetBSD__ */
#ifndef HAVE_BCOPY
#define bcopy(s,d,h) memcpy((d),(s),(h))

View File

@ -0,0 +1,10 @@
--- netperf.c~ Fri Jun 21 22:42:53 2002
+++ netperf.c Tue Jan 21 00:55:34 2003
@@ -47,6 +47,7 @@
#include <stdio.h>
#include <stdlib.h>
+#include <sys/types.h>
#ifdef WIN32
#include <windows.h>

View File

@ -0,0 +1,22 @@
--- nettest_bsd.c 21 Jan 2003 00:26:14 -0000 1.1.1.3
+++ nettest_bsd.c 21 Jan 2003 00:45:17 -0000
@@ -58,6 +58,7 @@
#include <netinet/in.h>
#include <netinet/tcp.h>
#include <netdb.h>
+#include <sys/param.h>
#else /* WIN32 */
#include <process.h>
#include <windows.h>
@@ -68,6 +69,11 @@
#include "netlib.h"
#include "netsh.h"
#include "nettest_bsd.h"
+
+#ifdef BSD
+#include <sys/time.h>
+#include <arpa/inet.h>
+#endif /* BSD */
#ifdef HISTOGRAM
#ifdef __sgi

View File

@ -0,0 +1,12 @@
--- nettest_unix.c 10 Mar 2001 13:04:39 -0000 1.1.1.2
+++ nettest_unix.c 21 Jan 2003 00:45:21 -0000
@@ -45,7 +45,8 @@
#include <string.h>
#include <time.h>
#include <unistd.h>
-#ifndef __bsdi__
+#include <sys/param.h>
+#ifndef BSD
#include <malloc.h>
#endif

View File

@ -0,0 +1,11 @@
--- snapshot_script 2 Aug 1999 12:01:24 -0000 1.1.1.1
+++ snapshot_script 21 Jan 2003 00:45:21 -0000
@@ -37,7 +37,7 @@
#
# where is netperf installed, there are a few possible places:
-NETPERF_CMD=${NETPERF_CMD:=/opt/netperf/netperf}
+NETPERF_CMD=${NETPERF_CMD:=%%PREFIX%%/netperf/netperf}
# there should be no more than two parms passed

View File

@ -0,0 +1,11 @@
--- tcp_range_script 2 Aug 1999 12:01:24 -0000 1.1.1.1
+++ tcp_range_script 21 Jan 2003 00:45:21 -0000
@@ -43,7 +43,7 @@
# where is netperf, and are there any "constant" options such as
# the netserver port number
#NETHOME=/usr/etc/net_perf
-NETHOME="."
+NETHOME="%%PREFIX%%/netperf"
NETPERF=$NETHOME/netperf $PORT
# How accurate we want the estimate of performance:

View File

@ -0,0 +1,14 @@
--- tcp_rr_script 2 Aug 1999 12:01:24 -0000 1.1.1.1
+++ tcp_rr_script 21 Jan 2003 00:45:21 -0000
@@ -23,9 +23,9 @@
fi
# where the programs are
-#NETHOME=/usr/local/netperf
+NETHOME=%%PREFIX%%/netperf
#NETHOME="/opt/netperf"
-NETHOME=.
+#NETHOME=.
# at what port will netserver be waiting? If you decide to run
# netserver at a differnet port than the default of 12865, then set

View File

@ -0,0 +1,14 @@
--- tcp_stream_script 2 Aug 1999 12:01:23 -0000 1.1.1.1
+++ tcp_stream_script 21 Jan 2003 00:45:21 -0000
@@ -22,9 +22,9 @@
fi
# where the programs are
-#NETHOME=/usr/local/netperf
+NETHOME=%%PREFIX%%/netperf
#NETHOME="/opt/netperf"
-NETHOME=.
+#NETHOME=.
# at what port will netserver be waiting? If you decide to run
# netserver at a differnet port than the default of 12865, then set

View File

@ -0,0 +1,14 @@
--- udp_rr_script 2 Aug 1999 12:01:24 -0000 1.1.1.1
+++ udp_rr_script 21 Jan 2003 00:45:21 -0000
@@ -20,9 +20,9 @@
# where the programs are
-#NETHOME=/usr/local/netperf
+NETHOME=%%PREFIX%%/netperf
#NETHOME="/opt/netperf"
-NETHOME="."
+#NETHOME="."
# at what port will netserver be waiting? If you decide to run
# netserver at a differnet port than the default of 12865, then set

View File

@ -0,0 +1,14 @@
--- udp_stream_script 2 Aug 1999 12:01:23 -0000 1.1.1.1
+++ udp_stream_script 21 Jan 2003 00:45:21 -0000
@@ -17,9 +17,9 @@
# where the programs are
-#NETHOME=/usr/local/netperf
+NETHOME=%%PREFIX%%/netperf
#NETHOME="/opt/netperf"
-NETHOME="."
+#NETHOME="."
# at what port will netserver be waiting? If you decide to run
# netserver at a differnet port than the default of 12865, then set