Introduce latest version of expat.
This development version will be released as 2.0 and maintained on sourceforge. Submitted by: Naoki IDO <ido@hitachi-ms.co.jp> Repo-copied by: PW
This commit is contained in:
parent
beb0bdaed0
commit
46022e220c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=34165
@ -6,34 +6,25 @@
|
||||
#
|
||||
|
||||
PORTNAME= expat
|
||||
PORTVERSION= 1.2
|
||||
PORTVERSION= 1.95.1
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ftp://ftp.jclark.com/pub/xml/
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= expat
|
||||
|
||||
MAINTAINER= knu@FreeBSD.org
|
||||
MAINTAINER= kuriyama@FreeBSD.org
|
||||
|
||||
SHLIB_MAJOR= 1
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-shared --enable-static
|
||||
USE_LIBTOOL= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
INSTALLS_SHLIBS= yes
|
||||
|
||||
SHLIB_MAJOR= 0
|
||||
|
||||
MAKEFILES= Makefile.lib Makefile.prog
|
||||
MAKE_ARGS= SHLIB_MAJOR="${SHLIB_MAJOR}" NOPROFILE=true
|
||||
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
|
||||
|
||||
do-build:
|
||||
.for f in ${MAKEFILES}
|
||||
${CP} ${FILESDIR}/${f} ${WRKSRC}/
|
||||
.endfor
|
||||
${MV} ${WRKSRC}/xmlwf/* ${WRKSRC}/
|
||||
${RMDIR} ${WRKSRC}/xmlwf
|
||||
.for f in ${MAKEFILES}
|
||||
@(cd ${WRKSRC}; \
|
||||
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${f} ${MAKE_ARGS} ${ALL_TARGET})
|
||||
.endfor
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/include/xml
|
||||
.for f in ${MAKEFILES}
|
||||
@(cd ${WRKSRC}; \
|
||||
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${f} ${MAKE_ARGS} ${INSTALL_TARGET})
|
||||
.endfor
|
||||
post-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/xmlwf/xmlwf ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (expat-1.2.tar.gz) = 9e3ecda3493f73fbc6632a00f8e42724
|
||||
MD5 (expat-1.95.1.tar.gz) = 113ebbf7efaf7179d869341cbb2879f7
|
||||
|
11
textproc/expat2/files/patch-aa
Normal file
11
textproc/expat2/files/patch-aa
Normal file
@ -0,0 +1,11 @@
|
||||
--- Makefile.in.orig Sat Sep 30 00:54:52 2000
|
||||
+++ Makefile.in Thu Oct 12 00:04:32 2000
|
||||
@@ -76,7 +76,7 @@
|
||||
RANLIB = @RANLIB@
|
||||
VERSION = @VERSION@
|
||||
|
||||
-SUBDIRS = lib
|
||||
+SUBDIRS = lib xmlwf
|
||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
||||
CONFIG_HEADERS = config.h:config.hin
|
||||
|
10
textproc/expat2/files/patch-ab
Normal file
10
textproc/expat2/files/patch-ab
Normal file
@ -0,0 +1,10 @@
|
||||
--- xmlwf/Makefile.in.orig Sat Sep 30 00:54:54 2000
|
||||
+++ xmlwf/Makefile.in Thu Oct 12 00:42:22 2000
|
||||
@@ -11,5 +11,7 @@
|
||||
xmlwf: $(OBJS)
|
||||
$(CC) -o xmlwf $(LDFLAGS) $(OBJS) $(LIBS)
|
||||
|
||||
+install:
|
||||
+
|
||||
clean:
|
||||
rm -f xmlwf core *.o
|
@ -1,4 +1,4 @@
|
||||
Expat is an XML 1.0 parser written in C. It aims to be fully
|
||||
conforming. It is currently not a validating XML processor.
|
||||
|
||||
WWW: http://www.jclark.com/xml/expat.html
|
||||
WWW: http://sourceforge.net/projects/expat/
|
||||
|
@ -1,7 +1,5 @@
|
||||
bin/xmlwf
|
||||
include/xml/xmlparse.h
|
||||
include/xml/xmltok.h
|
||||
include/expat.h
|
||||
lib/libexpat.a
|
||||
lib/libexpat.so
|
||||
lib/libexpat.so.%%SHLIB_MAJOR%%
|
||||
@dirrm include/xml
|
||||
|
Loading…
Reference in New Issue
Block a user