- Update to 1.0.1

PR:		207672
Submitted by:	yuri@rawbw.com(maintainer)
This commit is contained in:
Wen Heping 2016-03-06 02:14:06 +00:00
parent ad3a2293bc
commit 4541947007
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=410226
3 changed files with 10 additions and 22 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pynacl
PORTVERSION= 0.3.0
PORTVERSION= 1.0.1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -14,15 +14,17 @@ COMMENT= PyNaCl is a Python binding to the Networking and Cryptography library
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/lib/libnacl.a:${PORTSDIR}/security/nacl \
${PYTHON_PKGNAMEPREFIX}cffi>0:${PORTSDIR}/devel/py-cffi
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>0:${PORTSDIR}/devel/py-cffi
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>0:${PORTSDIR}/devel/py-cffi \
${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six
BUILD_DEPENDS= ${RUN_DEPENDS}
LIB_DEPENDS= libsodium.so:${PORTSDIR}/security/libsodium
USES= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
MAKE_ENV+= SODIUM_INSTALL=system
CFLAGS+= -I ${LOCALBASE}/include
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/nacl/_lib/_cffi__xfc5fefe5xfb751af7.so
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/nacl/_sodium.so
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (PyNaCl-0.3.0.tar.gz) = 124997314455605f61afae6cf8b99b32d10f2dba22f114acb4c80d352eed76c2
SIZE (PyNaCl-0.3.0.tar.gz) = 2569604
SHA256 (PyNaCl-1.0.1.tar.gz) = d21d7a7358a85fb9b9ddadfbd1176c40fe199334fe2202881255e77f6d3773f4
SIZE (PyNaCl-1.0.1.tar.gz) = 2710876

View File

@ -1,14 +0,0 @@
--- setup.py.orig 2015-03-04 07:00:53 UTC
+++ setup.py
@@ -167,9 +167,10 @@ class build_clib(_build_clib):
build_temp = os.path.abspath(self.build_temp)
# Ensure our temporary build directory exists
+ print("YURI build_temp="+build_temp)
try:
os.makedirs(build_temp)
- except IOError:
+ except:
pass
# Ensure all of our executanle files have their permission set