Add p5-Schedule-At (OS independent interface to the Unix 'at' command).

This commit is contained in:
Jun Kuriyama 2001-01-10 03:04:46 +00:00
parent 00a8c6dd4e
commit 453b6391fc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=37053
8 changed files with 82 additions and 0 deletions

View File

@ -73,6 +73,7 @@
SUBDIR += nwclient
SUBDIR += obliterate
SUBDIR += p5-Quota
SUBDIR += p5-Schedule-At
SUBDIR += p5-Schedule-Cron
SUBDIR += p5-Schedule-Match
SUBDIR += p5-SyslogScan

View File

@ -0,0 +1,23 @@
# New ports collection makefile for: p5-Schedule-At
# Date created: 10th Jan 2001
# Whom: kuriyama
#
# $FreeBSD$
#
PORTNAME= Schedule-At
PORTVERSION= 1.02
CATEGORIES= sysutils perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Schedule
PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
USE_PERL5= yes
PERL_CONFIGURE= yes
MAN3= Schedule::At.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (Schedule-At-1.02.tar.gz) = 2aed5f342888901be63b67751620ed1b

View File

@ -0,0 +1,27 @@
--- At.pm.orig Thu Feb 12 20:08:37 1998
+++ At.pm Wed Jan 10 11:56:50 2001
@@ -264,6 +264,7 @@
Jose A. Rodriguez (josear@ac.upc.es)
=cut
+#' for Emacs face
###############################################################################
# OS dependent code
@@ -330,4 +331,16 @@
$AT{'getCommand'} = 'at -c %JOBID% |';
$AT{'parseJobList'} =
sub { (substr($_[0], 27), substr($_[0], 0, 17)) } ;
+}
+
+sub AtCfg_freebsd {
+ $AT{'add'} = 'at %TIME% 2> /dev/null';
+ $AT{'addFile'} = 'at -f %FILE% %TIME% 2> /dev/null';
+ $AT{'timeFormat'} = '%HOUR%:%MINS% %MONTH%/%DAY%/%YEAR%';
+ $AT{'remove'} = 'atrm %JOBID%';
+ $AT{'getJobs'} = 'atq';
+ $AT{'headings'} = ['Date'];
+ $AT{'getCommand'} = 'at -c %JOBID% |';
+ $AT{'parseJobList'} =
+ sub { my @a = split(/\s+/, $_[0]); ("$a[0] $a[1]", $a[4]) } ;
}

View File

@ -0,0 +1,11 @@
--- t1.t.orig Thu Feb 12 19:59:26 1998
+++ t1.t Wed Jan 10 12:00:00 2001
@@ -28,7 +28,7 @@
print "ok 3\n";
my %atJobs = Schedule::At::getJobs();
-print "not " if !defined(%atJobs);
+print "not " if (not %atJobs);
print "ok 4\n";
$rv = Schedule::At::remove (TAG => 'Schedule::At');

View File

@ -0,0 +1 @@
OS independent interface to the Unix 'at' command

View File

@ -0,0 +1,4 @@
This modules provides an OS independent interface to 'at', the Unix
command that allows you to execute commands at a specified time.
WWW: http://search.cpan.org/search?dist=Schedule-At

View File

@ -0,0 +1,14 @@
lib/perl5/site_perl/%%PERL_VER%%/Schedule/At.pm
lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule/At/AtCfg.al
lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule/At/AtCfg_dec_osf.al
lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule/At/AtCfg_hpux.al
lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule/At/AtCfg_linux.al
lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule/At/AtCfg_solaris.al
lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule/At/AtCfg_sunos.al
lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule/At/autosplit.ix
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Schedule/At/.packlist
@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule/At
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Schedule/At
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Schedule 2>/dev/null || true
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule 2>/dev/null || true
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Schedule 2>/dev/null || true