- Update to 0.7.0 with the following changes:

* Manual cropping and scaling
  * Custom temporary directory
  * Rip from DVD structure
  * Minor UI redesign
  * Many many fixes

- Add a patch to fix the issue that caused error messages to be displayed in
  the console (incorrect cast) [1]

Obtained from:	Olivier Rolland <billl@users.sourceforge.net> (author) [1]
This commit is contained in:
Herve Quiroz 2005-02-24 02:04:26 +00:00
parent 0601a51252
commit 453ac91de6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=129631
4 changed files with 46 additions and 3 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= ogmrip
PORTVERSION= 0.6.2
PORTVERSION= 0.7.0
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -35,6 +35,14 @@ CONFIGURE_ARGS= --sharedstatedir=${PREFIX}/libdata
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/bin/mkvmerge)
BUILD_DEPENDS+= mkvmerge:${PORTSDIR}/multimedia/mkvtoolnix
RUN_DEPENDS+= mkvmerge:${PORTSDIR}/multimedia/mkvtoolnix
PLIST_SUB+= MKV_SUPPORT=""
.else
PLIST_SUB+= MKV_SUPPORT="@comment "
.endif
post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
${WRKSRC}/data/Makefile.in

View File

@ -1,2 +1,2 @@
MD5 (ogmrip-0.6.2.tar.gz) = c5a209a82d635523cdf43c5e35a30cd2
SIZE (ogmrip-0.6.2.tar.gz) = 469266
MD5 (ogmrip-0.7.0.tar.gz) = 6e29e1de82d4254620eab5f90ffd0903
SIZE (ogmrip-0.7.0.tar.gz) = 488594

View File

@ -0,0 +1,31 @@
$FreeBSD$
--- src/ogmrip-pref.c.orig 2005-02-24 02:25:46.143332080 +0100
+++ src/ogmrip-pref.c 2005-02-24 02:27:45.306216568 +0100
@@ -124,22 +124,22 @@
}
static void
-ogmrip_pref_output_dir_notified (GConfClient *gconf, guint id, GConfEntry *entry, GtkWidget *label)
+ogmrip_pref_output_dir_notified (GConfClient *gconf, guint id, GConfEntry *entry, GtkWidget *widget)
{
/*
* Sanity checks
*/
- gtk_label_set_text (GTK_LABEL (label),
+ gtk_entry_set_text (GTK_ENTRY (widget),
gconf_value_get_string (entry->value));
}
static void
-ogmrip_pref_tmp_dir_notified (GConfClient *gconf, guint id, GConfEntry *entry, GtkWidget *label)
+ogmrip_pref_tmp_dir_notified (GConfClient *gconf, guint id, GConfEntry *entry, GtkWidget *widget)
{
/*
* Sanity checks
*/
- gtk_label_set_text (GTK_LABEL (label),
+ gtk_entry_set_text (GTK_ENTRY (widget),
gconf_value_get_string (entry->value));
}

View File

@ -10,6 +10,7 @@ include/ogmrip/ogmrip-codec.h
include/ogmrip/ogmrip-lavc.h
include/ogmrip/ogmrip-merge.h
include/ogmrip/ogmrip-misc.h
%%MKV_SUPPORT%%include/ogmrip/ogmrip-mkv.h
include/ogmrip/ogmrip-mp3.h
include/ogmrip/ogmrip-mux.h
include/ogmrip/ogmrip-split.h
@ -19,6 +20,7 @@ include/ogmrip/ogmrip-tools.h
include/ogmrip/ogmrip-video.h
include/ogmrip/ogmrip-vobsub.h
include/ogmrip/ogmrip-vorbis.h
include/ogmrip/ogmrip-theora.h
include/ogmrip/ogmrip-wav.h
include/ogmrip/ogmrip-xvid.h
include/ogmrip/ogmrip.h
@ -42,7 +44,9 @@ libdata/pkgconfig/ogmdvd.pc
libdata/pkgconfig/ogmrip.pc
libdata/pkgconfig/ogmspawn.pc
share/applications/ogmrip.desktop
%%DATADIR%%/ogmrip-crop.glade
%%DATADIR%%/ogmrip-main.glade
%%DATADIR%%/ogmrip-options.glade
%%DATADIR%%/ogmrip-pref.glade
%%DATADIR%%/ogmrip-progress.glade
%%DATADIR%%/ogmrip-spell.glade