Fix build with LibreSSL

PR:		198754
Submitted by:	spil.oss@gmail.com
This commit is contained in:
Emanuel Haupt 2015-03-22 20:52:24 +00:00
parent 8200917f4b
commit 450cc4619f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=381960

View File

@ -1,5 +1,5 @@
--- ./Makefile.orig 2008-03-13 16:10:21.000000000 +0100
+++ ./Makefile 2008-03-13 16:10:39.000000000 +0100
--- Makefile.orig 2008-02-26 23:31:08 UTC
+++ Makefile
@@ -5,7 +5,7 @@
CC ?= cc
CFLAGS ?= -Wall -O2 -ggdb
@ -9,3 +9,19 @@
# Comment on non-gnu systems
OPTFLAGS += -DHAVE_GETOPT_LONG
@@ -38,13 +38,14 @@ OPTFLAGS += -DSO_REUSEPORT
# END system dependant block
SSL_LIBS := $(shell pkg-config --libs libssl 2>/dev/null)
+CRYPTO_LIBS := $(shell pkg-config --libs libcrypto 2>/dev/null)
ifeq ($(SSL_LIBS),)
SSL_LIBS := $(shell pkg-config --libs openssl 2>/dev/null)
endif
ifeq ($(SSL_LIBS),)
SSL_LIBS := -lssl -lcrypto
endif
-LDFLAGS += $(SSL_LIBS)
+LDFLAGS += $(SSL_LIBS) $(CRYPTO_LIBS)
PREFIX =/usr/local
BINDIR = $(PREFIX)/bin