Update to 1.4p2.
This commit is contained in:
parent
be13988225
commit
44f8659a1b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=95083
@ -6,27 +6,27 @@
|
||||
#
|
||||
|
||||
PORTNAME= mathopd
|
||||
PORTVERSION= 1.3p7
|
||||
PORTVERSION= 1.4p2
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.mathopd.org/dist/ \
|
||||
ftp://ftp.prima.eu.org/pub/mirrored_files/mathop.diva.nl/ \
|
||||
http://www.tobez.org/download/port-mirrors/www/mathopd/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/p/pl/}
|
||||
|
||||
MAINTAINER= tobez@FreeBSD.org
|
||||
COMMENT= A very small, yet very fast HTTP server
|
||||
|
||||
DOCS= CHANGES cgi.txt config.txt processing.txt running.txt sample.cfg syntax.txt
|
||||
|
||||
post-install:
|
||||
@${INSTALL_DATA} ${FILESDIR}/mathopd.conf.sample ${PREFIX}/etc
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/sample.cfg ${PREFIX}/etc/mathopd.conf.sample
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/mathopd
|
||||
@${INSTALL_DATA} ${WRKSRC}/CHANGES ${PREFIX}/share/doc/mathopd
|
||||
@${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/mathopd
|
||||
@${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/mathopd
|
||||
.for df in ${DOCS}
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/${df} ${PREFIX}/share/doc/mathopd
|
||||
.endfor
|
||||
.endif
|
||||
@if [ ! -f ${PREFIX}/etc/rc.d/mathopd.sh ]; then \
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/mathopd.sh ${PREFIX}/etc/rc.d/mathopd.sh; \
|
||||
fi
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/mathopd.sh ${PREFIX}/etc/rc.d/mathopd.sh-dist
|
||||
@${SED} -e 's,/usr/local,${PREFIX},g' ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (mathopd-1.3pl7.tar.gz) = 6adb0679c7d749ba33237cc58b92b388
|
||||
MD5 (mathopd-1.4p2.tar.gz) = 6d319309636e0f5a0149a2599546a18f
|
||||
|
@ -1,123 +0,0 @@
|
||||
Umask 026
|
||||
|
||||
Tuning {
|
||||
NumConnections 120
|
||||
BufSize 12288
|
||||
}
|
||||
|
||||
User daemon
|
||||
StayRoot On
|
||||
|
||||
PIDFile /tmp/mathopd/pid
|
||||
Log /tmp/mathopd/log.%Y%m%d
|
||||
ErrorLog /tmp/mathopd/errors.%Y%m
|
||||
|
||||
Control {
|
||||
Symlinks On
|
||||
Types {
|
||||
text/plain { * }
|
||||
text/css { css }
|
||||
application/octet-stream { zip gz tgz exe class }
|
||||
application/futuresplash { spl }
|
||||
model/vrml { wrl }
|
||||
application/pdf { pdf }
|
||||
text/html { html htm }
|
||||
image/gif { gif }
|
||||
image/jpeg { jpg }
|
||||
}
|
||||
Specials {
|
||||
Imagemap { map }
|
||||
CGI { cgi }
|
||||
Redirect { url }
|
||||
}
|
||||
External {
|
||||
/usr/bin/perl { pl }
|
||||
}
|
||||
IndexNames { home.html index.htm index.html redirect.url }
|
||||
}
|
||||
|
||||
DefaultName localtoast
|
||||
|
||||
Server {
|
||||
Port 8080
|
||||
|
||||
Virtual {
|
||||
Control {
|
||||
Alias /
|
||||
Location /home/www/oldclients
|
||||
}
|
||||
}
|
||||
|
||||
Virtual {
|
||||
Host localhost
|
||||
Control {
|
||||
Alias /
|
||||
Location /home/www/localhost
|
||||
}
|
||||
Control {
|
||||
Alias /protected
|
||||
Location /home/www/localhost/protected
|
||||
Realm "Protected Area"
|
||||
UserFile /home/www/htpasswd
|
||||
}
|
||||
}
|
||||
|
||||
Virtual {
|
||||
Host www.domain.com
|
||||
Control {
|
||||
Alias /
|
||||
Location /home/w/www/www.domain.com
|
||||
}
|
||||
Control {
|
||||
Alias /~
|
||||
Location http://www2.domain.com/~
|
||||
}
|
||||
}
|
||||
|
||||
Virtual {
|
||||
Host www3.domain.com
|
||||
Control {
|
||||
Alias /
|
||||
Location /home/www/www3.domain.com
|
||||
}
|
||||
}
|
||||
|
||||
Virtual {
|
||||
Host www4.domain.com
|
||||
Control {
|
||||
Alias /
|
||||
Location /home/www/www4.domain.com
|
||||
}
|
||||
Control {
|
||||
Alias /cgi-bin
|
||||
Location /home/www/www4.domain.com/cgi-bin
|
||||
Specials {
|
||||
CGI { * }
|
||||
}
|
||||
}
|
||||
}
|
||||
|
||||
Virtual {
|
||||
Host www5.domain.com
|
||||
Control {
|
||||
Alias /
|
||||
Location /home/www/www5.domain.com/silly.html
|
||||
PathArgs On
|
||||
}
|
||||
Control {
|
||||
Alias /private
|
||||
Location /home/www/www5.domain.com/private
|
||||
Access {
|
||||
Deny 0/0
|
||||
Allow 127.0.0.1/32
|
||||
Allow 192.168.57.0/24
|
||||
}
|
||||
}
|
||||
Control {
|
||||
Alias /funky
|
||||
Location /home/www/www5.domain.com/funky
|
||||
Refresh 300
|
||||
}
|
||||
}
|
||||
|
||||
}
|
@ -1,32 +1,48 @@
|
||||
--- Makefile.orig Fri Dec 17 11:09:22 1999
|
||||
+++ Makefile Fri Dec 17 11:09:08 1999
|
||||
@@ -1,23 +1,7 @@
|
||||
-BIN=mathopd
|
||||
-CC=gcc
|
||||
-CFLAGS=-O -Wall
|
||||
-CPPFLAGS=
|
||||
-LDFLAGS=
|
||||
-LDLIBS=
|
||||
-PREFIX=/usr/local
|
||||
-SBINDIR=$(PREFIX)/sbin
|
||||
--- src/Makefile.orig Fri Dec 5 00:20:58 2003
|
||||
+++ src/Makefile Fri Dec 5 00:23:13 2003
|
||||
@@ -1,38 +1,8 @@
|
||||
-BIN = mathopd
|
||||
-CC = gcc
|
||||
-CFLAGS = -O -Wall
|
||||
-CPPFLAGS =
|
||||
-LDFLAGS =
|
||||
-LIBS = -lcrypt
|
||||
-PREFIX = /usr/local
|
||||
-SBINDIR = $(PREFIX)/sbin
|
||||
+PROG= mathopd
|
||||
+SRCS= base64.c cgi.c config.c core.c dummy.c dump.c imap.c log.c \
|
||||
+SRCS= base64.c cgi.c config.c core.c dump.c imap.c log.c \
|
||||
+ main.c redirect.c request.c util.c
|
||||
+BINDIR?=${PREFIX}/sbin
|
||||
+NOMAN= yes
|
||||
+LDADD= -lcrypt
|
||||
|
||||
-OBJS= base64.o cgi.o config.o core.o dummy.o dump.o imap.o log.o main.o \
|
||||
-# On Solaris, uncomment the following
|
||||
-# CPPFLAGS = -DNEED_INET_ATON -DHAVE_CRYPT_H
|
||||
-# LIBS = -lsocket -lnsl
|
||||
-
|
||||
-# On Linux, uncomment the following
|
||||
-# CPPFLAGS = -DHAVE_CRYPT_H
|
||||
-
|
||||
-OBJS = base64.o cgi.o config.o core.o dump.o imap.o log.o main.o \
|
||||
- redirect.o request.o util.o
|
||||
-DEPENDS=mathopd.h Makefile
|
||||
-DEPENDS = mathopd.h Makefile
|
||||
-
|
||||
-# Uncomment the following if your system does not support the poll() function
|
||||
-# CPPFLAGS += -DPOLL_EMULATION
|
||||
-# OBJS += poll-emul.o
|
||||
-
|
||||
-# Uncomment the following if your system does not have the socklen_t type
|
||||
-# CPPFLAGS += -DNEED_SOCKLEN_T
|
||||
-
|
||||
-all: $(BIN)
|
||||
-install: $(BIN)
|
||||
- install -c $(BIN) $(SBINDIR)
|
||||
-$(BIN): $(OBJS)
|
||||
- $(CC) $(LDFLAGS) -o $(BIN) $(OBJS) $(LDLIBS)
|
||||
- $(CC) $(LDFLAGS) -o $(BIN) $(OBJS) $(LIBS)
|
||||
-$(OBJS): $(DEPENDS)
|
||||
-.c.o:
|
||||
- $(CC) -c $(CFLAGS) $(CPPFLAGS) $< -o $@
|
||||
-clean:
|
||||
- rm -f $(BIN) $(OBJS)
|
||||
-.PHONY: install clean
|
||||
+.include <bsd.prog.mk>
|
||||
|
6
www/mathopd/files/patch-ab
Normal file
6
www/mathopd/files/patch-ab
Normal file
@ -0,0 +1,6 @@
|
||||
--- Makefile.orig Fri Dec 5 00:24:18 2003
|
||||
+++ Makefile Fri Dec 5 00:24:44 2003
|
||||
@@ -0,0 +1,3 @@
|
||||
+SUBDIR= src
|
||||
+
|
||||
+.include <bsd.subdir.mk>
|
@ -1,7 +1,13 @@
|
||||
etc/mathopd.conf.sample
|
||||
etc/rc.d/mathopd.sh
|
||||
etc/rc.d/mathopd.sh-dist
|
||||
sbin/mathopd
|
||||
share/doc/mathopd/CHANGES
|
||||
share/doc/mathopd/COPYING
|
||||
share/doc/mathopd/README
|
||||
@dirrm share/doc/mathopd
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cgi.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/processing.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/running.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sample.cfg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/syntax.txt
|
||||
%%PORTDOCS%%@dirrm share/doc/mathopd
|
||||
|
Loading…
Reference in New Issue
Block a user